EVGA

Helpful ReplyHot!Has Support been abandoned for the cards?

Page: 12 > Showing page 1 of 2
Author
cyber44030
New Member
  • Total Posts : 50
  • Reward points : 0
  • Joined: 2020/02/20 00:36:02
  • Status: offline
  • Ribbons : 3
2020/07/24 03:41:18 (permalink)
Last driver update released was back in march and hasn't been anything since. the latest drivers released alot of people can't use them because of the installation bug. Hasn't been any hot fixes to solve this issue and it is a known common problem. I myself am stuck using the January 2.1.7 Drivers because the 2.1.10 drivers do not work. I paid $250 Dollars for your audio card it would be nice if you guys would fix the list of common problems these cards have. I shouldn't have to use a outdated driver just to use my card. If the Driver Dev team can't solve the software and driver issues then EVGA should outsource it to someone who can.
post edited by cyber44030 - 2020/07/24 03:43:55
#1
silentknyght
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2018/07/17 06:41:15
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/07/28 05:25:10 (permalink)
Yeah, this has been a disappointment.  However, COVID is still real and a problem, so I'm trying to cut them some slack.  There is a beta 0.2.11 driver link floating around these forums.  You can try finding & downloading that.
#2
MackWage
New Member
  • Total Posts : 54
  • Reward points : 0
  • Joined: 2016/06/10 18:58:50
  • Status: online
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/07/28 18:08:21 (permalink)
It's also not just on EVGA given the partnership with Nahimic. Unsure how they're impacted by pandemic 
#3
Fatal Futanari
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2015/05/04 17:15:31
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/07/30 10:29:44 (permalink)
Thank you for this thread. I was considering getting this card for my new build but I think I will go with an external solution instead.
#4
Airdoo
New Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2010/01/31 07:09:41
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/07/30 16:00:12 (permalink)
Certainly feels like it. There have been feature requests since product launch that seem to have gone nowhere. Sidetone, Stereo Mix, and Reducing Mic Input Gain.

Sidetone, pass the microphone input back to the listener with minimal delay. Creative has had this functionality for as long as I can remember.
Stereo Mix, an input channel of the output from the output device mixed down to stereo, 2 channels.
Reducing Mic Input Gain, the current being sent to microphones is too high. This causes signal clipping. Adjusting the volume slider does not solve the problem as that is just the output volume of the resulting signal captured.
 
There are likely more that I'm missing but I have had this card since it was released and have been apart of the group asking for these things since purchasing this card. These are are the items I really feel are holding back this card.
 
I'm looking at getting the Schiit Hel pending a few questions I've put out to people who have it, while it's not perfect it does what I consider the minimum for audio products targeted towards gamers, high quality both inputs and outputs with features that make sense.
#5
MackWage
New Member
  • Total Posts : 54
  • Reward points : 0
  • Joined: 2016/06/10 18:58:50
  • Status: online
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/07/31 10:03:06 (permalink)
As a big fan and supporter of EVGA, I am hopeful they can breathe more life into this product line. I love my sound card but agree that I am a bit disappointed not only in the ongoing support, but also the lack of communication. I know the community guys are great and actively following these threads. It would make a big difference if we could learn more about the roadmap or even short term support issues due to pandemic. We are all human so we would understand.. but we have to know first before we can understand. :) 
#6
Cool GTX
EVGA Forum Moderator
  • Total Posts : 24460
  • Reward points : 0
  • Joined: 2010/12/12 14:22:25
  • Location: Folding for the Greater Good
  • Status: offline
  • Ribbons : 117
Re: Has Support been abandoned for the cards? 2020/07/31 10:56:56 (permalink)
NU Audio Driver Release v0.2.1.10 (Win10)
 
 
 
  Have any of you submitted any information about an issue or feature you want them to add or address ?
 
If you having any issues submit Details of your PC & OS
 
Looking for New features ?
 
Complaints and Suggestions

RTX Project EVGA X99 FTWK-5930K@4.8GHz 2xEVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 Classified-5960X@4.5GHz 3-GPU Water Loop 1600P2 
AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
Thank You for Your Support


#7
Valliant1972
New Member
  • Total Posts : 31
  • Reward points : 0
  • Joined: 2019/02/01 18:36:19
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/01 13:07:27 (permalink)
I have requested features that are available on lower end and older cards since the card was released. Seems its all too much work to do any of it or make a stable driver. Trying to get solutions for things always seems to be made out to be the users fault. Hardware is good, just the software is limited and buggy.
#8
transdogmifier
CLASSIFIED Member
  • Total Posts : 4414
  • Reward points : 0
  • Joined: 2003/09/05 14:26:21
  • Location: Boston, MA
  • Status: offline
  • Ribbons : 11
Re: Has Support been abandoned for the cards? 2020/08/01 13:54:34 (permalink)
I was considering one of these cards but I've been seeing people complaining about lack of driver support...so I've been remiss in buying it.
 

Intel 9900k
Alphacool Eisbaer 420 CPU cooler
Gigabyte Aorus Z390 Ultra
eVGA GeForce RTX 3090 FTW3 Ultra Gaming
eVGA 1600W Supernova T2 PSU
32GB G.skill Ripjaws 3200MHz
Samsung Pro 970 512GB
Phanteks P500A Case
 
My Affiliate Code: 8ST3SZQYI7
My Associate Code: J4T7H4SOBIGFO8F
#9
playboyer
New Member
  • Total Posts : 85
  • Reward points : 0
  • Joined: 2007/07/18 01:36:24
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/02 15:33:01 (permalink)
Yeah I'm having sound issues in my GeForce Shadowplay recordings. Nvidia has tried to help on the issue and my solution was to uninstall Nahimic. I made a post here regarding this and none of the EVGA techs have cared to comment on it. I don't have this audio issue with my other PC with a Sound Blaster AE-9.
#10
silentknyght
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2018/07/17 06:41:15
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/02 17:25:50 (permalink)
playboyer
Yeah I'm having sound issues in my GeForce Shadowplay recordings. Nvidia has tried to help on the issue and my solution was to uninstall Nahimic. I made a post here regarding this and none of the EVGA techs have cared to comment on it. I don't have this audio issue with my other PC with a Sound Blaster AE-9.



I reinstalled the drivers with the Nahimic add-ons.  That, combined with an ASIO buffer size of <=128 samples, I've had minimal issues (aside from continually needing to cycle through the microphone settings to wake).  That's not to say that I think this many sacrifices should be needed, but it's at least meeting some minimum requirements.
#11
nireyn21
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2017/03/19 17:08:25
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/03 04:23:31 (permalink)
To add into the woes mentioned above, I'll occasionally get an issue that drops FPS in games / high-use browser add-ons (YouTube, streaming live TV, etc) to the point that I have to entirely reboot the system to get it to work normally.
 
Or, at times on a fresh boot-up, it just won't manifest any sound (Spotify comes back and says 'I can't play this track' for anything I attempt to do) - and again, it requires a reboot.
 
 
#12
silentknyght
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2018/07/17 06:41:15
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/03 07:49:16 (permalink)
nireyn21
To add into the woes mentioned above, I'll occasionally get an issue that drops FPS in games / high-use browser add-ons (YouTube, streaming live TV, etc) to the point that I have to entirely reboot the system to get it to work normally.
 
Or, at times on a fresh boot-up, it just won't manifest any sound (Spotify comes back and says 'I can't play this track' for anything I attempt to do) - and again, it requires a reboot.
 



To be fair, neither of those issues sounds like it's related to the Nu Audio card or its drivers. 
#13
vampiricwulf
New Member
  • Total Posts : 7
  • Reward points : 0
  • Joined: 2018/10/10 18:12:37
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/03 17:55:09 (permalink)
playboyer
Yeah I'm having sound issues in my GeForce Shadowplay recordings. Nvidia has tried to help on the issue and my solution was to uninstall Nahimic. I made a post here regarding this and none of the EVGA techs have cared to comment on it. I don't have this audio issue with my other PC with a Sound Blaster AE-9.

Yeah I have the same issue, it extends also to videos on Twitter, LoL both the client and the game, and Valorant both voice and game. It's random which one it will be, sometimes multiple at once. This is a severe issue, EVGA needs to say something, even if it's just a notice that they're aware of the issue.
#14
Hoggle
EVGA Forum Moderator
  • Total Posts : 6529
  • Reward points : 0
  • Joined: 2003/10/13 22:10:45
  • Location: Eugene, OR
  • Status: offline
  • Ribbons : 4
Re: Has Support been abandoned for the cards? 2020/08/04 04:46:49 (permalink)
I have not had any major issues with the NU Audio since I got my first one and decided to get a second one for my other older machine. It's nice to have new drivers but I haven't noticed much if any issue. I mean I have ran into having such a high bit rate that audio in games doesn't work but that is mostly older games and easily fixed by lowering it.

Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
 
 
#15
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 2258
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 14
Re: Has Support been abandoned for the cards? 2020/08/04 10:15:23 (permalink)
Hi everyone, I can assure you that support most definitely has not been abandoned for the NU Audio or NU Audio Pro cards.  I've asked our Audio team to update me when we should expect to see the next drivers for these cards, as well as updates on some of the issues that have been reported.  This may take a few days.
 
I've mentioned this before, but we do have some limitations on our software team, and there are a number of software projects in the works.  Some that you can probably guess, and some....well, we'll just leave it at that.  With that said, we'll continue to look through the forums for issues that people are reporting and see whether we can resolve them.
 
Airdoo
Certainly feels like it. There have been feature requests since product launch that seem to have gone nowhere. Sidetone, Stereo Mix, and Reducing Mic Input Gain.

Sidetone, pass the microphone input back to the listener with minimal delay. Creative has had this functionality for as long as I can remember.
Stereo Mix, an input channel of the output from the output device mixed down to stereo, 2 channels.
Reducing Mic Input Gain, the current being sent to microphones is too high. This causes signal clipping. Adjusting the volume slider does not solve the problem as that is just the output volume of the resulting signal captured.
 
There are likely more that I'm missing but I have had this card since it was released and have been apart of the group asking for these things since purchasing this card. These are are the items I really feel are holding back this card.
 
I'm looking at getting the Schiit Hel pending a few questions I've put out to people who have it, while it's not perfect it does what I consider the minimum for audio products targeted towards gamers, high quality both inputs and outputs with features that make sense.



Like many of you, I own a NU Audio Pro card, and there are many QoL items that I'd like to see implemented, as well. Now that I also have a pair of speakers, my request for hotkey or otherwise toggle switching between speakers and headphones without having to use the software is without a doubt still a high-priority for me.  With regards to these:
 
- Sidetone, also known as low latency monitoring, is not something they can implement at this time.  My understanding is that it is something that can be added, but it will take them too much time at present.
- Stereo mix is not something that can be easily implemented.  There are a number of reasons for this, but even working with one of our software partners for the NU Audio cards to implement this in the quickest and easiest fashion would not necessarily work properly.  However, I did ask our Audio team to look into something similar, which would be easier to integrate and provide the same essential function.  I'm still waiting to hear back on this.
- The mic input clipping is something that appears to only affect a small number of people.  It's not something that our team has been able to recreate in-house, so I might need you to PM me more detailed information about what you're using and when/how it occurs.
#16
silentknyght
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2018/07/17 06:41:15
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/04 14:06:06 (permalink)
I appreciate the update, Lee.  I'm sure I, and many others, would continue to welcome regular (weekly?  bi-monthly?) communication updates, even if the software/driver updates aren't ready.
 
PS.  I had mic input clipping, too, but it seems to be fixed with a reduction in the ASIO sample rate.  I have an entire thread on the topic, with one extra long post.
#17
Airdoo
New Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2010/01/31 07:09:41
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/04 19:30:00 (permalink)
EVGATech_LeeM
 
- The mic input clipping is something that appears to only affect a small number of people.  It's not something that our team has been able to recreate in-house, so I might need you to PM me more detailed information about what you're using and when/how it occurs.


Hi Lee, thanks for reaching out again. I know you're in a tough spot and we're not making it easy for you and the team.

I've tested the mic on the ATH-AG1, 2X ATH-AG1X, and now a ModMic Uni to try and see if those improve or point to an issue with with the actual devices I'm plugging in. I seriously feel like the card is providing the port with too much, current, amp, volts, what have you. I have a multimeter and I am willing to create some Frankenstein cables to test things if needed.

I'd be happy to reopen the PM we had regarding this matter already if that would be preferable for you.
#18
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 2258
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 14
Re: Has Support been abandoned for the cards? 2020/08/05 09:53:13 (permalink)
Airdoo
EVGATech_LeeM
 
- The mic input clipping is something that appears to only affect a small number of people.  It's not something that our team has been able to recreate in-house, so I might need you to PM me more detailed information about what you're using and when/how it occurs.


Hi Lee, thanks for reaching out again. I know you're in a tough spot and we're not making it easy for you and the team.

I've tested the mic on the ATH-AG1, 2X ATH-AG1X, and now a ModMic Uni to try and see if those improve or point to an issue with with the actual devices I'm plugging in. I seriously feel like the card is providing the port with too much, current, amp, volts, what have you. I have a multimeter and I am willing to create some Frankenstein cables to test things if needed.

I'd be happy to reopen the PM we had regarding this matter already if that would be preferable for you.

Either works for me.
 
What seems like a reasonable solution, if possible, is to see if we can provide a beta driver/firmware that lowers the gain on the mic for you to test.  Since we have few complaints from most members, I don't see a change in the mic input anytime soon.  But if it's possible, maybe we can try a one-off solution.  I'll kick that idea over to the Audio team to consider.
#19
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 2258
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 14
Re: Has Support been abandoned for the cards? 2020/08/05 09:59:30 (permalink) ☄ Helpfulby Cool GTX 2020/09/11 10:05:48
Feedback I received yesterday is to look for a new driver between mid-to-late August.  It will fix one issue that people were running into regarding user account issues, but they'll also try to add any of the more recent issues people have been reporting.
 
#20
Airdoo
New Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2010/01/31 07:09:41
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/05 19:15:05 (permalink)
EVGATech_LeeM
Airdoo
EVGATech_LeeM
 
- The mic input clipping is something that appears to only affect a small number of people.  It's not something that our team has been able to recreate in-house, so I might need you to PM me more detailed information about what you're using and when/how it occurs.


Hi Lee, thanks for reaching out again. I know you're in a tough spot and we're not making it easy for you and the team.

I've tested the mic on the ATH-AG1, 2X ATH-AG1X, and now a ModMic Uni to try and see if those improve or point to an issue with with the actual devices I'm plugging in. I seriously feel like the card is providing the port with too much, current, amp, volts, what have you. I have a multimeter and I am willing to create some Frankenstein cables to test things if needed.

I'd be happy to reopen the PM we had regarding this matter already if that would be preferable for you.

 
What seems like a reasonable solution, if possible, is to see if we can provide a beta driver/firmware that lowers the gain on the mic for you to test. 


That sounds great, I understand that rolling a one off driver to try and nail down an issue is not ideal but I would be happy to try it.
#21
cloud2424
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2009/09/15 13:18:57
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/12 19:15:47 (permalink)
EVGATech_LeeM
Feedback I received yesterday is to look for a new driver between mid-to-late August.  It will fix one issue that people were running into regarding user account issues, but they'll also try to add any of the more recent issues people have been reporting.
 


Sorry if this has been asked before but does anyone know if we will ever get EQ presets like others offer for FPS games, Movies, Music, etc..
#22
Vivicector
New Member
  • Total Posts : 47
  • Reward points : 0
  • Joined: 2020/02/18 20:59:28
  • Status: offline
  • Ribbons : 1
Re: Has Support been abandoned for the cards? 2020/08/12 20:46:34 (permalink)
cloud2424
Sorry if this has been asked before but does anyone know if we will ever get EQ presets like others offer for FPS games, Movies, Music, etc..

EQ presets like that are kind of useless anyway. It just changes the sound based on some random ideas of the devs. Not really enhancing anything. EQ is there to compensate for the shortcomings of your acoustics or headphones. Or to colorize sound to your liking. You will need to set it up manually for that.
 
The thing I wish to see here is parametric EQ as an efficient way to compensate the room reverbs.
#23
Injuis
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2020/04/03 19:06:50
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/15 12:00:44 (permalink)
I'm am still looking for native bass management.  Right now, the only solution for us is to, during installation, disable Nahimic features and use Window's enhancements.  Pretty bad to lose features.
Also, the Windows bass management feature is pretty crappy.  If you have 'full range speakers' option enabled it basically kills the bass forwarding and disabling them severely reduces gain.  It's just all around a bad sound experience.
post edited by Injuis - 2020/08/22 14:54:43
#24
Phileosophos
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2016/09/25 14:04:09
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/24 16:25:49 (permalink)
Injuis
I'm am still looking for native bass management.  Right now, the only solution for us is to, during installation, disable Nahimic features and use Window's enhancements.  Pretty bad to lose features.
Also, the Windows bass management feature is pretty crappy.  If you have 'full range speakers' option enabled it basically kills the bass forwarding and disabling them severely reduces gain.  It's just all around a bad sound experience.

 
Ditto. It's ridiculous that for a card with such pro-sumer price tag it doesn't do any proper channel handling for subwoofer audio. But then I'm talking about a driver that stops working altogether if you simply log out of Windows and log back in, so I'm giving them one last chance before I uninstall it and sell it.
#25
silentknyght
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2018/07/17 06:41:15
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/08/30 12:18:43 (permalink)
EVGATech_LeeM
Feedback I received yesterday is to look for a new driver between mid-to-late August.  It will fix one issue that people were running into regarding user account issues, but they'll also try to add any of the more recent issues people have been reporting.
 


August is about done, and I have not yet seen nor heard of any driver update (and I've checked regularly).  Continued communication & updates would be welcome.  Thanks.
 
EDIT: Driver 2.1.14 is available in the official driver section, dated 8/31.  Cheers.
post edited by silentknyght - 2020/08/31 16:30:05
#26
jmblazar
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2020/09/01 16:24:01
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/09/01 16:27:01 (permalink)
I just installed the EVGA Nu Audio card and tried to install the latest driver.  However, I get an error message saying the mfc140c.dll is missing. Reinstallation doesn't fix it.  Windows sfc /scannow finds no missing drivers.  Is this a card/driver problem?  How can I get my card to work?
#27
pmclean
New Member
  • Total Posts : 57
  • Reward points : 0
  • Joined: 2011/06/10 18:26:21
  • Location: Canada
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/09/03 17:11:31 (permalink)
I bought an EVGA Nu Audio card several months ago. I had an install error saying it was not installed correctly and to restart and re-install. I did so and it kept giving me the same error and same message to reinstall. I did reinstall several times. Uninstalled the drivers and app and restarted and reinstalled drivers same error. Uninstalled everything took out card, rebooted, shut down installed card in different slot and tried installing/reinstalling the drivers several more times with the same error every single time. Every time I boot up my system I get the same error message that the drivers are no installed correctly and to reinstall. 
The card works fine the whole time. I have an optical cable to my Sony AV Receiver STR-DN1080 and a set of KEF Q series 5.1 speakers, it works fine. It absolutely sounds so much better than the realtek onboard audio on my ASUS Prime Z390-A motherboard. But I still get this error message every time I start my system. 
I thought the last driver release would fix the issue but nope same thing, tried it all again reinstalling over and over, taking the card out, switching slots, reinstalling, rebooting nothing changed the error message. 
Again the card "seems" to work fine but I still get this error message.
 
Obviously I should have done a lot more research before I bought this. Funny thing is, I actually took several months trying to decide whether or not try an dedicated sound card or not. I always had one back in the 90's but on board sound took over on premium motherboards and I didn't use one for a long time. I read a lot about this sound card before deciding to buy it over a soundblaster card, because I always used soundblaster in the past but I thought this would be better. I never searched for problems with the card though. The main thing I was trying to decide was whether I needed a dedicated sound card, whether it would provide any tangible benefits over onboard audio. It most definitely sounds better than onboard but there is still issues. Maybe I should have gone with a Soundblaster. 
 
Are people having the same problem with the Nu Audio Pro cards? I wanted that model but I live in canada and the price of that when I bought mine was just outrageous. I paid over $300 for the original Nu Audio card. 
 
I sure wish EVGA would get their act together and put out drivers and apps that work.
 
My system specs;
i9 9900K
ASUS Prime Z390-A
32GB Corsair 3200 DDR4
Gigabyte RTX 2070 Super Gaming OC 3X White
Corsair Obsidian 800D Full Tower Case
Corsair AX1200w PSU
Deepcool Assassin III Cpu Cooler
9 Noctua 120&140mm Case Fans
Scythe Kaze Q-12 Fan Controller
2 x Corsair MPO510 960GB M.2 SSD, 2 x WD Blue SSD 1TB, 2 x 3TB Seagate Barracuda XT HHD - All RAID0
Samsung c49RG90 Super Ultrawide Monitor
Sony Multi Channel AV Receiver STR-DN1080
5.1 KEF Q Series Speakers
Corsair M65 Elite Gaming Mouse
Aorus K9 Optical Gaming Keyboard
 
I've been a PC Gaming Enthusiast for almost 30 years. I'm fairly competent building and maintaining my computers, this sound card shouldn't be any issue for me. However it has been an issue since day one, it's been a little more than 6 months since I bought. I would have expected the problem to be worked out by now.
 
I am very disappointed it is still a problem. I want to love this sound card because it does sound good but this problem has been going on too long. I read some reviews on amazon about people having the same problem and not even giving the card a chance just returning it or RMA'ing it because of the same error message I get. The sound worked for me so I was willing to over look this error message but it should have been fixed by now. Maybe I should start a support ticket and RMA process.
 
Edit-
One thing I forgot to mention is that I have also reinstalled Windows twice since first installing the sound card. That was the main reason I didn't think much of the error message in the beginning. I was overdue for a fresh install of Windows but after I did that there was no change. 
I'm running fully activated legit windows 10 pro. All drivers and windows are up to date.
Also I tried installing and reinstalling under safe mode with no change. 
 
 
post edited by pmclean - 2020/09/04 01:07:26

Attached Image(s)


My current build is a 9900K @ 5.1 all cores-24/7 on an ASUS Prime Z390-A, 32 GB 4000MHz CL17 Crucial Ballistix Elite RAM, EVGA RTX 3090 FTW3 Ultra, 2 x Corsair MP510 960GB M.2 RAID0, 2 x WD Blue 1 TB SSD RAID0, 2 x Seagate 3TB Barracuda XT 7200RPM HDD RAID0, WD Black 2 TB HDD, LG 14x BluRay Burner, EVGA Nu Audio Card, Corsair AX 1200 Watt PSU, White PSU Custom Sleeved Cables, Corsair Obsidian 800D Full Tower Case, DeepCool Assassin III CPU Cooler w 3rd Noctua NF-A15 Fan, RockitCool Delid & Direct Die Kit,  Coollaboratory Ultra Liquid Metal, 3 x Noctuna NF P12 Redux Fans, 3 x Noctuna NF P14 Redux Fan, Scythe Kaze Q12 - 12 Channel Fan Controller, Samsung c49RG9 Ultrawide Monitor, HyperX Cloud Orbit Headphones, Sony AV Reciever STR-DN 1080 via Optical Cable, KEF Q Series 5.1 Speakers, SteelSeries Rival 600 Mouse, Aorus Flaretech Mech K9 Keyboard, Corsair MM300 XL & MM350 XL Gaming Mouse Pad, Vartan Gaming Chair, APC Back UPS PRO BR 1350VA[/
#28
BizSAR
EGC Lead Admin / EVGA Forum Moderator
  • Total Posts : 1152
  • Reward points : 0
  • Joined: 2007/07/13 00:27:46
  • Location: Oregon, USA
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/09/03 17:36:51 (permalink)
Hi pmclean,
I'd suggest you contact EVGA's support team directly. Information can be found at: https://www.evga.com/support/custsupp.asp.
I've got the pro card and have not experienced this issue.

~BizSAR


 
#29
Injuis
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2020/04/03 19:06:50
  • Status: offline
  • Ribbons : 0
Re: Has Support been abandoned for the cards? 2020/09/03 19:39:54 (permalink)
Will there be a software update for Pro cards?
#30
Page: 12 > Showing page 1 of 2
Jump to:
  • Back to Mobile