EVGA

Hot!EVGA Precision XOC 6.2.7 Released

Page: < 12 Showing page 2 of 2
Author
bob16314
CLASSIFIED Member
  • Total Posts : 4716
  • Reward points : 0
  • Joined: 2008/11/07 22:33:22
  • Location: Transylvania
  • Status: online
  • Ribbons : 336
Re: EVGA Precision XOC 6.2.7 Released 2018/05/12 16:58:04 (permalink)
fearpoint
Profile hotkeys not working.
 
I have to open the settings menu and click ok to apply hotkey settings already showing present for them to work. Occurs every time I restart the software.



Create your profile/s..Assign your hotkey/s..Click OK..Close Precision (without restarting your PC) so the config gets updated..Then open Precision again and they should work..If you want overclock settings to remain, enable "Apply previous settings on load" and close Precision..Closing Precision after making changes is they key to getting most changes to be saved in the configs..See if that works for you.
 
Some hotkeys/combinations may be system reserved like in MSI Afterburner and won't work..I use Shift + 1 for Profile 1 (Hotkey 1), Shift + 2 for Profile 2 (Hotkey 2), and so on.
post edited by bob16314 - 2018/05/12 17:01:04

* Cooler Master NV-334 * ASUS P8Z77-V LE PLUS * Intel i7-2600K @ 5.0GHz * Corsair H80 * Seasonic M12II 750W * 4x4GB 2133MHz Patriot Viper Xtreme * EVGA GTX 760 SC * 2 x WD 500GB Caviar Black RAID 0 * 2 x Toshiba DT01ACA 500GB * Dual-boot Win7 Home Premium 64-bit/Win10 Home 64-bit *   
 
"If it ain't broke, fix it untill it is"


#31
trog69
Superclocked Member
  • Total Posts : 125
  • Reward points : 0
  • Joined: 2012/01/13 18:55:39
  • Location: S.W. USA
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/13 03:17:26 (permalink)
Thank you. I didn't think I had either one assigned, but I did. I'll see if this works. 

i7-6700k @4.4ghz/1080ti FE/16gb 2133 DDR4 ram/AsRock Extreme 4 z170 Mobo/EVGA Supernova 850 PSU/256gb SSD Main/WD 2tb Velociraptor/4k LG mon./pair B&W 601se + Affordable Accuracy Monitors/SVS PB-2000 sub/Denon AVR S710w 7.2ch receiver. 
 
#32
fearpoint
CLASSIFIED Member
  • Total Posts : 2280
  • Reward points : 0
  • Joined: 2006/12/16 21:53:57
  • Status: offline
  • Ribbons : 3
Re: EVGA Precision XOC 6.2.7 Released 2018/05/15 18:03:45 (permalink)
bob16314
fearpoint
Profile hotkeys not working.
 
I have to open the settings menu and click ok to apply hotkey settings already showing present for them to work. Occurs every time I restart the software.



Create your profile/s..Assign your hotkey/s..Click OK..Close Precision (without restarting your PC) so the config gets updated..Then open Precision again and they should work..If you want overclock settings to remain, enable "Apply previous settings on load" and close Precision..Closing Precision after making changes is they key to getting most changes to be saved in the configs..See if that works for you.
 
Some hotkeys/combinations may be system reserved like in MSI Afterburner and won't work..I use Shift + 1 for Profile 1 (Hotkey 1), Shift + 2 for Profile 2 (Hotkey 2), and so on.




Nope. Every time the program loads the hotkeys don't work. I open the setting menu and the profile hotkeys are displayed in the settings. If I want to use hotkeys I have to open the settings and press ok even though they are listed there each and every time I open it. Amazing!
#33
mikec11
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2017/08/04 20:18:24
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/15 22:43:11 (permalink)
This software seems to be causing Destiny 2 to crash.
#34
CriticalHit_NL
iCX Member
  • Total Posts : 346
  • Reward points : 0
  • Joined: 2009/09/08 10:23:06
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision XOC 6.2.7 Released 2018/05/16 05:08:06 (permalink)
mikec11
This software seems to be causing Destiny 2 to crash.

Just a suggestion, not sure if this will solve it, can you quit Precision XOC and rename the following files:
 
PrecisionXServer.exe
PrecisionXServer_x64.exe
 
Start Precision XOC after this.
Note that OSD will not function without these files having the proper name, but it appears they automatically wan't to hook into applications even though OSD is not active.
Maybe there is a conflict with Destiny 2 and this might solve it.

i7 3930K 3,8Ghz - EVGA 1080Ti FTW3 - 32GB Corsair Dominator DDR3-1866 - Asus Sabertooth X79 - Samsung 840 Pro 256GB - Samsung HD103SJ 1TB - 3x HGST 7K4000 Deskstar 4TB - 3x HGST Ultrastar He10 8TB - Corsair AX1200i - Asus PG279Q + BenQ G2110W - Logitech G502 & SBF98 - Logitech Z906 & G35 - Windows 7 Ultimate   
#35
pelaird
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2017/04/16 10:41:03
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/17 13:22:19 (permalink)
I have tried to install Precision XOC for my EVGA 1070 several times. I finally deleted all files related to Precision XOC including the registry. I reinstalled once again and everything went as expected until I launched Precision XOC. I get this ERROR: "The code execution cannot proceed because d3dx11_43.dll was not found. Reinstalling the program may fix this problem."

Windows 10 x64 - ver. 1803
EVGA 270FTW, i7 7700K, EVGA 1070
#36
Sajin
EVGA Forum Moderator
  • Total Posts : 28586
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: offline
  • Ribbons : 170
Re: EVGA Precision XOC 6.2.7 Released 2018/05/17 13:28:27 (permalink)
pelaird
I have tried to install Precision XOC for my EVGA 1070 several times. I finally deleted all files related to Precision XOC including the registry. I reinstalled once again and everything went as expected until I launched Precision XOC. I get this ERROR: "The code execution cannot proceed because d3dx11_43.dll was not found. Reinstalling the program may fix this problem."


https://forums.evga.com/F...recision-m2666020.aspx


#37
JRuff
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2004/08/25 19:18:47
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 08:13:42 (permalink)
For the longest time now, probably 3 or 4 versions, Precision will just close from the taskbar after hovering over it with the mouse...I'll go to right click over it to activate a Profile and before I can even do anything it just drops from the taskbar and I have to relaunch it.  Yes, I've reinstalled.  I've cleaned out old versions.  Nothing fixes this and it's been going on for a while now.
 
I'm currently using Precision version 6.27.
 
My specs are:
 
Enermax Triathlor ECO 1000W PSU
Gigabyte GA-990FXA-UD3 Mobo
AMD FX-8350 Eight Core Processor @ 4.22 Ghz
16 Gigs of G.SKILL PC3 12800 Ram Dual Channel Memory
EVGA GeForce GTX 1060 GAMING ACX 3.0 (6gb)
Samsung EVO 500Gig SSD
Windows 10 Pro x64 (Version: 1803; Build 17134.48)
#38
bob16314
CLASSIFIED Member
  • Total Posts : 4716
  • Reward points : 0
  • Joined: 2008/11/07 22:33:22
  • Location: Transylvania
  • Status: online
  • Ribbons : 336
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 08:58:46 (permalink)
JRuff
For the longest time now, probably 3 or 4 versions, Precision will just close from the taskbar after hovering over it with the mouse...I'll go to right click over it to activate a Profile and before I can even do anything it just drops from the taskbar and I have to relaunch it.  Yes, I've reinstalled.  I've cleaned out old versions.  Nothing fixes this and it's been going on for a while now.

 
Yep..Same bug here..See posts #9 and #28.
 
Assigning 2D/3D profiles can cause that..Set them to "Not assigned", then close and open Precision again (w/o restarting your PC) and see if it matters and post back with your results.
 

* Cooler Master NV-334 * ASUS P8Z77-V LE PLUS * Intel i7-2600K @ 5.0GHz * Corsair H80 * Seasonic M12II 750W * 4x4GB 2133MHz Patriot Viper Xtreme * EVGA GTX 760 SC * 2 x WD 500GB Caviar Black RAID 0 * 2 x Toshiba DT01ACA 500GB * Dual-boot Win7 Home Premium 64-bit/Win10 Home 64-bit *   
 
"If it ain't broke, fix it untill it is"


#39
CriticalHit_NL
iCX Member
  • Total Posts : 346
  • Reward points : 0
  • Joined: 2009/09/08 10:23:06
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 09:42:53 (permalink)
 
bob16314
JRuff
For the longest time now, probably 3 or 4 versions, Precision will just close from the taskbar after hovering over it with the mouse...I'll go to right click over it to activate a Profile and before I can even do anything it just drops from the taskbar and I have to relaunch it.  Yes, I've reinstalled.  I've cleaned out old versions.  Nothing fixes this and it's been going on for a while now.

 
Yep..Same bug here..See posts #9 and #28.
 
Assigning 2D/3D profiles can cause that..Set them to "Not assigned", then close and open Precision again (w/o restarting your PC) and see if it matters and post back with your results.
 



Looks like a Windows 10 specific bug, I'm not seeing this on Windows 7.
I think we're talking about the system tray. (mine is expanded however)

i7 3930K 3,8Ghz - EVGA 1080Ti FTW3 - 32GB Corsair Dominator DDR3-1866 - Asus Sabertooth X79 - Samsung 840 Pro 256GB - Samsung HD103SJ 1TB - 3x HGST 7K4000 Deskstar 4TB - 3x HGST Ultrastar He10 8TB - Corsair AX1200i - Asus PG279Q + BenQ G2110W - Logitech G502 & SBF98 - Logitech Z906 & G35 - Windows 7 Ultimate   
#40
bob16314
CLASSIFIED Member
  • Total Posts : 4716
  • Reward points : 0
  • Joined: 2008/11/07 22:33:22
  • Location: Transylvania
  • Status: online
  • Ribbons : 336
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 10:53:19 (permalink)
CriticalHit_NL
Looks like a Windows 10 specific bug, I'm not seeing this on Windows 7.
I think we're talking about the system tray. (mine is expanded however)




Yes, both the System Tray icon disappears and the program closes.
 
It happens in both Win7 and Win10 here, and I can make it happen all the time..The solution for me for that specific problem is to not assign any 2D and/or 3D profiles, or just to simply open and then close the Settings after Precision starts, or go back to using version 6.2.3 or earlier. 

* Cooler Master NV-334 * ASUS P8Z77-V LE PLUS * Intel i7-2600K @ 5.0GHz * Corsair H80 * Seasonic M12II 750W * 4x4GB 2133MHz Patriot Viper Xtreme * EVGA GTX 760 SC * 2 x WD 500GB Caviar Black RAID 0 * 2 x Toshiba DT01ACA 500GB * Dual-boot Win7 Home Premium 64-bit/Win10 Home 64-bit *   
 
"If it ain't broke, fix it untill it is"


#41
CriticalHit_NL
iCX Member
  • Total Posts : 346
  • Reward points : 0
  • Joined: 2009/09/08 10:23:06
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 11:32:16 (permalink)
bob16314
 
Yes, both the System Tray icon disappears and the program closes.

It happens in both Win7 and Win10 here, and I can make it happen all the time..The solution for me for that specific problem is to not assign any 2D and/or 3D profiles, or just to simply open and then close the Settings after Precision starts, or go back to using version 6.2.3 or earlier. 

Ok that's confusing, even wiped my settings and only set a profile and assigned 2d/3d profiles and it doesn't close, neither after restarting it.
I really wonder where this goes wrong for some.

i7 3930K 3,8Ghz - EVGA 1080Ti FTW3 - 32GB Corsair Dominator DDR3-1866 - Asus Sabertooth X79 - Samsung 840 Pro 256GB - Samsung HD103SJ 1TB - 3x HGST 7K4000 Deskstar 4TB - 3x HGST Ultrastar He10 8TB - Corsair AX1200i - Asus PG279Q + BenQ G2110W - Logitech G502 & SBF98 - Logitech Z906 & G35 - Windows 7 Ultimate   
#42
bob16314
CLASSIFIED Member
  • Total Posts : 4716
  • Reward points : 0
  • Joined: 2008/11/07 22:33:22
  • Location: Transylvania
  • Status: online
  • Ribbons : 336
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 12:50:55 (permalink)
 
CriticalHit_NL
Ok that's confusing, even wiped my settings and only set a profile and assigned 2d/3d profiles and it doesn't close, neither after restarting it.
I really wonder where this goes wrong for some.

 

Yeah, I hear ya, me too..But here's how I can make PXOC crash all day, every day, and on demand with versions 6.2.6, 6.2.7 and also with the Beta versions in between in both Win7 and Win10..Older versions work fine.
 
1. Create a profile/profiles and save it/them
2. Assign a 2D and/or 3D profile in the Profile tab
3. Close Precision and then open again so the profiles/settings stick
4. Run the GPU-Z Render Test or a 3D app or even open Edge or Internet Explorer or Windows Photos
 
Doesn't matter if PXOC starts with Windows or I start it from the desktop shortcut..Doesn't matter if PXOC is minimized to the System Tray or not..Doesn't matter if PXOC is set to Start Minimized or not..Sometimes the crash takes like 15 seconds or so and sometimes it happens immediately.

The problem is somehow related to the 2D/3D profiles and/or the Settings being activated or not..The problem goes away when no profiles are assigned, or when opening/closing the Settings (gear button) if 2D/3D profiles are assigned.

In Win7 I get the error popup shown in the attachment below and no solution from Win7 is offered.

I hope these findings can prove useful to the development team.
 

Attached Image(s)


* Cooler Master NV-334 * ASUS P8Z77-V LE PLUS * Intel i7-2600K @ 5.0GHz * Corsair H80 * Seasonic M12II 750W * 4x4GB 2133MHz Patriot Viper Xtreme * EVGA GTX 760 SC * 2 x WD 500GB Caviar Black RAID 0 * 2 x Toshiba DT01ACA 500GB * Dual-boot Win7 Home Premium 64-bit/Win10 Home 64-bit *   
 
"If it ain't broke, fix it untill it is"


#43
happaflapp
SSC Member
  • Total Posts : 666
  • Reward points : 0
  • Joined: 2006/10/03 17:26:14
  • Status: online
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 15:32:36 (permalink)
Was support for Logitech G19 keyboard removed with this version?  The OSD is lacking any sort of interface with my keyboard.

i7 920@ 3770 GHz w/HT & turbo*EVGA X58 X3 (E758-A1)*2x EVGA GTX 670 FTW *Corsair Dominator DDR3 1600 18gb (7-7-7-20 @ 1380 MHz \ 2T)*Corsair H50*Corsair HX850W*Corsair Force Series 60Gb +OS drive+SATA II (SSD)* Corsair Neutron series 120Gb SATA III (SSD)*XF-i  Fatal1ty Pro Series*Western Digital Caviar Black 1Tb & 500 Gb*Cooler Master Stacker 830se*Logitech G19 *Logitech G9x*fUnc Archetype1030MBA*Logitech X-540 5.1*Acer G245HQABD*Windows 10x64  

AMD Phenom II X4 BE 970@ 3500 MHz*Corsair H50*Asus M4N82 Deluxe*Corsair XMS2 800 8Gb DDR2(5-5-5-18 @ 800 MHz \1T)* 2x GTX470 Superclocked * XF-i Xtreme Music* Corsair Force Series 60 Gb +OS drive+ (SATA II)Western Digital Caviar Blue 1Tb & 500 Gb*Corsair 750TX*Cooler Master CM Storm*Logitech G15v2*Logitech G500*Logitech X-530 5.1*fUnc 1030 sUrface*Acer X233H bd*Windows 10x64 [/c
#44
CriticalHit_NL
iCX Member
  • Total Posts : 346
  • Reward points : 0
  • Joined: 2009/09/08 10:23:06
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision XOC 6.2.7 Released 2018/05/18 16:38:31 (permalink)
bob16314
Yeah, I hear ya, me too..But here's how I can make PXOC crash all day, every day, and on demand with versions 6.2.6, 6.2.7 and also with the Beta versions in between in both Win7 and Win10..Older versions work fine.

1. Create a profile/profiles and save it/them
2. Assign a 2D and/or 3D profile in the Profile tab
3. Close Precision and then open again so the profiles/settings stick
4. Run the GPU-Z Render Test or a 3D app or even open Edge or Internet Explorer or Windows Photos

Doesn't matter if PXOC starts with Windows or I start it from the desktop shortcut..Doesn't matter if PXOC is minimized to the System Tray or not..Doesn't matter if PXOC is set to Start Minimized or not..Sometimes the crash takes like 15 seconds or so and sometimes it happens immediately.

The problem is somehow related to the 2D/3D profiles and/or the Settings being activated or not..The problem goes away when no profiles are assigned, or when opening/closing the Settings (gear button) if 2D/3D profiles are assigned.

In Win7 I get the error popup shown in the attachment below and no solution from Win7 is offered.

I hope these findings can prove useful to the development team.

Thanks for the directions, I could reproduce this using GPU-Z atleast, crashed nearly immediately on PrecisionX_x64.exe.
I only wiped my settings and then created 3 profiles with the same info.
Assigned different profiles to 2d and 3d profile, but also happens using same profile.
I currently have renamed the OSD server executables so they can't be doing anything.
 
This is what the Windows logs had to say about it:
 
Faulting application name: PrecisionX_x64.exe, version: 6.2.7.0, time stamp: 0x5af10c52
Faulting module name: PrecisionX_x64.exe, version: 6.2.7.0, time stamp: 0x5af10c52
Exception code: 0xc0000005
Fault offset: 0x0000000000067ab9
Faulting process id: 0x1da0
Faulting application start time: 0x01d3eeff65eee7cf
Faulting application path: C:\Program Files (x86)\EVGA\Precision XOC\PrecisionX_x64.exe
Faulting module path: C:\Program Files (x86)\EVGA\Precision XOC\PrecisionX_x64.exe
Report id: ad2f9590-5af2-11e8-ac93-08606e8026d3
 
 
My guts are telling me that this has to do with how Precision XOC is loading its settings currently.
As we've seen before the first time you open the settings menu, there's a delay before it opens.
If settings is left unopened, things like Thermal LEDs currently do not update.
 
Now, we have 2d and 3d profiles which the program has defined profiles for, but without opening settings first, it is unable to change from profile state in the main Precision XOC window.
When the program detects the other 3d profile kicks in due to load from opening certain applications, it hangs.
 
You can see the same delay occur in Precision XOC like settings if you start it and directly click on one of the profile buttons.
Something is definitely messed up with how settings are currently loaded at program start-up and its breaking all sorts of things.
 
Maybe its done to lessen the initial start-up time of the application, but it seems its not the right way as of now.
 
Either way good find. 
 
PS: GPU-Z could use a bugfix too, pausing the rendertest keeps using processor power for no reason.
 
 
happaflapp
Was support for Logitech G19 keyboard removed with this version?  The OSD is lacking any sort of interface with my keyboard.

 
I don't think it was done intentionally, but since EVGA has their own keyboard now they might have made specific changes which breaks the old keyboards support.
post edited by CriticalHit_NL - 2018/05/18 16:54:58

i7 3930K 3,8Ghz - EVGA 1080Ti FTW3 - 32GB Corsair Dominator DDR3-1866 - Asus Sabertooth X79 - Samsung 840 Pro 256GB - Samsung HD103SJ 1TB - 3x HGST 7K4000 Deskstar 4TB - 3x HGST Ultrastar He10 8TB - Corsair AX1200i - Asus PG279Q + BenQ G2110W - Logitech G502 & SBF98 - Logitech Z906 & G35 - Windows 7 Ultimate   
#45
smokinV8
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2016/07/05 15:43:08
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/19 09:43:05 (permalink)
destiny 2 freezes/crashes when I use precision x is there a fix or workaround other than not using precision x when running destiny 2?

R7 2700x
G.skill Flare X 3200 cl14
Asus ROG Crosshair vii WiFi
EVGA GTX 1080 FTW2
Samsung Evo 970 500gb m.2 nvme
WD Black 2TB
Evga P2 850w psu
Fractal Design Define R6 Black
Acer X34 100hz G-sync 3440x1440
Razer Taipan \ Razer Black Widow Ultimate 
Astro A50
Windows 10
#46
XLYUS
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2017/06/28 03:24:03
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision XOC 6.2.7 Released 2018/05/19 14:28:56 (permalink)
Hi.
 
I Have problem with thermal sensor leds in my 1080ti ftw3.
Always blue not changed. If i close the precision xoc and restart its succesfull. I tried uninstall with all precision xoc regedits and files and reinstall but not fixed help me please.
 
6.2.7
#47
CriticalHit_NL
iCX Member
  • Total Posts : 346
  • Reward points : 0
  • Joined: 2009/09/08 10:23:06
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision XOC 6.2.7 Released 2018/05/19 15:24:24 (permalink)
smokinV8
destiny 2 freezes/crashes when I use precision x is there a fix or workaround other than not using precision x when running destiny 2?

 
Can you try this?
 
https://forums.evga.com/FindPost/2821625 (post #35)
 
XLYUS
Hi.
 
I Have problem with thermal sensor leds in my 1080ti ftw3.
Always blue not changed. If i close the precision xoc and restart its succesfull. I tried uninstall with all precision xoc regedits and files and reinstall but not fixed help me please.
 
6.2.7


Currently there is a bug that doesn't let Thermal LED update if Precision XOC settings is not opened once.
If Precision XOC is closed it doesn't seem to update either.
 
Unfortunately I don't pay too much attention to the LEDs behaviour so I don't know if Thermal LEDs actually updated previously without software running.

i7 3930K 3,8Ghz - EVGA 1080Ti FTW3 - 32GB Corsair Dominator DDR3-1866 - Asus Sabertooth X79 - Samsung 840 Pro 256GB - Samsung HD103SJ 1TB - 3x HGST 7K4000 Deskstar 4TB - 3x HGST Ultrastar He10 8TB - Corsair AX1200i - Asus PG279Q + BenQ G2110W - Logitech G502 & SBF98 - Logitech Z906 & G35 - Windows 7 Ultimate   
#48
Page: < 12 Showing page 2 of 2
Jump to:
  • Back to Mobile