EVGA

Hot!3070TI ftw 3 red ight led

Page: 12 > Showing page 1 of 2
Author
linkilloxd
New Member
  • Total Posts : 32
  • Reward points : 0
  • Joined: 2024/04/15 08:27:38
  • Status: offline
  • Ribbons : 0
2024/04/15 08:57:08 (permalink)
Hello how are you? Today I turned on my PC and an LED appeared on the right side of the PCIe cables. Last night it was working perfectly and I don't know what could be the cause. Can I upload an image of what it looks like.
 

edit by Cool GTX insert photo
post edited by Cool GTX - 2024/04/15 09:43:19
#1

57 Replies Related Threads

    ScottH17
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2014/06/21 01:22:07
    • Location: Folsom, CA
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:03:11 (permalink)
    I figure you should check cables!

     JESUS awesome always!
    #2
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:04:56 (permalink)
    Yes, I already checked the psu cables and there was no movement of the pc overnight. I have a Corsair CX650M psu and a Ryzen 5 3600 CPU. The strange thing is that when it is turned on for a while the red LED stops appearing and the RGB starts working normally.
    #3
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:13:49 (permalink)
    Welcome to the EVGA Forums, where members try to help
     
    PSA adding a photo to your Post - EVGA made some changes - Post Directions below
     
    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members
     see details about posting links & work around for those with low post counts & new accounts
     
     
    3070TI ftw 3 - Requirements
    • 750 Watt or greater power supply.
    I'd test with a new better PSU
     
    Is GPU plugged into the MB & the PCIe slot latch locked?   If using riser cable - test directly into MB
     
    PSA
    Only use power cables that came with a PSU .... or that you can confirm are compatible with your PSU ..... mixing cables between different PSU can cause damage as all PSU do not have the same pinout (location of voltages or ground) - the PSU MFG makes a custom cable so that the device end has the correct pinout
     
     

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #4
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:20:10 (permalink)
    Hello, the strange thing is that since I bought it in 2022 with this psu I had not had this problem until today.
     
    I have it connected directly to the mobo with its pciexpress, so I don't know what could have happened. I have no monetary means of being able to purchase a 750w psu at the moment, the strange thing, as I mentioned, is that after a while the PC is turned on the red LED stops flashing. (it is the third one on the right, it is not one of the ones that are connected to the psu cables)
    #5
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:27:02 (permalink)
    I'm not sure what the red led in question indicates.
     
    OS W10 or W11 ?
     
    Could possibly be PSU or GPU issue - very odd that red light seem to go out after a bit of time.

    Just a few suggestions on your trouble shooting:
     
    Do a complete "power flush" & clear the Windows startup "last good boot" file & make sure MB BIOS has Fast Boot = OFF:

     
     (power flush - remove all sources of power to any device connected to the PC)

    To do a full power down of the PC, this includes unplugging everything from the  power source (then hold start button 20 seconds to discharge the capacitors) - as "Windows Off mode" = a "soft off" with power still supplied to MB
     

    (clear the Windows startup "last good boot" file)

    Shut down Windows  HOLD the Shift key Down, then select shutdown for Windows --> Keep the shift key down until the PC is fully powered down ... this prevents Windows on restart from starting by loading "last good configuration file" .... Make Windows take inventory of all Hardware & Drivers on next Startup.

     
    MB BIOS - Fast Boot = OFF ---> You want the MB to do a full inventory of your hardware
     
    Have you or Windows install any updates or new software just before this all started?
     
    What background software is running? 

    Did you try testing by booting into Windows Safe mode?
     
    check with this tool https://www.evga.com/power-meter/
     
     

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #6
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:37:23 (permalink)
    Cool GTX
    I'm not sure what the red led in question indicates.
     
    OS W10 or W11 ?
     
    Could possibly be PSU or GPU issue - very odd that red light seem to go out after a bit of time.
     
    Do a complete "power flush" & clear the Windows startup "last good boot" file:
     
    Just a few suggestions on your trouble shooting:

    (power flush - remove all sources of power to any device connected to the PC)
    To do a full power down of the PC, this includes unplugging everything from the  power source (then hold start button 20 seconds to discharge the capacitors) - as "Windows Off mode" = a "soft off" with power still supplied to MB

    (clear the Windows startup "last good boot" file)
    Shut down Windows  HOLD the Shift key Down, then select shutdown for Windows --> Keep the shift key down until the PC is fully powered down ... this prevents Windows on restart from starting by loading "last good configuration file" .... Make Windows take inventory of all Hardware & Drivers on next Startup.

     
    Have you or Windows install any updates or new software just before this all started?
     
    check with this tool
     
     




    Hello, yes, I already tried the method of turning off completely, I even opened the case to remove the cables that power from the psu to the cpu and the mobo, my OS is w11.
     
    The power meter tells me that I need a 750w one but the strange thing is that for 2 years it has worked without problems with this one.
     
    No, there is no new installation of drivers or Windows updates.
     
    I was searching on the internet and I couldn't find any answer to what this LED represents, that's why I don't understand.
     
    #7
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:39:50 (permalink)
    Try using two separate PCIe power cables - one for each power port on the GPU, if your PSU has that option.
     
    Second best option is if your PSU came with another PCIe power cable, swap the current one for a new one.
     
    Unplug PC before doing anything inside of it.
     
     
     
    this seems to be your photo
     


    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #8
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:41:55 (permalink)
    Cool GTX
    this seems to be your photo
     



    Yes! thats my picture
     
    I also add that I tried the device manager, dxdiag and it does not present any problems, nor when playing or using it.
    The only thing it has is that the red LED comes out, blinks and makes the RGB flicker.
    I don't know how else I could check what the problem would be.
    #9
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:45:41 (permalink)
    I'm guessing your in North America; but, have no way of knowing where your located
     
    Please contact EVGA support team at support@evga.com with the serial number to your graphics card - After you register the card
     
    This is the link to your thread ---> https://forums.evga.com/FindPost/3621296
     
     
    You can always wait to see if another member has anything to add or ask in your thread

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #10
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:46:40 (permalink)
    Cool GTX
    I'm guessing your in North America; but, have no way of knowing where your located
     
    Please contact EVGA support team at  with the serial number to your graphics card - After you register the card
     
    You can always wait to see if another member has an thing to add or ask in your thread


    Nono, I'm in Latin America. Specifically in Argentina. I'll create a ticket in that case. Thank you!
    #11
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:51:25 (permalink)
    linkilloxd
    Cool GTX
    I'm guessing your in North America; but, have no way of knowing where your located
     
    Please contact EVGA support team at  with the serial number to your graphics card - After you register the card
     
    You can always wait to see if another member has an thing to add or ask in your thread


    Nono, I'm in Latin America. Specifically in Argentina. I'll create a ticket in that case. Thank you!


     

    You can Try the email I gave as that is the World Headquarters, any RMA would be through your local region
     
    Wish I could help you more
     
    I am still unclear if the PC works correctly?  
     
    Any issues with performance? 
     
    Or is this all about you noticed the red led?

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #12
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 09:56:14 (permalink)
    Cool GTX
    linkilloxd
    Cool GTX
    I'm guessing your in North America; but, have no way of knowing where your located
     
    Please contact EVGA support team at  with the serial number to your graphics card - After you register the card
     
    You can always wait to see if another member has an thing to add or ask in your thread


    Nono, I'm in Latin America. Specifically in Argentina. I'll create a ticket in that case. Thank you!


     

    You can Try the email I gave as that is the World Headquarters, any RMA would be through your local region
     
    Wish I could help you more
     
    I am still unclear if the PC works correctly?  
     
    Any issues with performance? 
     
    Or is this all about you noticed the red led?




    I'll explain a little about the context:
    During all these days there have been no problems with the PC, in terms of performance or anything like that.
    Today I turned on the computer and I see that the GPU's RGB starts to flicker, just like that red LED appears on the right side.
    I opened the PC, took out the cables, checked if they were inserted correctly or something like that (although it shouldn't move because no one opened it) and I still had the same problem.
    I haven't changed anything overnight, but in terms of performance it remains the same, except that from time to time the red LED appears and the RGB flashes. There is no solution on the internet (neither in this forum nor on reddit) regarding the same problem I have.
    Regarding the psu, as I mentioned, I bought the GPU and the psu together 2 years ago and it had not given me any problems until today, which is why it seems strange to me.
    #13
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 10:02:30 (permalink)
    ASK EVGA what that Red Led indicates, use the email I supplied
     
    I found this older thread:  3070ti FTW3 red light above power connector but seems to be working fine

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #14
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 10:16:33 (permalink)
    Cool GTX
    ASK EVGA what that Red Led indicates, use the email I supplied
     
    I found this older thread: 


    Yes, I saw that post, but in that case the red LED is on top of the pcie cable, in my case it is on the right side, that is, it is not in any of the two connectors of the cable (there it could be a power problem) That's why it seems strange to me.
    #15
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/15 14:49:41 (permalink)
    Run GPU-Z (it is Free) & look under the sensor tab to check voltages as seen by the GPU
     
    GPU-Z Graphics Card GPU Information Utility - TechPowerUp

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #16
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/15 15:53:30 (permalink)
    Cool GTX
    Run GPU-Z (it is Free) & look under the sensor tab to check voltages as seen by the GPU
     



    #17
    Sajin
    EVGA Forum Moderator
    • Total Posts : 49204
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: offline
    • Ribbons : 199
    Re: 3070TI ftw 3 red ight led 2024/04/15 23:42:10 (permalink)
    So just to confirm...
     
    You've already tried reseating the card to the motherboard along with reseating the cables at the psu & gpu?
    #18
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 102536
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Netherlands
    • Status: offline
    • Ribbons : 85
    Re: 3070TI ftw 3 red ight led 2024/04/15 23:50:53 (permalink)
    You can try the video card in another PC. If the same red light occurs you might have a GPU problem. 

    AMD Ryzen 9 7950X,  Corsair Mp700 Pro M.2, 64GB Corsair Dominator Titanium DDR5  X670E Steel Legend, MSI RTX 4090 Associate Code: H5U80QBH6BH0AXF. I am NOT an employee of EVGA

    #19
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/16 12:21:26 (permalink)
    rjohnson11
    You can try the video card in another PC. If the same red light occurs you might have a GPU problem. 


    I try on another PC with the same psu and i have rhat red light too, but in another (on My brother PC) with 650w don't have that problem.


    I think it's a power issue, i mean, i need to try on a 750w psu for confirm, but on gpuz i see a low volt energy
    #20
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 31075
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 123
    Re: 3070TI ftw 3 red ight led 2024/04/16 12:27:54 (permalink)
    linkilloxd
    rjohnson11
    You can try the video card in another PC. If the same red light occurs you might have a GPU problem. 


    I try on another PC with the same psu and i have rhat red light too, but in another (on My brother PC) with 650w don't have that problem.


    I think it's a power issue, i mean, i need to try on a 750w psu for confirm, but on gpuz i see a low volt energy



     
    my Bad, should have told you to stress GPU & CPU when checking GPU-Z sensors
     
    Run either a Game you own or a  software benchmark to stress (put under a load) your PC system

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New Members

    I am a Volunteer Moderator - not an EVGA employee

    Older RIG projects RTX Project  Nibbler




     
    #21
    bdary
    Omnipotent Enthusiast
    • Total Posts : 10382
    • Reward points : 0
    • Joined: 2008/04/25 14:08:16
    • Location: Florida
    • Status: offline
    • Ribbons : 116
    Re: 3070TI ftw 3 red ight led 2024/04/16 13:05:12 (permalink)
    Quote:



    Hello, yes, I already tried the method of turning off completely, I even opened the case to remove the cables that power from the psu to the cpu and the mobo, my OS is w11.
     
    The power meter tells me that I need a 750w one but the strange thing is that for 2 years it has worked without problems with this one.
     
    No, there is no new installation of drivers or Windows updates.
     
    I was searching on the internet and I couldn't find any answer to what this LED represents, that's why I don't understand.
     


    Since the power meter you used is recommending a 750W PSU, I'd say based on what you've been saying in your thread, the 650W unit you've been using was right on the edge of adequate.  Now after 2 years it's weakened a bit to the point you're having power issue's.  Buying a 750W PSU or finding one to test with would rule that out/in as being the source of your issue.
    post edited by bdary - 2024/04/16 13:06:17


     
     
     
     
     
     
     
     
     
    #22
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/16 14:37:34 (permalink)
    Cool GTX
    linkilloxd
    rjohnson11
    You can try the video card in another PC. If the same red light occurs you might have a GPU problem. 


    I try on another PC with the same psu and i have rhat red light too, but in another (on My brother PC) with 650w don't have that problem.


    I think it's a power issue, i mean, i need to try on a 750w psu for confirm, but on gpuz i see a low volt energy



     
    my Bad, should have told you to stress GPU & CPU when checking GPU-Z sensors
     
    Run either a Game you own or a  software benchmark to stress (put under a load) your PC system


    Hello how are you? I decided to perhaps avoid damage to the GPU not to use it or turn it on until further notice, since if it is something with the GPU I have to do the RMA and it is quite complicated to do it from Argentina to the USA, on top of that I would have to pay for the shipping and so on (they already clarified it to me in a support ticket)
     
    bdary
    Quote:



    Hello, yes, I already tried the method of turning off completely, I even opened the case to remove the cables that power from the psu to the cpu and the mobo, my OS is w11.
     
    The power meter tells me that I need a 750w one but the strange thing is that for 2 years it has worked without problems with this one.
     
    No, there is no new installation of drivers or Windows updates.
     
    I was searching on the internet and I couldn't find any answer to what this LED represents, that's why I don't understand.
     


    Since the power meter you used is recommending a 750W PSU, I'd say based on what you've been saying in your thread, the 650W unit you've been using was right on the edge of adequate.  Now after 2 years it's weakened a bit to the point you're having power issue's.  Buying a 750W PSU or finding one to test with would rule that out/in as being the source of your issue.


    Hello how are you? The strange thing is that the psu does work without problems. I checked it on my girlfriend's PC that has a 4060.
    It is probably what you are saying that perhaps the performance dropped over time, anyway, 2 years of a psu is not very short lifespan? It's a Corsair MX650W.
     
    Now I had to go into debt basically to be able to buy a 750w thermaltake and try it.
     
    Oh, a curious fact is that I also tried the GPU on my girlfriend's PC and she has a 650w gygabite psu and the red light went on, on my brother's PC,
    which is a 650w one, it didn't give me any errors. maybe because of the brand/quality?
     
    I still think that the conclusion is when I receive the 750w psu and we can check, I will be informing all of you
     
    also, i dont understand why evga dont have a users manual for the 3070s series, they have a 50/60/80 series manual's. IDK what that red light on the right side of the card appears and why (because its not uppon the pcie cables)
    #23
    bdary
    Omnipotent Enthusiast
    • Total Posts : 10382
    • Reward points : 0
    • Joined: 2008/04/25 14:08:16
    • Location: Florida
    • Status: offline
    • Ribbons : 116
    Re: 3070TI ftw 3 red ight led 2024/04/17 08:04:52 (permalink)
    Let us know how things go if/when you test with a 750W PSU.  I just hope there wasn't any damage to your GPU after running it for 2 years with an underrated PSU.


     
     
     
     
     
     
     
     
     
    #24
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/18 11:20:08 (permalink)
    Hi guys, so today came the new psu (a thermaltake smart bm2 semi-modular 750w bronze) and i tested it and the gpu was perfect.  No more the red light. 
     
    For the record, I use 2 separated pcie 6+2 cables for every slot on the gpu.
     
    This is starting world of warcraft (i mean, i dont play too much only for testing)
     

    #25
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/18 11:28:26 (permalink)
    But i have another question. It seens that my fans are descalibrated on precision x1 when i put it on auto ¿how can i callibrated again?
     
    #26
    bdary
    Omnipotent Enthusiast
    • Total Posts : 10382
    • Reward points : 0
    • Joined: 2008/04/25 14:08:16
    • Location: Florida
    • Status: offline
    • Ribbons : 116
    Re: 3070TI ftw 3 red ight led 2024/04/18 13:26:39 (permalink)
    Glad to hear you're up and running again. As far as the fans go, I would set up a custom fan profile to your liking.  That way you can tweak the curve how you want to balance the temps with a fan noise. It will likely take some trial and error on your part to dial it in.


     
     
     
     
     
     
     
     
     
    #27
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/23 15:33:17 (permalink)
    Hello guys, how are you? The GPU was working perfectly and today the red light reappeared but it flashes for less than a second and continues without problems. I already opened the PC, took out the pcie cables, took out the pcie gpu from the mobo and reconnected it and the problem continues. What do you think it could be, something about the GPU?
    #28
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/23 15:48:32 (permalink)
    this how gpu-z look like
    #29
    linkilloxd
    New Member
    • Total Posts : 32
    • Reward points : 0
    • Joined: 2024/04/15 08:27:38
    • Status: offline
    • Ribbons : 0
    Re: 3070TI ftw 3 red ight led 2024/04/23 15:53:33 (permalink)
    This is look like 5 minutes running kombustor
    #30
    Page: 12 > Showing page 1 of 2
    Jump to:
  • Back to Mobile