EVGA

Hot!RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting

Page: < 12345.. > >> Showing page 5 of 28
Author
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 03:35:59 (permalink)
Also I have information that this happened to some people with EK Strix blocks and EK XC3 blocks.
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 03:52:02 (permalink)
Filip1995
Personally, I think the real issue is the right installation of the thermal pads on the backplate, the instruction on that is pretty terrible. I saw a video of installation of the block and backplate on the ftw3 which worked out in the end and thu guy on the video installed the thermal pads very differently. Shareing the video for everyone:
 
https://www.youtube.com/watch?v=U7YtQfdSMGw&ab_channel=Csavez 
 


Can you express how is he doing it differently? To my eyes he isn't doing anything very abnormal. Yes, he is cutting some little partitions little different than the manual tells to but in the end all the pads are in the same spots as in the manual (atleast in my eyes. Please tell me if you see something that I don't :p) I installed the way the manual told to and I had very good contact on every pad. My card ran perfect around 2 months before the installation and about two hours after the installation. After about 2 hours, suddenly got artifacts on desktop and the card died. Error 97 on Asus board and error B2 on MSI board etc. The strange thing is that my card worked for a while and it survived couple timespy extreme runs etc. Then out of nowhere artifacts on desktop and the card was dead.
 
Personally I wouldn't be surprised if after all this would be caused because Evga's poor pcb quality (the sum of some cheap components and poor soldering job..?).
 
If I will get a replacement card from RMA, I will definitely not be installing the block before there is some clarification either from Evga or EK.
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 03:55:27 (permalink)
Eksu99
Filip1995
Personally, I think the real issue is the right installation of the thermal pads on the backplate, the instruction on that is pretty terrible. I saw a video of installation of the block and backplate on the ftw3 which worked out in the end and thu guy on the video installed the thermal pads very differently. Shareing the video for everyone:
 
https://www.youtube.com/watch?v=U7YtQfdSMGw&ab_channel=Csavez 
 


Can you express how is he doing it differently? To my eyes he isn't doing anything very abnormal. Yes, he is cutting some little partitions little different than the manual tells to but in the end all the pads are in the same spots as in the manual (atleast in my eyes. Please tell me if you see something that I don't :p) I installed the way the manual told to and I had very good contact on every pad. My card ran perfect around 2 months before the installation and about two hours after the installation. After about 2 hours, suddenly got artifacts on desktop and the card died. Error 97 on Asus board and error B2 on MSI board etc. The strange thing is that my card worked for a while and it survived couple timespy extreme runs etc. Then out of nowhere artifacts on desktop and the card was dead.
 
Personally I wouldn't be surprised if after all this would be caused because Evga's poor pcb quality (the sum of some cheap components and poor soldering job..?).
 
If I will get a replacement card from RMA, I will definitely not be installing the block before there is some clarification either from Evga or EK.




I mean the cutting especially. I didnt do cut outs like that on my install. Other thing I didnt do is removing the gpu bracket.  
c34webb
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2021/03/15 19:40:38
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 04:00:43 (permalink)
Seems to me it’s the thermal pads as well. But I’d think the card would **** off before it hits dangerous temps and be re-bootable with stock cooler solution. Very strange.
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 04:03:36 (permalink)
Filip1995
Eksu99
Filip1995
Personally, I think the real issue is the right installation of the thermal pads on the backplate, the instruction on that is pretty terrible. I saw a video of installation of the block and backplate on the ftw3 which worked out in the end and thu guy on the video installed the thermal pads very differently. Shareing the video for everyone:
 
https://www.youtube.com/watch?v=U7YtQfdSMGw&ab_channel=Csavez 
 


Can you express how is he doing it differently? To my eyes he isn't doing anything very abnormal. Yes, he is cutting some little partitions little different than the manual tells to but in the end all the pads are in the same spots as in the manual (atleast in my eyes. Please tell me if you see something that I don't :p) I installed the way the manual told to and I had very good contact on every pad. My card ran perfect around 2 months before the installation and about two hours after the installation. After about 2 hours, suddenly got artifacts on desktop and the card died. Error 97 on Asus board and error B2 on MSI board etc. The strange thing is that my card worked for a while and it survived couple timespy extreme runs etc. Then out of nowhere artifacts on desktop and the card was dead.
 
Personally I wouldn't be surprised if after all this would be caused because Evga's poor pcb quality (the sum of some cheap components and poor soldering job..?).
 
If I will get a replacement card from RMA, I will definitely not be installing the block before there is some clarification either from Evga or EK.




I mean the cutting especially. I didnt do cut outs like that on my install. Other thing I didnt do is removing the gpu bracket.  


Right, I didn't do the cutting that way either. However I would guess that the cutting shouldn't matter too much in the end as far as all the components are covered with the thermal pad and that the thermal pads are correct thickness. I don't see how those little tweaks in cutting would make any difference. I'm quite sure we both did the cutting alright and it shouldn't be the problem. The only problem that I could think of is the thickness of the pads but it's not in our hands either.
 
I removed the GPU bracket because Gamers Nexus did so also but I don't see why would it make any difference either. There isn't any screws going from the bracket to the cooler and as far as the bracket doesn't interference with the waterblock (it shouldn't as far as I can see), it shouldn't be a problem either.
 
EVGA FTW3 cards have been dying of different reasons here and there anyways so in the end I wouldn't be surprised if removing the cooler would be killing the cards too. That would only be a one more cherry on the cake..
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 04:06:20 (permalink)
c34webb
Seems to me it’s the thermal pads as well. But I’d think the card would **** off before it hits dangerous temps and be re-bootable with stock cooler solution. Very strange.

I agree. And as I have said, personally my card had excellent temperatures (Hwinfo64). And as you said, even if our cards were boiling, the protections should be good enough to keep the card safe from self destruction.
crestline33
New Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2021/02/20 21:22:03
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 04:13:57 (permalink)
I installed the alphacool ftw3 on my 3080 and have been running for 2 days with no problems now. Unfortunately It’s too late to get a refund from EK for my other block now or I would have. Don’t want to sell it either since I’m not certain it didn’t brick my first card, guess i’m just out $280 :/
DNAJAY
Superclocked Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2015/11/27 21:55:12
  • Status: offline
  • Ribbons : 1
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:09:21 (permalink)
c34webb
Seems to me it’s the thermal pads as well. But I’d think the card would **** off before it hits dangerous temps and be re-bootable with stock cooler solution. Very strange.


So the EK instructions have you putting the block onto the PCB. So you lay the PCB down and put the block on top it. He does it opposite where he lays the block down, and puts the PCB on it.

Seems to me that his way makes more sense. Less likely to break something. BUT I bet lots of folks did it the other way and that might account for some of the variability?
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:16:48 (permalink)
DNAJAY
c34webb
Seems to me it’s the thermal pads as well. But I’d think the card would **** off before it hits dangerous temps and be re-bootable with stock cooler solution. Very strange.


So the EK instructions have you putting the block onto the PCB. So you lay the PCB down and put the block on top it. He does it opposite where he lays the block down, and puts the PCB on it.

Seems to me that his way makes more sense. Less likely to break something. BUT I bet lots of folks did it the other way and that might account for some of the variability?



I did it like him before seeing the video. It doesnt make sesnse to put block on the pcb. There is no way to aligne the stand offs that way...
DNAJAY
Superclocked Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2015/11/27 21:55:12
  • Status: offline
  • Ribbons : 1
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:21:30 (permalink)
Filip1995
I did it like him before seeing the video. It doesnt make sesnse to put block on the pcb. There is no way to aligne the stand offs that way...


Precisely! So you got to wonder what else on those EK instructions is off. But If you did it like he did, then maybe my theory is wrong. :)
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:22:00 (permalink)
Status update:
 
EVGA shipped me the replacement day after they recieved my broken card. Really happy with the speed. However...
 
I didnt recieve any email about the RMA being honored, I just recieved tracking number and thats it. No comment about what happened to it whatsoever...  My rma history states that its completed.
 
Is this normal procedure? I would really like new information.
 
Also my replacement serial number is starting 20125... I heard that the 2014... are a bad batch... my first card was 20129... however
 
DNAJAY
Superclocked Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2015/11/27 21:55:12
  • Status: offline
  • Ribbons : 1
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:27:39 (permalink)
Filip1995
Status update:
 
EVGA shipped me the replacement day after they recieved my broken card. Really happy with the speed. However...
 
I didnt recieve any email about the RMA being honored, I just recieved tracking number and thats it. No comment about what happened to it whatsoever...  My rma history states that its completed.
 
Is this normal procedure? I would really like new information.
 
Also my replacement serial number is starting 20125... I heard that the 2014... are a bad batch... my first card was 20129... however
 


My first 3080 was a 2014. No issues other than when I took off the cooler and a capacitor popped out (like literally, that’s how far I got into the EK install).

Now I have a 2114, no problems other than now I’m seeing the MEM and PWR “glitches” where the temps are blipping to 140C in GPUZ/HWInfo. Pretty sure that’s a driver issue though. It very well have been like that on the 2014 too.
jaredbyoung
iCX Member
  • Total Posts : 317
  • Reward points : 0
  • Joined: 2020/10/15 16:42:59
  • Status: offline
  • Ribbons : 1
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:31:46 (permalink)
Eksu99
jaredbyoung
No chance I'd put an EKWB on an EVGA FTW3 3090 right now. More info is absolutely needed. Since there is no Alphacool thread like this I'd assume this is a EKWB issue with this card, but maybe Alphacool is used 10x less often so we're not hearing about it? 

This is a quite tricky situation right now. As you said, other brands’ waterblocks aren’t probably as popular as EK’s. Therefore it just might seem like there’s a problem with EK blocks.

As all we know, so far EK has not found a solid problem with their blocks. Instead they are suspecting Evga cards’ bad soldering joints or something like that and therefore the cards are dying during stock cooler disassembly.

I think that right now we would need to get information how are other people’s cards doing after disassembly (AIO installers, other brand block installers etc.). If they aren’t having the problems in the same scale or at all, there probably is something wrong with the EK blocks. However if they are having some cards dying on them the same way, the problem probably is on the Evga’s end.

EVGA's Hybrid AIO is arriving this afternoon. I'm putting it on a FTW3 Ultra 3090 that I got on Friday (via the que). I'll definitely give an update if I see anything interesting during disassembly/reassembly.
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 10:32:40 (permalink)
jaredbyoung
Eksu99
jaredbyoung
No chance I'd put an EKWB on an EVGA FTW3 3090 right now. More info is absolutely needed. Since there is no Alphacool thread like this I'd assume this is a EKWB issue with this card, but maybe Alphacool is used 10x less often so we're not hearing about it? 

This is a quite tricky situation right now. As you said, other brands’ waterblocks aren’t probably as popular as EK’s. Therefore it just might seem like there’s a problem with EK blocks.

As all we know, so far EK has not found a solid problem with their blocks. Instead they are suspecting Evga cards’ bad soldering joints or something like that and therefore the cards are dying during stock cooler disassembly.

I think that right now we would need to get information how are other people’s cards doing after disassembly (AIO installers, other brand block installers etc.). If they aren’t having the problems in the same scale or at all, there probably is something wrong with the EK blocks. However if they are having some cards dying on them the same way, the problem probably is on the Evga’s end.

EVGA's Hybrid AIO is arriving this afternoon. I'm putting it on a FTW3 Ultra 3090 that I got on Friday (via the que). I'll definitely give an update if I see anything interesting during disassembly/reassembly.


Cool! I hope you best of luck! 
HeinzNeu
New Member
  • Total Posts : 35
  • Reward points : 0
  • Joined: 2013/04/06 10:45:28
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 11:43:15 (permalink)
Yo buddy,
I removed the default cooler without testing the card and installed right away the EKWB cooling block plus back plate. 
No issues no nothing, just having a pretty good performance. You must have done something wrong installing the cooling block. 

AMD 5950X@EK-Monoblock@ ASUS Crosshair VIII Hero|EVGA FTW3 Ultra Gaming 3090 @H²O_EK_Waterblock H²O@Mo-Ra3|Corsair AV860W|4*8 GB G.Skill@3800 MHz@16-16-16 |Gigabyte Aorus NVMe Gen4| Cooler Master CoSmoS II |LG UltraGear 38GL950G-B, 37.5" |Win 10 Prof. 64 bit
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 12:01:41 (permalink)
HeinzNeu
Yo buddy,
I removed the default cooler without testing the card and installed right away the EKWB cooling block plus back plate. 
No issues no nothing, just having a pretty good performance. You must have done something wrong installing the cooling block. 

According to EK, statistically the majority of the cards work fine after water block installation, just like yours. However there seem to be quite a few identical break downs after either removal of the stock cooler or after installation of EK block/backplate. So far it is unclear what is the root cause of the problem.

Anyways I strongly believe that not everyone of us who had our cards dying after installation, made an error. For example my card worked after installation but out of nowhere suddenly died. I am quite sure I didn’t break the card during the installation because if I did, why would it work afterwards?

Your message didn’t bring any content to the discussion. I think you are just being a d**c because your card worked and ours didn’t for some reason. I really hope your card won’t die..
crestline33
New Member
  • Total Posts : 36
  • Reward points : 0
  • Joined: 2021/02/20 21:22:03
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 13:20:17 (permalink)
Pretty sure you just got lucky Heinz. There are dozens of people reporting this issue when installing the ek blocks. No need to rub it in people’s faces that you got lucky with your install. I have installed 7 waterblocks on GPUs since I started building pcs and never had an issue until this ek block, i’ve used alphacool, bitspower and heatkiller and had zero problems with them. Either way your coming on here to boast and brag that your installation was successful is just ignorant. If you weren’t providing any helpful info toward our problem you should have just kept on scrolling.
Spurious_ECG
Superclocked Member
  • Total Posts : 172
  • Reward points : 0
  • Joined: 2020/07/24 16:42:44
  • Location: Canada
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 18:13:40 (permalink)
I have not been able to get my 3090 FTW3 Ultra working unfortunately after having tried everything mentioned. Of course I did the same procedure as the guy in the video, doing it the opposite way makes no sense. Plan on putting my 3080 FTW3 Ultra back on the EK water block since I think the problem is unique to my 3090. Will start the RMA process tomorrow which is too bad, at least EVGA has the best policies. Hopefully the same issue doesn't crop up with the Kingpin card, but I'm guessing it should be fine.


HeinzNeu
New Member
  • Total Posts : 35
  • Reward points : 0
  • Joined: 2013/04/06 10:45:28
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/16 23:23:55 (permalink)
Eksu99
HeinzNeu
Yo buddy,
I removed the default cooler without testing the card and installed right away the EKWB cooling block plus back plate. 
No issues no nothing, just having a pretty good performance. You must have done something wrong installing the cooling block. 

According to EK, statistically the majority of the cards work fine after water block installation, just like yours. However there seem to be quite a few identical break downs after either removal of the stock cooler or after installation of EK block/backplate. So far it is unclear what is the root cause of the problem.

Anyways I strongly believe that not everyone of us who had our cards dying after installation, made an error. For example my card worked after installation but out of nowhere suddenly died. I am quite sure I didn’t break the card during the installation because if I did, why would it work afterwards?

Your message didn’t bring any content to the discussion. I think you are just being a d**c because your card worked and ours didn’t for some reason. I really hope your card won’t die..

Well, I deeply regret the posted issues.
My posting wasn't meant to be rude. I just answered the question on the first side, if anybody else had these issues. So I reported my story without any cynical remarks. I know about the "mysteries" screwing with electronical stuff.
Just put my posting as a "no" to his question. Nothing else was meant...
I hope you can come down with that. 
post edited by HeinzNeu - 2021/03/16 23:29:37

AMD 5950X@EK-Monoblock@ ASUS Crosshair VIII Hero|EVGA FTW3 Ultra Gaming 3090 @H²O_EK_Waterblock H²O@Mo-Ra3|Corsair AV860W|4*8 GB G.Skill@3800 MHz@16-16-16 |Gigabyte Aorus NVMe Gen4| Cooler Master CoSmoS II |LG UltraGear 38GL950G-B, 37.5" |Win 10 Prof. 64 bit
LargePuppy
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/10/14 11:21:30
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/17 14:21:54 (permalink)
Hope we come to some sort of resolution with these EKWB waterblocks... would very much love to silence the fan on this behemoth!
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/17 14:24:12 (permalink)
My replacement is gonna be delivered tomorrow. But I will not be trying to put the block on before there is some statement issued by evga or ekwb...
Spurious_ECG
Superclocked Member
  • Total Posts : 172
  • Reward points : 0
  • Joined: 2020/07/24 16:42:44
  • Location: Canada
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/17 15:29:14 (permalink)
Similar here for me, I started the RMA process and just bought a loop just to easily test my HC stock when I get a replacement. Though, I will still disassemble to repaste with KPX since the stock paste is trash and reassemble on the HC block. Might just put the EK block back on the 3080 FTW3 Ultra to be safe, though I'm running it on air until the weekend. The HC block is very nice but doesn't match my system as well and the EK kills it for looks (who doesn't like seeing the PCB and a mirror-like metal backplate?). But the more water cooling, the better :)


Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 05:28:32 (permalink)
Status update:

The replacement has arrived and I gotta say, EVGA deserves all praise for their RMA service.

EVGA has sent me new card, even when I originally purchased the card 4 months ago. I am really pleased with the outcome. It even has a black lips, originally I had the red version.

However, not gonna try to install the waterblock before some official statement is released by either side. Not gonna push my luck.

I feel confident with this card, its SN 20125... from china ( originally I has 20129 from taiwan). The chinese ones are supposed to be better overclockers as I read the forums.

Still, I have support ticket opened about the wb issue and if anything comes up, I will be updating
Eksu99
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2020/09/03 08:16:45
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 05:30:49 (permalink)
Filip1995
Status update:

The replacement has arrived and I gotta say, EVGA deserves all praise for their RMA service.

EVGA has sent me new card, even when I originally purchased the card 4 months ago. I am really pleased with the outcome. It even has a black lips, originally I had the red version.

However, not gonna try to install the waterblock before some official statement is released by either side. Not gonna push my luck.

I feel confident with this card, its SN 20125... from china ( originally I has 20129 from taiwan). The chinese ones are supposed to be better overclockers as I read the forums.

Still, I have support ticket opened about the wb issue and if anything comes up, I will be updating

Nice to hear. Hopefully the waterblock issue will be resolved.

I’m still waiting for my replacement. Shouldn’t have gone throught retailer for RMA. Been like 4 weeks :D
Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 05:42:00 (permalink)
Eksu99
Filip1995
Status update:

The replacement has arrived and I gotta say, EVGA deserves all praise for their RMA service.

EVGA has sent me new card, even when I originally purchased the card 4 months ago. I am really pleased with the outcome. It even has a black lips, originally I had the red version.

However, not gonna try to install the waterblock before some official statement is released by either side. Not gonna push my luck.

I feel confident with this card, its SN 20125... from china ( originally I has 20129 from taiwan). The chinese ones are supposed to be better overclockers as I read the forums.

Still, I have support ticket opened about the wb issue and if anything comes up, I will be updating

Nice to hear. Hopefully the waterblock issue will be resolved.

I’m still waiting for my replacement. Shouldn’t have gone throught retailer for RMA. Been like 4 weeks :D


Yeah, I believe you, I was deciding if to go to retailer too. Glad I didnt. This was the fastest RMA I ever experienced. Delivered them the card on 15.3. On 16.3. They sent the replacement, 18.3 Its here. Really professional. One nitpick is that they didnt tell me anything about the card I rmaed.
DNAJAY
Superclocked Member
  • Total Posts : 106
  • Reward points : 0
  • Joined: 2015/11/27 21:55:12
  • Status: offline
  • Ribbons : 1
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 07:52:19 (permalink)
Filip1995
Status update:

The replacement has arrived and I gotta say, EVGA deserves all praise for their RMA service.

EVGA has sent me new card, even when I originally purchased the card 4 months ago. I am really pleased with the outcome. It even has a black lips, originally I had the red version.

However, not gonna try to install the waterblock before some official statement is released by either side. Not gonna push my luck.

I feel confident with this card, its SN 20125... from china ( originally I has 20129 from taiwan). The chinese ones are supposed to be better overclockers as I read the forums.

Still, I have support ticket opened about the wb issue and if anything comes up, I will be updating


Good call. I can’t speak for EVGA, but I was worried my luck would run out if I tried it again and the card failed again. If that were to happen, you’d be paying those scalper prices to get back in the game. Enjoy your card, maybe consider getting a HC.
Spurious_ECG
Superclocked Member
  • Total Posts : 172
  • Reward points : 0
  • Joined: 2020/07/24 16:42:44
  • Location: Canada
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 15:06:36 (permalink)
Haha imagine being a power user and being told:
"If applicable, please test without using any riser or power extension cables/adapters. 
If possible, try testing the card in a different PCIe slot on the motherboard.
If available, try a different set of separate PCIe cables from the power supply.
If possible, please test the graphics card in a different system or swap in a similar powered known good graphics card to verify if the same issues still occur and help narrow down the cause."
 
Never used a riser, can't imagine ever using one and especially not with PCIe gen 4.0.
Tested the card in a completely different system.
Really? The EVGA 1000W P2/850W P2 power cables aren't the problem since the KP card I just received today works fine too.
Mentioned that my 3080 FTW3 Ultra works in the same slot with the EK waterblock in my question. Don't think support even bothered to read it at this point.
 
I just wanted a number to RMA the card or an actual solution to the problem.


Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 15:22:53 (permalink)
Spurious_ECG
Haha imagine being a power user and being told:
"If applicable, please test without using any riser or power extension cables/adapters. 
If possible, try testing the card in a different PCIe slot on the motherboard.
If available, try a different set of separate PCIe cables from the power supply.
If possible, please test the graphics card in a different system or swap in a similar powered known good graphics card to verify if the same issues still occur and help narrow down the cause."
 
Never used a riser, can't imagine ever using one and especially not with PCIe gen 4.0.
Tested the card in a completely different system.
Really? The EVGA 1000W P2/850W P2 power cables aren't the problem since the KP card I just received today works fine too.
Mentioned that my 3080 FTW3 Ultra works in the same slot with the EK waterblock in my question. Don't think support even bothered to read it at this point.
 
I just wanted a number to RMA the card or an actual solution to the problem.


Yeah, unfortunately, mediocre tech support is problem most of companies. But seriously, you cant expect a knowledgable person do a job where he answers emails all day...

Had a similar experience. I listed all fixes I already tried before contacting the tech support. Of course the support rep. repeated most of them. It pissed me off, so I forward the response to the support manager, saying the support rep didn't even bother to read my ticket fully. I got an answer from the support manager that the support rep also told me to try things I didnt mentioned in my ticket, like it changes anything that the answer was generic at best. At that point I just tried to get over with the RMA as fast as possible.

I still have an open ticket with my question about safety of a disassembly and installation of the EK waterblock. Also forwarded them EKs position on weak pcb and solder points.

They didnt respond for 3 days now, which is odd. Hopefully, there is actually going on some investigation in EVGA
Spurious_ECG
Superclocked Member
  • Total Posts : 172
  • Reward points : 0
  • Joined: 2020/07/24 16:42:44
  • Location: Canada
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 15:36:47 (permalink)
I'm hoping there is also an investigation, like I said the 3090 FTW3 PCB is the exact same as the 3080 FTW3 PCB, but just fully filled out. So if EK is to blame it would be very surprising since they matched both designs. That said, EVGA is unlikely to be at fault since most users never disassemble their cards to repaste, yet alone put a third party block on so this is not a typical use case of tossing it in a case and never touching it again. Also it's unlikely to be an inherent design flaw since the card is the same basic design as the 3080 FTW3 which doesn't appear to have the same issue, at least not to the extent of the 3090 FTW3.
 
I'd agree with your assessment, it's likely a manufacturing flaw or at least an oversight unique to the 3090 FTW3 construction process for some reason. I don't mind waiting for the RMA process to go through, as long as the warranty is honoured and given EVGA's reputation I'm not too worried about that.


Filip1995
New Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2020/10/17 12:57:58
  • Status: offline
  • Ribbons : 0
Re: RTX 3090 EVGA FTW 3 - Ekwb Waterblock install - Not booting 2021/03/18 15:52:34 (permalink)
Not only 3090s are bricked after disassembly. 3080s too, like in my case.

The EKs assessment about weak pcb is really the most probable cause. Of course the disassembly and waterblock installation is not the original purpose of the card. But they should be made to withstand it. Thats why EVGA keeps warranty is intact even when you disassemble the card. They wouldn’t have such a policy, if they weren’t confident about it.
Page: < 12345.. > >> Showing page 5 of 28
Jump to:
  • Back to Mobile