EVGA

Hot!Hdmi port not working on gpu

Author
Maxdehaas9
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2018/11/03 07:16:09
  • Status: offline
  • Ribbons : 0
2018/12/04 02:31:36 (permalink)
Yesterday i finished my first pc build. When i plugged everything in to start it for the first time, I didn't get footage on my monitor. I connected my graphics card and monitor with an hdmi cable, and i am confident that the cable works. While i haven't tried with the ondboard graphics i will do it later today. But that doesn't really fix the issue.

I use an EVGA rtx 2070 xc gaming. Did someone else had this problem happen, does anyone know how to fix it? The leds are working so it should have power.

I would like to thank everybody for giving the time to read and answer.
#1

12 Replies Related Threads

    bobmitch
    CLASSIFIED Member
    • Total Posts : 3882
    • Reward points : 0
    • Joined: 2007/05/07 09:36:29
    • Status: offline
    • Ribbons : 32
    Re: Hdmi port not working on gpu 2018/12/04 06:41:53 (permalink)
    Make sure that onboard graphics is disabled in your bios.  Even set to "Auto" may be an issue.  

    EVGA X299 FTW K with i7 7820X; EVGA RTX 2080TI XC Black; EVGA CLC 280 AIO Cooler; 32 GB Gskill Ripjaws V DDR4-3200; Samsung 512GB 960 Pro NVMe; Creative SoundBlaster Z; Corsair HX 850i; Pioneer BDR-2209; Corsair Obsidian 750 D Airflow; Tte Poseidon Z Brown Switch Ed. Keyboard; and Logitech G903 Lightspeed Mouse
    Heatware:  http://www.heatware.com/eval.php?id=72402     
     


    #2
    Maxdehaas9
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/11/03 07:16:09
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2018/12/04 09:01:15 (permalink)
    bobmitch
    Make sure that onboard graphics is disabled in your bios.  Even set to "Auto" may be an issue.  
    oke thank you i will try this and many other options i heard from people i will let you know if it worked
    #3
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 17483
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 113
    Re: Hdmi port not working on gpu 2018/12/04 09:24:53 (permalink)
    What MB & CPU ?


    Make sure the Monitor is set to "auto detect input" Or the HDMI input is selected.
     
    You have to use the Monitors on screen controls
     
    Monitor has been used before ?
     
    Monitor indicates power ? (usually LED)  
     
    Test outlet your using with a lamp or other device, to make sure its not controlled by a switch. 
     
    I've got several outlets where the bottom is always On & the Top outlet is controlled by a wall switch
     
     

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #4
    Maxdehaas9
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/11/03 07:16:09
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2018/12/07 18:53:21 (permalink)
    I know the monitor works and the settings were ok, i tried to connect the pc on multiple things
    #5
    Mustard_Gas123
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/09/04 19:55:56
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2019/09/16 01:53:16 (permalink)
    This might be an old thread but i have the same problem, it doesnt detect my evga rtx 2060 super sc ultra gaming at all, it works with my gtx 1050 ti though, why!
    #6
    Sajin
    EVGA Forum Moderator
    • Total Posts : 38519
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: Hdmi port not working on gpu 2019/09/17 21:01:00 (permalink)
    Mustard_Gas123
    This might be an old thread but i have the same problem, it doesnt detect my evga rtx 2060 super sc ultra gaming at all, it works with my gtx 1050 ti though, why!


    Card could have a faulty hdmi output.



    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #7
    Mustard_Gas123
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/09/04 19:55:56
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2019/09/18 03:24:55 (permalink)
    could the display port work if i get a display port cable
    #8
    Sajin
    EVGA Forum Moderator
    • Total Posts : 38519
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: Hdmi port not working on gpu 2019/09/18 08:43:16 (permalink)
    Mustard_Gas123
    could the display port work if i get a display port cable


    Yep.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #9
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 17483
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 113
    Re: Hdmi port not working on gpu 2019/09/18 09:57:19 (permalink)
    Mustard_Gas123
    This might be an old thread but i have the same problem, it doesnt detect my evga rtx 2060 super sc ultra gaming at all, it works with my gtx 1050 ti though, why!


    Did you remove the Nvidia driver before changing cards ?
     
    Have you tried a power flush - shut down - unplug - hold start button 30 sec to discharge all capacitors - plug in & restart
     
    Windows - Fast StartUp turned off ?

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #10
    Mustard_Gas123
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/09/04 19:55:56
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2019/09/18 19:53:43 (permalink)
    I removed the Nvidia driver it didn't work,
    I'll try the power flush,
    and windows fast start up how will that help, i have 1tb of ssd.
    #11
    Mustard_Gas123
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/09/04 19:55:56
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2019/09/18 20:05:05 (permalink)
    I mean it worked on my gtx 1050 ti, so why is it not working on my rtx 2060 super xc
    #12
    Mustard_Gas123
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/09/04 19:55:56
    • Status: offline
    • Ribbons : 0
    Re: Hdmi port not working on gpu 2019/09/18 22:47:36 (permalink)
    It worked on my 1050 ti
    #13
    Jump to:
  • Back to Mobile