EVGA

Hot!EVGA Z77/Z75 Motherboards - BIOS 1.22 Released

Page: < 12345 > Showing page 4 of 5
Author
nouguifred
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2011/11/03 08:35:52
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/09/11 10:15:13 (permalink)
Hello,
i've read all the thread but i haven't found an answer for me
 
I just bought some crucial ram at 1866 mhz, and it was not well recognized (only 1333mhz)
i tought that a flash bios would be an issue but i can't flash it, neither the two options.
when i try to flash, a window open and say that the computer will stop

 
Can you help me, i've sent also an email to the support.
 
 
#91
HAZMAN_THE_GREAT
CLASSIFIED Member
  • Total Posts : 4872
  • Reward points : 0
  • Joined: 2011/12/01 04:40:46
  • Location: Planet Earth
  • Status: offline
  • Ribbons : 7
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/10/04 04:07:48 (permalink)
nouguifred
Hello,
i've read all the thread but i haven't found an answer for me

I just bought some crucial ram at 1866 mhz, and it was not well recognized (only 1333mhz)
i tought that a flash bios would be an issue but i can't flash it, neither the two options.
when i try to flash, a window open and say that the computer will stop


Can you help me, i've sent also an email to the support.



Try this if you have not already.
 
First download the latest BIOS from our website (http://www.evga.com/support/download/)
Next create a folder in your C:\ drive called BIOS.
Extract all the files in the ZIP folder to C:\BIOS (Note: just copy the files themselves and the sub-folders.  Do not put the files in a folder in the BIOS folder.)
Under Start->All Programs->Accessories right click on the Command Prompt icon and select "Run as administrator".
Type CD\ (Enter) <- means push enter
Type CD BIOS (Enter)
Type fptwin(32/64).bat (Enter)
type: fptwin64.bat   (type this if you have 64 bit OS)   no spaces
The utility should now flash the BIOS. You can follow the same steps to flash the other BIOS' on the board if you desire.


#92
JoeyC
EVGA Alumni
  • Total Posts : 1703
  • Reward points : 0
  • Joined: 2012/02/22 09:56:36
  • Location: EVGA Brea
  • Status: offline
  • Ribbons : 4
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/10/04 11:53:20 (permalink)
nouguifred
Hello,
i've read all the thread but i haven't found an answer for me

I just bought some crucial ram at 1866 mhz, and it was not well recognized (only 1333mhz)
i tought that a flash bios would be an issue but i can't flash it, neither the two options.
when i try to flash, a window open and say that the computer will stop

Can you help me, i've sent also an email to the support.

The reason it was recognized at 1333mhz is due to the default memory controller on your CPU. You can attempt to achieve the 1866mhz by setting your memory timings, frequency and voltage in BIOS. I have uploaded a picture of what options you need to change. First change you will need to click Overclocking tab>Memory Configuration. Then change Performance Memory Profile to Manual, then Memory Frequency Limiter to 1866. Set the timings of your memory, the first four tcl, tRCD, tRP and tRAS to the rated speed of your RAM sticks. Then make sure to set the Dimm voltage which is located back on the overclocking tab. Hope this helps and if you have any other questions feel free to post back. 

Attached Image(s)


Rate my service by going to: http://www.evga.com/myevga/rateus/

#93
WickdKittie
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2013/03/24 09:30:17
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/11 22:20:47 (permalink)
lowe0
vinhus

Any instruction to flash  this bios under win8 Pro ??? every time I  enter ' Y " and hit 'Enter" the system automatically shut down  .!!!

Thanks

Right click the lower left corner of the desktop, choose command prompt (admin), and then run fptwin64 from the command prompt instead of double clicking it. You'll need to know the "cd" command (easy to understand from Google if you didn't use it in the DOS days), but that's about it.

Having same issue here but on Windows 7 Home Premium. Should I also use command prompt? Thanks!
#94
JoeyC
EVGA Alumni
  • Total Posts : 1703
  • Reward points : 0
  • Joined: 2012/02/22 09:56:36
  • Location: EVGA Brea
  • Status: offline
  • Ribbons : 4
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/12 06:00:35 (permalink)
If you are having the same issue, then I would follow this FAQ: http://www.evga.com/support/faq/afmmain.aspx?faqid=59335. This will guide you through a different way to do the BIOS flash. 

Rate my service by going to: http://www.evga.com/myevga/rateus/

#95
junghun
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2013/11/18 20:48:32
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/18 20:58:03 (permalink)
ok, i have a z77 ftw, 2600k and this bios, I was able to set mem to stock 1600 and get it to post finally at stock cpu speed.  followed the quick overclocking guides   and here   but no matter what i do i cant get the cpu to overclock. either just blue screen crashes, or even worse, wont even save the setting and just goes to black screen. after i try to set it up in the bios. im probably missing something small, cause it seems like there should be no problem for this board  to overclock the cpu to lets say 4.3-4.5. i run a h100i and live in cali, so im not trying to go crazy, just a nice conservative day to day clock. if you could please cover the new bios and any new things i should be aware of bc im using a sandy instead of an ivy please help. thank  you guys. 
post edited by junghun - 2013/11/18 21:00:40
#96
junghun
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2013/11/18 20:48:32
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/18 21:23:25 (permalink)
ive tried with eist on and off, ia core current at 896 and 2050 with the corresponding settings but tried with pll on and off. anytime i make a small change i see if it posts, and it does until i change the multiplier. once i change the multiplier to manual it just wont work. i have a h100i and set the mulitplier to a conservative 4.0 just to see if it posts but it just wont work
 
#97
Monster_Sausage
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2010/09/30 14:03:26
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/22 18:42:06 (permalink)
Muromets
The 1.22 bios on z77ftw runs my i2700K @ 4.8Ghz stable with 1.4v.

What setting are you using?  Having issues.  Just got some 2133 memory and can't get it to run past 1066.
#98
junghun
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2013/11/18 20:48:32
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/22 22:08:50 (permalink)
Thanks for the reply, I was able to get it working with another members help on the z77 ftw overclocking guide thread. I got it stable at 4.5 with ram running at 1333.  you can see the settings and replies here:  
#99
junghun
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2013/11/18 20:48:32
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/22 22:09:50 (permalink)
wont let me post the link to the page so here's what i wrote:
 
ok i set the ram to
[user defined]
[133]
[auto]
and frequency reads  1333 mhz
 
c1e disabled
 
cpu votage(1/256) auto
ia core current 2040
eist enabled
turbo mode enabled
 
power limit 1 2040
power limit 2 2040
 
c3, c6, c7 disabled
 
long duration power limit 255
long duration maintained 120
short duration power limit 255
 
acpi t state disabled
 
cpu multiplier manual
cpu multiplier setting 45
 
vdroop disabled
ocp disabled
oc mode disabled
evga performance tweak disabled
evgauge disabled
internal pll voltage override enabled
 
current vcore 1300
current vdimm 1500
 
auto....auto...auto
 
tried at 4.0 and there was no problems, tried at 4.6 and crashed, but temps seemed to be ok. maybe needs more voltage? temps at 4.5 are around 59 - 62C and mobo says 71 - 75. but no crashes. so ram is a little slower at 1333 but at least im on my way. any more tips would be greatly appreciated. thank you Vlada011. 
 
junghun
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2013/11/18 20:48:32
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/11/22 22:15:20 (permalink)
ive tried setting the ram 1600 manually and with xmp but both did not work, was going to mess with more voltage and timings but clearing cmos and trying to save profiles and all that has been unpleasant to say the least. so for now since its stable (stress tested with prime 95 for 3hrs). its good for now. might try again this weekend to tweak the ram to get it to stock 1600 if i have time. i hope you're able to get your ram to 2133.  if you figure it out please share. 
 
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/12/30 19:24:45 (permalink)
Where is our GUI BIOS??? 
We want same as X79 series... 

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
tracidtrax
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2008/09/12 20:28:40
  • Location: Australia
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/12/31 05:46:42 (permalink)
guys im trying to flash my Z77 FTW to the latest version and when i run the x64 bat script and push "Y" it just says Windows is shutting down and then it shuts down, nothing else happens.
 
I have tried this on both clean installs of Windows 7 x64 and Windows 8.1 x64, both do the same thing.
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2013/12/31 06:52:36 (permalink)
After you press Y and ENTER nothing happen...
You don't see some installation process in Command Promt after start fptwin64????

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
tracidtrax
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2008/09/12 20:28:40
  • Location: Australia
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/02 02:53:43 (permalink)
Vlada011
After you press Y and ENTER nothing happen...
You don't see some installation process in Command Promt after start fptwin64????




No, I just typed that in my post. It doesn't do anything except Windows just gracefully shuts down...
tracidtrax
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2008/09/12 20:28:40
  • Location: Australia
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/02 03:04:33 (permalink)
My current BIOS version is E699 1.04 x64 so its fairly out of date. Like i said I've tried to flash BIOS with clean installs of Windows 7 x64 and Windows 8.1 x64 using the fptwin64.bat file contained in the E699_122 zip file. After I push the "Y" key it just shuts down.
 
I now tried the 1.21 update and it does the exact same thing. The cmd window closes and shuts down again. Why does this thing not have a log file so i can see why its not working?
 
I also had a EVGA GTX 670 FTW fail on me last week, so far not really impressed with EVGA. I've paid a premium for these parts and they don't even work properly!
post edited by tracidtrax - 2014/01/02 03:10:26
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/02 19:30:54 (permalink)
Check this topic and try to flash BIOS with USB Flash Boot Device
 
http://forums.evga.com/tm.aspx?m=1142390
 
 
 
 
 
 
 

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
rangiroa
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2014/01/13 08:52:54
  • Location: FRANCE
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/13 09:54:40 (permalink)
tracidtrax
My current BIOS version is E699 1.04 x64 so its fairly out of date. Like i said I've tried to flash BIOS with clean installs of Windows 7 x64 and Windows 8.1 x64 using the fptwin64.bat file contained in the E699_122 zip file. After I push the "Y" key it just shuts down.
 
I now tried the 1.21 update and it does the exact same thing. The cmd window closes and shuts down again. Why does this thing not have a log file so i can see why its not working?
 
I also had a EVGA GTX 670 FTW fail on me last week, so far not really impressed with EVGA. I've paid a premium for these parts and they don't even work properly!


 
you can try activating the full administrator mode of Windows 8.1Pro edition. Attention after the update do not forget to turn it off.
 
WIN + R and then executes the command "lusrmgr.msc" then activates the selected administrator account.
 
Then changes on the account to make full administrator account. Makes your updated bios. After disables the account.
 
sorry for the french version :
 

 
post edited by rangiroa - 2014/01/13 10:22:30

EVGA Z77 Stinger / INTEL i7 3770K / Swiftech H220 / EVGA GTX770 SC 2Go
Gunyami
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2012/03/29 09:36:33
  • Status: offline
  • Ribbons : 0
Re: EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/26 14:20:36 (permalink)
anyone knows what is the intel orom version that comes with the latest bios?
corndogg18
iCX Member
  • Total Posts : 288
  • Reward points : 0
  • Joined: 2008/05/22 11:19:55
  • Location: Minnesota
  • Status: offline
  • Ribbons : 2
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/27 13:26:39 (permalink)
Vlada011
Where is our GUI BIOS??? 
We want same as X79 series... 


I am also wondering the same thing, will there ever be any more bios upgrades in the future? Or is this project done?

Specs:
EVGA X99 Classified Mobo
Intel I7 5960x @ 4.3Ghz
Corsair H100i CPU Cooler
8x4GB (32GB) G.Skill Ripjaws 4  @
2400Mhz 15-15-15-35 @ 1.20V
2x EVGA 580 Classifieds 3GB SLI  @ 900Mhz
Intel 750 series 1.2TB AIC SSD (Main Drive)
Intel 730 Series 480GB SSD (Storage Drive)  
Corsair AX1200 PSU
Corsair Obsidian Series 650D Case 
Corsair K70 RGB Keyboard
EVGA TORQ X10 Mouse

LazySoft
Superclocked Member
  • Total Posts : 185
  • Reward points : 0
  • Joined: 2010/06/03 12:51:59
  • Location: Sweden
  • Status: offline
  • Ribbons : 6
Re: EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/01/27 22:35:05 (permalink)
Gunyami
anyone knows what is the intel orom version that comes with the latest bios?


In this thread you will find a custom BIOS for Z77 FTW with the latest Intel ORom.
http://forums.evga.com/tm.aspx?m=1981698
 



Lazy or not Lazy. That's not a question.
BrettAJSr
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2012/12/08 22:14:12
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/29 13:36:41 (permalink)
Jacob, the download link is broken. I've tried in both IE and Chrome with no luck.

Case: Cooler Master Cosmos II
MB: ASUS RIVEBE
Memory: 32GB Dominator Platinum @ 2133MHz
GPU: EVGA GTX 680+ 4GB SLi'd
PSU: EVGA SUPERNOVA 750G
CPU: Intel Core i7-4930K @ 3.4GHz Stock voltage
Cooling: Corsair H110 
Win 8.1 SSD: Corsair Neutron GTX 120GB
Primary Games SDD: Corsair Neutron GTX 240GB 
Misc SSD: Corsair Neutron GTX 240GB
Storage HDD: Toshiba 1TB
Monitor: HP 27Xi LED IPS
Speaker: Logitech Z506 5.1
Firestrike: TBD
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/29 15:08:34 (permalink)
BrettAJSr
Jacob, the download link is broken. I've tried in both IE and Chrome with no luck.




You need to download something???
What??

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
BrettAJSr
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2012/12/08 22:14:12
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/29 16:16:45 (permalink)
Vlada011
BrettAJSr
Jacob, the download link is broken. I've tried in both IE and Chrome with no luck.




You need to download something???
What??




I'm trying to download the 1.22 Bios but each attempt, my browser reports the link as broken. I just attempted right from the download section on evga.com and that page too reports link as broken.

Case: Cooler Master Cosmos II
MB: ASUS RIVEBE
Memory: 32GB Dominator Platinum @ 2133MHz
GPU: EVGA GTX 680+ 4GB SLi'd
PSU: EVGA SUPERNOVA 750G
CPU: Intel Core i7-4930K @ 3.4GHz Stock voltage
Cooling: Corsair H110 
Win 8.1 SSD: Corsair Neutron GTX 120GB
Primary Games SDD: Corsair Neutron GTX 240GB 
Misc SSD: Corsair Neutron GTX 240GB
Storage HDD: Toshiba 1TB
Monitor: HP 27Xi LED IPS
Speaker: Logitech Z506 5.1
Firestrike: TBD
BrettAJSr
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2012/12/08 22:14:12
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/29 16:19:09 (permalink)
This is the error I receive. Downloading for Z77 FTW

Oops! Google Chrome could not connect to ftp.evga.com


Case: Cooler Master Cosmos II
MB: ASUS RIVEBE
Memory: 32GB Dominator Platinum @ 2133MHz
GPU: EVGA GTX 680+ 4GB SLi'd
PSU: EVGA SUPERNOVA 750G
CPU: Intel Core i7-4930K @ 3.4GHz Stock voltage
Cooling: Corsair H110 
Win 8.1 SSD: Corsair Neutron GTX 120GB
Primary Games SDD: Corsair Neutron GTX 240GB 
Misc SSD: Corsair Neutron GTX 240GB
Storage HDD: Toshiba 1TB
Monitor: HP 27Xi LED IPS
Speaker: Logitech Z506 5.1
Firestrike: TBD
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/29 19:02:48 (permalink)

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
BrettAJSr
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2012/12/08 22:14:12
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/30 17:26:42 (permalink)
Vlada011
BIOS 1.22

 
BIOS 1.21

 
BIOS 1.17

 
BIOS 1.12

 
BIOS 1.10

 
BIOS 1.09 BETA

 
BIOS 1.07 BETA

 
BIOS 1.05 BETA

 
BIOS 1.04 BETA

 
This is everything what I saw for EVGA Z77 FTW (E699), BIOS 1.21 was remove fast because some errors probably, I don' t remember.
 
 
 
 
 




Great info! Thanks Vlada011. Anything else you'd like to share? I'd like to get the MOST out of this board. Does it work well with your Ti?

Case: Cooler Master Cosmos II
MB: ASUS RIVEBE
Memory: 32GB Dominator Platinum @ 2133MHz
GPU: EVGA GTX 680+ 4GB SLi'd
PSU: EVGA SUPERNOVA 750G
CPU: Intel Core i7-4930K @ 3.4GHz Stock voltage
Cooling: Corsair H110 
Win 8.1 SSD: Corsair Neutron GTX 120GB
Primary Games SDD: Corsair Neutron GTX 240GB 
Misc SSD: Corsair Neutron GTX 240GB
Storage HDD: Toshiba 1TB
Monitor: HP 27Xi LED IPS
Speaker: Logitech Z506 5.1
Firestrike: TBD
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10113
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 10
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/30 19:45:34 (permalink)
I tried different cards on this board, four to be precise...
HD5870, GTX580, GTX780 and GTX780Ti and yes all of them work in proper speed PCIE 2.0 or PCIE 3.0 depend of graphics and points are normal as on other boards.

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
 
https://xdevs.com/guide/2080ti_kpe/#intro
 
 
 

 
 
_corTEC
New Member
  • Total Posts : 50
  • Reward points : 0
  • Joined: 2010/11/27 10:00:58
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/03/31 15:33:48 (permalink)
I don't think that the infos in the bios are good enough!! I can't stress this enough!! Is there no way these can be improved somehow!!?? I am not ****in' talking a full gui just some IN-DEPTH goddamn info.
 
PLL, VOLTAGES, MEMORY SETTINGS, WHAT THE **** IS GOING ON!!??
 
I know that the text has improved since last releases?? What holds back the budding BIOS file writer from elaborating more on delicate prose which should heighten my senses and let me revel in the sheer pleasantry of the habitable learning environment which you have so lovingly created for me.. Is it a file size thang' (Yeah, that's slang, not mis-spelt. Or is that missplelt? What the ****!? HOw do you spell mispletlltlsmsmiipsosposeltltlltlt!!!!!!!!!!
 
 
AaaarrghgghhghghhhhhhhhhhhhhhhhH!!!!!!!
mstng123
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2012/11/21 17:08:37
  • Status: offline
  • Ribbons : 0
Re:EVGA Z77/Z75 Motherboards - BIOS 1.22 Released 2014/04/08 17:06:23 (permalink)
Hey guys.  hoping some one on this forum can help me.  I installed a TP-LINK TL-WDN4800 wireless pci-e adapter on pci-e x1 slot.  Unfortunately the MB doesn't seem to like it.  It stops boot and show code 94.  MB is on BIOS (1.22) I cleared CMOS as suggested by tech support, and unfortunately still have the same problem.
 
Odd part thou, is that the pc will boot if I switch to BIOS 2 (1.07) original bios.  Any ideas on how I can fix this problem and still use BIOS 1.22 ? 

Motherboard - Z77 FTW  (bios 1.17) // Video - GTX 660 Ti superclocked 3gb
CPU - Intel i7-3770k  // Memory - - Intel Extreme Masters 1866 16gb (2x8gb)
Intel 240gb - SSD (windows 7 64bit) // 500 HD - Programs / Storage // 160 HD - OSX Lion
PSU - - OCZ Zx1000 watt 
 
Page: < 12345 > Showing page 4 of 5
Jump to:
  • Back to Mobile