EVGA

Hot!Z370 with SSD in Legacy Mode doesn't boot drive

Author
mbmoseley
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2018/07/12 03:13:54
  • Status: offline
  • Ribbons : 0
2018/07/12 03:21:30 (permalink)
I recently replaced my MOBO with the Z370 and also added a SanDisk 512gb SSD. Not having the necessary knowledge at the time to use UEFI, I installed everything in legacy mode. My PC boots fast and runs well, but every time it reboots it says I need to add bootable media. In order to boot I have to load up the bios, and then save and restart. Mind you I don't actually change anything, just load bios and F10, and then it boots fine.
 
I saw somewhere that I should disable CSM after I get everything setup, but I admit my knowledge is lacking in this newer technology (originally built this computer almost 10 years ago).
 
Any advice would be greatly appreciated.
#1

2 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 35416
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: offline
    • Ribbons : 191
    Re: Z370 with SSD in Legacy Mode doesn't boot drive 2018/07/12 09:36:55 (permalink)
    CSM should only be disabled if you're strictly trying to run uefi only.

    Want to save 5 to 10% on your next evga purchase? No problem. Just click on my evga associates banner to save, or enter my associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #2
    blaise
    Superclocked Member
    • Total Posts : 111
    • Reward points : 0
    • Joined: 2009/03/10 21:48:56
    • Location: Sydney, Australia
    • Status: offline
    • Ribbons : 4
    Re: Z370 with SSD in Legacy Mode doesn't boot drive 2018/07/12 10:59:51 (permalink)
    When I installed my Classified K yesterday I had to enable "Legacy Boot" in the UEFI as I was using an existing install built using legacy. However, I have since changed from using a MBR to GPT which allows me to boot using UEFI. It's quite simple really; open an elevated command prompt and enter the command "mbr2gpt.exe /convert /allowfullOS". On reboot, change your UEFI boot setting from Legacy to UEFI and you're done.
     
    The info in greater detail can be found here (Intel site).
    #3
    Jump to:
  • Back to Mobile