EVGA

Hot!Anyone still having issues with artifacts + freeze with rtx 2080 ti?

Page: 1234 > Showing page 1 of 4
Author
shinobier
iCX Member
  • Total Posts : 285
  • Reward points : 0
  • Joined: 2009/01/27 20:56:22
  • Status: offline
  • Ribbons : 0
2018/10/21 13:40:21 (permalink)
Mine is still freezing with bad static noise so often. 
 
I didn't even overclock and I have latest driver from Nvidia too. I unplugged my second monitor just in case if it makes any difference since original problem of black screen was windows 10 select non-existent monitor as default. That issue seems to be fixed after latest nvidia driver released on 10/11 but my RTX 2080 TI is still freezing. I am pretty sure rest of my pc parts are good cause I never had this problem when I had gtx 1080 ti.
 
Should I just RMA the card?

Spec
I7 8700K
16GB DDR4 3000mhz RAM
EVGA RTX 2080 TI
Samsung 1TB 840 Evo SSD 
Corsair 1200 Watts Platinum PSU
#1

100 Replies Related Threads

    EVGA_Thomas123
    Superclocked Member
    • Total Posts : 151
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: EVGA
    • Status: offline
    • Ribbons : 1
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 08:50:48 (permalink)
    Hello Shinobier, 
     
     
    I'll be sending you a quick email shortly! Stand by! We'll try to get this issue resolved as soon as possible! 
     
     
    Regards,
    Thomas N.
    #2
    toncij
    Superclocked Member
    • Total Posts : 191
    • Reward points : 0
    • Joined: 2016/07/27 08:17:38
    • Location: Europe
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 13:18:46 (permalink)
    This is the level of support we love. Classic EVGA. :)
    #3
    shinobier
    iCX Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/01/27 20:56:22
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 20:04:12 (permalink)
    EVGATech_ThomasN
    Hello Shinobier, 
     
     
    I'll be sending you a quick email shortly! Stand by! We'll try to get this issue resolved as soon as possible! 
     
     
    Regards,
    Thomas N.




    Hi. I saw your email and followed direction but that still didn't work. PC froze again 20 mins into playing dragon quest xi. This happens randomly and yesterday alone happened 4 times. Half of those times, I wasn't even playing games but watching youtube video. I didn't overclock the gpu either. I am starting to worry that this may damage other parts of pc as well. Frequent sudden freeze can't be good for cpu, motherboard, ram, psu etc either. :(

    Spec
    I7 8700K
    16GB DDR4 3000mhz RAM
    EVGA RTX 2080 TI
    Samsung 1TB 840 Evo SSD 
    Corsair 1200 Watts Platinum PSU
    #4
    jayriavieock10
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/05/08 23:44:25
    • Location: OKC, OK
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 21:06:13 (permalink)
    Mine was artifacting like crazy. I ended up RMA'ing it.
     
    note, the blurriness is caused by the GPU. not my picture.

    #5
    shinobier
    iCX Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/01/27 20:56:22
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 21:09:55 (permalink)
    That looks like my case. How is your new card doing? Any problem after RMA it?
     
    I am just worried coz if I RMA it, my pc won't be usable for weeks till I get new unit. I don't suppose EVGA do advanced replacement, or do they?

    Spec
    I7 8700K
    16GB DDR4 3000mhz RAM
    EVGA RTX 2080 TI
    Samsung 1TB 840 Evo SSD 
    Corsair 1200 Watts Platinum PSU
    #6
    jayriavieock10
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/05/08 23:44:25
    • Location: OKC, OK
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 21:12:33 (permalink)
    I haven't received my RMA yet. Thankfully it's a cross ship RMA with next day delivery.
    I RMA'd it on Thursday but it didn't ship till today(Monday).
     
    Edit: just saw your other comment. Not unless you purchased the extended warranty and EAR when you registered it!
    post edited by jayriavieock10 - 2018/10/22 21:15:44
    #7
    ComboSlicer
    Superclocked Member
    • Total Posts : 246
    • Reward points : 0
    • Joined: 2016/07/25 02:51:10
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/22 21:50:51 (permalink)
    There was a mentioning in reddit that in nvidia forums there are a lot of complainers about artifacts and root cause is a batch of defective video memory (gddr6 is new adter all).


    #8
    bcavnaugh
    The Crunchinator
    • Total Posts : 32940
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 210
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 09:02:00 (permalink)
    ComboSlicer
    There was a mentioning in reddit that in nvidia forums there are a lot of complainers about artifacts and root cause is a batch of defective video memory (gddr6 is new adter all).

    Do have the Batch Number or a link to reddit that talks about it?

      Associate Code: 9E88QK5L7811G3H
    "Earn EVGA Bucks For Folding with EVGA!" it is not "Fold for EVGA Bucks with EVGA!"



    #9
    shinobier
    iCX Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/01/27 20:56:22
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 18:39:56 (permalink)
    omg.. make it stop.. I can't even do anything with this garbage now. It froze 4 times in past 1 hour.
     
    This is absolute letdown after spending $1300 on this card.. Is RMA only way? Is there no other way to fix this?
     
    I just downgraded to 411.70 as a last ditch  effort. :(
     
    Hopefully, it runs better now. I really hope it's driver issue.
    post edited by shinobier - 2018/10/23 18:52:02

    Spec
    I7 8700K
    16GB DDR4 3000mhz RAM
    EVGA RTX 2080 TI
    Samsung 1TB 840 Evo SSD 
    Corsair 1200 Watts Platinum PSU
    #10
    shinobier
    iCX Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/01/27 20:56:22
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 20:05:07 (permalink)
    OMG.. That's it. Now it won't even boot to window anymore. It's black screen of death and I can't even make it to windows menu.
     
    I took it out of my pc and put gtx 480 I was keeping in my closet for past 10 years or something and my pc is working flawlessly again.
     
    It's RTX 2080 TI that's dead. I am gonna RMA it today. This is first time in my 20 years pc building history that I have ever received any defected gpu. :(
     
    Hopefully, I get good one for RMA.
    post edited by shinobier - 2018/10/23 20:29:21

    Spec
    I7 8700K
    16GB DDR4 3000mhz RAM
    EVGA RTX 2080 TI
    Samsung 1TB 840 Evo SSD 
    Corsair 1200 Watts Platinum PSU
    #11
    shinobier
    iCX Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/01/27 20:56:22
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 20:43:10 (permalink)
    EVGATech_ThomasN
    Hello Shinobier, 
     
     
    I'll be sending you a quick email shortly! Stand by! We'll try to get this issue resolved as soon as possible! 
     
     
    Regards,
    Thomas N.




    I sent you an email. Please send me support ticket # so I can send this for RMA. I didn't expect this would happen with EVGA brand gpu. Now there goes my return shipping. Sigh.. $25 that I did not have to spend for shipping as well as 4 weeks of hardship with this card. I believed in you. sigh.. :(

    Spec
    I7 8700K
    16GB DDR4 3000mhz RAM
    EVGA RTX 2080 TI
    Samsung 1TB 840 Evo SSD 
    Corsair 1200 Watts Platinum PSU
    #12
    toncij
    Superclocked Member
    • Total Posts : 191
    • Reward points : 0
    • Joined: 2016/07/27 08:17:38
    • Location: Europe
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 22:10:02 (permalink)
    shinobier
    EVGATech_ThomasN
    Hello Shinobier, 
     
     
    I'll be sending you a quick email shortly! Stand by! We'll try to get this issue resolved as soon as possible! 
     
     
    Regards,
    Thomas N.




    I sent you an email. Please send me support ticket # so I can send this for RMA. I didn't expect this would happen with EVGA brand gpu. Now there goes my return shipping. Sigh.. $25 that I did not have to spend for shipping as well as 4 weeks of hardship with this card. I believed in you. sigh.. :(



    It's not EVGA's fault. Could've happened with any other card.
    #13
    jayriavieock10
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/05/08 23:44:25
    • Location: OKC, OK
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/23 22:36:37 (permalink)
    So far my RMA replacement is working fine. Wish I had a way to stress test the GPU memory.
    #14
    GTXJackBauer
    CLASSIFIED Member
    • Total Posts : 4397
    • Reward points : 0
    • Joined: 2010/04/19 22:23:25
    • Location: U.S.A
    • Status: offline
    • Ribbons : 23
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/24 14:34:07 (permalink)
    jayriavieock10
    So far my RMA replacement is working fine. Wish I had a way to stress test the GPU memory.





    Play a game at high res with all the eye candy at full blast.  Better yet, see if there are any benchmarks for the RTX line or use some of the older ones.

     
    (Use the Associate Code below to get 5%-10% discounts on your next purchases.)
     
    (Use this Rewards Code below when registering your EVGA products.)
      
    #15
    jayriavieock10
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/05/08 23:44:25
    • Location: OKC, OK
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2018/10/24 18:06:13 (permalink)
    Well, ran Shadow of the Tomb Raider and GTA V at the same time and had to frame scale GTA V at 150% to get it to hit up to ~9800MB of video memory usage. Didn't encounter any artifacts when that happened. But I'm still going to have to wait with this new card.
    #16
    jays_han
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/12/17 07:38:52
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/03 12:27:49 (permalink)
    How is your RMA doing? I just RMA my card and waiting on a replacement. My 2080ti FTW3 Ultra straight up died on me. Couldnt play any games without crashing within secs/mins.
    #17
    jays_han
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/12/17 07:38:52
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/03 19:31:01 (permalink)
    Did you get your RMA? Everything good with your replacement?
    #18
    Tyver
    Superclocked Member
    • Total Posts : 168
    • Reward points : 0
    • Joined: 2018/11/28 17:25:55
    • Location: Illinios
    • Status: offline
    • Ribbons : 1
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/03 19:56:00 (permalink)
    shinobier
    OMG.. That's it. Now it won't even boot to window anymore. It's black screen of death and I can't even make it to windows menu.
     
    I took it out of my pc and put gtx 480 I was keeping in my closet for past 10 years or something and my pc is working flawlessly again.
     
    It's RTX 2080 TI that's dead. I am gonna RMA it today. This is first time in my 20 years pc building history that I have ever received any defected gpu. :(
     
    Hopefully, I get good one for RMA.


     
     
    This chain of events is exactly what happened with my card before I had to RMA it. I mean exactly. it started with artifacts and crashes in BF5 and Heaven. It continued to crash more and more steadily for the next few days. Then it wouldnt boot correctly after a crash. Taking several attempts to do it. Eventaully it wouldnt boot at all with the graphics card installed. I RMA'd it and the new card has been running fine for nearly a month. Fingers crossed it stays that way. Im no expert and cant say Im qualified to say the card is your problem.....but from the sounds of it, you descibed my chain of events exactly from a month ago.

    Just a novice following the dream to be a master

    #19
    jays_han
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/12/17 07:38:52
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/03 20:05:27 (permalink)
    Have you tried overclocking the card yet? Mine started having all these issues once i started trying to overclock. It became very unstable and even at stock settings it was just getting worse and worse like u mentioned.
    #20
    jayriavieock10
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/05/08 23:44:25
    • Location: OKC, OK
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/03 20:12:21 (permalink)
    My card's been fine so far! no issues seen the past couple months. I haven't tried OC'ing it yet(waiting on money to watercool it).
    #21
    inatanz
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2019/01/03 19:45:23
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/04 21:05:53 (permalink)
    Having same issues with the card I got few weeks ago (XC Gaming). Worked fine for a week, then suddenly game (PoE) started crashing and artifacts showed up. Then monitors would go out at random (or get filled with random color). Event viewer is filled with nvidia driver errors. 
    The crashes are getting more and more frequent - from once a day to many per hour.
    Haven't even had a chance to attempt an overclock ...
    #22
    Tyver
    Superclocked Member
    • Total Posts : 168
    • Reward points : 0
    • Joined: 2018/11/28 17:25:55
    • Location: Illinios
    • Status: offline
    • Ribbons : 1
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/04 21:14:25 (permalink)
    inatanz, revert graphics drivers and make sure everything is up to day on everything else is all I can say. Also get in contact with support if reverting does nothing and problem continues. I hate to say it but that sounds similar to what we were experiencing.


    jayriavieock10
    My card's been fine so far! no issues seen the past couple months. I haven't tried OC'ing it yet(waiting on money to watercool it).


    I did it last night right before you asked. I was a bit wary because of the same reason. I used the OC scan feature on PX1. Granted its been only a day but it hadn't shown anything wrong yet. It also closed 2,115 MHz, where the old one barely got above 2,000 MHz.

    Just a novice following the dream to be a master

    #23
    inatanz
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2019/01/03 19:45:23
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/05 10:23:16 (permalink)
    Tyver
    inatanz, revert graphics drivers and make sure everything is up to day on everything else is all I can say. Also get in contact with support if reverting does nothing and problem continues. I hate to say it but that sounds similar to what we were experiencing.



    Figures :( ..
    I installed older Nvidia driver (clean install) but it didn't help. Just now, reinstalled latest driver while in safe mode. But still, driver crashes every few minutes (usually when new UI element is being generated, like a screen popup). All other drivers and MB firmware are up to date. I even replaced DisplayPort cables with new, certified versions, in case the cables were causing this, but it didn't matter. I filed a ticket with support, and am about to pull the card and install my old one, as it's making the machine completely unusable.
    #24
    nesbit
    New Member
    • Total Posts : 76
    • Reward points : 0
    • Joined: 2016/11/04 18:38:37
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/05 17:02:49 (permalink)
    Welp, add mine to the statistic.  After weeks of no problems, just started artifacting out of the blue.  
     
    https://imgur.com/a/lIfKoPH
     
    post edited by nesbit - 2019/01/05 17:06:27
    #25
    fdsonn
    New Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2018/11/27 06:44:53
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/06 06:40:30 (permalink)
    I see people having their cards failing 2 months after purchase.  I wonder if all rtx 2080 ti's, 2080's and 2070's will fail eventually. 
    #26
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 69842
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Europe
    • Status: offline
    • Ribbons : 65
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/06 06:47:22 (permalink)
    For anyone having issues contact EVGA technical support.

    Specs: AMD 2920X Threadripper, Corsair MP510 M.2, 128GB Corsair RGB Vengeance Pro,  ASRock X399 Taichi, Corsair 1000D, EVGA RTX 2070




    #27
    nesbit
    New Member
    • Total Posts : 76
    • Reward points : 0
    • Joined: 2016/11/04 18:38:37
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/06 15:09:50 (permalink)
    fdsonn
    I see people having their cards failing 2 months after purchase.  I wonder if all rtx 2080 ti's, 2080's and 2070's will fail eventually. 




    If we believe Nvidia that it was a certain "test" batch the answer should be no.  If it is related to RAM then who knows.  Has there been any  development as to whether it's been memory or GPU that's been causing artifacting?  
     
    rjohnson11
    For anyone having issues contact EVGA technical support.


    Done, but of course my card dies on a weekend so tech support is closed. 
    #28
    bcavnaugh
    The Crunchinator
    • Total Posts : 32940
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 210
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/06 15:14:33 (permalink)
    nesbit
    Done, but of course my card dies on a weekend so tech support is closed. 

    Service Hours
    • Toll Free: +1.888.881.EVGA (3842)
    • 24 Hour / 7 Day Phone and Email Service
    post edited by bcavnaugh - 2019/01/06 15:18:26

      Associate Code: 9E88QK5L7811G3H
    "Earn EVGA Bucks For Folding with EVGA!" it is not "Fold for EVGA Bucks with EVGA!"



    #29
    Customersupportisprioritynumba1
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2019/01/10 05:54:50
    • Status: offline
    • Ribbons : 0
    Re: Anyone still having issues with artifacts + freeze with rtx 2080 ti? 2019/01/12 06:29:12 (permalink)
    2080 ti xc gaming arrived today, since first start it gave green artifacts and failed to install. Tried everything i could, ddu in safe mode, win reinstall, different slot.. Waiting reply from support but im sure its rma..
    post edited by Customersupportisprioritynumba1 - 2019/01/12 06:31:55
    #30
    Page: 1234 > Showing page 1 of 4
    Jump to:
  • Back to Mobile