EVGA

Hot!Z590 FTW won't clock CPU to it's full boost clock. FIXED

Author
kram36
The Destroyer
  • Total Posts : 21486
  • Reward points : 0
  • Joined: 2009/10/27 19:00:58
  • Location: United States
  • Status: offline
  • Ribbons : 72
2022/05/29 08:33:34 (permalink)
I just got a Z590 FTW motherboard and have a i5-11500T CPU in it and the CPU will only clock up to 3.4GHz instead of it's default 3.9GHz. Have the latest bios installed. Thought it was Windows 10 holding it back and did a new install and it still will not go over 3.4GHz.
 
Even if I manually set the multiplier in the bios to 39, it's still only going to 3.4GHz.
 
Is there a setting I'm missing to allow the CPU to hit 3.9GHz?
post edited by kram36 - 2022/06/21 15:01:44
#1

11 Replies Related Threads

    B0baganoosh
    FTW Member
    • Total Posts : 1602
    • Reward points : 0
    • Joined: 2009/08/04 04:27:18
    • Status: offline
    • Ribbons : 21
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/05/31 06:59:22 (permalink)
    It shouldn't even be an option for that CPU, but I know with 11900k, if you turn on ABT in the advanced settings it won't boost to 5.3, only 5.1 no matter what other settings you put in. Could be worth checking to see if that setting is somehow accidentally still active for you. Long shot and something that shouldn't be happening, but it's the only one I can think of off the top of my head.

    6Q6CPFHPBPCU691 is a discount code anyone can use.
     
    i9 12900k - EVGA Z690 Classy - EVGA RTX 3080 ti FTW3 Ultra (+Hybrid Kit) - G.Skill 32GB 6000MHz  - WD SN850 2TB NVMe Gen4 - EVGA 1000W G3 - BeQuiet! Dark Base 900 Pro. Project Dark Water MODS RIGS post for build notes.
    #2
    Sajin
    EVGA Forum Moderator
    • Total Posts : 47462
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 198
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/05/31 10:01:22 (permalink)
    Was going to say make sure a slow mode switch wasn’t enabled on the board, but there is no such switch on that board.

    Want to save 3% to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase.
     
    #3
    kalsim
    New Member
    • Total Posts : 91
    • Reward points : 0
    • Joined: 2015/06/19 22:40:11
    • Status: offline
    • Ribbons : 1
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/06/01 15:49:56 (permalink)
    On my board with an 11700K, I had to set each core individually to match Intel's specs. No matter what, the board wouldn't do it on its own.

    These EVGA boards are rock solid but very quirky.
    post edited by kalsim - 2022/06/01 15:51:28

    11700K 5.0 2C / 4.9 8C | EVGA Z590 FTW 1.08 | EVGA RTX 3080Ti FTW3 Ultra | EVGA 750 G2 | 2x16GB DR G.Skill TridentZ 3600 CL16 @ 4266 CL16 Gear 2 | Samsung 980 Pro NVMe 1TB | Phanteks Evolv ATX | Alienware 34" AW3418DW
    #4
    kram36
    The Destroyer
    • Total Posts : 21486
    • Reward points : 0
    • Joined: 2009/10/27 19:00:58
    • Location: United States
    • Status: offline
    • Ribbons : 72
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/06/01 18:22:08 (permalink)
    B0baganoosh
    It shouldn't even be an option for that CPU, but I know with 11900k, if you turn on ABT in the advanced settings it won't boost to 5.3, only 5.1 no matter what other settings you put in. Could be worth checking to see if that setting is somehow accidentally still active for you. Long shot and something that shouldn't be happening, but it's the only one I can think of off the top of my head.


    I'll have to look into this. Have not had a chance yet.
     
    kalsim
    On my board with an 11700K, I had to set each core individually to match Intel's specs. No matter what, the board wouldn't do it on its own.

    These EVGA boards are rock solid but very quirky.

    I tried that and the CPU would only go to 3.4Ghz, plus I really don't want a constant higher clock speed, but I would like the CPU to clock to it's rated 3.9GHz when I need it.
     
    Thanks for the replies.
    #5
    kram36
    The Destroyer
    • Total Posts : 21486
    • Reward points : 0
    • Joined: 2009/10/27 19:00:58
    • Location: United States
    • Status: offline
    • Ribbons : 72
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/06/05 11:06:07 (permalink)
    B0baganoosh
    It shouldn't even be an option for that CPU, but I know with 11900k, if you turn on ABT in the advanced settings it won't boost to 5.3, only 5.1 no matter what other settings you put in. Could be worth checking to see if that setting is somehow accidentally still active for you. Long shot and something that shouldn't be happening, but it's the only one I can think of off the top of my head.


    I do have the ABT option in the bios, but it was disabled.


    I think EVGA needs to do a micro code update that properly supports this CPU. I had this CPU in a MSI MAG B560 TOMAHAWK WIFI motherboard and it worked perfectly in that board.
    #6
    kram36
    The Destroyer
    • Total Posts : 21486
    • Reward points : 0
    • Joined: 2009/10/27 19:00:58
    • Location: United States
    • Status: offline
    • Ribbons : 72
    Re: Z590 FTW won't clock CPU to it's full boost clock. 2022/06/08 15:10:41 (permalink)
    Update:
     
    I got in touch with EVGATech_LeeM about this issue. He passed it onto the BIOS Team and they were able to reproduce the bug. They are working on debugging the issue and I will be sent a test bios try out.
    #7
    kram36
    The Destroyer
    • Total Posts : 21486
    • Reward points : 0
    • Joined: 2009/10/27 19:00:58
    • Location: United States
    • Status: offline
    • Ribbons : 72
    Re: Z590 FTW won't clock CPU to it's full boost clock. FIXED 2022/06/21 15:02:37 (permalink)
    Received a new bios from EVGA and it fixed the issue. My CPU now clocks to it's correct speeds.
    #8
    Sgt Hoit
    SSC Member
    • Total Posts : 553
    • Reward points : 0
    • Joined: 2008/12/28 14:19:52
    • Location: Newport, NC
    • Status: offline
    • Ribbons : 1
    Re: Z590 FTW won't clock CPU to it's full boost clock. FIXED 2022/06/23 07:57:59 (permalink)
    I'm having a similar issue.  I wonder how long it will take for EVGA to post the new BIOS for download?

    Caselabs Mecury S8, EVGA X299 Dark, i9 - 9980XE
    EVGA CLC 240mm CPU cooler, 64gb Corsair Dominator Platinum
      EVGA GeForce RTX 2080 Ti KINGPIN
    EVGA SuperNOVA 1300w G2 PSU, Samsung 870 Pro 512gb NVMe
    EVGA Z10 Keyboard, EVGA Torq X10 Carbon Mouse 
    3 x Dell S2716 DGR G Sync 27 inch monitors 
    HeatWare
    #9
    kram36
    The Destroyer
    • Total Posts : 21486
    • Reward points : 0
    • Joined: 2009/10/27 19:00:58
    • Location: United States
    • Status: offline
    • Ribbons : 72
    Re: Z590 FTW won't clock CPU to it's full boost clock. FIXED 2022/06/23 09:49:19 (permalink)
    Sgt Hoit
    I'm having a similar issue.  I wonder how long it will take for EVGA to post the new BIOS for download?


    I would send EVGATech_LeeM a pm about your issue.
    #10
    kalsim
    New Member
    • Total Posts : 91
    • Reward points : 0
    • Joined: 2015/06/19 22:40:11
    • Status: offline
    • Ribbons : 1
    Re: Z590 FTW won't clock CPU to it's full boost clock. FIXED 2022/06/24 09:45:32 (permalink)
    kram36
    Received a new bios from EVGA and it fixed the issue. My CPU now clocks to it's correct speeds.


    Funny. When I contacted support about that same issue back when the board first came out, they basically stopped responding to me.

    11700K 5.0 2C / 4.9 8C | EVGA Z590 FTW 1.08 | EVGA RTX 3080Ti FTW3 Ultra | EVGA 750 G2 | 2x16GB DR G.Skill TridentZ 3600 CL16 @ 4266 CL16 Gear 2 | Samsung 980 Pro NVMe 1TB | Phanteks Evolv ATX | Alienware 34" AW3418DW
    #11
    mobb-1
    New Member
    • Total Posts : 42
    • Reward points : 0
    • Joined: 2019/02/06 15:01:11
    • Status: offline
    • Ribbons : 1
    Re: Z590 FTW won't clock CPU to it's full boost clock. FIXED 2022/06/27 09:13:35 (permalink)
    I reported this over a year ago,
    Bios and POST code questions - EVGA Forums
    #12
    Jump to:
  • Back to Mobile