EVGA

RMA Problem.

Author
AdmiralDonut
New Member
  • Total Posts : 41
  • Reward points : 0
  • Joined: 2014/06/14 09:37:44
  • Status: offline
  • Ribbons : 0
2017/09/12 10:02:34 (permalink)
I'm apparently getting my 1070 RMA'd (thanks to some great staff on here and in the EVGA office) however, something seems a little amiss. I sent off the GPU this morning, all boxed up and whatnot, and tonight I get an email from UPS detailing a pick up they are supposed to be making for the GPU I just sent off. Does this mean they are sending my replacement card out with UPS and he is supposed to take my old one in exchange? Because if so I have nothing to give him. Help! What do! Is there anyone from EVGA around I can talk to?
#1

5 Replies Related Threads

    EVGATech_JosephL
    EVGA Tech Support
    • Total Posts : 626
    • Reward points : 0
    • Joined: 2016/06/12 10:33:58
    • Status: offline
    • Ribbons : 1
    Re: RMA Problem. 2017/09/12 10:14:16 (permalink)
    I checked your account and you do have a Standard RMA that has not yet been received. We will be sending the replacement after we have received and processed the card you sent. We can arrange for UPS pickups in your region but you can ignore the pickup message as you have already shipped the card and the service is not needed.

    If you have a moment, please rate my service. We appreciate the feedback!
    #2
    AdmiralDonut
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2014/06/14 09:37:44
    • Status: offline
    • Ribbons : 0
    Re: RMA Problem. 2017/09/12 10:30:33 (permalink)
    EVGATech_JosephL
    I checked your account and you do have a Standard RMA that has not yet been received. We will be sending the replacement after we have received and processed the card you sent. We can arrange for UPS pickups in your region but you can ignore the pickup message as you have already shipped the card and the service is not needed.


    So you'll cancel the UPS pickup from your end then? I don't need to do anything else?
    #3
    EVGATech_JosephL
    EVGA Tech Support
    • Total Posts : 626
    • Reward points : 0
    • Joined: 2016/06/12 10:33:58
    • Status: offline
    • Ribbons : 1
    Re: RMA Problem. 2017/09/12 11:46:40 (permalink)
    Yes, that is correct. I have contacted our EU management to cancel the pickup request if it is still active. Please let me know if you have any questions. You can also feel free to PM me if needed.

    If you have a moment, please rate my service. We appreciate the feedback!
    #4
    AdmiralDonut
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2014/06/14 09:37:44
    • Status: offline
    • Ribbons : 0
    Re: RMA Problem. 2017/09/12 12:14:51 (permalink)
    EVGATech_JosephL
    Yes, that is correct. I have contacted our EU management to cancel the pickup request if it is still active. Please let me know if you have any questions. You can also feel free to PM me if needed.


    Ah, you're a legend Jospeh. Thanks for taking care of that for me, it's much appreciated :D I'll go do that feedback thing you've got in your forum sig.
    #5
    EVGATech_JosephL
    EVGA Tech Support
    • Total Posts : 626
    • Reward points : 0
    • Joined: 2016/06/12 10:33:58
    • Status: offline
    • Ribbons : 1
    Re: RMA Problem. 2017/09/12 13:30:30 (permalink)
    Thank you very much, feedback is always appreciated! Glad I could help. 

    If you have a moment, please rate my service. We appreciate the feedback!
    #6
    Jump to:
  • Back to Mobile