EVGA

Hot!Precision OSD doesn't work. Specifically the framerate monitor.

Author
JonathanA-P
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/08/18 13:17:02
  • Status: offline
  • Ribbons : 0
2019/10/22 01:04:32 (permalink)
Precision OSD doesn't show in my games. All my games. It works after a fresh install but then it stops after a while. I have the main OSD button and the OSD buttons on the HWM graphs on. The graphs work fine except for the framerate graph. Which seems to be what's causing the problem. I just really like to see how many frames i'm getting in my games without using any other software.
#1

13 Replies Related Threads

    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 18182
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: online
    • Ribbons : 114
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/22 04:27:23 (permalink)
    OS details & what Version of Precision are you using - with which Nvidia driver ?

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #2
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5918
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 460
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/22 05:51:31 (permalink)
    Cool GTX
    OS details & what Version of Precision are you using - with which Nvidia driver ?



    Yeah, all that kinda sorta might help.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit * 
     
    Confucius say "He who has the most guns wins"
     
     
     
    #3
    Sajin
    EVGA Forum Moderator
    • Total Posts : 38956
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: offline
    • Ribbons : 195
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/22 11:59:56 (permalink)
    Do you have this problem with msi afterburner too?

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #4
    battlelog
    New Member
    • Total Posts : 44
    • Reward points : 0
    • Joined: 2018/06/26 08:49:49
    • Status: online
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 20:32:54 (permalink)
    I just upgraded my gpu to 2080 ti FTW3 ultra today, did clean install of drivers. I did not uninstall PX1 and reinstall it again, figured that should be fine. 
     
    I am also having issues with PX1 Ver. 1.0.1, the frame rate graph does not show anything other than 0???
     
    Any fix for this?
     
    Thanks in advance.

    CPU: Intel i9 9900k
    MOBO: Asus Rog Maximus XI (Wi-Fi)Z390
    GPU: EVGA RTX 2080 Ti FTW3 Ultra OVERCLOCKED
    RAM: Corsiar Dominator Platinum 32GB 3200MHZ
    AIO: Corsair H100i Pro RGB
    PSU: Corsair HX1000i
    SSD: 1 v-NAND SSD 970 PRO 2 TB
    CASE: COOL MASTER MC500P
    MONITOR: Asus Swift PG279QZ 2560x1440
    #5
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5918
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 460
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:33:53 (permalink)
    battlelog
     
    I am also having issues with PX1 Ver. 1.0.1, the frame rate graph does not show anything other than 0???
     
    Any fix for this?

     

    You have to be running a Game/3D App for the Framerate to show in the graph..It will show 0 just running on the Desktop.

    Run the Render Test in GPU-Z and it should register..Open the Render Test by clicking on the little '?' button to the right of Bus Interface.
     
    See if that works.
     

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit * 
     
    Confucius say "He who has the most guns wins"
     
     
     
    #6
    battlelog
    New Member
    • Total Posts : 44
    • Reward points : 0
    • Joined: 2018/06/26 08:49:49
    • Status: online
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:36:00 (permalink)
    I was running the Valley benchmark and it stayed at zero. Will try to do what you said. 
     
    Thanks.

    CPU: Intel i9 9900k
    MOBO: Asus Rog Maximus XI (Wi-Fi)Z390
    GPU: EVGA RTX 2080 Ti FTW3 Ultra OVERCLOCKED
    RAM: Corsiar Dominator Platinum 32GB 3200MHZ
    AIO: Corsair H100i Pro RGB
    PSU: Corsair HX1000i
    SSD: 1 v-NAND SSD 970 PRO 2 TB
    CASE: COOL MASTER MC500P
    MONITOR: Asus Swift PG279QZ 2560x1440
    #7
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5918
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 460
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:42:01 (permalink)
    battlelog
    I was running the Valley benchmark and it stayed at zero. 



    I'll grab Valley and see if it works for me.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit * 
     
    Confucius say "He who has the most guns wins"
     
     
     
    #8
    battlelog
    New Member
    • Total Posts : 44
    • Reward points : 0
    • Joined: 2018/06/26 08:49:49
    • Status: online
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:49:37 (permalink)
    Nothing shows up on the GPU-z render thing?? Very weird.

    CPU: Intel i9 9900k
    MOBO: Asus Rog Maximus XI (Wi-Fi)Z390
    GPU: EVGA RTX 2080 Ti FTW3 Ultra OVERCLOCKED
    RAM: Corsiar Dominator Platinum 32GB 3200MHZ
    AIO: Corsair H100i Pro RGB
    PSU: Corsair HX1000i
    SSD: 1 v-NAND SSD 970 PRO 2 TB
    CASE: COOL MASTER MC500P
    MONITOR: Asus Swift PG279QZ 2560x1440
    #9
    battlelog
    New Member
    • Total Posts : 44
    • Reward points : 0
    • Joined: 2018/06/26 08:49:49
    • Status: online
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:55:58 (permalink)
    Now it wont even show up in BF4,BFV, and thew valley benchmark? I think I will uninstall and reinstall again, will try tomorrow and report back, got to work early in the morning.

    CPU: Intel i9 9900k
    MOBO: Asus Rog Maximus XI (Wi-Fi)Z390
    GPU: EVGA RTX 2080 Ti FTW3 Ultra OVERCLOCKED
    RAM: Corsiar Dominator Platinum 32GB 3200MHZ
    AIO: Corsair H100i Pro RGB
    PSU: Corsair HX1000i
    SSD: 1 v-NAND SSD 970 PRO 2 TB
    CASE: COOL MASTER MC500P
    MONITOR: Asus Swift PG279QZ 2560x1440
    #10
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5918
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 460
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:57:35 (permalink)
    battlelog
    Nothing shows up on the GPU-z render thing?? Very weird.



    Yeah..I just ran Valley (as is), Framerate showed up fine in OSD and the Graph..Running Win10, latest Graphics Driver.
     

    Try Revo Unistaller (Free) to uninstall PX1..Use the Advanced Mode to delete files/folders/registry entries, but be SURE you ONLY checkmark to delete the Precision registry entries shown in bold text..Then restart your PC..Then delete the leftover EVGA_Co.,_Ltd folder normally located in the C:\Users\Username\AppData\Local folder*..Then install PX1 again.
     
    *Those folders are normally hidden so you need to set the folder View Options to Show hidden files, folders, and drives to see them.
     
    Other than that, hmmm, maybe see if an older PX1 version works.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit * 
     
    Confucius say "He who has the most guns wins"
     
     
     
    #11
    battlelog
    New Member
    • Total Posts : 44
    • Reward points : 0
    • Joined: 2018/06/26 08:49:49
    • Status: online
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 21:59:39 (permalink)
    I see will try that, weird that it was working fine before I installed the new card?? But will try and report back.
     
    Thanks for your help man.

    CPU: Intel i9 9900k
    MOBO: Asus Rog Maximus XI (Wi-Fi)Z390
    GPU: EVGA RTX 2080 Ti FTW3 Ultra OVERCLOCKED
    RAM: Corsiar Dominator Platinum 32GB 3200MHZ
    AIO: Corsair H100i Pro RGB
    PSU: Corsair HX1000i
    SSD: 1 v-NAND SSD 970 PRO 2 TB
    CASE: COOL MASTER MC500P
    MONITOR: Asus Swift PG279QZ 2560x1440
    #12
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5918
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 460
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/10/25 22:05:14 (permalink)
    battlelog
    I see will try that, weird that it was working fine before I installed the new card?? But will try and report back.
     
    Thanks for your help man.



    No problemo..Good luck with it.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit * 
     
    Confucius say "He who has the most guns wins"
     
     
     
    #13
    MeowMeowTiger
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2018/11/27 16:50:47
    • Status: offline
    • Ribbons : 0
    Re: Precision OSD doesn't work. Specifically the framerate monitor. 2019/11/06 12:25:14 (permalink)
    I have the same exact problem!
    #14
    Jump to:
  • Back to Mobile