EVGA

Hot!Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1

Author
HeavyHemi
Omnipotent Enthusiast
  • Total Posts : 13514
  • Reward points : 0
  • Joined: 2008/11/28 20:31:42
  • Location: Western Washington
  • Status: offline
  • Ribbons : 84
2018/07/08 17:06:05 (permalink)
Current problem GPU EVGA 1080 Ti Founders Edition with EVGA Hybrid (old model) installed. It is now removed.
Issue: The three screws used to mount the PWM heatsink and fan assembly are incorrect.  They call out for using three #13 screw standoffs (as labeled in the instructions) which  are incorrect. The shoulder on the screws meets the shoulder on the heatsink standoffs which leaves about 1mm of slop in the assembly. Using 3 #14 screw standoffs WITHOUT the shoulder works perfectly. Of course, those screws (which are also used elsewhere) are not in the kit. So I had to cannabalize the second BRAND NEW kit to make one good working one. So, if EVGA could send me another set of #14 standoffs, that sure would be swell and I could box the other kit back up as a spare as I intended or maybe another 1080 Ti for SLI.

EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
Fire Strike                        24,163
Fire  Strike Extreme        14,452 
Fire Strike Ultra                7,711 
Time Spy                        10,357

#1

8 Replies Related Threads

    EVGATech_JoseC
    EVGA Tech Support
    • Total Posts : 226
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: EVGA
    • Status: offline
    • Ribbons : 2
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/08 20:19:21 (permalink)
    Hello HeavyHemi~

    Next time give us a call or open a support ticket! We don't bite. Go ahead and register the hybrid kit to your account by using the serial number and give us a call or start a ticket. We can go ahead and assist you with this request. 
     
    -Jose C.
    #2
    HeavyHemi
    Omnipotent Enthusiast
    • Total Posts : 13514
    • Reward points : 0
    • Joined: 2008/11/28 20:31:42
    • Location: Western Washington
    • Status: offline
    • Ribbons : 84
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/08 22:18:56 (permalink)
    EVGATech_JoseC
    Hello HeavyHemi~

    Next time give us a call or open a support ticket! We don't bite. Go ahead and register the hybrid kit to your account by using the serial number and give us a call or start a ticket. We can go ahead and assist you with this request. 
     
    -Jose C.




    I've actually two of them I'm going to register in a minute.  But seriously, if I did not have the second kit, I would have been SOL using the screws in the kit that are identified in the instructions. They will not work following the instructions on an EVGA FE model.I could have stopped to start a ticket etc..etc... But I was in a hurry, system is back up an running. I'll call tomorrow.
    Oh hey.... this is a KNOWN issue from LAST year.
     
    https://forums.evga.com/F...oler-Kit-m2697681.aspx
     

     
    Also, having the fan hitting the shroud at about 75%. Since it never gets hot enough to hardly get past idle on the default fan profile you'd never notice it. QC folks. Come on.
    Update, after removing the card and readjusting the fan to center it in the opening the fan no longer rubs at any speed. However the issue is of course, you won't know if you need to do this until you install the GPU and test it under the full fan speed range because the fit is that close. It is doable, but could be made easier.
     
    post edited by HeavyHemi - 2018/07/10 09:53:47

    EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
    Fire Strike                        24,163
    Fire  Strike Extreme        14,452 
    Fire Strike Ultra                7,711 
    Time Spy                        10,357

    #3
    EVGATech_JoseR
    EVGA Tech Support
    • Total Posts : 616
    • Reward points : 0
    • Joined: 2014/04/11 09:39:05
    • Status: offline
    • Ribbons : 1
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/10 10:09:12 (permalink)
    don't worry fam, we got you covered! 
    #4
    HeavyHemi
    Omnipotent Enthusiast
    • Total Posts : 13514
    • Reward points : 0
    • Joined: 2008/11/28 20:31:42
    • Location: Western Washington
    • Status: offline
    • Ribbons : 84
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/10 10:13:10 (permalink)
    EVGATech_JoseR
    don't worry fam, we got you covered! 






    Just got off the phone. I hope I (nicely) impressed your tech with the importance of getting this fixed for the FE models. The kit is unusable as is unless you jerry rig it or get lucky enough to have another kit to cannibalize for the screws. I have another set of screws on the way to put the other kit back together Thanks for that. But again, FIX THE ISSUE.

    EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
    Fire Strike                        24,163
    Fire  Strike Extreme        14,452 
    Fire Strike Ultra                7,711 
    Time Spy                        10,357

    #5
    leo281
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2014/02/09 22:04:10
    • Status: offline
    • Ribbons : 0
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/11 10:49:32 (permalink)
    I'm planning on ordering Hybrid Waterblock Cooler 400-HY-5598-B1 and want to know if this issue is resolved or if I'll have to contact support prior to installing to ensure I have the right screws?
     
    My card is the EVGA GeForce GTX 1080 Ti SC Black Edition 11G-P4-6393-KR
    post edited by leo281 - 2018/07/11 10:58:59
    #6
    HeavyHemi
    Omnipotent Enthusiast
    • Total Posts : 13514
    • Reward points : 0
    • Joined: 2008/11/28 20:31:42
    • Location: Western Washington
    • Status: offline
    • Ribbons : 84
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/07/27 12:16:33 (permalink)
    leo281
    I'm planning on ordering Hybrid Waterblock Cooler 400-HY-5598-B1 and want to know if this issue is resolved or if I'll have to contact support prior to installing to ensure I have the right screws?
     
    My card is the EVGA GeForce GTX 1080 Ti SC Black Edition 11G-P4-6393-KR


    The kit I got was manufactured June of this year.  So, it's the same kit with the same problems.

    EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
    Fire Strike                        24,163
    Fire  Strike Extreme        14,452 
    Fire Strike Ultra                7,711 
    Time Spy                        10,357

    #7
    MILLOCRACY
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2017/07/16 21:07:32
    • Status: offline
    • Ribbons : 0
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/08/08 12:53:28 (permalink)
    EVGATech_JoseC
    Hello HeavyHemi~

    Next time give us a call or open a support ticket! We don't bite. Go ahead and register the hybrid kit to your account by using the serial number and give us a call or start a ticket. We can go ahead and assist you with this request. 
     
    -Jose C.


    Hi sir! I just purchased this cooler from ebay and have the same issue as others. Can I have those #14 screws too? TIA
    #8
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 12372
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Mid-Atlantic
    • Status: online
    • Ribbons : 90
    Re: Hardeware issue with EVGA GTX 1080 Ti SC Hybrid Waterblock Cooler 400-HY-5598-B1 2018/08/08 13:08:41 (permalink)
    MILLOCRACY
    EVGATech_JoseC
    Hello HeavyHemi~

    Next time give us a call or open a support ticket! We don't bite. Go ahead and register the hybrid kit to your account by using the serial number and give us a call or start a ticket. We can go ahead and assist you with this request. 
     
    -Jose C.


    Hi sir! I just purchased this cooler from ebay and have the same issue as others. Can I have those #14 screws too? TIA


    Best to contact EVGA directly    https://www.evga.com/about/contactus/
     
    Or PM Jose C. and give a link to this post

    RTX Project EVGA X99 FTW-K-5930K, 2-EVGA2080Ti, EVGA 1200P2
    Rig-2 AIO Folding  X99-5930K 2-1080Ti FTW3 Hybrid, EVGA-1200P2
    Rig-3 Nibbler EVGA X99 Classy-5960X 3GPU H2O 4K Acer-XB280HK  Folding@EVGA



    #9
    Jump to:
  • Back to Mobile