EVGA

For all those experiencing the 4090 no display issue here is the official fix from Nvidia

Author
Ravenmaster
SSC Member
  • Total Posts : 743
  • Reward points : 0
  • Joined: 2008/10/24 18:02:00
  • Status: offline
  • Ribbons : 7
2022/11/17 07:54:50 (permalink)
This firmware works for the 4090 FE and AIB partner models.

https://nvidia.custhelp.c...i-firmware-update-tool

Asus ROG Maximus Z790 Dark Hero | Intel Core i9-14900KF | RTX 4090 FE | 2x32GB Corsair Dominator Titanium DDR5 RAM (7200mhz) | 2x Samsung 990 Pro 4TB M.2 NVMe's for main OS and backup) | Windows 11 Pro 64-bit 23H2 |Klipsch 5.1.2 Dolby Atmos speakers + Denon AVR-X2800H Receiver | LG 42" C2 OLED | EVGA ASSOCIATE CODE: JRKV0L1B1GY3ADW

#1

12 Replies Related Threads

    EVGA_Lee
    Moderator
    • Total Posts : 4247
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/17 09:16:40 (permalink)
    Since you were first, I'm going to move this into the RTX 40 Series section and keep my post as a sticky in the Z690 section.
    #2
    MXHALOFAN
    New Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2022/05/19 01:20:19
    • Status: offline
    • Ribbons : 0
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/18 11:39:24 (permalink)
    Well I'm getting no display from my Gigabyte Eagle 4080, wonder if this will help me too
     


     
    #3
    PhantomApollyon
    Superclocked Member
    • Total Posts : 212
    • Reward points : 0
    • Joined: 2010/01/27 23:49:20
    • Status: offline
    • Ribbons : 1
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/19 11:48:17 (permalink)
    FWIW - 
     
    This may sound odd but although I was NOT having the UEFI blank screen issue this was intended to fix, I updated anyway and this firmware corrected/modified my UEFI/boot-up sequence to once again show the ASUS ROG logo instead of the normal Windows 11 blue logo.  It never really bothered me or created a functional issue of any sort, but I observed the boot logo change to the Windows logo when I initially switched to my 4090 FE and always wondered why and found no answer. I guess this is the answer given that it corrected/changed back immediately after installing/rebooting, but I wonder if anyone else experienced this.
    post edited by PhantomApollyon - 2022/11/19 11:50:24

    ASUS Maximus z690 Hero // i9 12900K // 4090 FE // 32GB 6000Mhz DDR5 // EVGA 1600 T2
    #4
    blaise
    iCX Member
    • Total Posts : 291
    • Reward points : 0
    • Joined: 2009/03/10 21:48:56
    • Location: Sydney, Australia
    • Status: offline
    • Ribbons : 5
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/19 14:14:37 (permalink)
    PhantomApollyon
    FWIW - 
     
    This may sound odd but although I was NOT having the UEFI blank screen issue this was intended to fix, I updated anyway and this firmware corrected/modified my UEFI/boot-up sequence to once again show the ASUS ROG logo instead of the normal Windows 11 blue logo.  It never really bothered me or created a functional issue of any sort, but I observed the boot logo change to the Windows logo when I initially switched to my 4090 FE and always wondered why and found no answer. I guess this is the answer given that it corrected/changed back immediately after installing/rebooting, but I wonder if anyone else experienced this.


    That's a weird one. I have an ASUS motherboard (and an ASUS 4090) and my ROG startup logo has worked fine all along.
    #5
    Ravenmaster
    SSC Member
    • Total Posts : 743
    • Reward points : 0
    • Joined: 2008/10/24 18:02:00
    • Status: offline
    • Ribbons : 7
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/19 14:39:51 (permalink)
    MXHALOFAN
    Well I'm getting no display from my Gigabyte Eagle 4080, wonder if this will help me too
     




    This firmware update is for 4090 and 4080 so it's worth a shot. 

    Asus ROG Maximus Z790 Dark Hero | Intel Core i9-14900KF | RTX 4090 FE | 2x32GB Corsair Dominator Titanium DDR5 RAM (7200mhz) | 2x Samsung 990 Pro 4TB M.2 NVMe's for main OS and backup) | Windows 11 Pro 64-bit 23H2 |Klipsch 5.1.2 Dolby Atmos speakers + Denon AVR-X2800H Receiver | LG 42" C2 OLED | EVGA ASSOCIATE CODE: JRKV0L1B1GY3ADW

    #6
    MXHALOFAN
    New Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2022/05/19 01:20:19
    • Status: offline
    • Ribbons : 0
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/11/20 08:03:43 (permalink)
    I couldn't get this to install, no on board video or room for another card on my z570. I just unplugged one of the 8 pin connectors and my rig booted right up LOL. I still installed this firmware after that. Wonder if I can plug my connector back in LOL. Gettting some Rel V while gaming (reliable voltage)


     
    #7
    mizzer
    iCX Member
    • Total Posts : 309
    • Reward points : 0
    • Joined: 2010/02/06 12:52:24
    • Status: offline
    • Ribbons : 1
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/12/15 05:50:00 (permalink)
    I had to set my motherboard settings to default, install the card and driver, then reload motherboard settings.

    Gigabyte Aorus Master x570 * AMD 5900X * 32GB G.SKILL Trident 3600 * Arctic Liquid Freezer II 420 * GeForce 4090 FE  * Corsair RM1000x PSU * 1TB Samsung 970 EVO NVMe * 2x 2TB Samsung 870 QVO SSDs * LG OLED48CXPUB * Fractal Design Meshify 2 XL
    #8
    skyline090
    Superclocked Member
    • Total Posts : 154
    • Reward points : 0
    • Joined: 2018/03/17 16:02:59
    • Status: offline
    • Ribbons : 1
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/12/30 22:18:07 (permalink)
    PhantomApollyon
    FWIW - 
     
    This may sound odd but although I was NOT having the UEFI blank screen issue this was intended to fix, I updated anyway and this firmware corrected/modified my UEFI/boot-up sequence to once again show the ASUS ROG logo instead of the normal Windows 11 blue logo.  It never really bothered me or created a functional issue of any sort, but I observed the boot logo change to the Windows logo when I initially switched to my 4090 FE and always wondered why and found no answer. I guess this is the answer given that it corrected/changed back immediately after installing/rebooting, but I wonder if anyone else experienced this.




    Same here. Installed 4090 FE yesterday and got the win 11 boot logo. Ran/updated with Nvidia firmware tool and back to the Asus ROG logo.

    Custom loop w/EK blocks - 12900k, 4090 FE, z690 Apex, G.Skill DDR5 6600 c32, EVGA 1000 P6, Lian Li O11D XL


     
    #9
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 10070
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: offline
    • Ribbons : 4
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2022/12/31 01:10:20 (permalink)
    mizzer
    I had to set my motherboard settings to default, install the card and driver, then reload motherboard settings.


    Probably the best way to do it. I would reset it just for more stability when updating firmware on hardware I really don’t want to have any problems with.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #10
    flyinion
    CLASSIFIED Member
    • Total Posts : 2269
    • Reward points : 0
    • Joined: 2007/03/27 12:17:04
    • Location: California
    • Status: offline
    • Ribbons : 8
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2023/01/09 19:59:34 (permalink)
    Is this still potentially needed on newly acquired 4090’s?  Or should we expect new stock to have it by this point?

    AMD Ryzen 5950X | Asus Crosshair VIII Hero | Gigabyte Gaming OC 4090 w/EK Vector2 | GSkill Trident Z Neo 2x16GB DDR4-3600 | WD SN850 2TB | Samsung 970 EVO Plus 500GB & 860 Evo 2TB | Phanteks Enthoo 719 | Seasonic Prime Ultra Gold 1000W | Steelseries M750 TKL | SteelSeries Prime Wireless | SteelSeries Arctis Pro + GameDAC | Kanto YU2 + Yamaha sub | Schiit Magni 2 Uber & Modi 2 Uber | LG 34GN850 | Asus PG279Q | Win 11 Pro | Custom water loop
    #11
    Tbone16
    New Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2023/01/15 01:38:58
    • Status: offline
    • Ribbons : 0
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2023/01/15 01:57:11 (permalink)
    Did it work? Are you using windows 11?
    #12
    Tbone16
    New Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2023/01/15 01:38:58
    • Status: offline
    • Ribbons : 0
    Re: For all those experiencing the 4090 no display issue here is the official fix from Nvi 2023/01/16 13:11:52 (permalink)
    Did it help?
    #13
    Jump to:
  • Back to Mobile