EVGA

Hot!EVGA X58 SLI - Failure to upgrade to WIndows 10 1903

Author
NazcaC2
EGC Admin
  • Total Posts : 7015
  • Reward points : 0
  • Joined: 2008/06/21 09:43:08
  • Location: Niagara Falls, Ontario Canada
  • Status: offline
  • Ribbons : 31
2019/05/26 10:43:13 (permalink)
Since there aren't any driver updates available, going from 1809 to 1903 seems out of the question right now. I know a few others have had this issue. Can any of the EVGA techs shed light on this? Will it ever be possible to upgrade to 1903 with the X58?
 
Error: "Your PC has a driver or service that isn't ready for this version of Windows 10"
#1

11 Replies Related Threads

    HeavyHemi
    Omnipotent Enthusiast
    • Total Posts : 13995
    • Reward points : 0
    • Joined: 2008/11/28 20:31:42
    • Location: Western Washington
    • Status: offline
    • Ribbons : 94
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/05/26 12:34:01 (permalink)
    NazcaC2
    Since there aren't any driver updates available, going from 1809 to 1903 seems out of the question right now. I know a few others have had this issue. Can any of the EVGA techs shed light on this? Will it ever be possible to upgrade to 1903 with the X58?
     
    Error: "Your PC has a driver or service that isn't ready for this version of Windows 10"




    I might have to let my nephew, who is using my old X58, to hold off on updating.
     
    How about this:

    Windows 19H1 and BattlEye

    https://forums.guru3d.com...1-and-battleye.426192/
    post edited by HeavyHemi - 2019/05/26 12:37:21

    EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
    Fire Strike                        24,163
    Fire  Strike Extreme        14,452 
    Fire Strike Ultra                7,711 
    Time Spy                        10,357

    #2
    Sajin
    EVGA Forum Moderator
    • Total Posts : 38044
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/05/26 14:45:55 (permalink)
    Perform a clean boot of windows then try updating again.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #3
    NazcaC2
    EGC Admin
    • Total Posts : 7015
    • Reward points : 0
    • Joined: 2008/06/21 09:43:08
    • Location: Niagara Falls, Ontario Canada
    • Status: offline
    • Ribbons : 31
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/05/26 17:59:16 (permalink)
    Thanks, I'll look into that.

    If not, I'll just wait until my next build to upgrade (should be this year).
    post edited by NazcaC2 - 2019/05/26 18:05:13
    #4
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 73268
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Europe
    • Status: online
    • Ribbons : 68
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/06/01 04:07:48 (permalink)
    You might need a clean install as Sajin has recommended. However I wish to add to that:
     
    1. When you wish to to do a clean install with that motherboard disconnect all drives except for the system drive
    2. If the clean install still doesn't work or gives errors power down and remove all memory except for 1 stick. Make sure the single stick is in the DIMM slot designated for a single DIMM
    3. Try the fresh install again

    Specs: AMD 2920X Threadripper, Corsair MP510 M.2, 64GB Corsair RGB Dominator,  ASRock X399 Taichi, Corsair 1000D, EVGA RTX 2080ti Black

    Associate Code: H5U80QBH6BH0AXF



    #5
    Neutro
    iCX Member
    • Total Posts : 325
    • Reward points : 0
    • Joined: 2018/07/19 15:31:31
    • Location: France
    • Status: offline
    • Ribbons : 10
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/06/01 12:56:55 (permalink)
    I have an EVGA X58 SLI E760 motherboard.
     
    I've installed Windows 10 1903 2 days ago on my Samsung 950 Pro SSD NVME through a PCIE adapter card. I didn't have any problem with drivers. I just installed the chipset driver for Win10 from EVGA drivers download page and everything works fine.
     
    No errors, no crashes, no disabled overclocking, no boot problems... Everything runs smooth as silk :)
     
    You might have a problem because you're trying to upgrade from an existing version of Windows. Don't. Download the original 1903 iso from microsoft, format and install from scratch.
    post edited by Neutro - 2019/06/01 12:59:53

    I do not work for EVGA - I try to provide help on my spare time with no guarantee of results.
    If you require official support from EVGA please visit EVGA Service Center.
     
    Rocking a 980X @ 5 Ghz 6C 12T on EVGA X58 E760 Classified - DDR3 2500 Mhz CL10
    Nvidia GTX 1080Ti @ 2100 Mhz - Everything fully watercooled with a phobya xtreme 1260 radiator!
    Mods Rigs link with pictures - 10 yo rig better than 97% of all results on 3DMark Firestrike 
    #6
    SuperConker
    iCX Member
    • Total Posts : 251
    • Reward points : 0
    • Joined: 2010/08/22 14:55:25
    • Status: offline
    • Ribbons : 3
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/12 07:56:46 (permalink)
    I am happy to say that X58 owners should be able to update from 1809 to 1903 now.
     
    I was having the same problem on my older X58 rig ever since the 1903 update was launched.
    (Evga X58 E760 motherboard + Xeon X5690 CPU). 
     
    However, today i turned this computer back on after a few weeks of being turned off,
    and was surprised to see the 1903 update offered once again
    (it would previously say my computer wasn't ready for it).
     
    The update took almost 2 hours (lol) but completed without any problems.
    It also updated straight to version 18362.239 without any aditonal CU's.
    post edited by SuperConker - 2019/07/12 08:07:38


    #7
    bcavnaugh
    The Crunchinator
    • Total Posts : 37517
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 271
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/12 08:54:55 (permalink)
    This will fix you Windows 10 1903 Fails to Upgrade From Any USB Device.
    Windows 10 1903 Fails to Upgrade on my EVGA Z370 X99 and X299 Motherboards From Any USB Device.
    We have to copy the files from the USB Drive (Device) to a local drive and then run the Setup file.
    Also make sure you have 430.86 installed unlike the last upgrade with the Standard Video Driver installed 1903 will install 388.xx Driver.
    You will still need to do a Clean Up of the Driver with DDU as MS Still Leaves you an incomplete Driver Install.
    A Known Issues with Microsoft so is 1903 Really Ready?
    https://support.microsoft.com/en-us/help/4500988/windows-update-hold-for-windows-10
    Use the https://www.microsoft.com/en-us/software-download/windows10 
    and create the USB Install Device and then Copy the USB to a Folder on your Local hard drive and do not use the C: Drive or Boot Drive to install from.
    Remove the USB Device before you start and have ONLY a USB Mouse and Keyboard connected to the Computer.
    Then do an upgrade, this is also a better method to upgrade your OS and not using Windows Update to do an upgrade.
    Best to still do a Fresh Install but when you have 2 or 3 Terabytes of Games installed an upgrade works a lot better than before.
    post edited by bcavnaugh - 2019/07/12 09:08:58


    #8
    bcavnaugh
    The Crunchinator
    • Total Posts : 37517
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 271
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/12 09:04:23 (permalink)
    Oops, did not catch that this was an old Thread.


    #9
    SuperConker
    iCX Member
    • Total Posts : 251
    • Reward points : 0
    • Joined: 2010/08/22 14:55:25
    • Status: offline
    • Ribbons : 3
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/12 09:06:17 (permalink)
    I didn't have any USB devices connected, and i had disconnected all my HDD/SSD/Optical drives except for the C:\ drive,
    and Windows 10 would still fail to update to 1903 on my X58 computer.
     
    After a few weeks of having this problem, Windows update would tell me my device wasn't ready for 1903.
     
     
    That was until today, when the update was offered through Windows Update once again, without said message.
    It updated just fine even with all my drives connected, and took me straight to version 18362.239.
     
    It seems Microsoft has finally fixed the issue of older devices not being able to update to 1903.


    #10
    charlie164
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2019/07/15 01:06:24
    • Status: offline
    • Ribbons : 0
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/15 01:10:26 (permalink)
    Is anyone else facing the problem with the after the Windows 10 updating? Kindly let me know. 
    #11
    AfterBurner_1
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2012/03/24 00:05:59
    • Location: Sensational Adelaide
    • Status: offline
    • Ribbons : 0
    Re: EVGA X58 SLI - Failure to upgrade to WIndows 10 1903 2019/07/22 23:36:55 (permalink)
    I had all sorts of random troubles it seemed with Win 10, however it turns out i had both a dying CMOS battery and kinda dead TIM on my NB/SB complex which im in the process of replacing at present. just trying to find info on what thickness thermal pads to get.

    Aside from that hardware trouble my install of Win 10 has been great. most major updates went through with minimal issues. hell, I'm still running a WD6000HLHX. I'm Running a E760-A1.
    post edited by AfterBurner_1 - 2019/07/22 23:51:12
    #12
    Jump to:
  • Back to Mobile