EVGA

Hot!EVGA Precision X1 1.0.3.0

Author
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 2006
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 14
2020/03/03 11:18:20 (permalink)
Release: 2/26/2020
  • Update firmware for RTX 2080 Ti FTW3 HYBRID.
  • Fixed where NVLink LED could not be controlled if the VGA does not support LED function.
 
https://www.evga.com/precisionx1/
 
#1

19 Replies Related Threads

    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 23316
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 117
    Re: EVGA Precision X1 1.0.3.0 2020/03/03 13:57:48 (permalink)
    good to see an update

    RTX Project EVGA X99 FTWK-5930K@4.8GHz 2xEVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 Classified-5960X@4.5GHz 3-GPU Water Loop 1600P2 
    AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #2
    Sajin
    EVGA Forum Moderator
    • Total Posts : 41631
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 197
    Re: EVGA Precision X1 1.0.3.0 2020/03/03 19:00:19 (permalink)


    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #3
    Velcade
    New Member
    • Total Posts : 26
    • Reward points : 0
    • Joined: 2019/01/31 12:19:05
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/04 11:03:11 (permalink)
    EVGATech_LeeM
    Release: 2/26/2020
    • Update firmware for RTX 2080 Ti FTW3 HYBRID
     

     
    What's new?

    Fractal Design Define R6 || 8700K @ 5.0Ghz || Celsius S36 || Maximus X Hero || Trident Z 32GB @ 3200MHz || EVGA RTX 2080ti FTW3 hybrid || MX500 2TB || WD Gold 4GB || PRIME Ultra Titanium 850w || ASUS PG279Q and ASUS MG248Q
    #4
    daddyd302
    CLASSIFIED Member
    • Total Posts : 2126
    • Reward points : 0
    • Joined: 2006/09/15 17:10:20
    • Location: West Allis, WI
    • Status: offline
    • Ribbons : 5
    Re: EVGA Precision X1 1.0.3.0 2020/03/04 15:52:22 (permalink)
    My led option is missing from my 2080ti XC2. It was there when I had the older version with my 2 1080ti SC. 


    EDIT: Never mind after rebooting it a few times it came back. Not sure what happened there.
    post edited by daddyd302 - 2020/03/04 16:57:15

    ** AMD 3900X ** Gigabyte X570 Master  ** EVGA 2080Ti XC2 Ultra ** Soundblaster X AE-5 ** Corsair Vengeance RGB 32G ** Corsair H115i RGB Platinum ** Inland M2 SSD 2TB ** Crucial MX300 1TB ** Seagate Barracuda Pro 8TB ** Lian Li O11 XL ** EVGA 1000 P2 ** Dell S3220 ** Razer Huntsman Elite ** Razer Basilisk Ultimate**
     
    #5
    badboy64
    SSC Member
    • Total Posts : 555
    • Reward points : 0
    • Joined: 2006/06/05 15:11:40
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/07 15:17:05 (permalink)
    Is there a way to rerun the firmware update as mine failed to run and I have the 3 leds on all of the time. I have 2 cards and it worked on the first card but failed to run on 2nd one. I don't have a LED at all. It failed to update on Z390 Dark setup. The 1 that failed has a Hybrid Kit on it that I installed on it and the 1 that worked has a water block on it. The other card is in my signature which it completed the flash. I don't even see why it flashed both my cards in the first place to begin with since neither of my cards are labeled as Hybrids. So now I have a non hybrid card that has no LED and 3 leds that are on all of the time.Card is now fixed after new driver update from NVIDIA. Have the LED and no more 3 LED lights.
    https://valid.x86.fr/hg2sgd
    post edited by badboy64 - 2020/03/10 13:25:13


    Processor Intel® Core™ i9 7960K CPU 2.8GHz@4.7ghz, Memory 32GB GSkill Trident Z RPG 3000 Ram, HighPoint SSD7103 NVMe Raid Controller, Motherboard eVga Dark x299, Operating System Windows 10 Pro 64-Bit, eVga 2080TI FTW3 Ultra 11GB , Monitor Acer CG437K , Logitech G910, Razer Lancehead Tournament Edition,Thermaltake View 71 RGB, eVga SUPERNOVA 1600 T2 PSU, Custom watercooling.
    Time Spy Extreme eVga 2080TI FTW3 Ultra
    7824
    https://www.3dmark.com/spy/8280194


    #6
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 65664
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 109
    Re: EVGA Precision X1 1.0.3.0 2020/03/08 18:22:22 (permalink)
    Cool GTX
    good to see an update




       +1   

                My Affiliate Code: 8WEQVXMCJL
     
            Associate Code: VHKH33QN4W77V6A
     
                 
     
     
                      
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #7
    Badrick16
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2020/03/08 16:08:12
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/10 11:51:48 (permalink)
    First of all, Thank you for the effort to make this happen 
    Environment:

    Some issues what I've experienced so far. I hope I'm in the good thread. 
    • I can not save the HVM settings even if I ad 1 or more signals.
    • I can use only once the save button. If I press several times( sorry for that ) it's closing itself. And I figured out, you can click on it once the second click freeze the X1.
    • I cannot save profiles at all, sometimes it works, sometimes it forget everything. (except HVM)
    • CPU temperature somehow add +20C to the correct value. ( I tried uninstall everything and keep only the precision x, same results occurred)

     
    Some tips if I may suggest for OSD:
    - CPU usage overall and /core
    - CPU core speed
    - DRAM usage
    - Graph plot 
    - Case/CPU fan rpm or %
     
    Hope this helps.
    That's all from my side after a few days! Keep it up guys!
    Looking for the next releases!
     
     

    Attached Image(s)

    #8
    jack0001
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2019/12/08 06:57:11
    • Status: offline
    • Ribbons : 1
    Re: EVGA Precision X1 1.0.3.0 2020/03/10 16:36:57 (permalink)
    Just wanted to say thanks for this update!
     
    My old 1.0.2 x1 would occasionally just exit without warning - I'd notice it when sitting at my desk when the fans would start to speed up and slow down.
    I've had 1.0.3 installed for a few days now and It's stayed running all day long so far.
    #9
    MaverickSY19
    New Member
    • Total Posts : 89
    • Reward points : 0
    • Joined: 2009/02/19 04:35:57
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/16 06:56:35 (permalink)
    Update firmware for RTX 2080 Ti FTW3 HYBRID
     
    I have this card, the update went ok, just wondering specifically what it updated.  Was this to fix an issue?  I have a problem where sometimes when I boot up the fans would be at max speed and if I open Precision 1X it will only show GPU 1 temperature and nothing else.  I then have to shut down (restart won't work) Windows and turn my PC back on it again and the problem clears.  This happens only like 1-2 a month max but still annoying, wondering if this firmware might have fixed that.

    Intel i9-10920X with Corsair H115i Pro
    Asus Rampage VI Apex 
    G.SKILL TridentZ RGB Series 32GB 3800MHz 17-17-17-37-2T
    EVGA 2080Ti FTW3 Ultra Hybrid Gaming
    Samsung 960 Pro M.2 1TB
    LG 38GL950G-B 38" 3840x1600 144Hz GSync
    EVGA SuperNova 1200 P2 P/S 
    Corsair Graphite Series 780T White Full Tower
    #10
    transdogmifier
    CLASSIFIED Member
    • Total Posts : 4071
    • Reward points : 0
    • Joined: 2003/09/05 14:26:21
    • Location: Boston, MA
    • Status: offline
    • Ribbons : 10
    Re: EVGA Precision X1 1.0.3.0 2020/03/16 07:00:13 (permalink)
    MaverickSY19
    Update firmware for RTX 2080 Ti FTW3 HYBRID
     
    I have this card, the update went ok, just wondering specifically what it updated.  Was this to fix an issue?  I have a problem where sometimes when I boot up the fans would be at max speed and if I open Precision 1X it will only show GPU 1 temperature and nothing else.  I then have to shut down (restart won't work) Windows and turn my PC back on it again and the problem clears.  This happens only like 1-2 a month max but still annoying, wondering if this firmware might have fixed that.




    I'd also like to know what was changed...ie: where's the changelog?

    Intel 9900k
    Alphacool Eisbaer 420 CPU cooler
    Gigabyte Aorus Z390 Ultra
    eVGA GeForce RTX 2080 Ti FTW3 Ultra Gaming (Hybrid kit on it)
    eVGA 1600W Supernova G2 PSU
    32GB G.skill Ripjaws 3200MHz
    Samsung Pro 970 512GB
    Thermaltake Core X9 Case
     
    My Affiliate Code: 8ST3SZQYI7
    My Associate Code: J4T7H4SOBIGFO8F
    #11
    kacan22
    Superclocked Member
    • Total Posts : 157
    • Reward points : 0
    • Joined: 2017/07/13 20:36:08
    • Location: Europe
    • Status: offline
    • Ribbons : 2
    Re: EVGA Precision X1 1.0.3.0 2020/03/16 09:09:45 (permalink)
    CPU USAGE IS STILL NOT FIXED. REPORTED IN SEPTEMBER 2018. HELLOOOOOOOOOOOOOOOOOOOOOOOO?


     

     
    #12
    MrEWhite
    New Member
    • Total Posts : 92
    • Reward points : 0
    • Joined: 2013/10/24 14:58:43
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/25 10:31:03 (permalink)
    kacan22
    CPU USAGE IS STILL NOT FIXED. REPORTED IN SEPTEMBER 2018. HELLOOOOOOOOOOOOOOOOOOOOOOOO?


    I'm not getting any CPU usage issue. It uses about 0.5% of my CPU at any given time in the background.
    #13
    kacan22
    Superclocked Member
    • Total Posts : 157
    • Reward points : 0
    • Joined: 2017/07/13 20:36:08
    • Location: Europe
    • Status: offline
    • Ribbons : 2
    Re: EVGA Precision X1 1.0.3.0 2020/03/25 14:31:46 (permalink)
    MrEWhite
    kacan22
    CPU USAGE IS STILL NOT FIXED. REPORTED IN SEPTEMBER 2018. HELLOOOOOOOOOOOOOOOOOOOOOOOO?


    I'm not getting any CPU usage issue. It uses about 0.5% of my CPU at any given time in the background.


    Not everyone is affected by this. There was a post with a lot of users reporting same problem with cpu usage. 
     
    I have 3 different computers with same gpus 2080tis in sli they all have this problem with PX1.


     

     
    #14
    kindofabuzz
    New Member
    • Total Posts : 24
    • Reward points : 0
    • Joined: 2019/09/09 18:54:44
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/29 07:39:59 (permalink)
    transdogmifier
    MaverickSY19
    Update firmware for RTX 2080 Ti FTW3 HYBRID
     
    I have this card, the update went ok, just wondering specifically what it updated.  Was this to fix an issue?  I have a problem where sometimes when I boot up the fans would be at max speed and if I open Precision 1X it will only show GPU 1 temperature and nothing else.  I then have to shut down (restart won't work) Windows and turn my PC back on it again and the problem clears.  This happens only like 1-2 a month max but still annoying, wondering if this firmware might have fixed that.




    I'd also like to know what was changed...ie: where's the changelog?




    It says in the very first post.
    #15
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 65664
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 109
    Re: EVGA Precision X1 1.0.3.0 2020/03/29 17:13:41 (permalink)
    kacan22
    CPU USAGE IS STILL NOT FIXED. REPORTED IN SEPTEMBER 2018. HELLOOOOOOOOOOOOOOOOOOOOOOOO?




    No need to yell.

                My Affiliate Code: 8WEQVXMCJL
     
            Associate Code: VHKH33QN4W77V6A
     
                 
     
     
                      
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #16
    Eagle3386
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2013/07/13 14:07:00
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/03/30 01:44:12 (permalink)
    @EVGATech_LeeM what about fixing the broken achievements over in the Steam version of this application?
    These are never awarded, no matter how often I repeatedly fulfill the required action(s):
    - A Picture is Worth a Thousand Words
    - Instructions Not Included
    - Its OK to be Cautions (mind the spell error, i. e. the missing apostrophe!)
    - Speed Limit
    post edited by Eagle3386 - 2020/03/30 01:48:07
    #17
    digitaldemon
    New Member
    • Total Posts : 25
    • Reward points : 0
    • Joined: 2009/07/24 03:30:21
    • Location: Jacksonville, Florida, USA
    • Status: online
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/04/02 16:30:30 (permalink)
    Now 1.0.4.0 is out with the same old issues. OSD still doesn't work in most games and Target slider still doesn't save. 


     
    Intel Core i7-6700K @ 4.6GHz | ASUS Maximus VIII Ranger |  ASUS PG348Q | G.Skill Ripjaws V DDR4 3000 - 16GB | EVGA GTX 1080 Ti SC2 @ +60 MHz | EVGA SuperNOVA 750 T2 | EVGA CLC 280 | Samsung 840 Evo - 500GB | Seagate Barracuda - 3TB | Corsair 760T | Corsair K70 LUX | Corsair Dark Core Pro RGB SE | Massdrop x Sennheiser PC37X
    #18
    Opolis
    CLASSIFIED Member
    • Total Posts : 2572
    • Reward points : 0
    • Joined: 2010/03/25 18:49:16
    • Status: offline
    • Ribbons : 7
    Re: EVGA Precision X1 1.0.3.0 2020/04/03 07:34:14 (permalink)
    I keep coming back to the software to give it another shot and have the same basic functionality issues as before.
    I would at least think that profiles would work by now and that the tray monitoring font wasn't microscopic...it's been YEARS.

     EVGA Associates Code: ZSD7CURL30EWPG4
    #19
    GODLIKE99KINGZ
    Superclocked Member
    • Total Posts : 134
    • Reward points : 0
    • Joined: 2009/07/28 07:37:31
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 1.0.3.0 2020/05/08 11:14:30 (permalink)
    1.0.4 OSD doesn't show in any game. Was once in Quake Champions but now don't as well. What causes that ?
    #20
    Jump to:
  • Back to Mobile