EVGA

3080 ULTRA on Z370 Classified K

Author
cotter32
New Member
  • Total Posts : 50
  • Reward points : 0
  • Joined: 2018/07/19 01:36:14
  • Status: offline
  • Ribbons : 0
2021/10/21 20:53:51 (permalink)
My System
 
Intel 8086K CPU
EVGA Z370 Classified K M/B in UFEI mode
G.SKILL TridentZ Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Intel Z370 Platform Desktop Memory Model F4-3200C14Q-32GTZ
GIGABYTE AORUS AIC 1TB PCI-Express 3.0 x4, NVMe 1.3 3D TLC ToshiBa BiCS3 Internal Solid State Drive (SSD) GP-ASACNE2100TTTDR ( in PCIe slot PE6, GPT formatted )
WH16NS40 Internal SATA 16x Super Multi Blue DVD burner ( in SATA port 1 )
HyperX Savage 2.5" 240GB SATA III Internal Solid State Drive (SSD) SHSS37A/240G
( data storage, SATA port 2, GPT formatted )
WD Black 1TB Performance Desktop Hard Disk Drive - 7200 RPM SATA 6Gb/s
( data storage, SATA port 3, GPT formatted )
Windows 10 home 64 bit system drive, all drives GPT formatted by Windows
EVGA GeForce RTX 3080 XC3 ULTRA, 10G-P5-3885KH, ( Video card in PCIe slot PE2 )
EVGA SuperNOVA P2 850W Modular Power Supply ( eco mode off )
LG 32” Class QHD Gaming Monitor with G-SYNC 32GK850G-B
Logitech USB keyboard, Logitech USB mouse, Xbox1 USB game controller
BIOS version 1.17, latest Windows, all drivers up to date, and Microsoft, or
Vendor provided .
 
RTX 3080 XC3 Ultra successfully installed on EVGA Z370 motherboard replacing EVGA 1080 .  The 1080 was a great card .  I would like to thank EVGA for making this compact
new 3080 card that fits nicely into my SilverStone GD 08 case .  I've only used the new set-up for a few days, and no gaming, or heavy duty stuff, but so far it's great .
I've also cured a problem I've had with this computer ever since I built it, and switched it to UFEI booting .  Ever since then the computer would only restart
to the UFEI BIOS screen .  Cold boot was always normal .  Well, now it restarts to Windows every time just like it's supposed to :)
 
I had asked the EVGA forum about the restarting bug, and got some good suggestions, but one I didn't want to do because my graphics card covered my BIOS selector switch .
Specifically, they said to switch to BIOS 2, and start the computer as if I was starting it for the first time ( first boot on p. 50 of the printed manual ) .
With that in mind, and the need to update to BIOS 1.17 anyway, I began to install my brand new extremely expensive EVGA 3080 Video Card .
 
I'll run through it quickly for anyone shy about messing with their computer hard ware ( as you should be ):
 
I first uninstalled CPUZ, Precision X1, and GeForce Experience software, then powered it down, unplugged it, and drained the capacitors by slowly clicking the on switch 5 or 6 times .
Next, onto the work table where an old LG 22" HDMI capable 16:10 aspect ratio monitor sits .  Perfect for displaying the BIOS .  Opened the case, and removed the old EVGA 1080 .
Switched the BIOS selector switch to position two .  Because now I could reach it .  Also, unplugged the SATA devices .
Hooked up the USB key board and mouse .  Then, plugged the monitor into the HDMI port on the back of the EVGA Z370 Classified K mother board .  No internet cable, no WIFI .
Powered it all on, and it started to ( BIOS ver 1.07 ) and it threw a CHECKSUM ERROR message, normal .  I pressed F12 to let the machine boot to Windows, and shut it down
from Windows after about five minutes .  The little monitor displayed Win10 perfectly .  Then I hit the ON button, let it start to Windows again, and clicked Restart expecting to
restart to BIOS, but it restasrted to Windows like it was always supposed to .  GREAT !  So, I shut it down again, pushed the ON button, while tapping DELETE to enter BIOS as
the machine started .  Then I flashed the new ver. 1.17 BIOS from USB thumb drive ( manual p. 50 ) saved and reset to Windows . 
The intel graphics work so well I almost hated to put the new Vid card in, oh well .
Shut down the computer, unplugged it, drained it, and then put in the new RTX 3080 .  Hooked up the card's HDMI port to the monitor's cable, and powered up .
The windows system provided a working driver and the display worked perfectly after a flash, or two .  I then CLEAN installed the current EVGA driver that I had previously 
downloaded and saved .  That removes all the old NVIDIA drivers .  Then I shut down and went into BIOS again to set the 3200 XMP memory speed, and PCIe to X4 on slot PE6 .
That's basically it except for replugging my SATA drives, putting the machine back, and hooking up my 32" 1440 Gsync monitor via display port .
Oh, and cleaning the dust out of my grills .  All still works issue free .
 
I havn't tried resizable bar yet, but I will .
 
To the Moon !
cottrer32
 
#1

2 Replies Related Threads

    cotter32
    New Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2018/07/19 01:36:14
    • Status: offline
    • Ribbons : 0
    Re: 3080 ULTRA on Z370 Classified K 2021/10/24 21:52:32 (permalink)
    Update; I have enabled resizable bar using the EVGA faq EVGA FAQ - How Do I Enable Resizable Bar Support On My EVGA Motherboard?
    and confirming the status per NVIDIA article NVIDIA Resizable BAR Firmware Update Tool | NVIDIA (custhelp.com)
    After restarting, I down loaded, and installed Precision X1, and E-LEET Tuning Utility from EVGA .  Precision X1 did a further driver update .
    I then tested by playing a blu ray movie with power DVD on highest quality setting, and playing Star Wars Battlefront, and
    Fallout4 on ultra settings .  Gsync on, 120hz refresh rate .  All worked great .
    I conclude that BIOS 1.17 and the resizable bar option are a success on the Z370 Classified K mother board with an EVGA RTX 3080 XC3 Ultra :)
     
    Happy ( moon ) landings;
    cotter32
     
    #2
    cotter32
    New Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2018/07/19 01:36:14
    • Status: offline
    • Ribbons : 0
    Re: 3080 ULTRA on Z370 Classified K 2021/10/27 19:36:00 (permalink)
     
    Excuse me for droning on, but here's a few notes for anyone who may be interested:
     
    1  I probably rebooted and checked the BIOS settings I made ten times during the above process .  Everything stayed set every time except once;
        after I got a STEAM update, that was a microsoft redistributable package, CSM reset itself to ENABLE .  I reset it to DISABLE, and it didn't happen again .
        Hopefully it won't happen again .
    2  The new 3080 graphics card reserved 16 gig. of system memory as shared video memory .  I've read that about half of what you have is normal .
    3  I left fast boot ON, and all of the other BIOS settings at default the whole time except memory XMP profile, fan speeds, and others mentioned above .
    4  I have further tested by running UNIGINE Superposition Benchmark, and got a score of 14531 at av. 108.69 frames/sec. with 97-98% GPU usage .
        No bottle neck there .
        That puts me near the top of their rankings along with the RTX 3090 card, 10 to 16 core Intel, and AMD machines .
        Not bad for an old Z370 moon lander with a 3080xc3 .  I am well pleased with the EVGA card, software, and tips from the forum .  Thanks to all .
     
    One giant leap ...
    cotter32
     
     
    #3
    Jump to:
  • Back to Mobile