EVGA

2080ti Black Displayport not working

Page: < 12 Showing page 2 of 2
Author
luiztosi
New Member
  • Total Posts : 53
  • Reward points : 0
  • Joined: 2018/12/05 05:19:42
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/10 14:30:18 (permalink)
GGTV-Jon
luiztosi
GGTV-Jon
Try this,
Take whatever monitor you want as the primary and plug the DP-HDMI cable into the top DP port on the card, hook the other monitor directly on the HDMI
Also, perhaps one of the monitors does not being on an DP-HDMI cable
 
If your primary monitor only likes the HDMI cable then put the other monitor on the DP port just below the HDMI




I really dont have any primary, does not matter...
 
I already tried... no signal on both monitors using only DP and testing on all ports... 




If you have no DP with either monitor on your adapter cable I would suggest either getting a new cable or seeing if you can borrow a real DP capable monitor and cable from a friend to test your system. Perhaps see if a local repair shop can test your system for you. The card should support the adapter cable, my friends 2080 XC has a secondary monitor on an DP-HDMI cable




 
I know i have a very cheap DP > HDMI cable so I bought yesterday a HP displayport adapter, expansive, but this is my last shot... otherwise I rma and banish EVGA brand as a hole... cmon.. what stupid produt.. i had a 1050TI running on both monitors very fine...
 
i want to see how they`ll manage this stupid situation...
 
 
#31
GGTV-Jon
FTW Member
  • Total Posts : 1821
  • Reward points : 0
  • Joined: 2017/11/25 14:11:43
  • Location: WA, USA
  • Status: offline
  • Ribbons : 19
Re: 2080ti Black Displayport not working 2018/12/10 15:00:37 (permalink)
luiztosi
GGTV-Jon
luiztosi
GGTV-Jon
Try this,
Take whatever monitor you want as the primary and plug the DP-HDMI cable into the top DP port on the card, hook the other monitor directly on the HDMI
Also, perhaps one of the monitors does not being on an DP-HDMI cable
 
If your primary monitor only likes the HDMI cable then put the other monitor on the DP port just below the HDMI




I really dont have any primary, does not matter...
 
I already tried... no signal on both monitors using only DP and testing on all ports... 




If you have no DP with either monitor on your adapter cable I would suggest either getting a new cable or seeing if you can borrow a real DP capable monitor and cable from a friend to test your system. Perhaps see if a local repair shop can test your system for you. The card should support the adapter cable, my friends 2080 XC has a secondary monitor on an DP-HDMI cable




 
I know i have a very cheap DP > HDMI cable so I bought yesterday a HP displayport adapter, expansive, but this is my last shot... otherwise I rma and banish EVGA brand as a hole... cmon.. what stupid produt.. i had a 1050TI running on both monitors very fine...
 
i want to see how they`ll manage this stupid situation...
 
 




Probably should have had you create your own thread as I feel we have hijacked Verge59's thread here with your problem
One thing you could try is with each monitor hooked up too the HDMI port look to see what drivers / firmware are available from the manufacturer as you might find a firmware update from them to address issues such as this
I know you have your mind set on blaming EVGA on this but in the end if it is a card / bios issue it is nvidia. The 1080 series cards had a re flash from nvidia just for DP issues but that was for DP 1.3 - 1.4 I think, where you are trying to convert to HDMI. And as I stated I know it works on the 2080, perhaps limited on your 2070
post edited by GGTV-Jon - 2018/12/10 15:03:18
#32
g0kK;;
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2018/12/15 06:31:34
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/15 07:03:43 (permalink)
i have same problem on my rtx 2080 my gpu working well on hdmi but not work display port my monitor MSI OPTIX MPG27CQ
#33
Cool GTX
EVGA Forum Moderator
  • Total Posts : 26472
  • Reward points : 0
  • Joined: 2010/12/12 14:22:25
  • Location: Folding for the Greater Good
  • Status: offline
  • Ribbons : 119
Re: 2080ti Black Displayport not working 2018/12/15 07:49:15 (permalink)
If your using any adapters DP to HDMI --->  You may need an active adapter to get it to work
 
Check for firmware updates from Monitor Mfg
 
You might want to test with a newer Monitor that has DP inputs & Certified DP cable - before blaming the video card
 
 
https://www.displayport.org/products-database/
 
I use the Accell brand DP cable @ 4K with no issues.  Amazon or other retailers - usually less than $20
 

RTX Project EVGA X99 FTWK 2xEVGA2080Ti EVGA1200P2  Nibbler EVGA X99 Classified 3-GPU Water cooled 1600P2 AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
Thank You for Your Support      I'm a Volunteer Moderator on the EVGA Forums ... Not an EVGA employee

#34
luiztosi
New Member
  • Total Posts : 53
  • Reward points : 0
  • Joined: 2018/12/05 05:19:42
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/15 07:59:56 (permalink)
Why it’s necessary an active adapter ? If is there any leverage I can understand but IMO its a card problem, once (as for what I know) its not necessary at all... you can use simple cables and get the sinal properly ... but I might be wrong
#35
Cool GTX
EVGA Forum Moderator
  • Total Posts : 26472
  • Reward points : 0
  • Joined: 2010/12/12 14:22:25
  • Location: Folding for the Greater Good
  • Status: offline
  • Ribbons : 119
Re: 2080ti Black Displayport not working 2018/12/15 08:17:34 (permalink)

RTX Project EVGA X99 FTWK 2xEVGA2080Ti EVGA1200P2  Nibbler EVGA X99 Classified 3-GPU Water cooled 1600P2 AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
Thank You for Your Support      I'm a Volunteer Moderator on the EVGA Forums ... Not an EVGA employee

#36
luiztosi
New Member
  • Total Posts : 53
  • Reward points : 0
  • Joined: 2018/12/05 05:19:42
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/15 09:14:45 (permalink)
Cool GTX
This

An Introduction to TMDS - Understanding DVI-D, HDMI and DisplayPort Signals
  
 
 
 
 
What is the difference between a passive and active DisplayPort converter?
 
 
 
 What’s the Difference Between Passive and Active DisplayPort Adapters?
 




Thanks, but I still dont get why it's necessary... i can understand there are different standards but i cant see any difference between then... is dual mode better in any way? once again it seem something its there just to create need.... 
#37
auron117
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2018/12/26 17:12:36
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/26 17:15:23 (permalink)
Hey was searching the web for a solution to this issue. I have a Gigabyte Aorus 2080TI and am having the same issue. I do not think this is brand specific. Fairly certain that this is a firmware issue. Have you found any solution yet?
#38
luiztosi
New Member
  • Total Posts : 53
  • Reward points : 0
  • Joined: 2018/12/05 05:19:42
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2018/12/26 18:30:17 (permalink)
auron117
Hey was searching the web for a solution to this issue. I have a Gigabyte Aorus 2080TI and am having the same issue. I do not think this is brand specific. Fairly certain that this is a firmware issue. Have you found any solution yet?




 
Well.. the way i fixed my problem was buying an active DP adapter from HP...  :) 
#39
SunnyPRO
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/01/07 17:00:42
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2019/01/07 17:03:59 (permalink)
auron117
Hey was searching the web for a solution to this issue. I have a Gigabyte Aorus 2080TI and am having the same issue. I do not think this is brand specific. Fairly certain that this is a firmware issue. Have you found any solution yet?

 
Hey i had same issue with Aorus 2080ti Xtreme and this video was the saver (watch?v=XXP0aqfsBXM on youtube or "Display Port No Signal FIX !! [Step-by-Step in Description]") + do clean driver install (use older ~416), use DDU from safe mode.
Answer if it helps, good luck!
 
post edited by SunnyPRO - 2019/01/07 17:11:38
#40
y2farrukh
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/03/29 13:53:24
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2019/03/29 14:03:23 (permalink)
HI,
 
I had the same issue today. My config is GIgabyte aorus monitor 27 and rtx 2080ti. 
 
My DP screen went completely blank out of nowhere. I changed the cable (none were VESA certified). However, my hdmi display was working. 
 
Actions performed: 
-Update monitor firmware
-Nvidia driver
- Switch monitor and pc of for 1 mins
 
After doing the above three I started receiving Display port no signal where as previously it was completely blank
 
- Last thing I did was I went to PIP mode setting of my monitor (displayed via hdmi) and display port connected as well. I went into NVIDIA control panel, change resolution and compared the setting against HMDI connecions vs DP, for some reason the DP setting were changed to NVIDIA color setting from default color setting.  Changed that and every thing normal. Thanks to VESA cable cost I did some playing and didn't lose hope in my monitor or GPU.
 
Hope this helps.
 
Muhammad
 
#41
ericandi
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2018/05/21 23:44:21
  • Status: offline
  • Ribbons : 0
Re: 2080ti Black Displayport not working 2019/07/24 02:52:02 (permalink)
I tried all guys of fixes including updating drivers, BIOS updates, uninstaling drivers, reinstalling drivers, and a few other things as well but nothing fixed my display port on my new Nvidia RTX 2080 ti. Then I read this last post. All I did was connect both hdmi and display port at the same time so I was able to see a picture thru hdmi which always worked fine. I then went into my monitor settings which aren’t in windows but controlled using physical buttons on the monitor itself and using a monitor user interface on the display not in windows. I went to display settings and simply changed the source from hdmi to display port and amazingly it worked. The screen flashed black for a split second then came right back on. I then unplugged my hdmi to be sure that the signal was actually coming thru the display port cable and it was.

In addition to this issue with the display port I had a bunch of other with Nvidia drivers and Nvidia control panel not working even though I had the latest drives and I had the latest version of Nvidia control panel installed when I tried to open it, it would tell me that I didn’t have NVIDIA drivers but Geoforce Experience and windows Device Manager both said that I had the latest drivers. I ended up installing every Nvidia drivers and app and then installed the drivers directly from the Nvidia website as opposed to downloading Geoforce experience and then letting it install the drivers. This fixed my other issue. What an absolute nightmare the Nvidia graphic card has been with Window. Nvidia And Microsoft really need to get their stuff together. This is insane. I’ve seen hundreds of posts online from people experiencing these same issues and many are never able to find a resolution. Macs don’t have any of these issues. They just work. No blue screens of death. No messing with bios.

I had to replace my 1 year old Nvidia 1080 ti because it just all of a sudden stopped be recognized by windows and after spending 80 plus hours on dozens of fixes, nothing worked so I said screw it and bought a new graphic card. I guess I should have not gotten another Nvidia.
post edited by Sajin - 2019/07/24 09:36:46
#42
GTXJackBauer
Omnipotent Enthusiast
  • Total Posts : 9507
  • Reward points : 0
  • Joined: 2010/04/19 22:23:25
  • Location: (EVGA Discount) Associate Code : LMD3DNZM9LGK8GJ
  • Status: offline
  • Ribbons : 46
Re: 2080ti Black Displayport not working 2019/07/24 15:50:31 (permalink)
ericandi
I tried all guys of fixes including updating drivers, BIOS updates, uninstaling drivers, reinstalling drivers, and a few other things as well but nothing fixed my display port on my new Nvidia RTX 2080 ti. Then I read this last post. All I did was connect both hdmi and display port at the same time so I was able to see a picture thru hdmi which always worked fine. I then went into my monitor settings which aren’t in windows but controlled using physical buttons on the monitor itself and using a monitor user interface on the display not in windows. I went to display settings and simply changed the source from hdmi to display port and amazingly it worked. The screen flashed black for a split second then came right back on. I then unplugged my hdmi to be sure that the signal was actually coming thru the display port cable and it was.

In addition to this issue with the display port I had a bunch of other with Nvidia drivers and Nvidia control panel not working even though I had the latest drives and I had the latest version of Nvidia control panel installed when I tried to open it, it would tell me that I didn’t have NVIDIA drivers but Geoforce Experience and windows Device Manager both said that I had the latest drivers. I ended up installing every Nvidia drivers and app and then installed the drivers directly from the Nvidia website as opposed to downloading Geoforce experience and then letting it install the drivers. This fixed my other issue. What an absolute nightmare the Nvidia graphic card has been with Window. Nvidia And Microsoft really need to get their stuff together. This is insane. I’ve seen hundreds of posts online from people experiencing these same issues and many are never able to find a resolution. Macs don’t have any of these issues. They just work. No blue screens of death. No messing with bios.

I had to replace my 1 year old Nvidia 1080 ti because it just all of a sudden stopped be recognized by windows and after spending 80 plus hours on dozens of fixes, nothing worked so I said screw it and bought a new graphic card. I guess I should have not gotten another Nvidia.




Glad you found the fix to your issue as simple as switching the inputs on your screen.  I can't imagine how many more had the same issue and haven't figured it out yet on such a simple thing.  I've had the same thing happened to me in the past but I always checked my cables and screen settings because HDMI by most standards is the default in most cases until DP becomes more mainstream which I feel we are on our way eventually to that point.

 Use this Associate Code at your checkouts or follow these instructions for Up to 10% OFF on all your EVGA purchases:
LMD3DNZM9LGK8GJ
#43
Page: < 12 Showing page 2 of 2
Jump to:
  • Back to Mobile