EVGA

z370 classified k won't turn on

Author
jalatorr
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2021/09/19 11:00:23
  • Status: offline
  • Ribbons : 0
2021/09/19 11:17:32 (permalink)
Hello all,
 
I got my hands on a used Z370 Classified K motherboard. It's supposed to be in working condition, but when I press the power button on the mobo or the chassis, nothing happens, the fans won't spin, the mobo leds won't light up, nothing. Only the 5VSB led is lit up red when I connect the PSU to the electricity outlet. Nothing else is lit up.
 
I'm using it with parts that were working on another PC:
CPU: i5-9400F
Corsair DDR4 vengeance 3200mhz 8GBx2 RAM
Also tried a Crucial 8GB 2666mhz stick
Silverstone Strider gold 850W PSU.
 
All these parts work fine on an Asrock Z390 phantom gaming Mobo.
 
I did all the usual testing, I took the mobo off the pc case, tried it with only the CPU and RAM, but no luck.
I did the same with the Asrock MOBO and it worked fine.
 
I see that the Z370 classified K, only supports the 9400F starting on BIOS version 1.12. I do not know what BIOS version is currently installed on it. But even if it was still on version 1.00, it would at least turn on and not POST, correct?
 
 
#1

3 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 45829
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: offline
    • Ribbons : 198
    Re: z370 classified k won't turn on 2021/09/20 18:40:49 (permalink)
    The red 5VSB LED means that your motherboard is detecting that voltage and nothing more. Yes, the bios version shouldn’t prevent the board from powering on, and displaying a post code.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #2
    jalatorr
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2021/09/19 11:00:23
    • Status: offline
    • Ribbons : 0
    Re: z370 classified k won't turn on 2021/09/20 21:24:39 (permalink)
    Thanks for your reply.

    That's what I thought.

    I was able to test today with a 8700K and another PSU, but still it didn't turn on.

    I guess the MOBO is dead after all.
    #3
    nighthawkrmx
    New Member
    • Total Posts : 34
    • Reward points : 0
    • Joined: 2020/03/20 18:35:18
    • Status: offline
    • Ribbons : 1
    Re: z370 classified k won't turn on 2021/09/21 19:39:43 (permalink)
    Even without the correct bios version including support for the 9400f it wouldn't refuse to power on.

    I would contact the seller and try to return it.
    #4
    Jump to:
  • Back to Mobile