EVGA

Z170 FTW does not post. Code C

Author
shadedurza
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2017/06/16 20:45:44
  • Status: offline
  • Ribbons : 0
2017/06/16 21:08:36 (permalink)
Hello,
I got home yesterday and my computer was off for some reason (working fine for over a year now). Attempt to turn on and no post from the board. Displaying code "C". Motherboard book doesn't seem to have a listing for single "C" code. Googling find page. Looks like it can either be CPU, power to CPU, or faulty board.
So far I have tried:
  1. Brand new CPU (skylake 6700k). Same code.
  2. Different known working power supply. Same code.
  3. Not even having power for the CPU plugged into the board. Same code.
  4. Tear the motherboard out of the case. Setup like testing a new one with only the brand new CPU in and 1 stick of RAM. Same code.
  5. "Clear CMOS" button. Same code.
Am I missing something here or do EVGA boards just sometimes die for no reason?
The rest pf my specs can be found .
 
If anyone can provide any help at all here I would be very grateful.
Thanks.
 
#1

2 Replies Related Threads

    rsabatino
    SSC Member
    • Total Posts : 931
    • Reward points : 0
    • Joined: 2010/02/04 14:00:46
    • Location: new jersey usa
    • Status: offline
    • Ribbons : 4
    Re: Z170 FTW does not post. Code C 2017/06/17 19:23:19 (permalink)
    i had the same problem with a z68 motherboard look for bent pins my pins were bent. or see if your cpu cooler is too tight try loosing it up a bit. if your pin are bent you would have to rma the board. i had to pay $70.00 so they can fix the board .

    my affiliate code is : DPSRRUOCHM
     Summary
      Operating System
       Windows 10 Pro 64-bit
      CPU
       Intel Core i7 6700K @ 4.00GHz 26 °C
       Skylake 14nm Technology
      RAM
       16.0GB Dual-Channel Unknown @ 1066MHz (15-15-15-36)
      Motherboard
       EVGA INTERNATIONAL CO.LTD 140-SS-E177 (U3E1) 27 °C
      Graphics
       ASUS VE278 (1920x1080@60Hz)
       4095MB NVIDIA GeForce GTX 1080 (EVGA) 40 °C
       4095MB NVIDIA GeForce GTX 1080 (EVGA) 34 °C
       ForceWare version: 375.70
       SLI Enabled
      Storage
       931GB Western Digital WDC WD1000DHTZ-04N21V0 (SATA) 30 °C
       1863GB Western Digital WDC WD20EZRX-00D8PB0 (SATA) 29 °C
      Optical Drives
       ASUS BC-12B1ST b
      Audio
     &n[/p
    #2
    EVGATech_JoseR
    EVGA Tech Support
    • Total Posts : 439
    • Reward points : 0
    • Joined: 2014/04/11 09:39:05
    • Status: offline
    • Ribbons : 0
    Re: Z170 FTW does not post. Code C 2017/06/18 20:12:40 (permalink)
    Hello Shadedurza!
     
    Sorry for the inconvenience but at this point you will need to RMA the motherboard. Please register the product to your account and email support@evga.com for further assistance. 
    #3
    Jump to:
  • Back to Mobile