EVGA

Hot!Z10 Keyboard (Nothing shows in OSD)

Author
XrayMan
EVGA Forum Moderator
  • Total Posts : 62001
  • Reward points : 0
  • Joined: 2006/12/14 22:10:06
  • Location: Santa Clarita, Ca.
  • Status: offline
  • Ribbons : 106
2019/04/07 15:54:20 (permalink)
 
How do I get anything to show up on screen? Want GPU temp, etc. Can't change colors for each display in the tray either.

            My Affiliate Code: 8WEQVXMCJL
 
 
                 
 
 
 
          
 
   
 
           
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 &nbsp
#1

16 Replies Related Threads

    coolmistry
    FTW Member
    • Total Posts : 1753
    • Reward points : 0
    • Joined: 2009/04/08 11:13:01
    • Location: Hemel Hempstead , London
    • Status: offline
    • Ribbons : 23
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/08 10:16:28 (permalink)
    Try my best to help you 
    My one is no problem for long time. I still use latest Version EVGA Unleash Software but it not running background cos cause flick on KB Screen running with Aidi64.
    Have you try 'Driver Reset' KB in EVGA Unleash Software and try start again setup as before what your setting is!  
     

    Use my Affiliate Code: RWYTPFDMCP
    My Rigs 
     Windows 10 Home 64bits v1903 (Retail)
    i7 8086k @ 5225 ghz || EVGA Z370 Classifield K || 2 x EVGA GTX 1080 Classified  || 16 gb Dominator Platinum DDR3 3200mhz XMP || 256 gb Samsung 970 EVO NVNm M.2 (3 x SSD and 1xHHD) || Killer Wireless AC1550 ||EVGA Supernova 1000w G2 || EVGA Z10 Keyboard || EVGA TORQ X10 mouse || Acer Predator Z35 35" 160Hz G-Sync v2 Pro
     
    MSI Z87 X-Power
    XFX nForce 780SLi
     
     
    #2
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/08 18:38:55 (permalink)
     
    I tried that too. No luck. KB screen stays blank always.

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #3
    coolmistry
    FTW Member
    • Total Posts : 1753
    • Reward points : 0
    • Joined: 2009/04/08 11:13:01
    • Location: Hemel Hempstead , London
    • Status: offline
    • Ribbons : 23
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/09 10:14:36 (permalink)
     how do we know if your KB Display working so have you try use Aidi64 to test if your KB OSD Display working.
    Try close POX and Flow Control software (if you have). 
    Reset KB driver... try this ..wait for finish reset do unplug KB USB and close EVGA Unleash Software make sure not running background. 
    Try again plug KB USB to see if display working....
     

    Use my Affiliate Code: RWYTPFDMCP
    My Rigs 
     Windows 10 Home 64bits v1903 (Retail)
    i7 8086k @ 5225 ghz || EVGA Z370 Classifield K || 2 x EVGA GTX 1080 Classified  || 16 gb Dominator Platinum DDR3 3200mhz XMP || 256 gb Samsung 970 EVO NVNm M.2 (3 x SSD and 1xHHD) || Killer Wireless AC1550 ||EVGA Supernova 1000w G2 || EVGA Z10 Keyboard || EVGA TORQ X10 mouse || Acer Predator Z35 35" 160Hz G-Sync v2 Pro
     
    MSI Z87 X-Power
    XFX nForce 780SLi
     
     
    #4
    Aza1979
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2018/10/26 10:27:29
    • Status: offline
    • Ribbons : 0
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/14 04:24:26 (permalink)
    PX1 0.3.14 seems to work on Z10 Display now.
    #5
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/14 16:16:03 (permalink)
    Aza1979
    PX1 0.3.14 seems to work on Z10 Display now.




    My 3.12 hasn't worked for me. I'll try 14, and see if that version works.

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #6
    Aza1979
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2018/10/26 10:27:29
    • Status: offline
    • Ribbons : 0
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/15 02:23:49 (permalink)
    XrayMan
     
     
    My 3.12 hasn't worked for me. I'll try 14, and see if that version works.


    Same here, 3.12 wasn't working at all. 3.14 with v72 of "Unleashed" is functionally now. Still the Z10 LCD display is barely readable, at least in red. Switching to green light helped a bit, still the font is pretty ugly.
    #7
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 4326
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: offline
    • Ribbons : 3
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/15 08:17:22 (permalink)
    When you go into the Z10 software and change it away from the Graphics card do you get a display?

    On mine the X1 software didn’t give me a display so I switched it to the date and time. Figure they will patch it but wasn’t fixed when I last looked.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #8
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/15 19:38:16 (permalink)
    Aza1979
    XrayMan
     
     
    My 3.12 hasn't worked for me. I'll try 14, and see if that version works.


    Same here, 3.12 wasn't working at all. 3.14 with v72 of "Unleashed" is functionally now. Still the Z10 LCD display is barely readable, at least in red. Switching to green light helped a bit, still the font is pretty ugly.




    I finally got it to work after updating to 3.14. It wouldn't work still until I unplugged, and plugged the KB back in again. I just wish I can make the fonts in the KB bigger, and also be able to use different color settings for the temp and fan speed in the taskbar. (EX: Red/Green).
     
    Also it keeps wanting to update to 3.14 after I already installed it. It say's it won't install because it's 16 bit. This is crazy.

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #9
    Aza1979
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2018/10/26 10:27:29
    • Status: offline
    • Ribbons : 0
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/15 23:30:39 (permalink)
    XrayMan
     
     
    I finally got it to work after updating to 3.14. It wouldn't work still until I unplugged, and plugged the KB back in again. I just wish I can make the fonts in the KB bigger, and also be able to use different color settings for the temp and fan speed in the taskbar. (EX: Red/Green).
     
    Also it keeps wanting to update to 3.14 after I already installed it. It say's it won't install because it's 16 bit. This is crazy.


    I had similar issues, unplugged, updated "Unleashed" again and ignored it from then on. PX1 and Unleashed autostart, but I do not interact with them. Display on Z10 is set to green, red and yellow aren't really good to read. PX1 is set to "autofan", and that work perfectly. Aside, my RTX FTW3 is so cool-running, it barely needs more than 50% fan speed at all.

    Need to check if the update gets rebumped as "available" over and over again, I found it happening with "Unleashed", but not with PX1 so far.
    #10
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/16 12:15:03 (permalink)
     
    Used to be able to change the color of each display in the taskbar. Shame they all can only be one color now. Also used to be able to increase the font size in the LCD screen.    

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #11
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1277
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/22 13:33:43 (permalink)
    I've tested a beta version of PX1 that fixes the OSD issue with the Z10.  You will also be able to have both PX1 and Unleash open at the same time without causing issues.  It's undergoing final testing, but I hope it will be up by the end of the week or early next week.
    #12
    bcavnaugh
    The Crunchinator
    • Total Posts : 35644
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 231
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/22 13:50:17 (permalink)
    EVGATech_LeeM
    I've tested a beta version of PX1 that fixes the OSD issue with the Z10.  You will also be able to have both PX1 and Unleash open at the same time without causing issues.  It's undergoing final testing, but I hope it will be up by the end of the week or early next week.

    Been Waiting a long time for this.
    EVGA Unleash Z10 Keyboard Software/Firmware update to support Windows 10 1809 


    #13
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/22 21:07:57 (permalink)
    EVGATech_LeeM
    I've tested a beta version of PX1 that fixes the OSD issue with the Z10.  You will also be able to have both PX1 and Unleash open at the same time without causing issues.  It's undergoing final testing, but I hope it will be up by the end of the week or early next week.




    Sounds good. Even the fix you gave me in the past won't work anymore for these issues. Just wanted to let you know that.    ;)

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #14
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 4326
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: offline
    • Ribbons : 3
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/22 22:27:52 (permalink)
    I got it to work on 3.15 but had to have X1 software open then go into the monitor and enable the keyboard to be monitored.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #15
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5604
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: online
    • Ribbons : 425
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/24 20:02:58 (permalink)
     
    EVGA Precision X1 - 0.3.16 Released
     
    Release: 4/24/2019
    • Fix online update error.
    • Improved GeForce GTX 1660 Ti support
    • Updated GeForce RTX 2080 Ti K|NGP|N Firmware
    • Improved Compatibility with EVGA Z10 Keyboard
    • Various other fixes
    Maybe this version will work.

    * Cooler Master NV-334 * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
     
    God created man... Samuel Colt made them equal.
     
     
     
    #16
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62001
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: offline
    • Ribbons : 106
    Re: Z10 Keyboard (Nothing shows in OSD) 2019/04/25 13:41:23 (permalink)
     
    I haven't noticed any improvements Bob. It's still the same with the exact same problems.   :(

                My Affiliate Code: 8WEQVXMCJL
     
     
                     
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #17
    Jump to:
  • Back to Mobile