EVGA

AnsweredHow to force PCIE Gen 3 in Windows 10?

Page: 12 > Showing page 1 of 2
Author
gridironcpj
iCX Member
  • Total Posts : 351
  • Reward points : 0
  • Joined: 2013/01/13 02:00:46
  • Location: CA
  • Status: offline
  • Ribbons : 0
2015/07/30 16:39:23 (permalink)
So I decided to upgrade to Windows 10 and so far I haven't encountered any problems except that PCIE Gen 3 is not enabled.  I had to force this with Windows 8.1, so does anyone have a clean way to force it in Windows 10? 
 
Side note: If you have a g-sync display and an SLI setup, Gen 2 will cripple your performance by a lot (30 percent for me) as opposed to having Gen 3 enabled.  I made a thread about this a while ago.  G-sync has a 3-5 percent hit with SLI even with Gen 3 enabled (tested by me and others on this thread, Nvidia seems to care less about fixing this). 
#1
Sajin
EVGA Forum Moderator
  • Total Posts : 44284
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 197
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 16:43:09 (permalink) ☼ Best Answerby gridironcpj 2015/07/30 17:31:50
Enable it manually via regedit...
 
#1 Press windows key + r to bring up the run box.
 
#2 Type regedit and hit enter.

#3 Goto  HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video 

#4 Identify the correct registry folders for each of graphics cards you have installed. There will be one associated folder for each card installed. To identify the correct folder for each card, you will need to review the names of each folder within the “HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video” registry directory. The folder associated with a graphics card will have three or more subfolders (depending on how many PCI-E slots available on the motherboard). The values listed for each subfolder will be 0000, 0001, 0002, 0003, 0004, and Video. Review only the subfolders labeled as "0000". You will know you have selected the correct "0000" subfolder when you see a registry labeled “DriverDesc” with a value that matches the graphics card you have installed. 

#5 Right click on the folder labeled “0000”. Select “New”, then select “DWORD (32-bit) Value“, then enter “RMPcieLinkSpeed” for the name of the registry. 

#6 Right click the “RMPcieLinkSpeed” registry you just created, then select “Modify”, then enter “4” as the data value and verify that the “Hexadecimal” option is checked under “Base”, and then select “OK”. 

#7 Repeat steps 5 and 6 for each graphics card associated folder (named “0000”) 

#8 Once you have completed creating the RMPcieLinkSpeed registry for each card, close the Registry Editor window and restart your computer. 

#9 Once your system is back into operating system environment, run GPU-Z and verify that the “Graphics Bus interface” value shows PCI-E 3.0 for each card. 
post edited by Sajin - 2015/07/30 17:04:45

Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
 

 
#2
gridironcpj
iCX Member
  • Total Posts : 351
  • Reward points : 0
  • Joined: 2013/01/13 02:00:46
  • Location: CA
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:08:57 (permalink)
Sajin
Enable it manually via regedit...
 
#1 Press windows key + r to bring up the run box.
 
#2 Type regedit and hit enter.

#3 Goto  HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video 

#4 Identify the correct registry folders for each of graphics cards you have installed. There will be one associated folder for each card installed. To identify the correct folder for each card, you will need to review the names of each folder within the “HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video” registry directory. The folder associated with a graphics card will have three or more subfolders (depending on how many PCI-E slots available on the motherboard). The values listed for each subfolder will be 0000, 0001, 0002, 0003, 0004, and Video. Review only the subfolders labeled as "0000". You will know you have selected the correct "0000" subfolder when you see a registry labeled “DriverDesc” with a value that matches the graphics card you have installed. 

#5 Right click on the folder labeled “0000”. Select “New”, then select “DWORD (32-bit) Value“, then enter “RMPcieLinkSpeed” for the name of the registry. 

#6 Right click the “RMPcieLinkSpeed” registry you just created, then select “Modify”, then enter “4” as the data value and verify that the “Hexadecimal” option is checked under “Base”, and then select “OK”. 

#7 Repeat steps 5 and 6 for each graphics card associated folder (named “0000”) 

#8 Once you have completed creating the RMPcieLinkSpeed registry for each card, close the Registry Editor window and restart your computer. 

#9 Once your system is back into operating system environment, run GPU-Z and verify that the “Graphics Bus interface” value shows PCI-E 3.0 for each card. 




Ah yes, I remember this method from Windows 8.1.  Don't you need to do this every time you update your drivers?  Also, I only came across one folder from step 4, instead of 2 (one for each card).  SLI is working for me and I remember doing this in Windows 8.1 with two different folders, one for each card.  Perhaps Windows 10 condenses them into one?
#3
Sajin
EVGA Forum Moderator
  • Total Posts : 44284
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 197
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:12:40 (permalink)
gridironcpj
Sajin
Enable it manually via regedit...
 
#1 Press windows key + r to bring up the run box.
 
#2 Type regedit and hit enter.

#3 Goto  HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video 

#4 Identify the correct registry folders for each of graphics cards you have installed. There will be one associated folder for each card installed. To identify the correct folder for each card, you will need to review the names of each folder within the “HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video” registry directory. The folder associated with a graphics card will have three or more subfolders (depending on how many PCI-E slots available on the motherboard). The values listed for each subfolder will be 0000, 0001, 0002, 0003, 0004, and Video. Review only the subfolders labeled as "0000". You will know you have selected the correct "0000" subfolder when you see a registry labeled “DriverDesc” with a value that matches the graphics card you have installed. 

#5 Right click on the folder labeled “0000”. Select “New”, then select “DWORD (32-bit) Value“, then enter “RMPcieLinkSpeed” for the name of the registry. 

#6 Right click the “RMPcieLinkSpeed” registry you just created, then select “Modify”, then enter “4” as the data value and verify that the “Hexadecimal” option is checked under “Base”, and then select “OK”. 

#7 Repeat steps 5 and 6 for each graphics card associated folder (named “0000”) 

#8 Once you have completed creating the RMPcieLinkSpeed registry for each card, close the Registry Editor window and restart your computer. 

#9 Once your system is back into operating system environment, run GPU-Z and verify that the “Graphics Bus interface” value shows PCI-E 3.0 for each card. 




Ah yes, I remember this method from Windows 8.1.  Don't you need to do this every time you update your drivers?  Also, I only came across one folder from step 4, instead of 2 (one for each card).  SLI is working for me and I remember doing this in Windows 8.1 with two different folders, one for each card.  Perhaps Windows 10 condenses them into one?


Yes, you will need to do it every time you update your drivers. Perhaps... only one way to find out.

Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
 

 
#4
gridironcpj
iCX Member
  • Total Posts : 351
  • Reward points : 0
  • Joined: 2013/01/13 02:00:46
  • Location: CA
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:17:42 (permalink)
Sajin
gridironcpj
Sajin
Enable it manually via regedit...
 
#1 Press windows key + r to bring up the run box.
 
#2 Type regedit and hit enter.

#3 Goto  HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video 

#4 Identify the correct registry folders for each of graphics cards you have installed. There will be one associated folder for each card installed. To identify the correct folder for each card, you will need to review the names of each folder within the “HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video” registry directory. The folder associated with a graphics card will have three or more subfolders (depending on how many PCI-E slots available on the motherboard). The values listed for each subfolder will be 0000, 0001, 0002, 0003, 0004, and Video. Review only the subfolders labeled as "0000". You will know you have selected the correct "0000" subfolder when you see a registry labeled “DriverDesc” with a value that matches the graphics card you have installed. 

#5 Right click on the folder labeled “0000”. Select “New”, then select “DWORD (32-bit) Value“, then enter “RMPcieLinkSpeed” for the name of the registry. 

#6 Right click the “RMPcieLinkSpeed” registry you just created, then select “Modify”, then enter “4” as the data value and verify that the “Hexadecimal” option is checked under “Base”, and then select “OK”. 

#7 Repeat steps 5 and 6 for each graphics card associated folder (named “0000”) 

#8 Once you have completed creating the RMPcieLinkSpeed registry for each card, close the Registry Editor window and restart your computer. 

#9 Once your system is back into operating system environment, run GPU-Z and verify that the “Graphics Bus interface” value shows PCI-E 3.0 for each card. 




Ah yes, I remember this method from Windows 8.1.  Don't you need to do this every time you update your drivers?  Also, I only came across one folder from step 4, instead of 2 (one for each card).  SLI is working for me and I remember doing this in Windows 8.1 with two different folders, one for each card.  Perhaps Windows 10 condenses them into one?


Yes, you will need to do it every time you update your drivers. Perhaps... only one way to find out.




The method was successful, but only for one graphics card.  The second is still under Gen 2.  It seems like Windows 10 doesn't recognize the second card under the registry. 
#5
Sajin
EVGA Forum Moderator
  • Total Posts : 44284
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 197
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:23:46 (permalink)
Search the registry for "NVIDIA GeForce GTX 980 TI" and add the "RMPcieLinkSpeed" to all folders that contain the "DriverDesc" entry.

Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
 

 
#6
gridironcpj
iCX Member
  • Total Posts : 351
  • Reward points : 0
  • Joined: 2013/01/13 02:00:46
  • Location: CA
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:30:54 (permalink)
I performed a clean install of the Nvidia drivers to see if that would cause the second card to appear in the registry.  This worked and now both cards have Gen 3 activated.  However, a clean install always turns SLI off, so was I supposed to have SLI off before attempting this?  If so, that may have been why I couldn't see the second card in the registry.  Thanks for the help!
#7
Sajin
EVGA Forum Moderator
  • Total Posts : 44284
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 197
Re: How to force PCIE Gen 3 in Windows 10? 2015/07/30 17:35:50 (permalink)
gridironcpj
I performed a clean install of the Nvidia drivers to see if that would cause the second card to appear in the registry.  This worked and now both cards have Gen 3 activated.  However, a clean install always turns SLI off, so was I supposed to have SLI off before attempting this?  If so, that may have been why I couldn't see the second card in the registry.  Thanks for the help!


Yes, sli should have been disabled. No problem. 

Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
 

 
#8
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/13 21:02:19 (permalink)
This actually did the opposite of what I wanted and what you said Sajin. Adding RMPcieLinkSpeed with a hexidecimal value of 4 made my GPU run in PCIex16 1.1 mode.
#9
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/13 21:33:50 (permalink)
jdcranke07
This actually did the opposite of what I wanted and what you said Sajin. Adding RMPcieLinkSpeed with a hexidecimal value of 4 made my GPU run in PCIex16 1.1 mode.




You can just run the patch as admin and it will work. I did it for my backup rig when it was my main and had a 3930K (with Windows 10 pro x64).
 
http://nvidia.custhelp.com/app/answers/detail/a_id/3135/session/L3RpbWUvMTM0MDIyMzU2OC9zaWQvaDEzbE45X2s= 

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#10
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 07:53:12 (permalink)
Unfortunately, I tried the regedit in admin first. It did nothing. Then I tried the .exe you listed and it activated and then nothing happened. Currently doing a clean install again to see if that will do the trick. If that doesn't work, then I'm at a loss. Is there by chance a power savings setting or some type of BIOS setting that could allow the Xeons to keep everything in a low power state until rendering happens? GPU-Z's rendering option is still either having all GPUs at 2.0 or even scaling them down to 1.1. Still have not seen 3.0.
#11
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:09:23 (permalink)
jdcranke07
Unfortunately, I tried the regedit in admin first. It did nothing. Then I tried the .exe you listed and it activated and then nothing happened. Currently doing a clean install again to see if that will do the trick. If that doesn't work, then I'm at a loss. Is there by chance a power savings setting or some type of BIOS setting that could allow the Xeons to keep everything in a low power state until rendering happens? GPU-Z's rendering option is still either having all GPUs at 2.0 or even scaling them down to 1.1. Still have not seen 3.0.

 
Yes, your PCIE lanes will "underclock" themselves when not in use. That is normal behavior - which is why you have to sometimes press the little "?" to start a GPU render test to see the true 3D PCIE lane speed.
 
Did you restart your computer after editing the registry? Do you have your motherboard's BIOS set as PCIE 3.0 for the lanes that you want running in PCIE 3.0 mode? Do you have a video card that supports PCIE 3.0? (on that note, what OS, motherboard, CPU, and GPU DO you have?).
 
Have you tried a full DDU uninstall of the drivers in safe mode? Then restart, install the latest drivers from Nvidia, restart (might be optional, I always do this), then apply the registry values as per above (you have to do this with every new driver install).
 
post edited by arestavo - 2016/08/14 08:14:41

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#12
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:21:10 (permalink)
Sajin mentioned that part in step 6 in the step by step fix he recommended to gridironcpj.
 
Makes sense for the underclocking.
 
So, far there is no setting that directly sets any of my PCIe slots to Gen3 or any other that I or the Asus tech I'm speaking to can find. If there is one, then I just can't find it or Asus' descriptions just suck. And yes, I used DDU for and performed a clean install with registry done. Still no changes according to GPU-Z (I am using the latest version too).
 
I have all 3.0 capable tech. The three GPUs I have are 980TI SC Classys from EVGA. Mobo is Asus Z9PE-D8 WS with two Xeon E5-2690 v1 filling each socket. This mobo has seven PCIe x16 3.0 slots and no other type. The mobo is up to four-way/quad SLI and CF capable and I have the GPUs set in three of the four blue slots that talk with the CPUs and not the chipset (black slots). The only thing that was weird was that the C602 chipset doesn't have 3.0 capable, but that's because Intel wanted that to be directly supported by the Xeons for better communication during rendering between the CPUs and the GPUs.
#13
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:28:42 (permalink)
It has got to be the motherboard or OS. Do you have the latest BIOS flashed? What OS are you running?
 
https://www.asus.com/us/Motherboards/Z9PED8_WS/HelpDesk_Download/ 
 
post edited by arestavo - 2016/08/14 08:35:34

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#14
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:33:25 (permalink)
Yeah, it's the latest that Asus released. I wish that I could get in contact with the Asus techs, but for some reason there was a disconnect during the call and now it won't let me get a call through to them. Just waiting it out a bit more to try that again.
 
Now I do have a quad port NIC installed on the fourth blue slot and a sound card on the 3rd black. GPUs are in slots 1,3,and 5 (blue), Sound card in slot 6 (black), and NIC in slot 7 (blue). As far as I can tell, there should be no shortage of PCIe lanes and that shouldn't be an issue, right? Mainly, because each CPU can handle 40 lanes and slots 1 through 4 are on CPU0 and slots 5 through 7 are on CPU1.
post edited by jdcranke07 - 2016/08/14 08:35:59
#15
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:36:39 (permalink)
jdcranke07
Yeah, it's the latest that Asus released. I wish that I could get in contact with the Asus techs, but for some reason there was a disconnect during the call and now it won't let me get a call through to them. Just waiting it out a bit more to try that again.
 
Now I do have a quad port NIC installed on the fourth blue slot and a sound card on the 3rd black. GPUs are in slots 1,3,and 5 (blue), Sound card in slot 6 (black), and NIC in slot 7 (blue). As far as I can tell, there should be no shortage of PCIe lanes and that shouldn't be an issue, right?




PCIE lane numbers don't dictate lane speed AFAIK. 
 
Have you tried a full DDU uninstall of the drivers in safe mode? Then restart, install the latest drivers from Nvidia, restart (might be optional, I always do this), then check GPU-Z again as your system is NATIVE PCIE 3.0 capable - no registry hack needed.
 
Have you tried removing all cards except 1 GPU to test with?

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#16
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 08:41:07 (permalink)
I tried the DDU in safe mode and installed the drivers, but did not do a restart after that. Should I just delete the registry hacks and try again?
 
Unfortunately, I can't remove any of the GPUs from the system. Hard tubing water loops prevent this from being done. I don't believe I have the capability to turn off PCIe slots on this mobo either like my other ASRock mobo did.
#17
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 09:10:05 (permalink)
I just spoke with the techs at Asus and they said, "This motherboard will not support x16 with quad SLI and will only max out at x8". The problem is, that I'm not trying to run quad or four-way SLI. With each CPU able to handle 40 lanes and the chipset able to handle 8, this seems like a load of crap. The tech also basically said that the mobo will not engage 3.0 because there is a limitation of lanes, which he did not elaborate on what this said limitation was. So far, it just seemed like he had no idea what he was talking about. Scheduled a call back from a supervisor to see if they can help with this explanation or if they know more. Until then, I'm lost on how to get this going.
#18
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 09:48:30 (permalink)
Who cares if it runs at X16? X8 is fine for SLI or non-SLI (1-3% difference in BENCHMARKS - not gaming), you want it to run at PCIE 3.0 instead of PCIE 2.0 right? Because PCIE 3.0 X8 has the same bandwidth as PCIE 2.0 X16.
 
The last thing that I would try would be to run CC Cleaner to clean up your registry. Run it a couple of times to make sure you cleaned out all of the garbage in the registry.
 
AND YES! RESTART your computer! We aren't quite there, software technology wise, with not needing to restart yet. Especially for registry changes.

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#19
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/14 11:22:44 (permalink)
K, will run CC Cleaner just in case. I retried the clean install and for some reason it partially worked. Personally, I think this mobo sucks, but anyways. I got two out of three running in 3.0 currently. If need be I'll do another clean install after the CC Cleaner. This is ridiculous, but it reminds me of when I tried to reset the CMOS and taking the battery out and using the jumper in various combos didn't work initially, but then it somehow just started working fine. Sounds like I got a crap mobo tbh.
#20
Dave3d
SSC Member
  • Total Posts : 720
  • Reward points : 0
  • Joined: 2008/09/04 13:20:44
  • Status: offline
  • Ribbons : 1
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/17 13:05:08 (permalink)
Go to nvidia Control panel, click Manage 3d setting, scroll to Power Management Modem and set to Prefer Maximum Performance. Save and reboot.

I7 9700k water cooled-32GB Ram-Zotac 2080 x2 SLI-Asrock Z390 SLI mobo-EVGA 1600W G2 psu-ABS Glass case-2560x1440 144hz IPS monitor-Windows 10 Home
#21
gridironcpj
iCX Member
  • Total Posts : 351
  • Reward points : 0
  • Joined: 2013/01/13 02:00:46
  • Location: CA
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/19 17:03:42 (permalink)
arestavo
Who cares if it runs at X16? X8 is fine for SLI or non-SLI (1-3% difference in BENCHMARKS - not gaming), you want it to run at PCIE 3.0 instead of PCIE 2.0 right? Because PCIE 3.0 X8 has the same bandwidth as PCIE 2.0 X16.
 
The last thing that I would try would be to run CC Cleaner to clean up your registry. Run it a couple of times to make sure you cleaned out all of the garbage in the registry.
 
AND YES! RESTART your computer! We aren't quite there, software technology wise, with not needing to restart yet. Especially for registry changes.




It matters for the combination of g-sync, SLI, and X79.  Without PCI-e 3.0 enabled, I was taking a 25-30% performance hit in 3DMark and in games.  With PCI-e enabled, that performance hit decreased to 5-10% depending on the resolution.  It isn't an issue for a single GPU.  Please keep in mind I've only tested this for X79, not any other platforms.  
#22
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2016/08/19 17:48:57 (permalink)
gridironcpj
arestavo
Who cares if it runs at X16? X8 is fine for SLI or non-SLI (1-3% difference in BENCHMARKS - not gaming), you want it to run at PCIE 3.0 instead of PCIE 2.0 right? Because PCIE 3.0 X8 has the same bandwidth as PCIE 2.0 X16.
 
The last thing that I would try would be to run CC Cleaner to clean up your registry. Run it a couple of times to make sure you cleaned out all of the garbage in the registry.
 
AND YES! RESTART your computer! We aren't quite there, software technology wise, with not needing to restart yet. Especially for registry changes.




It matters for the combination of g-sync, SLI, and X79.  Without PCI-e 3.0 enabled, I was taking a 25-30% performance hit in 3DMark and in games.  With PCI-e enabled, that performance hit decreased to 5-10% depending on the resolution.  It isn't an issue for a single GPU.  Please keep in mind I've only tested this for X79, not any other platforms.  


You might want to really read what I wrote.

At one point I had two 980 TIs in SLI on an X79 with a 3930K. It was minimal difference in FPS between PCIE 3.0 X16 and X8.

P.S. - Gsync only kicks in around 30FPS to the max refresh rate of the monitor when it is turned on. It has no bearing at higher than the refresh rate of your monitor, and it is fairly unimportant to this particular discussion.
post edited by arestavo - 2016/08/19 17:51:42

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#23
jdcranke07
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2014/09/12 22:06:07
  • Status: offline
  • Ribbons : 0
Re: How to force PCIE Gen 3 in Windows 10? 2017/06/24 20:06:12 (permalink)
arestavo
gridironcpj
arestavo
Who cares if it runs at X16? X8 is fine for SLI or non-SLI (1-3% difference in BENCHMARKS - not gaming), you want it to run at PCIE 3.0 instead of PCIE 2.0 right? Because PCIE 3.0 X8 has the same bandwidth as PCIE 2.0 X16.
 
The last thing that I would try would be to run CC Cleaner to clean up your registry. Run it a couple of times to make sure you cleaned out all of the garbage in the registry.
 
AND YES! RESTART your computer! We aren't quite there, software technology wise, with not needing to restart yet. Especially for registry changes.




It matters for the combination of g-sync, SLI, and X79.  Without PCI-e 3.0 enabled, I was taking a 25-30% performance hit in 3DMark and in games.  With PCI-e enabled, that performance hit decreased to 5-10% depending on the resolution.  It isn't an issue for a single GPU.  Please keep in mind I've only tested this for X79, not any other platforms.  


You might want to really read what I wrote.

At one point I had two 980 TIs in SLI on an X79 with a 3930K. It was minimal difference in FPS between PCIE 3.0 X16 and X8.

P.S. - Gsync only kicks in around 30FPS to the max refresh rate of the monitor when it is turned on. It has no bearing at higher than the refresh rate of your monitor, and it is fairly unimportant to this particular discussion.



So, even though I eventually swapped the GPUs to slots 3,5,7 instead of having them in 1,3,5, there is no difference in performance. Apparently if you populate slots 2 and 4, 1 and 3 are dropped to x8; however, 5 and 7 are permanently at x16 and slot 6 is permanently at x8. Theoretically, I'm supposed to have all GPUs in the correct slots and system laid out to where my GPUs should be running at Gen3x16. Regardless if that is a minor fps gain or loss, that's not the point. If the manufacturer and the manual for the mobo state that the mobo should run the GPUs at Gen3x16, then it should be. The only thing I can think that is wrong is that i have a **** mobo. Even the techs on an additional call were stumped at why this mobo isn't running all my GPUs at Gen3x16. In the future I won't be running 3 GPUs, but I probably won't buy another Asus mobo. First and final one. Gigabyte and ASRock are better IMO.
#24
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6304
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 49
Re: How to force PCIE Gen 3 in Windows 10? 2017/06/25 05:55:33 (permalink)
Blast from the past!
 
You run a 3XXX series or 4XXX series processor? If a 3XXX, look for a cheap 4XXX and see if that fixes things.
 
I had issues when forcing my 3930K to run PCIE 3.0, but no issues after I sold it and got a 1650V2 (4930K equivalent) with getting it to run at PCIE 3.0.

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#25
bcavnaugh
The Crunchinator
  • Total Posts : 38112
  • Reward points : 0
  • Joined: 2012/09/18 17:31:18
  • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
  • Status: offline
  • Ribbons : 276
Re: How to force PCIE Gen 3 in Windows 10? 2017/06/25 11:10:33 (permalink)
force-enable-gen3.exe applies to the X79 Chipset MBs + i7-39xx CPU but not the X99.
I am not seeing that gridironcp is setting the Bios on his MSI X99A Titanium MB to GEN3 from the default of Auto.
Inside your Bios are your cards Showing Gen3?
 
I do use force-enable-gen3.exe on my two X79 Classified MBs under Windows 10 only because of the CPU.
I have never any X99 and GEN3 Issues with Windows 7 8.1 or 10, but I do have an EVGA MB and not an MSI MB.
I do set GEN3 in the Bios on all Motherboards.
post edited by bcavnaugh - 2017/06/25 11:39:25

Affiliate Code: E5L3CTGE12 & Associate Code: 9E88QK5L7811G3H  NoDarkSkies


 
#26
squall-leonhart
CLASSIFIED Member
  • Total Posts : 2941
  • Reward points : 0
  • Joined: 2009/07/27 19:57:03
  • Location: Australia
  • Status: offline
  • Ribbons : 24
Re: How to force PCIE Gen 3 in Windows 10? 2018/10/14 06:32:40 (permalink)
The GEN3 tool doesn't work  via powershell, this might be where some people are seeing it fail as powershell is now the default item in the winkey+x menu.

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme
#27
bcavnaugh
The Crunchinator
  • Total Posts : 38112
  • Reward points : 0
  • Joined: 2012/09/18 17:31:18
  • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
  • Status: offline
  • Ribbons : 276
Re: How to force PCIE Gen 3 in Windows 10? 2018/10/14 08:53:45 (permalink)
squall-leonhart
The GEN3 tool doesn't work  via powershell, this might be where some people are seeing it fail as powershell is now the default item in the winkey+x menu.


What brought this Topic back into the Light? *You can change default back to CMD
Inside of Powershell you can type cmd enter then run force-enable-gen3.exe or just right click on the file and Click Run a administrator.
If you have more than ONE GPU make sure SLI is Disabled before running force-enable-gen3.exe It works dine under Windows 7-10 *1809.
There is no need to mess around in the registry for this to work on the X79 with a (Sandy Bridge E) Processor installed
The tool works fine on the X79 Platform with Older CPU's like the i7-3930K or  i7-3970X (Sandy Bridge E) Processors and is not need on the i7-4960X or i7-4820K (Ivy Bridge E) Processors
post edited by bcavnaugh - 2018/10/14 11:20:56

Affiliate Code: E5L3CTGE12 & Associate Code: 9E88QK5L7811G3H  NoDarkSkies


 
#28
squall-leonhart
CLASSIFIED Member
  • Total Posts : 2941
  • Reward points : 0
  • Joined: 2009/07/27 19:57:03
  • Location: Australia
  • Status: offline
  • Ribbons : 24
Re: How to force PCIE Gen 3 in Windows 10? 2018/10/14 10:34:08 (permalink)

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme
#29
rusTORK
New Member
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2018/09/14 10:00:39
  • Location: Russian Federation
  • Status: offline
  • Ribbons : 1
Re: How to force PCIE Gen 3 in Windows 10? 2018/10/15 13:10:14 (permalink)
Since it's popped up, i would like to ask question:
 
My system have got both Intel i7-3630QM (Ivy Bridge) which support PCI-E v3.0 and NVIDIA VGAs (GeForce GT 650M and GTX 1080Ti) which also support PCI-E v3.0, but GPU-Z only showing me PCIe x16 2.0 @ x8 2.0 (on both cards).
 
At the same time, HWiNFO64 showing me, that Root Ports have got PCI-E v3.0 (both, for each card), but VGAs again - only v2.0.
 
I even founded Root Ports in BIOS (PEG0-GenX, and PEG1-GenX), double check it's correct ports (B0:D1:F0 & B0:D1:F1) and set them Gen3. No results.
 
I updated drivers for Root Ports from Microsoft Catalog (was something like 2011, now they are 2016). No results.
#30
Page: 12 > Showing page 1 of 2
Jump to:
  • Back to Mobile