EVGA

Hot!Game not working with OSD?

Page: 12345.. > >> Showing page 1 of 11
Author
EVGA_JacobF
EVGA Product Manager
  • Total Posts : 16246
  • Reward points : 0
  • Joined: 2006/01/17 12:10:20
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 26
2015/01/30 10:35:29 (permalink)
If you find any games not working with the OSD, please list them in this thread and we can try to fix each one. Direct3D only games please! OpenGL is not currently supported. (So this means games like Wolfenstein, Rage, etc. are not currently supported)
 
Games currently being investigated for OSD compatibility
  • Batman Arkham Knight
 
post edited by EVGA_JacobF - 2015/06/23 10:07:06


#1

313 Replies Related Threads

    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/01/30 15:59:27 (permalink)
    BF4 64 bit, OSD does not work.
    #2
    perptt
    Superclocked Member
    • Total Posts : 172
    • Reward points : 0
    • Joined: 2007/10/21 02:28:34
    • Location: Stockholm, Sweden
    • Status: offline
    • Ribbons : 3
    Re: Game not working with OSD? 2015/01/30 23:56:45 (permalink)
    Trackmania 2 Stadium / Maniaplanet.
     
    http://maniaplanet.com/
     
    The OSD function is very unstable, it shows at launch but goes away during login.
     
    Thanks for looking into this. 

    Maximus VI Extreme| i7 4770K | H110 | 16Gb Vengeance PRO (2x8) | 2x eVGA GTX 980 Classified ACX2    
    |AX860W|Intel 520 180 gb Raid0 [bootdrive]|Corsair 120gb SSD [Temp.files] & 300GB [Storage] 
    |Carbide AIR 540|Soundblaster Z|Asus PG278 27" 2560x1440| Z9300| Win10 PRO x64 
      
     
    #3
    the_Scarlet_one
    EVGA Forum Moderator
    • Total Posts : 19317
    • Reward points : 0
    • Joined: 2013/11/13 02:48:57
    • Location: East Coast
    • Status: offline
    • Ribbons : 75
    Re: Game not working with OSD? 2015/02/01 06:15:09 (permalink)
    zkanuck
    @ Jacob
     
    While you're checking on game OSD compatibility... After update to 5.2.9 from 5.2.8 I can no longer get OSD in Battlefield 4 (64bit). Haven't tried 32bit version.

      <- Clickable link to my Main PC Specs
    #4
    Shelledfade
    New Member
    • Total Posts : 90
    • Reward points : 0
    • Joined: 2014/09/24 07:49:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/01 08:20:45 (permalink)
    _edited, nvm.
    post edited by Shelledfade - 2015/02/01 08:39:30
    #5
    MBOmnis
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2014/12/15 09:15:21
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/01 08:35:08 (permalink)
    Shelledfade
    Add dragon age inquisition to that list. 

    The weird thing is that with 5.2.7 the OSD worked but after uninstalling 5.2.7 installing 5.2.9 the OSD doesn't work in dragon age inquisition. I can't find the precision x server anywhere but it says its running in task manager, that didn't happen with 5.2.7 either.


    Odd... I'm running version 5.2.9 and the OSD works with Dragon Age Inquisition.
    #6
    Shelledfade
    New Member
    • Total Posts : 90
    • Reward points : 0
    • Joined: 2014/09/24 07:49:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/01 08:42:13 (permalink)
    MBOmnis
    Shelledfade
    Add dragon age inquisition to that list. 

    The weird thing is that with 5.2.7 the OSD worked but after uninstalling 5.2.7 installing 5.2.9 the OSD doesn't work in dragon age inquisition. I can't find the precision x server anywhere but it says its running in task manager, that didn't happen with 5.2.7 either.


    Odd... I'm running version 5.2.9 and the OSD works with Dragon Age Inquisition.



    I double-checked and found the problem. I wasn't aware that I had to press "OK" each time in OSD with regards to gpu clock / memory clock / gpu temp, that sort of thing. So what happened was I just clicked "Show in osd" and kept going to each setting I wanted to view and never pressed "ok" so it never showed up.

    Kind of odd that you need to press "OK" after each individual setting though to get it to stick.
    #7
    mindtrip
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2013/10/30 19:23:39
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/02 20:01:30 (permalink)
    deleted
    post edited by mindtrip - 2015/02/02 20:04:00
    #8
    EVGA_JacobF
    EVGA Product Manager
    • Total Posts : 16246
    • Reward points : 0
    • Joined: 2006/01/17 12:10:20
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 26
    Re: Game not working with OSD? 2015/02/03 11:48:43 (permalink)
     


    I double-checked and found the problem. I wasn't aware that I had to press "OK" each time in OSD with regards to gpu clock / memory clock / gpu temp, that sort of thing. So what happened was I just clicked "Show in osd" and kept going to each setting I wanted to view and never pressed "ok" so it never showed up.

    Kind of odd that you need to press "OK" after each individual setting though to get it to stick.




    Updated in 5.3.0


    #9
    Teemeister
    New Member
    • Total Posts : 49
    • Reward points : 0
    • Joined: 2014/11/08 02:51:04
    • Location: Vienna, Austria
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/03 14:48:16 (permalink)
    The Witcher 2:
    Sometimes I'm only getting a snapshot, sometimes it works as expected.

    EVGA GeForce GTX 970 SSC (3975) - EVGA SuperNOVA 850 G2 - EVGA e-GeForce 8800GTX 768MB (collecting dust) - BFG GeForce GTX 285
    #10
    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/04 07:35:47 (permalink)
    This is ridiculous.....A new version and same crap as all the others. v 5.3 does NOT hold the OSD, it goes out. plus, OSD still does not work on BF4 64 bit.
    #11
    HarryBojangles
    New Member
    • Total Posts : 12
    • Reward points : 0
    • Joined: 2006/02/15 13:32:50
    • Location: MD
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/08 12:14:15 (permalink)
    OSD in 5.3 works fine in 64bit BF4 for me, no problems.
     
    Civ5:BNW and Civ:BE the OSD does not work on.
    Using 5.3, just updated today from 5.2.5 in hopes the OSD would work in 5.3, in both versions it doesnt show up.
     
    *Edit:
     
    World of Warcraft is also very spotty. Will work sometimes, other times does not.
    #12
    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/08 14:44:06 (permalink)
    How in the heck do I get it to work? when selecting framerate, the GPU buttons don't work, only the system buttons.
    #13
    scyth16
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2014/10/04 11:24:20
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/10 13:19:21 (permalink)
    Dayz since the update last week. I'm thinking it has to do with battleeye's update that came with dayz
    #14
    gummytyke
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2013/07/06 17:27:44
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/10 19:08:13 (permalink)
    ETA on dying light fix?
    #15
    antandbetty
    iCX Member
    • Total Posts : 319
    • Reward points : 0
    • Joined: 2014/12/01 19:13:42
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/12 12:25:06 (permalink)
    Latest version 5.3.0 OSD displays  on Black flag but most values are at 0 including fps,gpu usage ect.... No OSD on far cry 4 at all. 
     
    EVGA_JacobF
    If you find any games not working with the OSD, please list them in this thread and we can try to fix each one. Direct3D only games please! OpenGL is not currently supported. (So this means games like Wolfenstein, Rage, etc. are not currently supported)
     
    Games currently being investigated for OSD compatibility
    • Dying Light
    • Elder Scrolls Online
    • Crysis 3
    • Diablo 3
    • BioShock Infinite
    • World of Tanks
     





    "Freedom is never more than one generation away from extinction. We didn't pass it to our children in the bloodstream. It must be fought for, protected, and handed on for them to do the same, or one day we will spend our sunset years telling our children and our children's children what it was once like in the United States where men were free" R.R.
    #16
    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/13 14:42:27 (permalink)
    antandbetty
    Latest version 5.3.0 OSD displays  on Black flag but most values are at 0 including fps,gpu usage ect.... No OSD on far cry 4 at all. 
     
    EVGA_JacobF
    If you find any games not working with the OSD, please list them in this thread and we can try to fix each one. Direct3D only games please! OpenGL is not currently supported. (So this means games like Wolfenstein, Rage, etc. are not currently supported)
     
    Games currently being investigated for OSD compatibility
    • Dying Light
    • Elder Scrolls Online
    • Crysis 3
    • Diablo 3
    • BioShock Infinite
    • World of Tanks
     






    Please add BF4 64 bit to the list.
    #17
    EVGA_JacobF
    EVGA Product Manager
    • Total Posts : 16246
    • Reward points : 0
    • Joined: 2006/01/17 12:10:20
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 26
    Re: Game not working with OSD? 2015/02/13 17:32:55 (permalink)
    gummytyke
    ETA on dying light fix?




    No ETA right now, but it is our top priority for OSD.


    #18
    Diff_1
    CLASSIFIED Member
    • Total Posts : 4958
    • Reward points : 0
    • Joined: 2007/06/08 23:08:44
    • Status: offline
    • Ribbons : 31
    Re: Game not working with OSD? 2015/02/13 22:22:35 (permalink)
    I'll add Horizon and Expeditions: Conquistador to the list. It's more then just the OSD working or not, it crashes those games as soon as or sometimes within 20 seconds of loading into the game worlds.
     
     
    EDIT: Back happening again and it is related to the OSD.

    Also this may not be the right place for this or it may have been mentioned someplace else but Precision OSD has a problem problem with Youtube and Twitch when using Firefox (<35.0.1). I can watch one video windowed or full screen with PrecisionX 16 OSD setup to run but upon trying to run the next video, the video plays but the screen either shows black or grey. I can either restart Firefox to get one video view again or I can open task manager and end the flash player plugin processes and then just reload the Youtube or Twitch page to then view the video. This problem does not occur at all if I do not have the OSD setup to run before going to watch Youtube or Twitch.
     
    i7 920 @ 3.2GHz
    GTX 480 FTW (stock clocks and voltages) 347.09 driver
    post edited by Diff_1 - 2015/02/24 10:09:00

    EVGA x58 E758 BIOS 83, i7 920 C0 @ 3.3GHZ, Corsair 750TX, EVGA GTX 480 HC FTW 11th anniversary prize THX EVGA, OCZ3P1600LV6GK, OCZ Vertex 2 SSD 120GB, Logitech X-540 5.1, LG W2453V, Swiftech H20-220-Ultra-GT WC kit with XSPC rx360, Windows 7 pro 64 bit OEM
    #19
    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/18 12:18:57 (permalink)
    OSD
    BF4 both 32 and 64 bit NOT working
    #20
    GoodDoggy1
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2015/01/25 23:08:05
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/02/24 17:06:08 (permalink)
    World of Tanks, 64 bit windows 7.
    evga gtx 970 ftw 2.0.
    precisionx 16 x64 5.3.1
     
    Can't get the monitoring to display on screen..... working on my other games though so far
    #21
    EVGAReg
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2008/01/06 10:28:55
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/02 16:30:24 (permalink)
    Euro Truck Simulator 2.  No OSD at all.
    #22
    dellguyz
    New Member
    • Total Posts : 45
    • Reward points : 0
    • Joined: 2015/03/04 07:01:21
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/08 15:15:08 (permalink)
    may I check in how to use the OSD function from PrecisionX? Do I need running RivaTuner together as a server to capture value?

    Case: Phantek Enthoo Luxe
    PSU: Superflower Leadex Platinum 1200W
    GPU:Palit Super JetStream 980Ti (2 Way-SLI)
    CPU: Intel i7-5820K @ 4.4Ghz 
    CPU Cooler: NZXT Kraken X61
    Motherboard: EVGA X99 FTW
    Memory: G.SKILL Ripjaws 4 2400MHz 16GB (4 x 4GB) 
    Hard drive 1: Crucial M550 256GB SSD
    Hard drive 2: Crucial MX100 512GB SSD
    Hard drive 3: TOSHIBA DT01ACA300 3TB HDD
    Monitor: BenQ BL3201PT 32" 4K LCDmonitor
    #23
    Diff_1
    CLASSIFIED Member
    • Total Posts : 4958
    • Reward points : 0
    • Joined: 2007/06/08 23:08:44
    • Status: offline
    • Ribbons : 31
    Re: Game not working with OSD? 2015/03/10 00:54:56 (permalink)
    dellguyz
    may I check in how to use the OSD function from PrecisionX? Do I need running RivaTuner together as a server to capture value?



    No no need for Rivatuner.
    You turn on the OSD display within Precisions settings, click on the innocent looking yellow arrows on both sides of the PrecisionX 16 logo at the bottom. It's not exactly new user friendly I know.
    Use the "OSD" setting to setup what hotkeys you want to turn it on and off and "monitoring" option to setup where and what you want it to monitor.

    EVGA x58 E758 BIOS 83, i7 920 C0 @ 3.3GHZ, Corsair 750TX, EVGA GTX 480 HC FTW 11th anniversary prize THX EVGA, OCZ3P1600LV6GK, OCZ Vertex 2 SSD 120GB, Logitech X-540 5.1, LG W2453V, Swiftech H20-220-Ultra-GT WC kit with XSPC rx360, Windows 7 pro 64 bit OEM
    #24
    diamond-optic
    iCX Member
    • Total Posts : 263
    • Reward points : 0
    • Joined: 2007/07/04 07:31:10
    • Location: Upstate NY
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/15 10:56:22 (permalink)
    Cities XXL
     
    If I start the game with the osd enabled, I just get a black screen with the cursor visible and the game audio too.
     
    When I enable the osd after already playing, the game just freezes up. If I disable the osd and alt tab out and back in to the game it resumes working. It just doesnt seem to like when the osd is active.
    post edited by diamond-optic - 2015/03/15 10:59:10
    #25
    eduncan911
    SSC Member
    • Total Posts : 848
    • Reward points : 0
    • Joined: 2010/11/26 10:31:52
    • Status: offline
    • Ribbons : 8
    Re: Game not working with OSD? 2015/03/17 09:12:07 (permalink)
    Windows 8.1
    Specs in signature...
     
    Previous Precision X 4.2.1
    BF4 32bit: YES
    BF4 64bit: NO (obviously), always have played BF4 in 32bit for over a year.
     
    Precision v5.3.1
    BF4 x86 (32bit): YES
    BF4 x64 (64bit): YES, yay!
     
    X-Rebirth (only 64bit, latest patch forces game to only 64):
    Got a problem: The OSD shows on the screen; but, it never refreshes.  It's static.
    This is with Precision v5.3.1.

    -=[ MODSRIGS :: FOR-SALE :: HEAT :: EBAY :: EVGA AFFILIATE CODE - HUVCIK9P42 :: TING ]=-

    Dell XPS 730X Modified H2C Hybrid TEC Chassis

    :: ASUS R4BE, 4930k @ 4.8 w/160 Bclk, 16 GB @ 2400
    :: 2x EVGA GTX TITAN SC @ 1202 / 7200 Mhz
    :: 3x 24" 120 Hz for 3D Vision Surround (6000x1080 @ 120 Hz)

    Dell Precision M4700
    :: 4720hq @ 3.6, 16 GB @ 1866, 2x 240 GB SSD, 240 GB mSATA SSD, 15 Hrs battery, tri-monitor 5760x1080
    :: 2014 Macbook Pro 15" Retina w/Nvidia 750M, tri-monitor 5760x1080
    #26
    braz989
    New Member
    • Total Posts : 99
    • Reward points : 0
    • Joined: 2008/02/07 15:32:40
    • Location: Tinley Park, IL
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/18 14:13:03 (permalink)
    Battlefield Hardline is having an issue where if EVGA Precision is running, the game runs zoomed in to the top left corner of the screen as if it is having a resolution issue.


    #27
    Brian6751
    New Member
    • Total Posts : 45
    • Reward points : 0
    • Joined: 2014/11/10 18:48:33
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/18 15:00:54 (permalink)
    not working for me with BF4 32 or 64 bit
     
    windows 8.1
    GTX 980 FTW
    i5 4690K
     

    i5 4690K @ 4.6 GHz on Cryorig H5, 16 GB 1866 Corsair Dominator, 240 GB Crucial MX100 SSD system drive, 500 GB Samsung EVO 850 for games, 1 TB WD Black for other games, 2 TB WD Green for storage,, EVGA 850 G2
    #28
    skippergonzo
    Superclocked Member
    • Total Posts : 127
    • Reward points : 0
    • Joined: 2011/07/25 09:18:06
    • Status: offline
    • Ribbons : 0
    Re: Game not working with OSD? 2015/03/19 15:09:39 (permalink)
    Dump precision. it flat out is full of bugs. Complaint after complaint from users, no OSD In games. Use Afterburner. It Works!
     
    #29
    bcavnaugh
    The Crunchinator
    • Total Posts : 35063
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 226
    Re: Game not working with OSD? 2015/03/19 15:12:18 (permalink)
    braz989
    Battlefield Hardline is having an issue where if EVGA Precision is running, the game runs zoomed in to the top left corner of the screen as if it is having a resolution issue.


    That is in Beta or Pre-Release ATM, I have no issue with BF4 and EVGA Precision 16 5.3.1

      Associate Code: 9E88QK5L7811G3H
    "Earn EVGA Bucks For Folding with EVGA!" it is not "Fold for EVGA Bucks with EVGA!" “Do it for the sake of it"



    #30
    Page: 12345.. > >> Showing page 1 of 11
    Jump to:
  • Back to Mobile