EVGA

Helpful ReplyHot!EVGA Precision X1 Beta 1.2.9.3

Author
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
2021/12/02 10:17:15 (permalink)
This beta addresses some of the reported issues with the last several versions, including the RGB LED failing to save.
 
Note - To reduce potential MCU/BIOS flashing issues, please disable "Fast Boot" in your motherboard BIOS before changing cards or flashing to a different BIOS.  Just a PSA....
 
  • Although not officially supported, this version should allow GTX 980 cards to use PX1 without the application crashing due to the VF curve.
  • Fix LED color not saving issue.
 
 
Download here:  Precision X1 Beta v1.2.9.3
 
Please let us know if you run into any issues.
#1
harley262
Superclocked Member
  • Total Posts : 250
  • Reward points : 0
  • Joined: 2021/11/16 07:59:41
  • Location: numba won in youre hart
  • Status: online
  • Ribbons : 1
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/05 16:14:25 (permalink)
works with a 780 ti kingpin, although its identified as an xc3 ultra hybrid 
#2
OCretribution
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2014/02/04 20:41:33
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/05 17:10:58 (permalink)
fwiw, I am still experiencing a zeroed value on the FPS counter with this build installed cleanly.
#3
whpony96
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2014/04/21 21:45:46
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/07 21:06:05 (permalink)
Incorrect the LED settings saving issue is NOT resolved. (nVidia 3080Ti Founders Edition)
 
I can't believe this issue was brought up in June and no resolution yet. 
#4
nomoss
FTW Member
  • Total Posts : 1550
  • Reward points : 0
  • Joined: 2009/04/04 19:45:27
  • Status: offline
  • Ribbons : 7
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/07 21:52:05 (permalink)
The program interface displayed, so I guess that's a "yes" for me.

Associates code:  9OYA1P1FRHQ3SGN
Imgur    modsrigs:  Chemical X   RedWing   Utonium   TY for the +1s! 

#5
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/08 10:24:06 (permalink)
whpony96
Incorrect the LED settings saving issue is NOT resolved. (nVidia 3080Ti Founders Edition)
 
I can't believe this issue was brought up in June and no resolution yet. 


Is the issue that the LED settings aren't saving while in Windows, or are they not saving after a reboot?  If it's the latter, PX1 cannot fix that; it's an NVIDIA issue with FE cards.
#6
transdogmifier
CLASSIFIED ULTRA Member
  • Total Posts : 5692
  • Reward points : 0
  • Joined: 2003/09/05 14:26:21
  • Location: Orlando, Fl
  • Status: offline
  • Ribbons : 15
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/08 10:34:58 (permalink)
whpony96
Incorrect the LED settings saving issue is NOT resolved. (nVidia 3080Ti Founders Edition)
 
I can't believe this issue was brought up in June and no resolution yet. 




This issue was brought up before June....and yes, I agree it's silly that it's not fixed properly yet.

Edit: If indeed it isn't fixed...I haven't tried the beta.
 
 

AMD Ryzen 5950x
Coolermaster ML360R RGB
Asus ROG Crosshair VIII Dark Hero
eVGA GeForce RTX 3090 FTW3 Ultra Gaming (Hybrid kit on it)
Asus ROG Swift PG43UQ 4k Monitor
eVGA 1600W Supernova T2 PSU
32GB G.Skill 3600 DDR4 (2x16GB) Trident Z Neo
Corsair MP600 Pro 2TB (Boot)
Corsair MP600 2TB (Games/Data)
Phanteks P500A Case
 
Associate Code: J4T7H4SOBIGFO8F
#7
whpony96
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2014/04/21 21:45:46
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/08 22:23:37 (permalink)
EVGATech_LeeM
whpony96
Incorrect the LED settings saving issue is NOT resolved. (nVidia 3080Ti Founders Edition)
 
I can't believe this issue was brought up in June and no resolution yet. 


Is the issue that the LED settings aren't saving while in Windows, or are they not saving after a reboot?  If it's the latter, PX1 cannot fix that; it's an NVIDIA issue with FE cards.


That's NOT true if you can apply the settings in X1 while in Windows and it works (Which I can and it works fine.) then during reboot the software should be able to reapply them after restart. This is a X1 software issue NOT a hardware issue. X1 is not saving the settings or applying the settings after restart. Otherwise it would not work at all.
 
#8
whpony96
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2014/04/21 21:45:46
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/08 22:40:15 (permalink)
Look here's proof X1 doesn't save LED settings. Try to create a few different LED profiles with different colors....Now go back and load each profile....None of them will load....
 
#9
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/09 10:38:01 (permalink)
whpony96
Look here's proof X1 doesn't save LED settings. Try to create a few different LED profiles with different colors....Now go back and load each profile....None of them will load....

This doesn't really prove your point.  The roadblock here is that FE cards do not work properly when saving to a firmware profile.  This is a known issue on the NVIDIA end.  PX1 saves to firmware when configuring profiles or different settings, especially RGB.  Using your example, changing profiles will not help here, since there will be no firmware profile to recover after loading a different profile.  You will need to configure your RGB settings each time on a FE card.
 
whpony96
That's NOT true if you can apply the settings in X1 while in Windows and it works (Which I can and it works fine.) then during reboot the software should be able to reapply them after restart. This is a X1 software issue NOT a hardware issue. X1 is not saving the settings or applying the settings after restart. Otherwise it would not work at all.

Because there is no firmware profile that can be saved on an FE card, you cannot recover a RGB configuration profile after reboot.  The most PX1 can do with an FE card is to apply settings in real-time, which will take effect until you restart your PC.
#10
whpony96
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2014/04/21 21:45:46
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/09 10:51:53 (permalink)
OK, well that explains why I also noticed my card will no longer go into 0db mode after using the X1 software then. It seams X1 must of corrupted the OEM firmware. So my question to you is how do I correct that issue your software caused?
 
 
#11
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/09 11:01:16 (permalink)
whpony96
OK, well that explains why I also noticed my card will no longer go into 0db mode after using the X1 software then. It seams X1 must of corrupted the OEM firmware. So my question to you is how do I correct that issue your software caused?

The issue you described is not something that can be permanently caused by using Precision X1.  RGB lighting is saved to firmware, which does not occur with an FE card.  Fan profiles/clock speeds are changed and saved only at a low-level driver level with PX1, and this can be applied after a reboot if you select the proper settings. 
 
If you uninstall PX1, reinstall drivers, and the issue still occurs, then you should contact NVIDIA for further troubleshooting if the fan should be lowering itself to a 0dB mode.
#12
Squall_Rinoa86
FTW Member
  • Total Posts : 1784
  • Reward points : 0
  • Joined: 2010/07/26 14:09:48
  • Location: The Empire State -> Hyde Park
  • Status: offline
  • Ribbons : 5
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/10 23:29:22 (permalink)
LED still isnt saving on reboot.




PSU: EVGA SuperNOVA 1300 G2
My Affiliate Code: AN1FW0VMG6
#13
tc0566
Superclocked Member
  • Total Posts : 154
  • Reward points : 0
  • Joined: 2012/03/05 16:14:55
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/11 16:01:32 (permalink)
EVGATech_LeeM
Both the newest stable and this Beta version of PX1 did no update for VBIOS  and no firmware update on 3080TI FTW3 Ultra. PX1 version was a bit old too, so it should have done at least the firmware update. My current bios is 94.02.71.80.86.
 
post edited by tc0566 - 2021/12/11 16:02:42

 
Use my Associate code to save money on your next purchase!
K8KDH9WX5PDC7ZN
And for all those that use it THANK YOU

#14
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/13 10:24:56 (permalink)
tc0566
EVGATech_LeeM
Both the newest stable and this Beta version of PX1 did no update for VBIOS  and no firmware update on 3080TI FTW3 Ultra. PX1 version was a bit old too, so it should have done at least the firmware update. My current bios is 94.02.71.80.86.
 


What about MCU version?
#15
tc0566
Superclocked Member
  • Total Posts : 154
  • Reward points : 0
  • Joined: 2012/03/05 16:14:55
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/13 13:54:20 (permalink)
EVGATech_LeeM
tc0566
EVGATech_LeeM
Both the newest stable and this Beta version of PX1 did no update for VBIOS  and no firmware update on 3080TI FTW3 Ultra. PX1 version was a bit old too, so it should have done at least the firmware update. My current bios is 94.02.71.80.86.
 


What about MCU version?


Not sure what MCU is exactly lol... But neither version updates anything. And on anything I've seen in regards to EVGA software there has always been a firmware update. Here is a screenshot from PX1.
 
 
 
 

post edited by tc0566 - 2021/12/13 13:58:31

 
Use my Associate code to save money on your next purchase!
K8KDH9WX5PDC7ZN
And for all those that use it THANK YOU

#16
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/13 14:01:23 (permalink)
tc0566
EVGATech_LeeM
What about MCU version?


Not sure what MCU is exactly lol... But neither version updates anything. And on anything I've seen in regards to EVGA software there has always been a firmware update. Here is a screenshot from PX1. And will you ever be abler to drag and drop an image in this forum?

Thanks, the picture has the firmware version (aka MCU firmware version).  Also, I edited your post to make the image show up properly. 
 
The MCU controls fans, RGB, the way PX1 sees the card, etc.  I need the version to have our team compare your version to whatever the latest version is for your cardd, which...might be exactly the one you have.  That screen is everything needed at the moment.
#17
tc0566
Superclocked Member
  • Total Posts : 154
  • Reward points : 0
  • Joined: 2012/03/05 16:14:55
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/13 14:04:41 (permalink)
EVGATech_LeeM
tc0566
EVGATech_LeeM
What about MCU version?


Not sure what MCU is exactly lol... But neither version updates anything. And on anything I've seen in regards to EVGA software there has always been a firmware update. Here is a screenshot from PX1. And will you ever be abler to drag and drop an image in this forum?

Thanks, the picture has the firmware version (aka MCU firmware version).  Also, I edited your post to make the image show up properly. 
 
The MCU controls fans, RGB, the way PX1 sees the card, etc.  I need the version to have our team compare your version to whatever the latest version is for your cardd, which...might be exactly the one you have.  That screen is everything needed at the moment.


Yes the way you can't drag and drop photos into posts on this forum is a bit outdated and always causes me problems.

 
Use my Associate code to save money on your next purchase!
K8KDH9WX5PDC7ZN
And for all those that use it THANK YOU

#18
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/13 14:16:07 (permalink)
tc0566
Yes the way you can't drag and drop photos into posts on this forum is a bit outdated and always causes me problems.


Trust me, if that's the only thing you find outdated about this forum....
#19
ntzphyr
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2012/04/27 01:00:31
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/14 17:28:29 (permalink)
whpony96
Incorrect the LED settings saving issue is NOT resolved. (nVidia 3080Ti Founders Edition)
 
I can't believe this issue was brought up in June and no resolution yet. 




Try running LEDSync from C:\Program Files (x86)\ EVGA \LED sync  once. It's the only way I ever got it to work on my 1080ti ftw regardless of PX1 version. When I do change LED color, I use the now running LEDSync from the task bar manually
post edited by ntzphyr - 2021/12/14 17:32:51

CPU: i9 10900k 
Corsair H150i Elite Capellix cpu cooler
ROG Strix Z590-A gaming WiFi
GPU: EVGA GTX 1080TI FTW3 
Corsair Dominator Platinum 32 GB
Power Supply: Corsair HX1000i 
Monitor X 2 : ASUS 27" VS 278
Keyboard: Corsair K95 Platinum RGB
Mouse: Corsair M65 ultra Wireless
Headset: Corsair Virtuoso SE
VR: Samsung HMD Odyssey Headset
#20
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/15 09:30:34 (permalink) ☄ Helpfulby BizSAR 2021/12/15 15:44:18
Squall_Rinoa86
LED still isnt saving on reboot.


We can reproduce this now.  Seems like the profile isn't saved if PX1 is open when you shut down or restart the system.
 
While we work on a more permanent solution, the basic fix for this is to close PX1 before restarting Windows.  Should work fine after you reboot.
#21
zippytek
SSC Member
  • Total Posts : 638
  • Reward points : 0
  • Joined: 2020/10/06 17:25:35
  • Status: offline
  • Ribbons : 3
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/15 10:48:59 (permalink)
EVGATech_LeeM
Squall_Rinoa86
LED still isnt saving on reboot.


We can reproduce this now.  Seems like the profile isn't saved if PX1 is open when you shut down or restart the system.
 
While we work on a more permanent solution, the basic fix for this is to close PX1 before restarting Windows.  Should work fine after you reboot.




some of these dudes are rude meanies. keep up the good work, y'all are appreciated more than you're blamed. 
#22
bracenet
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2008/06/28 13:59:11
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/15 17:07:05 (permalink)
Yes I'm having issues with x1 on my new 3090 FTW3 ULTRA HYBRID GAMING. I only see 4 different available options to display on the osd where are the rest ?  I'm looking to display more info like cpu Temps and other Temps like it shows on the icx button. Is this something with my install or not an option on x1 ? Also was looking for info on the fans it shows 2 fans but there's 3 2 on the rad and 1 on the shroud? What's up with that. I think I'll have to call you guys at evga support and ask about that plus my running Temps if there normal.  Thank you for reading 
#23
ekwk1983
New Member
  • Total Posts : 24
  • Reward points : 0
  • Joined: 2020/12/18 12:32:54
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/16 12:31:00 (permalink)
I recently upgraded to 1.2.9.3 hoping it will fix my issues but the problem still persists.
My default Fan speed for Fan 1 is 75% and on my desktop without anything running it goes to 1860-1890 odd and remains.
The problem starts when I run any 3d application like Games or benchmarks like 3D Mark. The card does not seem to adhere to the 75% min speed and the fan goes down to 1200-1400 RPM and spikes up to 2k+ causing a lot of unwanted fan spins going up and down.
Videos of what's happening below. The percentage seems to stay but the RPMs are out of control during operation.
https://www.youtube.com/watch?v=S-5ftBOwJlA
https://www.youtube.com/watch?v=80oFXVtU4EQ
 
Here I also recorded both screens. The moment 3D Mark loads and starts is when the problem occurs.
https://youtu.be/0qtg4u02DeE
 
I am recently on windows 11. Is this a known problem? Is it a Software (PX1) / Driver Issue? Firmware Issue? Bios Issue? Or Hardware?
 
Need some help, it's driving me nuts.
#24
ekwk1983
New Member
  • Total Posts : 24
  • Reward points : 0
  • Joined: 2020/12/18 12:32:54
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/16 12:34:29 (permalink)
Here is my PX1 setting.
 

 

#25
Squall_Rinoa86
FTW Member
  • Total Posts : 1784
  • Reward points : 0
  • Joined: 2010/07/26 14:09:48
  • Location: The Empire State -> Hyde Park
  • Status: offline
  • Ribbons : 5
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/16 19:27:28 (permalink)
EVGATech_LeeM
Squall_Rinoa86
LED still isnt saving on reboot.


We can reproduce this now.  Seems like the profile isn't saved if PX1 is open when you shut down or restart the system.
 
While we work on a more permanent solution, the basic fix for this is to close PX1 before restarting Windows.  Should work fine after you reboot.




Hmm Intresting.. I will try this and see. Thanks! 

MCU version for my 3080 if it matters is 2.01.22


zippytek
EVGATech_LeeM
Squall_Rinoa86
LED still isnt saving on reboot.


We can reproduce this now.  Seems like the profile isn't saved if PX1 is open when you shut down or restart the system.
 
While we work on a more permanent solution, the basic fix for this is to close PX1 before restarting Windows.  Should work fine after you reboot.




some of these dudes are rude meanies. keep up the good work, y'all are appreciated more than you're blamed. 



If I didn't care, for what EVGA does, I wouldn't have a huge list of products from them on many things from PSU's to AIO's to GPU's.
post edited by Squall_Rinoa86 - 2021/12/16 19:28:48




PSU: EVGA SuperNOVA 1300 G2
My Affiliate Code: AN1FW0VMG6
#26
Radical_53
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2021/01/03 13:36:55
  • Status: offline
  • Ribbons : 0
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/17 06:02:14 (permalink)
This version solved an issue I had since the last update for W11 (regular channel) & Battle.Net with version 1.2.9. The application simply wouldn't open anymore after showing the splash screen, profiles weren't loaded anymore.
Now everything is back to normal, thanks!

PS: Even better than normal actually, great improvement so far concerning v/f curve and fan regulation.
#27
EVGATech_LeeM
EVGA Forum Moderator
  • Total Posts : 3514
  • Reward points : 0
  • Joined: 2016/11/04 14:43:35
  • Location: Brea, CA
  • Status: online
  • Ribbons : 14
Re: EVGA Precision X1 Beta 1.2.9.3 2021/12/17 10:54:44 (permalink)
#28
Jump to:
  • Back to Mobile