EVGA

Hot!EVGA PSU not working.

Author
Antily15503
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2018/02/15 21:49:53
  • Status: offline
  • Ribbons : 0
2018/02/15 22:02:48 (permalink)
Hi everyone, so I just got my first PSU from EVGA and I was met with some problems (or lack of there of)
 
So I just got my EVGA PSU last month for my 3 GPU Zcash mining rig, (yeah I didnt want to spend lots of money on GPU cuz they are expensive) and finally wired everything. When I plugged my PSU into my outlet and turned it on, nothing happened. I was pretty confused at this time and turned it off. Then I tried the Eco switch, but it still didn't turn on. I don't know if the PSU is broken or something, or if I didnt wire it correctly, but it is powering NOTHING. So I thought maybe I should use the PSU tester or if I was just dumb and shorted something.
 
In case you are wondering
Motherboard: ASUS B250 19 GPU slots (kind of overkill)
GPU: 2 XFX Raedon Rx580 and a MSI Raedon Rx580.
RAM: Ballistix 8GB
CPU: Intel Celeron
PSU: EVGA Supernova 1200 P2 Platinum
Using Dell Monitor
SanDisk USB stick but maybe using Crucial SSD.
 
plz give suggestions on how to fix this.
Also feel free to leave me suggestions on what I should add to my rig or what im missing or etc. 
#1

16 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 37123
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: EVGA PSU not working. 2018/02/15 22:13:19 (permalink)
    Psu won't start with the tester connected?

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #2
    Antily15503
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/02/15 21:49:53
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2018/02/15 22:28:21 (permalink)
    I didnt try tester yet, should I try it?
     
    #3
    Sajin
    EVGA Forum Moderator
    • Total Posts : 37123
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: EVGA PSU not working. 2018/02/15 22:29:45 (permalink)
    Yes, make sure you're only trying to start the psu, and everything else is disconnected from it.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #4
    Antily15503
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/02/15 21:49:53
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2018/02/15 22:36:11 (permalink)
    k, will do tomorrow
     
    #5
    Antily15503
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/02/15 21:49:53
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2018/02/16 21:39:49 (permalink)
    how do I test the PSU?
     
    #6
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5623
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: offline
    • Ribbons : 431
    Re: EVGA PSU not working. 2018/02/16 23:54:06 (permalink)
    See How do I test my power supply? in the EVGA FAQs (or your PSU manual) for basic functionality testing using the included PSU Tester that came with your unit and the link on the page for advanced voltage testing.
     
    Also some good info on PSUs and testing in the Power Supply FAQs over at JonnyGURU.
    post edited by bob16314 - 2018/02/17 00:30:05

    * Cooler Master NV-334 * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
     
    God created man... Samuel Colt made them equal.
     
     
     
    #7
    Antily15503
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/02/15 21:49:53
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2018/02/22 17:07:50 (permalink)
    Took me a while to finally test the PSU, since I had other stuff to do.
    When I plugged it in, it worked and the fan started spinning, so I think I wired something wrong.
    #8
    Sajin
    EVGA Forum Moderator
    • Total Posts : 37123
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 195
    Re: EVGA PSU not working. 2018/02/22 17:27:17 (permalink)


    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #9
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62476
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: online
    • Ribbons : 106
    Re: EVGA PSU not working. 2018/03/09 22:44:07 (permalink)
     
    Post back with an update, if you find out what you did wrong.

                My Affiliate Code: 8WEQVXMCJL
     
     
                      
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #10
    Antily15503
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/02/15 21:49:53
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2018/03/17 21:55:13 (permalink)
    Oh yes, sorry
    I found out why
    Thanks everyone for your time :)
    #11
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 4489
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: online
    • Ribbons : 3
    Re: EVGA PSU not working. 2018/03/17 22:43:03 (permalink)
    Antily15503
    Oh yes, sorry
    I found out why
    Thanks everyone for your time :)




    No problem and glad we could help out. That is what the forums are for.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #12
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62476
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: online
    • Ribbons : 106
    Re: EVGA PSU not working. 2018/03/18 00:34:28 (permalink)
     
    Glad you got the answer.     

                My Affiliate Code: 8WEQVXMCJL
     
     
                      
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #13
    mirandap53
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2019/06/04 18:40:15
    • Status: offline
    • Ribbons : 0
    Re: EVGA PSU not working. 2019/06/04 18:42:31 (permalink)
    I’m having a similar issue, where my power supply will only supply power when it is connected to the tester.
    #14
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5623
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: offline
    • Ribbons : 431
    Re: EVGA PSU not working. 2019/06/04 19:21:12 (permalink)
    mirandap53
    I’m having a similar issue, where my power supply will only supply power when it is connected to the tester.

     
    Welcome to the forums.
     
    To receive better help, you should probably create your own thread.
     
    Go to the EVGA Power Supplies main page and select "Post New Thread" at the top-left area of the page.

    * Cooler Master NV-334 * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
     
    God created man... Samuel Colt made them equal.
     
     
     
    #15
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 4489
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: online
    • Ribbons : 3
    Re: EVGA PSU not working. 2019/06/04 22:35:08 (permalink)
    mirandap53
    I’m having a similar issue, where my power supply will only supply power when it is connected to the tester.


    As said above it’s best to start your own thread and include what hardware you are using and which model of PSU you are having an issue with.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #16
    XrayMan
    EVGA Forum Moderator
    • Total Posts : 62476
    • Reward points : 0
    • Joined: 2006/12/14 22:10:06
    • Location: Santa Clarita, Ca.
    • Status: online
    • Ribbons : 106
    Re: EVGA PSU not working. 2019/06/16 19:40:04 (permalink)
    Hoggle
    mirandap53
    I’m having a similar issue, where my power supply will only supply power when it is connected to the tester.


    As said above it’s best to start your own thread and include what hardware you are using and which model of PSU you are having an issue with.



      +1

                My Affiliate Code: 8WEQVXMCJL
     
     
                      
     
     
     
              
     
       
     
               
     
     
     
     
     
     
     
     
     
     
     
     
     
     
     



     
     
     
     
     
     &nbsp
    #17
    Jump to:
  • Back to Mobile