EVGA

Warning FTW3 and PowerLink

Author
sutt359
New Member
  • Total Posts : 72
  • Reward points : 0
  • Joined: 2008/08/13 04:15:12
  • Status: offline
  • Ribbons : 0
2017/05/19 08:46:29 (permalink)
Hi Guys

I've just installed my FTW3 and PowerLink, and found it stopped the end fan from spinning.

Dont install Precision x before adjusting the power link. As you need to pull it away from the card to leave a gap to clear the fan.

The Precision x software will do a firmware update to the fans and push each one to 100% and will cause it to grind on the PowerLink.

Update
It looks like when the PowerLink is installed it can push the orange and black power/fan cable into the fan stopping it. So just check that you have adjusted this before powering up.
 

 

post edited by Sajin - 2017/05/19 11:57:57

EVGA X99 FTW, Intel i7 5930k, 16gb Corsair Dominator Platinum, EVGA GTX 1080 TI FTW3, EVGA DG-87, EVGA CLC280, Crucial MX100 1TB SSD, Coolermaster Gold 1000w PSU, Creative SB ZX.
#1

8 Replies Related Threads

    jsarver101
    Superclocked Member
    • Total Posts : 228
    • Reward points : 0
    • Joined: 2013/02/25 18:10:00
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 08:50:57 (permalink)
    I have two with powerlink installed and have no issues. They are flush with the edge of the card too


    Enthoo Elite - Asus Rampage V E10 - 6850K 4.3 @ 1.3v - 32GB Gskill Trident RGB 3200mhz - GTX 1080Ti FTW3 x2 - Creative Sound Blaster ZxR - Corsair 1500i - Samsung 960 Evo 1Tb NVMe - Samsung 840 Pro 512 SSD - Samsung 850 Pro 1Tb SSD - Samsung 840 Evo 1Tb SSD- Corsair H110i - ROG Swift @ 1440p w/ Gsync x2 - Sen. HD700 - Razer Chroma X - Razer Naga - Razer Deathadder Elite 
     
    #2
    furiousreload
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2012/02/01 20:52:59
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 10:26:40 (permalink)
    My FTW3 did that right out of the box, I spun all three and that cable was in the way, I put my powerlink on well after that and the problem did not come back.
    #3
    123Testing123
    iCX Member
    • Total Posts : 337
    • Reward points : 0
    • Joined: 2017/02/28 20:07:02
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 11:11:42 (permalink)
    furiousreload
    My FTW3 did that right out of the box, I spun all three and that cable was in the way, I put my powerlink on well after that and the problem did not come back.




    So you're saying that the right most (as you look at it installed) cable may be in the path of a portion of the right most fan as the FTW3 is shipped ("out of the box" as you put it)?
    This is the 1st I've heard of this issue. Thanks for the heads-up!
    #4
    furiousreload
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2012/02/01 20:52:59
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 11:53:14 (permalink)
    123Testing123
    furiousreload
    My FTW3 did that right out of the box, I spun all three and that cable was in the way, I put my powerlink on well after that and the problem did not come back.




    So you're saying that the right most (as you look at it installed) cable may be in the path of a portion of the right most fan as the FTW3 is shipped ("out of the box" as you put it)?
    This is the 1st I've heard of this issue. Thanks for the heads-up!


    Yes, I spun each fan by finger when I took it out of the box the first time. The right most fan at the end by the power connectors was catching and not spinning well. Upon inspection, I found that same cable from the above pictures was in the path of the right fan. I bent it out and all was well after that.
    post edited by furiousreload - 2017/05/19 11:55:27
    #5
    123Testing123
    iCX Member
    • Total Posts : 337
    • Reward points : 0
    • Joined: 2017/02/28 20:07:02
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 14:55:06 (permalink)
    furiousreload
    123Testing123
    furiousreload
    My FTW3 did that right out of the box, I spun all three and that cable was in the way, I put my powerlink on well after that and the problem did not come back.




    So you're saying that the right most (as you look at it installed) cable may be in the path of a portion of the right most fan as the FTW3 is shipped ("out of the box" as you put it)?
    This is the 1st I've heard of this issue. Thanks for the heads-up!


    Yes, I spun each fan by finger when I took it out of the box the first time. The right most fan at the end by the power connectors was catching and not spinning well. Upon inspection, I found that same cable from the above pictures was in the path of the right fan. I bent it out and all was well after that.



    Wow, I hope someone from EVGA is reading this thread, or that they've been notified of this issue.
    #6
    Capt_Caveman
    Superclocked Member
    • Total Posts : 144
    • Reward points : 0
    • Joined: 2005/12/09 14:41:35
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/19 20:38:56 (permalink)
    Powerlink installed on my FTW3 with no issues
    #7
    Ab1987
    Superclocked Member
    • Total Posts : 191
    • Reward points : 0
    • Joined: 2017/03/28 14:35:01
    • Location: NYC
    • Status: offline
    • Ribbons : 1
    Re: Warning FTW3 and PowerLink 2017/05/19 21:07:38 (permalink)
    No power link. But out of the box that cable was in the way getting hit by the fan at 100 percent speed when doing whatever evga software was doing , thankfully nothing messed up and I fixed it
    #8
    JustinXCIV
    New Member
    • Total Posts : 20
    • Reward points : 0
    • Joined: 2013/09/14 00:56:58
    • Status: offline
    • Ribbons : 0
    Re: Warning FTW3 and PowerLink 2017/05/20 18:36:01 (permalink)
    My FTW3 also has that cable sticking out near the fan closest to the power connectors. Out of the box it wasn't in the way of the fans or anything but I definitely took note that it was protruding out past the shroud so the black/orange cable wouldn't catch on the fan.

    Not that it's a problem, but because it sticks out I notice it.
    #9
    Jump to:
  • Back to Mobile