EVGA

Hot!EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work)

Author
DevilxDoge
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2020/09/22 16:24:14
  • Status: offline
  • Ribbons : 0
2020/10/15 03:27:55 (permalink)
I've had the card for about a couple weeks now and noticed that the LED's don't work immediately. Weird thing is, they come on after several hours of the pc being on and running. Once I turn it off or put my pc into sleep mode they go out and have to wait a while before they come back on. As of right now, I've had the pc running for over 6 hrs and they haven't turned back on. I read some posts on older cards for some fixes but it looks like there was some kind of update to actually fix these problems. I've checked for loose connections, refit the card, and uninstalled Precision X1 and re-installed it. I also downloaded the most recent update for it. I made sure that the the 3 8 pin connections are separate. The only led that seems to consistently on is the smaller "EVGA" led on top of the card. Another thing to mention, if the lights go on and I start messing with the led settings, they will stop functioning as I cycle through the settings. For example: if they are currently static red, and I switch them to static white, it will stay static red.
 
Current Specs for pc:
 
Intel core i9 9900k
Rog Strix z390-E gaming
EVGA supernova g3 750w
EVGA 3080 FTW3 ultra
 
Not sure what other information might be needed but I can update if necessary. Other than the LED's, the card seems to be running fine. Only thing I've noticed so far is there is some gpu sagging going on but not too much, the card's in all the way.  Also, I have corsair LEDs on my fans and use their software to control the lighting. Could that cause any issues? Any help or advice is appreciated.
#1

21 Replies Related Threads

    ReZpawN
    iCX Member
    • Total Posts : 304
    • Reward points : 0
    • Joined: 2020/09/17 16:22:46
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/15 06:55:03 (permalink)
    Are you hitting apply when you set them? Also do you have them saved to a profile and do you have px1 launch when you boot windows and apply that profile?
    #2
    DevilxDoge
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2020/09/22 16:24:14
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/15 12:04:27 (permalink)
    Yes, the smaller EVGA led top of the card will stay lit and can change colors. If the other lights are out, the apply button will be grey’d out and nothing happens. So the issue here is the lights are not turning on during boot up and it seems like precision x1 won’t even detect them.
    #3
    ReZpawN
    iCX Member
    • Total Posts : 304
    • Reward points : 0
    • Joined: 2020/09/17 16:22:46
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/15 12:12:34 (permalink)
    DevilxDoge
    Yes, the smaller EVGA led top of the card will stay lit and can change colors. If the other lights are out, the apply button will be grey’d out and nothing happens. So the issue here is the lights are not turning on during boot up and it seems like precision x1 won’t even detect them.
    could be something going on with px1 because I had some issues like that a couple times but restarting px1 fixed it
    #4
    DevilxDoge
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2020/09/22 16:24:14
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/15 12:22:51 (permalink)
    I thought that too at first, but I uninstalled and reinstalled it several times. I’m starting to think it might be an issue with the bios or maybe I just got a faulty card. When I look up “rgb not working” for older cards EVGA reps directed them to updates for the fix. I don’t expect them to have a fix immediately but I thought I’d post so if they see this they’re aware of a possible issue people might have. I haven’t seen any posts for led issues on 3080s yet.
    #5
    ReZpawN
    iCX Member
    • Total Posts : 304
    • Reward points : 0
    • Joined: 2020/09/17 16:22:46
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/15 22:42:08 (permalink)
    DevilxDoge
    I thought that too at first, but I uninstalled and reinstalled it several times. I’m starting to think it might be an issue with the bios or maybe I just got a faulty card. When I look up “rgb not working” for older cards EVGA reps directed them to updates for the fix. I don’t expect them to have a fix immediately but I thought I’d post so if they see this they’re aware of a possible issue people might have. I haven’t seen any posts for led issues on 3080s yet.

    have you tried putting bios switch to the other bios and seeing if that fixes it? If not you might have to reach out to support and rma it possibly 
    #6
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/26 16:51:04 (permalink)
    im having the same issue, im about to throw this card out the window just because of that 
    #7
    Saltgrass
    Superclocked Member
    • Total Posts : 169
    • Reward points : 0
    • Joined: 2010/03/19 20:31:08
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/27 08:19:34 (permalink)
    Which LEDs are you referring to?  I will assume the 3090 FTW is like the 3080 in this respect.   It has 4 small LEDs on the back/top right, are those the ones?
     
    Right now, I have the impression the Precision X1 is still being developed and may be allowing more functionality with upgrades..

    ******************** 
     W10 x64
    Asus Maximus Hero XII (Wi-Fi)
    Intel i9 10900K
     EVGA RTX 3090 FTW Ultra
     32 GB G.Skill 4000.
    #8
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/27 10:49:30 (permalink)
    Saltgrass
    Which LEDs are you referring to?  I will assume the 3090 FTW is like the 3080 in this respect.   It has 4 small LEDs on the back/top right, are those the ones?
     
    Right now, I have the impression the Precision X1 is still being developed and may be allowing more functionality with upgrades..




    im talking about the rbg lightbar. sometimes it turns on when I hit the power button on the pc, other times it takes 5minutes, 10 minutes or even 40 minutes. its only the main bar, all the other rgb lights on it turn on just fine.
    #9
    MattN247
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2018/07/26 15:22:38
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/28 13:27:11 (permalink)
    I'm having issues with all the LEDs on my FTW 3080 also.
    *Correction-the only LED that works is the small "EVGA" logo that's on the backplate.  None of the other LEDs are turning on no matter what I do in PX1
    post edited by MattN247 - 2020/10/28 13:32:14
    #10
    Saltgrass
    Superclocked Member
    • Total Posts : 169
    • Reward points : 0
    • Joined: 2010/03/19 20:31:08
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/29 04:14:01 (permalink)
    If it is only the Light Bar, perhaps it is a connection situation.  That might be a modification EVGA does to the card and something isn't making good contact..

    ******************** 
     W10 x64
    Asus Maximus Hero XII (Wi-Fi)
    Intel i9 10900K
     EVGA RTX 3090 FTW Ultra
     32 GB G.Skill 4000.
    #11
    _7ucky_
    Superclocked Member
    • Total Posts : 108
    • Reward points : 0
    • Joined: 2020/09/27 23:38:45
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/29 09:33:17 (permalink)
    I'm all for the black lips. Didn't Jacob say something about multiple colors being offered to users "soon" as well? 

    CPU: Intel Core i9 10900k @5.1Ghz
    GPU: RTX 2060 SUPER SC ULTRA BLACK GAMING 8GB
    RAM: 2x 16GB CORSAIR Vengeance RGB PRO (3200)
    SSDs: Samsung 970 EVO Plus 1TB
    Monitor: Acer Predator X34 (120hz TN)
    OS: Windows 10 Home 64-bit
    #12
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/10/29 10:21:10 (permalink)
    my computer has been on for 3 hours and not once has that huge bar turned on once... last night i gamed for 5 hours lol. didnt turn on. the evga logo on top works,  but the light bar and evga logo on the red lips isnt working.........  SHOULD I BE WORRIED!!!
    post edited by jplaza28 - 2020/10/30 15:35:38
    #13
    Nfsdude0125
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2011/03/02 17:57:14
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/11/01 02:17:22 (permalink)
    Hey man, I made another post with the exact same issue. The only light that works for me is the one on the backplate, nothing else does. It has worked a couple times, completely randomly. 

    I imagine it may be a software problem. It works flawlessly otherwise so I'm not going to waste people's time with an RMA. Just annoying. 
    #14
    Nfsdude0125
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2011/03/02 17:57:14
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/11/01 02:18:23 (permalink)
    Oh, side note. 

    When I made some overclocking adjustments on PX1, I thought I'd try and fool it by applying the changes with a change in the light settings for the light bar, and PX1 crashed. 
     
    #15
    Exigos
    New Member
    • Total Posts : 11
    • Reward points : 0
    • Joined: 2020/11/13 20:15:19
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/11/14 14:19:01 (permalink)
    Having the same issue, did you solve your problem?
    #16
    whitefoxmax
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2020/11/23 05:34:05
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/11/26 03:33:11 (permalink)
    I have a similar issue, RMAing the card, no response from support for several days, paid extra for premium which includes support and received faster response from MSI... 
     
    some part of the bar has it's on life, it either off or on no matter what, if i turn off the rgb it stays on...
    sometimes in blue sometimes in orange something is wrong there... 
    #17
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/12/02 05:42:28 (permalink)
    Exigos
    Having the same issue, did you solve your problem?

    I ending up RMAing it. I called evga and they set it all up. I did the program where they put a charge on my credit card and they ship me a new card. Once the new card is received, I used the same shipping box with the paid return label and sent the bad card back to them. The charge on my account was returned a few days later. 

    evga solved it quickly. the new 3080 I have is solid.
    #18
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/12/02 05:43:47 (permalink)
    whitefoxmax
    I have a similar issue, RMAing the card, no response from support for several days, paid extra for premium which includes support and received faster response from MSI... 
     
    some part of the bar has it's on life, it either off or on no matter what, if i turn off the rgb it stays on...
    sometimes in blue sometimes in orange something is wrong there... 


    thats weird. I'd call them. They resolved my issue within 3 days. I called, they put a hold on my credit card. Received the new 3080 within 72hours( i live 20 mins from EVGA HQ ). Then I returned it and boom done!
     
    #19
    jplaza28
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/10/22 16:45:13
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/12/02 05:49:35 (permalink)
    I did the CROSS SHIP RMA option. hope this helps you guys!
    #20
    Guardo
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2020/12/10 14:31:10
    • Status: offline
    • Ribbons : 0
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/12/18 03:05:26 (permalink)
    Same problem started on my Rtx 3080 ftw 3 ultra 1 day ago...
    #21
    glenn37216
    FTW Member
    • Total Posts : 1133
    • Reward points : 0
    • Joined: 2007/02/09 11:43:25
    • Location: Nashville , Tn 37216
    • Status: offline
    • Ribbons : 5
    Re: EVGA 3080 FTW3 Ultra RGB not working (second post because image did not work) 2020/12/18 04:05:18 (permalink)
    Just finished a customers build with the 3080 ftw 3 ultra and the gpu has the same issue with the LED's. No quality control checks on these cards?> why is it that so many have the failing led's ? 

    I 3d print stuff ! :P 
    https://www.thingiverse.com/glenn37216/designs
    Rig 1 of 6
    Ryzen 9 5900X @4.7ghz 1.275v (All Core)
    NZXT KRAKEN X73 360MM w/ Fractal De​sign Prism​a AL-12 fans PUSH/PULL
    GIGABYTE X570 AORUS Master (F31q Bios)
    RAID 0 ARRAY - 2x SAMSUNG 980 PRO 500GB NVMe - SAMSUNG 860 PRO SSD 1TB (4x)
    32GB G.Skill Trident Z Neo DDR4 3600MHZ -
    CASE - Phanteks Eclipse P500A - (Front Panel FAN modded) -
    PSU - EVGA G2 1300
    NO GPU YET ! WAITING ON EVGA queue
    #22
    Jump to:
  • Back to Mobile