EVGA

Helpful ReplyBios boot priority (display port)

Author
danielchowrf
New Member
  • Total Posts : 16
  • Reward points : 0
  • Joined: 2016/02/17 21:34:10
  • Status: offline
  • Ribbons : 0
2016/03/25 21:29:14 (permalink)
My card is booting on the 2nd monitor (hdmi) and not on the primary monitor (dp). I turn my computer on and the bios screen will display on the 2nd monitor while the 1st sleeps until Windows loads.
 
Is there a way to switch this?
#1
arestavo
CLASSIFIED ULTRA Member
  • Total Posts : 6329
  • Reward points : 0
  • Joined: 2008/02/06 06:58:57
  • Location: Through the Scary Door
  • Status: online
  • Ribbons : 53
Re: Bios boot priority (display port) 2016/03/25 21:35:15 (permalink)
No way to switch it.
 
Nvidia sets the boot priority, and it goes something like: VGA - DVI - HDMI - then finally DP (basically oldest to newest)
 
EDIT: I suppose you could get a DP to DVI adapter (so the DVI port is used on the video card) so that it gets the priority boot order.
post edited by arestavo - 2016/03/25 21:37:57

EVGA affiliate code: 9ZWDWFNW6A
(Don't forget to upload your invoice or no credit is given!)
 
FOLD ON
#2
bsmegreg
FTW Member
  • Total Posts : 1611
  • Reward points : 0
  • Joined: 2014/07/19 19:18:29
  • Status: offline
  • Ribbons : 6
Re: Bios boot priority (display port) 2016/03/25 23:20:36 (permalink)
Basically you need to live with it... RIP NVIDIA firmware....

#3
kinb_eggy
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2017/02/14 13:11:23
  • Status: offline
  • Ribbons : 1
Re: Bios boot priority (display port) 2017/02/14 13:14:46 (permalink) ☄ Helpfulby XrayMan 2018/01/30 22:53:09
"Basically you need to live with it". That's not necessarily true. I have fixed this problem for my setup but it does reply on your motherboard and whether or not you installed Windows in UEFI mode. 
 
I had a 2 monitor setup. My old 24" monitor on DVI ( in portrait mode to make matters worse!) and a 27" 2K on Display Port connected to my EVGA GTX 970. 
Motherboard is ASUS Z270-P but I know from others that this will work on other boards.

NOTE: You must have a UEFI setup, if you have an older legacy non-UEFI setup then this will not work.

If you don't have a UEFI setup I'm not sure what you can do other than to reinstall Windows in UEFI mode on a clean disk/partition. To be honest I would have done this anyway as it reduces boot time quite a bit.

The BIOS POST and setup screens would only ever show on the monitor connected via DVI. Apparently the graphics card prioritises the connections in this order 
DVI -> HDMI -> Display Port

After a while rotating my head to read the BIOS screen I decided enough was enough. After some research and trial and error I came across a very simple solution.

Anyway, to the point finally.
In the motherboard BIOS settings under the BOOT menu (on my board) there is an option called "CSM (Compatibility Support Module)". This is Enabled by default. Changing this to Disabled instantly fixed the issue. You may want to also try 'Auto' in case you have other non-UEFI devices connected but this may not work, it didn't for me.


Anyway, hope this helps somebody.
#4
Molokaiboy
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2016/05/14 19:24:52
  • Status: offline
  • Ribbons : 0
Re: Bios boot priority (display port) 2018/01/20 11:49:06 (permalink)
Dam.....thanks dud...been trying to figure this one out for a while...changed the settings in the bios worked great...now my system boots to the right monitor...good job
#5
Jump to:
  • Back to Mobile