X58 FTW3 Won't resume from S3 sleep

Post
driftwolf0076
New Member
2011/03/01 13:31:25
Update:
I found a Microsoft hotfix for this problem link
 
Hey guys,
 
My computer has been hanging at the S3 sleep state.  It started last week sometime after I did a BIOS flash.  What I didn't realize was that I didn't need to do this flash since I already had the latest BIOS.  No harm was done except I lost a few settings.  
 
The real issue is that now my computer won't resume from the S3 sleep state.  I've done a little reading on the issue and made some adjustments to BIOS (below is a picture with relevant settings).  I also made adjustments to the windows power profile to allow S3 sleep.
 
Does anyone know what settings are specifically required to ensure S3 works?  
 

post edited by driftwolf0076 - 2011/03/01 17:20:55

Attached Image(s)

tcermak
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 14:40:55
Have you installed Windows 7 sp1. After installation my my resume from sleep didn't work either. Uninstall fixed the issue
driftwolf0076
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 14:46:52
Yes, I have installed SP1.  That was also last week about the same time S3 stopped working.  I need to investigate.  Thanks for the tip.  Did anyone else experience problems with S3 after installing sp1 for Windows 7?
revenantx02
EGC Admin
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 14:50:29
now that you mention it. I thought it was just my rubbish motherboard(non EVGA company :) ).
But my computer has done it more than usually since installing SP1
driftwolf0076
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 17:18:59
Success!
 
After a little research, I fount that this is a Sp1 problem not a hardware problem.  Here is a link to Microsoft's hotfix for the issue.  I must warn that Microsoft has not fully tested this hotfix, so use at your own risk.  The problem exists if your boot drive is connected to your motherboard through a third party controller that shows up as a  SCSIport miniport driver.  This is the case for Marvell controller used for 6Gb SATA III.  
 
Anyone running Windows 7 Sp1 having problems with hibernate or S3 sleep that has their boot drive connected to a Marvell controller should try this hotfix after backing up their data and creating a restore point.
tcermak
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 17:35:01
i Have tried the hotfix but it didnt help matters. Plus i am not using the marvell ports. only fix at the moment is to uninstall sp1 and all is bck to norm
driftwolf0076
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/01 18:45:24
I'm sorry to hear that the hotfix didn't work.  I hope Microsoft has a permanent fix for this problem quickly.  My only thought is to check for chipset driver updates.
justin_43
CLASSIFIED Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 00:01:17
Nvm
post edited by jethc9 - 2012/01/15 11:34:21
Davewm24
FTW Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 01:06:10
lol I literally just started my own thread on this a second ago.  Then I saw this right below.  Ill have to give this a try.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 04:29:25
I have the same problem.  After installing sp1 the 770 won't wake from sleep.  If I uninstall sp1 it works fine.  This was driving me crazy trying to find the solution. 
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 04:37:42
I don't use the Mavell ports but I have the Marvell 91xx driver installed. I have the same problem after installing sp1. I have removed sp1 and wake up from sleep works. I wonder if I uninstall the driver then add sp1, will it wake up from S3 sleep like without sp1? I'll try this when I have time. Thanks
idiegoit
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 06:59:27
I have the same problem with the follow assembed PC:
MB: EVGA X58 CLASSIFIED 3, latest bios E770.78, 
CPU: Intel Core i7 980X ovk 4.4 GHz
RAM: Corsair Dominator DDR3 PC3-12800 DHX Pro - 2 Kit 6Gb
PSU: Zalman ZM850-HP - 850 Watt
GPU: Gainward GeForce GTX 470
HD:  OCZ RevoDrive x2 PCIe SSD - 240GB
S.O.: Microsoft Windows 7 Ultimate 64 Bit ITA retail
Without the SP1, the system wake up from sleep very well, since one UpDate from Microsoft, a little time before the SP1 release . So, actually, I remouve the SP1, and I stopped the automatic UpDate. I'm waiting enyone that found a fix to this problem.
 
 
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 20:29:32
I tried removing the Marvell driver and reinstalled sp1 and it didn't help.  770 board won't resume from sleep (S3).  Is this only happening with the 770 or does anyone with a 760 or 759 have the problem after installing sp1 ?
HeavyHemi
Omnipotent Enthusiast
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/02 20:41:09
Same issue. After installing SP1  S3 resume from sleep no longer works. It just hangs with a black screen. Resume from hibernate works. This is on a E758 board.
mechanicguy
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/04 20:41:43
I am having this problem too. However, hotfix http://support.microsoft.com/kb/2495523 does NOT fix my issue. It doesn't matter if the hotfix is installed or not, if my drives are plugged into the Marvell controller or not, the only thing that makes the issue go away is if uninstall Windows 7 SP1.
 
I opened a thread in the MS forums for this same issue: http://answers.microsoft....e011-9bac-78e7d160ad4e
 
EVGA FTW3 motherboard
Core i7 980x processor
Corsair Dominator DDR3 1600 (3 X 4GB) memory
EVGA GTX 580 Graphics
Crucial C300 SATA 6.0 Gps SSD
Western Digital 1 TB SATA 6.0 Gps data drive
Nvidia 3d Vision Kit
Windows 7 Pro x64
benthomas
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/05 02:12:50
This is so weird..I just posted about having the same problem when I found my system to pass 20 intel burn tests fine.  I was going to start thinking it was my memory but I've had SP1 installed now for a while.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/05 18:55:54
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/05 18:57:40
Does anyone have a fix yet?
jasonanderson
SSC Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/07 15:28:50
I recently ran into this issue and in my case I think the issue was related to my SSDs being on the Marvell ports (I first had them on the Intel SATA II ports with no problem).  I did not try the hotfix, but I went into the advanced power settings and disabled hybrid sleep.  Now, my computer will sleep and resume properly.  In my case it seems to be a hibernation issue and when hybrid sleep is enabled, it does write to the hibernation file before going to sleep.  You might try that to see if it helps in your scenario.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/17 20:31:51
Has anyone figued this out yet?  I tried to reinstall sp1 with a differnt monitor and it didn't help at all.  It still won't resume from sleep after sp1. I am restoring from a system image now.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/17 20:34:09
Please, someone give me a fix.
gvansly1
iCX Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/18 02:30:16
Please, someone give me a fix.

I have the same issue on the 759
The fix is .....Remove SP1
If you don't need why install it:http://www.howtogeek.com/...should-you-install-it/
I read the article at the above link, then uninstalled SP1, now my baby wakes up from sleep as it should....
DMIINC
CLASSIFIED ULTRA Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/18 05:55:03
Please guys, go and post about your problems over at the MS forums. This is the only way this problem will get fixed. I already did so.
Bentmind
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/19 12:08:35
I have a Classified 3 that I use as a Media Center/Server/Game machine.  I have an Intel SSD plugged into the 6g or Marvell controller.  I had an issue where it would not resume from sleep but cold boot instead, it would not wake up with wake-up timer events either.  The hotfix posted above fixed the issue.
 
Thought I would add my experience to the pile.
 
 
ExcessiveGBH
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/21 01:24:40
I have the same issues with SP1.  When I move the mouse to boot PC from S3 the hard drive light comes on for a second or two, then the fans start, motherboard displays F3 then 01 but that is as far as it gets. Pressing the reset button will make it boot in resume mode.
amatotg
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/26 19:38:15
Something to be aware of here is that resume from sleep issues can be caused by Windows and/or hardware.  This isn't just a single issue attributed to Windows 7 SP1 updating in ALL cased.
I own the X58 760 Classified and been having issues with resume from sleep since the BIOS versions started to hit the versions enumerated in the 70's.  Interestingly enough, 77 was kosher, even with SP1.  I just upgraded to 78 last night and now the problem isn't just intermittent like I had experienced back at BIOS 74 (if I remember the version correctly) but it's hard and fast now each and every time.  When the mobo goes through initial POST routines and your Power LED mysteriously comes on and then goes off just seconds after hitting the mouse, keyboard or power button - that's indicative of a BIOS/mobo POST initialization problem and has nothing to do with Windows - be it the base kernel or a SP.
 
eVGA needs to get this sorted because BIOS 78 with the Intel Rapid Storage firmware update has the problem in it - and like I said - it's hard & fast repeatable.
HalloweenWeed
CLASSIFIED Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/26 19:59:27
amatotg

Something to be aware of here is that resume from sleep issues can be caused by Windows and/or hardware.  This isn't just a single issue attributed to Windows 7 SP1 updating in ALL cased.
I own the X58 760 Classified and been having issues with resume from sleep since the BIOS versions started to hit the versions enumerated in the 70's.  Interestingly enough, 77 was kosher, even with SP1.  I just upgraded to 78 last night and now the problem isn't just intermittent like I had experienced back at BIOS 74 (if I remember the version correctly) but it's hard and fast now each and every time.  When the mobo goes through initial POST routines and your Power LED mysteriously comes on and then goes off just seconds after hitting the mouse, keyboard or power button - that's indicative of a BIOS/mobo POST initialization problem and has nothing to do with Windows - be it the base kernel or a SP.

eVGA needs to get this sorted because BIOS 78 with the Intel Rapid Storage firmware update has the problem in it - and like I said - it's hard & fast repeatable.

amatotg, EVGA may not be monitoring this thread. Please post this where they will read it:
EVGA X58 Motherboards - BIOS 78 Released
 
amatotg
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/26 20:26:13
Done.
 
Thx
dilburt
iCX Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/28 21:38:25
This is a problem with all X58 boards.  There are lots of posts about it on every motherboard site.  The root cause is that the DDR voltage is set to default during S3 sleep mode.  This is why many support people don't find this problem because it won't affect the system unless the RAM is overclocked to some combination of settings that require more than the default voltage and support people use stock settings.  For example, my Corsair XMS1600C7 RAM runs at 1.5v for the stock SPD table frequencies and S3 sleep will work with these settings.  As soon as the RAM is set to 1.65v for the XMP timings or above the S3 sleep fails.
 
You can easily prove this to yourself.  Hang a volt meter on the DDR test point and start your system with a configuration that requires a DDR voltage over 1.5 volts.  Enter S3 sleep and watch your volt meter drop from 1.65v (or whatever) to 1.5v during S3 sleep then move back to 1.65v when you resume.  This lack of voltage causes RAM corruption which is the true root cause of this problem (S3 is also call "suspend to RAM").  Most people report their CAS timing has changed after running this test.
 
Unfortunately, there is no work-around although some people say that some manufacturers have figured out how to fix it in BIOS for some boards.  I cannot verify this.
 
- D
ExcessiveGBH
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/29 04:41:09
dilburt

This is a problem with all X58 boards.  There are lots of posts about it on every motherboard site.  The root cause is that the DDR voltage is set to default during S3 sleep mode.  This is why many support people don't find this problem because it won't affect the system unless the RAM is overclocked to some combination of settings that require more than the default voltage and support people use stock settings.  For example, my Corsair XMS1600C7 RAM runs at 1.5v for the stock SPD table frequencies and S3 sleep will work with these settings.  As soon as the RAM is set to 1.65v for the XMP timings or above the S3 sleep fails.

You can easily prove this to yourself.  Hang a volt meter on the DDR test point and start your system with a configuration that requires a DDR voltage over 1.5 volts.  Enter S3 sleep and watch your volt meter drop from 1.65v (or whatever) to 1.5v during S3 sleep then move back to 1.65v when you resume.  This lack of voltage causes RAM corruption which is the true root cause of this problem (S3 is also call "suspend to RAM").  Most people report their CAS timing has changed after running this test.

Unfortunately, there is no work-around although some people say that some manufacturers have figured out how to fix it in BIOS for some boards.  I cannot verify this.

- D

 
Even If I have it set to S1 it still won't boot or am I barking up the wrong tree?
HalloweenWeed
CLASSIFIED Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/29 09:33:23
S1 works fine without fail for me. Even at C6, with Speedstep and Turbo on; no matter HT.
IMHO if S1 is failing for you, your OC is not stable.
dilburt
iCX Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/29 17:22:04
I would agree, if you can't resume from S1 then there is a more fundamental problem.  Have you run prime95 after a normal restart since you installed SP1 to see if the system is still stable?
 
-  D
mechanicguy
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/30 16:41:12
The new beta bios "80" released on 3/29/2011 fixed my issue. http://forums.evga.com/tm.aspx?m=932958 Thanks EVGA for fixing this sleep problem. I've missed my sleep mode very much and now it works again! Yeeeeaaah!!!
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/30 18:34:33
Mechanicguy,
 Besides the beta bios 80 what if anything did you change to get sp1 to resume from sleep?
 
mechanicguy
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/30 19:21:33
jcohenmd,
 
after updating the bios I made the following changes in the bios:
changed hard drive mode to AHCI
set memory target frequency/timings/dimm voltage to manufacturers specifications
change sleep mode to s3(save to ram) 
 
and changes in power options in the control panel:
loaded power option defaults in the control panel and then disabled hybrid sleep
 
hope this helps
post edited by mechanicguy - 2011/03/30 20:06:06
ExcessiveGBH
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/30 22:45:09
mechanicguy

The new beta bios "80" released on 3/29/2011 fixed my issue. http://forums.evga.com/tm.aspx?m=932958 Thanks EVGA for fixing this sleep problem. I've missed my sleep mode very much and now it works again! Yeeeeaaah!!!


I have now loaded BIOS 80 and sleep mode working very well.
Thanks for the support EVGA.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 04:08:32
Mechanicguy,
Did you have sp1 loaded before the bios flash or did you put it in after the flash?  Do you think that this matters, probably not.
Also what model board and what cpu did you have?  I have read that it may be a problem with the 980x.  I have the problem with a 770 board and a 980x but not with a 760 and a 950.
Looks like ExcessiveGBH hin the post above has a 980x also.
Thanks.
ckavadas
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 06:05:57
After Sp 1 install from microsoft in Windows 7 you must then disable the "allow hybrid sleep" in advanced power options in Windows. Then everything works fine. This problem only happens after SP1 install. When you disable this hybrid sleep it seems to fix the problem.I have my bios set to "s1 &s3"
 
Costa
mechanicguy
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 06:35:57
jcohenmd

Mechanicguy,
Did you have sp1 loaded before the bios flash or did you put it in after the flash?  Do you think that this matters, probably not.
Also what model board and what cpu did you have?  I have read that it may be a problem with the 980x.  I have the problem with a 770 board and a 980x but not with a 760 and a 950.
Looks like ExcessiveGBH hin the post above has a 980x also.
Thanks.

jcohenmd,

I had SP1 installed prior to flashing the bios. I agree, I don't think it matters if it is installed or not prior to the bios update.
 
I have the EVGA E768 (EVGA X58 FTW3) motherboard and the intel i7 980x cpu.
ExcessiveGBH
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 09:06:36
I also have SP1 installed before flashing...no issues here either.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 21:13:50
Just Flashed.  Will try and install SP1 tomorrow night and see what happens. I'll cross my fingers. Thanks .
HeavyHemi
Omnipotent Enthusiast
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 21:50:23
Add me to the list of simply flashing to the 80 BIOS fixed my S3 sleep issue that started with a clean install of Win 7 with SP1 integrated (technet). Same exact settings used prior to SP1 now work with the BIOS update. Watch them break it in the final release LOL
basaraba
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/03/31 22:32:36
The following worked for me.  No more resume from S3 issues on Windows 7 SP1! 
 
1. Disable Hybrid Sleep in Windows 7
2. Update Marvell SATA 6 driver to v1051
3. Update X58 FTW3 Bios to v80
4. Load Default Bios Settings and then adjust as follows:
4.1 Integrated Peripherals > Onboard PATA/SATA Device >  SATA Mode >  AHCI
4.2 Power Management Setup > ACPI Suspend Type >  S3 (STR)
5. Install SP1 patch
post edited by basaraba - 2011/03/31 22:34:43
amatotg
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/04/01 12:34:09
This is a problem with all X58 boards. There are lots of posts about it on every motherboard site. The root cause is that the DDR voltage is set to default during S3 sleep mode. This is why many support people don't find this problem because it won't affect the system unless the RAM is overclocked to some combination of settings that require more than the default voltage and support people use stock settings. For example, my Corsair XMS1600C7 RAM runs at 1.5v for the stock SPD table frequencies and S3 sleep will work with these settings. As soon as the RAM is set to 1.65v for the XMP timings or above the S3 sleep fails.

You can easily prove this to yourself. Hang a volt meter on the DDR test point and start your system with a configuration that requires a DDR voltage over 1.5 volts. Enter S3 sleep and watch your volt meter drop from 1.65v (or whatever) to 1.5v during S3 sleep then move back to 1.65v when you resume. This lack of voltage causes RAM corruption which is the true root cause of this problem (S3 is also call "suspend to RAM"). Most people report their CAS timing has changed after running this test.

Unfortunately, there is no work-around although some people say that some manufacturers have figured out how to fix it in BIOS for some boards. I cannot verify this.

- D
 
 
thanks Dilbert!  Good info summary and real troubleshooting steps to follow.  One thing to mention though is that I tried running through problem tracing with everything Default refreshed in the BIOS - meaning nothing overclocked - and memory returned to base JEDECC settings @ 1.5V.  Even at that, it still wouldn't resume from sleep.
 
To update my previous posts, eVGA is processing an RMA.  My board is Rev 1.0 and is being replaced with a Rev 1.1 board to address the issue.  Hopefully the 770 board has this issue already addressed as I'm soon to be building another sys for a friend...
 
 
post edited by amatotg - 2011/04/01 12:39:35
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/04/02 05:08:46
It worked!!!
Last night I reinstalled sp1 with the new Bios flash already on the 770 motherboard with 980x. Initially something got corrupted with the sp1 instal and computer acted really flakey.  I took it back to an earlier system image.  Made sure everything was good then reinstalled sp1.  Put it into sleep and with my fingers crossed hit a key on the keyboard and it woke right back up.   Finally it is fixed.
DMIINC
CLASSIFIED ULTRA Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/04/04 07:29:35
I guess microcode update fixed it for S3 and SP1 on W7. It works for me now.
jcohenmd
Superclocked Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/04/07 04:24:01
Working great.  I did have a couple of instances where it wouldn't wake from sleep but it was do to my video cards.  I got "video hardware error" .  I put in the latest nvidea beta drivers and all has been fine for 5 days now. 
gvalkov
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2011/05/13 02:41:35
basaraba 
1. Disable Hybrid Sleep in Windows 7 
 
When Hybrid sleep is enabled, the system attempts to dump the memory to the hibernate file, and then sleeps. So if the power is lost, the system may resume from hibernation instead of sleep. Due to some Microsoft bug related to the SCSI miniport, the system fails to dump the memory to the boot disk and a blue screen is displayed.
 
Disabling the Hybrid sleep alone prevents the system from dumping the memory so the S3 sleep function will work properly. Disabling the hibernation will also workaround the issue.
 
basaraba 
2. Update Marvell SATA 6 driver to v1051
3. Update X58 FTW3 Bios to v80
4. Load Default Bios Settings and then adjust as follows:
4.1 Integrated Peripherals > Onboard PATA/SATA Device >  SATA Mode >  AHCI
4.2 Power Management Setup > ACPI Suspend Type >  S3 (STR)
5. Install SP1 patch

Performing the rest of the steps resolved the hibernation problem for me. 
 
Cheers!
http://support.microsoft.com/kb/2495523
ahninchang
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2012/01/12 15:06:30
Hello Everyone!.
I had the same problem but I followed the simple instruction by 'gvalklov' Thank you very much!
 
System
i7 950
6 x 2GB Dominator
EVGA X58 Classfied 3
ATI 5850 
OCZ Revodrive 120GB on PCI-E 
Win7 Ultimate 64 SP1 (6.1.7601 Win7 RTM)
 
It didn't wake up from either S1 or S3.
I upgraded BIOS to 83 but the problem persisted.
I could not uninstall SP1.
The hotfix above was not an applicable option for my system.
Finally I went to into Windows Control Panel> Power Options> Change Plan Settings> Changae advanced power settings> Sleep > Allow hybrid sleep >(and selected) Off. (Apply and OK)
 
Now my system wakes up as normal computers do.
 
 
 
 
 
 
 
 
 
post edited by ahninchang - 2012/01/12 15:09:22
photios
New Member
Re:X58 FTW3 Won't resume from S3 sleep 2012/01/13 14:17:41
S3 can be a little tricky to get right with OC.
jonny80s
SSC Member
Re:X58 FTW3 Won't resume from S3 sleep 2012/03/15 15:07:36
My 758 had no problems with S3 and a 920 @ 3.8GHZ, memory @ stock settings 1600mhz.
 
My new 770, major issues, will not resume from any sleep mode... all hardware @ stock timings and voltages.  This board has a lot of problems though and is currently awaiting RMA approval.
  • Back to Mobile