2022/04/15 08:24:25
Hey guys,
Ever since the last firmware update for the X15 my mouse has been randomly disconnecting, then a few seconds and it reconnects, making that windows usb connected device sound when it happens. I've had this mouse for a good few months and not had any connectivity issues until this most recent firmware update. Is this a known issue, is there anything I can do to fix it?
2022/04/15 15:14:28
Yeah I have the same issue, that it randomly disconnects. It doesn't matter what you are doing (Doing nothing, or playing games)  I have tried some fixes:
  •  Reset the settings multiple times
  •  Changed every possible setting, be it button assignment or RGB speed, since on the firmware installation it reset all settings and was a bit wonky, so I thought the problem might be there.
  • Tried different ports (USB 2.0 / 3.0) on 2.0 it freezes, on 3.0 I didn't wait enough, since I am almost out of ports and needed it for an USB stick.
    • USB ports shouldn't make a difference, since the X15 only has 4 pins in its connector, not using the 3.0 extra pins. Also apparently it is still connected to the same USB controller on the mainboard. This also can be verified by the same browser measured polling rate (around 3000Hz) and same input lag (unscientific method of doing reaction time tests and comparing the average of them) (May edit this later if the issue persist on the 3.0 port)
Another thing I noticed is that after the firmware update I get massive FPS drops in Valorant when moving the mouse (like 30fps for 3 frames). It only happens on higher (>1000Hz) polling rates. The CPU render time goes up to 50ms, which then causes the drops. (Also tested on 2 different USB ports)
My PC specs aren't bad, so it shouldn't be possible to overload the CPU with USB packets:
  • Ryzen 7 5800x
  • RTX 3070
  • 3000Mhz 32Gb CL16 RAM
  • Aorus B550m Pro-P
  • (My build on Modsrigs is very outdated, since I upgraded it recently)
It would be helpful if EVGA could add the possibility of rolling back, or freely flashing firmware versions, due to it being a mild annoyance and the old firmware worked perfectly fine. (Luckily it didn't disconnect in an important moment during a game)
2022/04/16 01:01:55
dr. husam
I have the same issue after the update, the x15 will randomly disconnect and reconnect with the error message "USB device not recognized". I have to unplug the mouse from the computer and re-plug it for it to work again. 
2022/04/17 12:07:28
It is confirmed that it also happens on an USB 3.0 port. I only tested it on 8000Hz polling rate.
Also I have captured the event on USBLogView if it is of any use for troubleshooting. As you can see it disconnects for a second, only to be reconnected again shortly after.
Edit: It also happens on 1000hz polling rate on USB 3.0 aswell
2022/04/18 14:08:02
I'll be doing further tests with it to help EVGA finally fix the issue:
It also happens on 125Hz polling rate, now on an USB 2.0 port. I will now test it on a 3.0 port, but needing 125Hz would be bad since it is under my current monitor refresh rate of 144Hz.
Also on a side note I saw a video somewhere where they measured the click to photon latency with different polling rates and also measured the USB wire with the oscilloscope and then came to the conclusion, that even though the polling rate was set low, the USB transfer was still occurring at the highest polling rate.
Screenshot of disconnect attached.
Edit: after moving the plug to USB 3.0 approx 15 seconds later it froze aswell. I'll wait for a second one for confirmation
Edit2: happened again on 3.0
2022/04/19 07:07:15
I just update firmware and Unleash will see if I get the problem. before I had it having all this symptoms than strangely went away. Now all I can do is wait. 
2022/04/20 12:09:51
Yeah it is still happening, but it has like 3 variations:
  1. Hearing a windows disconnect sound, but still responding and LEDs stay on, with the profile select led turning on (rare)
  2. Hearing disconnect sound, LEDs go off, reconnect sound sometimes, profile led turns on, not responding (no mouse movement)
  3. Disconnect, with the error message, windows couldn't recognize the device. (Happened only once when starting VirtualBox)
And I have also looked at the FPS drops in Valorant with a driver latency monitor, and in theory, the drivers are fast enough, so that it shouldn't drop the FPS. And apparently every poll causes an ISR (Interrupt service routine) in the framework driver. (Around 800k polls in 100 seconds for the 8k polling rate, if moving around mouse.)(This is how I also determined that the ISR count is responsible for handling mouse interrupts, since when moving the mouse the count rises faster.) So by this I can say, that the mouse is sending around 8000 packets per second to the controller, which is it's advertised speed. It also doesn't send too many, which was my suspicion, since that could cause problems, like the USB controller disconnecting it. I still suspect that the firmware is somehow broken and overloads the controller in the mouse itself for a little too long, which then causes missing packets, which then breaks the link. Here is the image of the latency monitor:

Here is the test for 100 seconds without touching the mouse and keyboard:

Apparently it adds a whole 5 seconds to process the requests over the 100 measured seconds, which is quite a lot. But since I think it is handled over a single CPU core, and I have 8 (16 threads) of them, the interrupts account for a whole 0,625% of the available computing power, if only the physical cores are counted.
So I still don't really have an idea what is causing the FPS drops and the disconnects, but I am hopeful that my observations can help figuring out the problem.
2022/04/20 18:00:29
I had this problem with 2 of my x15 on two different computers. 
I had this on both of them, which is what it recommends to update to:

Drivers and BIOS

OS: Windows 11
Driver Version:
Release Date: 4/11/2022
Driver File: 
Unleash RGB Release Notes v1.0.15.0
  • Fix debounce issue with Z15
So i searched online and someone recommended downgrading to an earlier version.
I downgraded to Firmware version v1.28 for windows 10, which i have.
I dont know if it matters why the new drivers say only windows 11. After that I've had no issues at all.
2022/04/20 23:37:41
How do you downgrade firmware, since there is no option for it in unleash? Do you install a way older version of unleash or how?
Edit: by the way it doesn't matter that the driver (Unleash Software) only says windows 11 because when you look in the download center every version is backwards compatible up to windows 7 (idk why windows 8 is missing) due to the download link being the same.
2022/04/21 05:39:27
I don't remember where I got it, but yea I Uninstalled unleash and re installed an older version. I might have found the drivers around this forum somewhere. When I get home from work I'll look around.

Use My Existing Forum Account

Use My Social Media Account