2021/07/30 11:10:52
This is absolutely not a "solution" but I set my PEG1 port to Gen 3 and errors have not yet started rolling in. Will continue to monitor. 
2021/07/30 11:13:16
Do you have any CPU OC configured? I do so may try reverting to default
2021/07/30 11:25:03
I've reset everything to default in the bios and just changed the xmp profile for the ram. No other OCs. I wonder if a bios update is needed? I have not tried setting the PCI-e to auto though. Wonder what would happen?
2021/07/30 11:29:00
I never got the error while hardcoding to Gen3. I just rebooted and hardcoded it to Gen4 and within seconds of getting into Windows, the errors started rolling in.
Update: in Nvidia Control Panel, I set power mgmt to prefer max performance and haven't gotten an error yet. 
2021/07/30 11:41:30
I've set that too and get the same results :(
EDIT: In fact I'm getting 4 errors at the same exact time once I set that.
2021/07/30 12:13:12
Interesting. What about your Win10 power / performance profile? I have mine set to Balanced right now but thinking about trying to disable the power mgmt / sleep settings for pci-express to see if that makes an impact. 
2021/07/30 12:20:09
I'm set to high performance and PCI link state is off. Still spewing the warning.
EDIT: Since you have a Dark board, I wonder if we're slightly different due to slightly different BIOS versions?
P.S. Thank you so much for helping! I'm glad we can troubleshoot this together!
2021/07/30 14:05:07
Okay so I am starting to think this may be at least partially due to a bios bug? My above troubleshooting was on my second bios running v 1.0.3. I just switched to bios 1 and updated to 1.0.4 and now it's only negotiating my GPU at gen4 8x instead of 16x. 
2021/07/30 14:29:56
I just updated to BIOS 1.06 for the Z590 FTW and same results. Did a memtest as well, passed that. Changed the PCI slot to Auto instead of GEN4, same results. I'm not sure at this point if it's faulty boards or just needs BIOS attention...
EDIT: And like you said switching to GEN3 solves the issue...
2021/07/30 16:14:18
Okay I feel like it has to be a bios issue at this point. Additional observations:
  • Issue persists across different pci-e 4.0 riser cables
  • Issue persists if gpu is directly connected
  • Issue persists across both z590 DARK 1.0.3 and 1.0.4
  • Issue persists across multiple ftw3 ultra 3090 cards I have available to me
  • Issue persists across both the Normal and OC bios on the cards
  • Have tried DDU and install + old nvidia drivers
  • If running the top pcie4 port on Gen4, there *seems* to be a roll of the die on whether or not it negotiates x16 vs x8 across both bois versions and multiple cards. The errors in event log occur regardless of x8 or x16
  • Forcing Gen3 in bios seems to be only way to avoid these errors

Use My Existing Forum Account

Use My Social Media Account