2021/05/28 16:20:14
Early holiday weekend surprise to support Z590 FTW WIFI and Z590 DARK.
Release Notes:
  • Supports Z590 per-core function
  • Fixes Z590 FTW issue where RGB shuts off when power is disconnected from system
As always, please leave your feedback and let us know if you run into any issues.
2021/06/08 11:42:56
Sweet thanks for the heads up
2021/06/08 11:54:13
Glad the issue has been resolved.
2021/06/10 06:47:02
2021/06/10 15:11:55

Greatly appreciated... but now we need the board.... The Dark
2021/06/19 08:13:06
Any news on elite x1 support for z390 dark?
2021/07/05 23:54:21
Cool thanks for this. I installed the board last week and kin of forgot to get the Eleet software.
2021/07/26 10:32:01
EDIT: Added the mentioned error from exception.log to bottom. 
Are there particular steps one should take or avoid when installing Eleet X1? I cannot get it to work on either my z590 FTW or z590 DARK board with fresh and fully patched Win10 installs. 
  • If I just run the Eleet X1 binary as normal, I get the error about ring0 not being open.
  • If I run the binary as administrator to get the elevated token, I get an Exception.log created with the text at the bottom of this post. 
What I have tried:
  • Ensured bios settings were at default and on latest bios versions
  • Fresh reinstall of Win10
  • Tried both Eleet X1 1.0.5 and 1.0.6
  • Have tried deleting the Eleet X1 profile folder and rebooting
  • No third party security software / agents have been installed at this time
  • Tried disabling most of the default Win10 Exploit Guard settings as a test
  • I reviewed the Win10 event logs and found no related errors in App / System / Win Defender. 
  • Praised the sun
  • Clicked my heels 3 times and said "there's no OC'er like Kingpin"
Message: The given key was not present in the dictionary.
StackTrace: at System.ThrowHelper.ThrowKeyNotFoundException()
   at Z590Lib.Hardware.Memory.RocketMemory..ctor()
   at Z590Lib.Models.ELeetXCtrl.hardwareAdded(IHardware hardware)
   at Z590Lib.Hardware.Computer.Add(IGroup group)
   at Z590Lib.Hardware.Computer.Open()
   at Z590Lib.Models.ELeetXCtrl.<InitializeAsync>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Z590Lib.Z590LibModule.<OnInitialized>d__3.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

2021/07/26 12:16:09
What I have tried:
  • Praised the sun

*in walks Lumbergh for no reason at all*
"Yeeaaaah, see, one of these is the Dark board and we were looking for praise of the Moon actually...so if you could go ahead and do that instead, that'd be greaaaaat, thanks."
No, but seriously, that's weird. You may want to put in an actual ticket or message Lee about that to make sure they see you're having trouble and see if they can help.
2021/07/26 16:13:36
I haven't experienced the same issue, Z590 Dark user here. I run Eleet X1 in administrator mode and comparability mode for Windows 7, seems to work fine on both Windows 7 and Windows 10 build 21354.

Use My Existing Forum Account

Use My Social Media Account