EVGA

Hot!Z370 Micro - update bios with Pentium G5400?

Author
Lion99999
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2018/06/30 08:06:14
  • Status: offline
  • Ribbons : 0
2020/11/24 22:17:44 (permalink)
Few years ago I RMAd a brand new Z370 Micro because the Bios was not updated for my 9900k.  The RMA I received was also not updated.  The tech who helped me was great but the service tech must have missed some notes or something.  Who knows?!  I posted in the forums throughout the decision and purchase process. 
 
We ended up going to Frys and buying an MSI Z390 AC Gaming Edge.  Put the brand new Z370 Micro on the shelf where it sat all this time.  Now I want to build another gaming rig with another 9900k.  According to Intels cross reference tool, the G5400 should work with 300 series chipsets for Bios update.  Anyone know for certain if this will work?
 
Edit:
Intels website tool:https:// ark.intel.com/content/www/us/en/ark/search/featurefilter.html?productType=873&1_Filter-SocketsSupported=3582&1_Filter-Family=29862&2_MarketSegment=Desktop\\
 
EVGAs compatibility tool for the Z370 Micro only shows i3 though i9.  It does not show the Pentiums as being compatible.  If you remove that space in the link above you can see the Pentium should work with 300 series chipsets.  I would assume EVGA wouldn't have to do anything extra to make the Pentium's work (Pentiums are supposedly just failed core series they sell as Pentiums...sounds believable to me but who knows if its true).
post edited by Lion99999 - 2020/11/24 22:58:42
#1

6 Replies Related Threads

    GenjoKoan
    New Member
    • Total Posts : 53
    • Reward points : 0
    • Joined: 2017/10/13 15:24:11
    • Location: Suburban Atlanta
    • Status: offline
    • Ribbons : 0
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/03 10:47:52 (permalink)
    I *think* it should work.  Mine was done with an I5.  I have a vague memory of asking tech support if I could use the Pentium CPU and they said; "sure, I think so".  So I paid Microcenter ~ $25 to do it for me.  I needed more than and "I think so" to risk a perfectly functional motherboard.  I have a soft spot for the mATX size and I did not relish trying to find a replacement.
    #2
    Lion99999
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2018/06/30 08:06:14
    • Status: offline
    • Ribbons : 0
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/04 18:57:07 (permalink)
    Received my parts!  Put the 9900k in the Z370 Micro and fired it up....found out EVGA DID UPDATE THE BIOS to 1.09 all them years ago.  Dam!  Wish the tech had taken the 5 seconds to note that either on the paperwork I received, OR in their system so the customer service rep would have known and told me! 
     
    9900k was recognized by the Z370 Micro.  The G5400 I wasted $70 on will now sit on a shelf for a while.  Dam
     
    Gskill Ram XMP profile worked right out of the plastic package (the package arrived from Newegg in a large yellow padded envelope, inside was the normal DDR plastic with the 2 G Skill labeled DDR 4 3600 Cl 16, but literally had no insert paperwork of any kind....weird).
     
    Regardless, I updated to 1.11 and tried to install Windows 10 from both DVD and USB (from previous builds).  It would "loading files...", then the windows logo would appear on the screen and it would sit like that for hours.  I tried 4 different DVD drives before swapping to the USB install.  USB did the exact same thing.  Flipped to the other bios....also had been updated by EVGA to 1.09 but still froze at the windows logo during windows 10 install. 
     
    What should I try next?  How about installing the known current limiting, CPU overclock blocking, BIOS 1.13? 
     
    Installed 1.13 and sure enough windows 10 immediately installed with no more freezes!  Am now on Windows 10 1909.  However, my 9900k sits at 3.6ghz no matter what settings I use! 
     
    This build is re-purposing an EK WB custom loop I had on a 7600k + Radeon VII: cpu and gpu block, 360 Rad w/3 Vardar fans + 280 Rad w/2 Noctua fans + 1 Noctua fan on the back of the case blowing in to help keep the VRM cool.  The Z370 Micro only has 3 fan headers that offer fan control.  I was surprised by that.  (2) cpu fan headers, and (1) additional fan header offer a pre-defined four point fan % based on temp, but the other fan headers only allow a flat settings of a set % which it will stay at, at all times.  I had to use a couple Noctua Fan splitters.  The reservoir pump combo was originally plugged into one of the CPU fan headers, but it stayed at half rpm.  I moved it to the header labeled PWR FAN and now it runs at max rpm.  Nowhere in the manual did it explain the differences in all the fan headers.  The manual refers to all of them as the same number designation in their board layout schematic.  I also found that odd.  
     
    I open CPU-Z.  Hit Stress test, and watch with MSI afterburner "detached" view.  9900k pulls a whopping 45 watts and reaches a water boiling 57C (obvious joke) and sits at 3600mhz.  I have another 9900k system windows 10 1903 (not 1909) Noctua D15 air cooler that using default settings hits 5ghz all core, MSI AC Gaming Edge Z390, same model 1TB Samsung Evo 860 SSD, 32Gb 3200 Cl14 Gskill RAm (16X2), EVGA 1080ti DT FTW3, and a 1000 EVGA G+ power supply.  When I stress test that thing it pulls over 200 watts and hits 90+C in seconds...I have to press STOP as fast as possible.
     
    In windows I set power plan to Perfer Maximum performance and even set min to 5% and max to 100%.
     
    In the BIOS I changed one or two things, hit F10 to save and restart, and tried it out.  Each time had zero effect. 
     
    Examples: set multiplier to 50, left all on auto...no change...stayed at 3600mhz
    -went back to BIOS, left multiplier to 50 and set vcore to 1.34, left rest on auto...no change...stayed at 3600mhz
    -went back to BIOS, left above settings and changed to override mode, left bclock at 100, left ring ratio at auto...no change....stayed at 3600mhz
     
    The issue is either the BIOS or Windows 10.  I dug around on the interwebs and found a 2 yr old reddit post saying Windows 10 blocked many peoples overclock after an update.  It gave detailed instructions on how to take control of the offending file that Microsoft installed and change its name so it doesnt force intel cpus to run at it's pre defined frequencies (https:// www. reddit.com/r/overclocking/comments/9g8lqi/windows_10_interfering_with_overclock /. 
     
    Here is part of what he wrote:
    EDIT: Okay putting this here in case anyone ever finds this through a search or something. I finally after many hours of research and screwing around resolved it. It apparently really was another one of Microsoft's fuqqing "we know better than you" updates, and put a file in at C:\Windows\System32\mcupdate_GenuineIntel.dll that basically controlled what frequencies various processors are allowed to run at. So it was literally seeing an i7-6850K running at 4.3GHz and going "Oh, no no no, you're not allowed to do that, 3.8 and no faster!"
    So what you have to do is go to that file and make it so it isn't ran by the system (best way is to just rename it and make it be mcupdate.GenuineIntel.dll.BAK instead). In order to change the file name though you will need to take ownership of the file and grant yourself full control permission of the file. In order to do that you will want to follow the following steps after finding the file using Windows File Explorer.
    1.- Right click on the file and select "Properties"
    2.- Go to the "security" tab
    3.- Click the "Advanced" button
    4.- Near the top of the resulting window there should be an "Owner:" line and "TrustedInstaller" is likely going to be the currently listed owner.
    5.- Next to that click "Change"
    6.- In the resulting window there is a field "Enter the object name to select (examples):"; type your username in this window and click on the "Check Names" button. This should change the contents of the field to something with an underline. The format should be COMPUTERNAME\USERNAME.
    7.- Hit OK
    8.- Now back on the window titled "Advanced Security Settings for mcupdate_GenuineIntel.dll" click the "Add" button near the bottom left of the window.
    9.- Near the top of the resulting window click "Select a principal"
    10.- Same window as step 6, same thing needing to be done as well
    11.- Click OK to return to the "Premission Entry for mcupdate_GenuineIntel.dll"
    12.- Place a checkmark in the box labeled "Full Control" and then hit the "OK" button on the window.
    13.- On the "Advanced Security Settings for mcupdate_GenuineIntel.dll" window click the "OK" button
    14.- On "mcupdate_GenuineIntel.dll" click "OK"
    Now you should be able to rename it, it'll give you two UAC prompts when you try, but you just need to click through them. If it gives you an error after the two windows that you need permission from yourself or from TrustedInstaller then go back through the steps as you may have missed one.
     
    Further down in the thread, he did say an update re-broke his fix so he had to re-take control and re-name the offending file again but that fix worked for him.
    #3
    Lion99999
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2018/06/30 08:06:14
    • Status: offline
    • Ribbons : 0
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/04 22:35:04 (permalink)
    After all my testing, I lost the ability to get into BIOS.  I ended up pressing the clear cmos button.  After restart I had to replug in my Roccat Ryos TKL keyboard for it to work, but I did get into bios.  This time the BIOS acted differently.  When I changed from Auto to manual for cpu, now there is a ratio box for each core.  Strange.......it did not do that before my clear cmos but ok...I suspect this board is going to be a few weeks of working, then breaking, before I buy a new board, but at least it is on a path to working for a while!
     
    I set the cpu multiplier to 50, left all the individual cores at what it already said, 50.  I left everything else auto.  Left the RAM at default speed no xmp profile. 
     
    I went back into Windows 10 power settings, and changed minimum back to 5% and max to 100%.  I had read a thread that said if they were put to 0 for min and max, it allows unlimited max...yeah that didnt work.  If it used to work, they patched that out apparently...
     
    Did some stress testing using CPU-Z and now it hits 5ghz at 1.21 volts.  There is no way this can be correct.  I am going to check with some other software to confirm the voltage is what it says it is.  Most 9900k's require at least 1.30 volts to hit 5ghz.  I will update when I have more info...
    #4
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 7575
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Planet of the Babes
    • Status: offline
    • Ribbons : 633
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/04 23:29:19 (permalink)
    You can get/make sure you have the latest version of Win10 using the Update Assistant..Click 'Update now' and then 'Run'..To see your currently installed version and build, type winver in the search box and press enter.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K (Delidded, TG Conductonaut) @ 5.4GHz* 16GB G.SKILL Trident Z 4133MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H115i Pro * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit (Winver 2004) * 
     
    "Whatever it takes, as long as it works" - Me
     
     
     
    #5
    Lion99999
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2018/06/30 08:06:14
    • Status: offline
    • Ribbons : 0
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/05 16:42:37 (permalink)
    I always appreciate feedback/pro tips/advice.  I just installed a brand new Windows Pro 10 on a brand new SSD and went thru all the updates before I used group policy to set it to, "let me control my own stuff that I paid for, thank you very much..." (paraphrasing lol)  $200 after tax at Fred Meyers for Windows 10 Pro is kind of ridiculous if you ask me but that is where we are today.  I don't trust those $15 for a win10 license deals on sites like WCCFtech.
     
    I do not want to update to 2004 with all its bugs I have been reading about.  I might try it on my downstairs 3900x - MSI Unify X570 - EVGA 2080 super XC Ultra - Gskill 32Gb 3200 Cl14 because of the supposed enhancements for AMD but not until the bugs are worked out.
     
    Latest working flawlessly settings:
    XMP profile worked with no hiccups: Gskill 2X16Gb 3600 cl16 19 19 19 36
    cpu set to: 52
    cache ratio set to: 46
    avx offset set to: 0
    Everything else set to: auto including the fans
    Intel Speed step: left enabled even though I want to disable it...its working fine so I will leave it enabled for now
     
    After hours of tweaking and messing around, turns out I must have won the silicon lottery....I stopped pushing it at 5.3ghz with all settings on auto in bios.  It didnt have any issues at all. 
     
    I downloaded Intels Extreme Tuning Utility and adjusted stuff just to see if I could reach a breaking point.  I gave up at 5.3ghz and 4.7 cache ratio.  As I pushed my cpu/cache upwards my score went downwards but it never crashed or froze.  I tried messing with the turbo boost duration settings and stuff in the Intel Utility, but its worded in such a bizarre way, I cannot tell if more time is better or worse.  Doesn't really matter to me, I am not trying to win any contests or beat anyone.
     
    My best benchmark score was 3316 I think it was but after that run every score was in the 3200s after that.  No idea why.  I didn't actually care that much about the score, as much as having stability and reliability.  When I checked online to compare it just to see if I was running hot garbage or if it was performing as expected, it said better than most.
     
    Default voltage using auto is 1.28Volts according to CPU-Z & CPUID HWMonitor.  There are offsets showing in CPUID HWMonitor so maybe the core is getting a bit more than it looks?  Intel's Utility shows a .16 offset, which I assume is EVGAs default Load Line Calibration using auto.
     
    Under stress test using Intels Extreme Utility or CPU-Z it drops to 1.24Volts.  I find this hard to believe but so far its stable with no issues.  Intels utility is showing that I am "current throttling".  Not sure if I should care about that or not. 
     
    So far the only benchmarks I have tried:
    -Heavenly 1080p medium, which runs perfect at over 200fps
    -Superposition free version which crashes immediately no matter which resolution I try.  That might be the Radeon VII (driver 20.11.2 installed thru Device Manager) or MSI afterburner Version 4.6.2, no idea.  I had issues running superposition originally when I bought the Radeon VII so it's not related to this build.
    -Played SMITE from Steam...runs flawlessly except for being annoyingly locked to 60 fps despite vsync being off.  Monitors: LG 32" 32UK50T-W 4k 60hz set to 2k (2560X1440) Costco model + Benq 27" XL2720 1080p 144hz set to 60hz. 
     
    Normally you can change a setting under properties for the games desktop icon to stop it "optimizing for full screen"...the SMITE icon is a dam web link though.  Still gotta figure that one out.
     
    -CPU-Z stress test: CPU 5.2ghz, pulls 76 watts, reaches 65C temp, shows 1.256 Volts in CPU-Z
    -Intel Extreme Tuning Utility stress test: CPU 5.2ghz, pulls 65.8 watts, reaches 53C temp, shows 1.264 Volts in CPU-Z
    -Intel Extreme Tuning Utilty stress test with AVX1: cpu 5.1ghz (I set avx offset in bios to 0), pulls 71.48 watts, reaches 65C temp, shows 1.19 to 1.288 Volts goes back and forth in CPU-Z
     
    I am confused about why its pulling so much less power then my other 9900k.  My other 9900k on MSI AC Gaming Edge Z390 using Win 10 Pro 1903 pulls 111 Watts in CPU-Z stress test and drops down from 5ghz to 4.7ghz.  That BIOS is all set to auto including AVX offset.  I assume there is some setting in EVGAs bios limiting current that is different then the MSI AC Gaming Edge Z390 downstairs.
     
    Regardless, the Z370 Micro appears to be awesome after all the hiccups!  Fingers crossed it lasts!
    post edited by Lion99999 - 2020/12/05 16:51:55
    #6
    Lion99999
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2018/06/30 08:06:14
    • Status: offline
    • Ribbons : 0
    Re: Z370 Micro - update bios with Pentium G5400? 2020/12/05 19:20:26 (permalink)
    Update...I enabled the extreme LN2 overclocking option under CPU.  Whadda ya know....now this 9900k acts exactly like my other one.
     
    It no longer hits the current limit in the Intel Tuning Utility.  During the stress test At default speeds for the 9900k with XMP enabled for the RAM, it pulls 110Watts, hits 85 degrees but scored higher.  I raised from 4.7ghz to 4.8ghz and score went up, but watts and temps went up also. 
     
    Its rather confusing.  With these artifically low limits set in the BIOS by EVGA, I can sit at 5.3ghz but only pull 70+ watts.  I can play games, run stress tests and it barely uses any power or heats up but everything works just fine. 
     
    I suppose if I tried to do some productivity like video encoding or something, I would see a drop in performace using the EVGA Bios default limit.  For just gaming though why not just use this artifically low current limit?  Where is the downside just for gaming?  Any ideas???
    #7
    Jump to:
  • Back to Mobile