EVGA

Hot!RMA issue - have to ask why support service is so slow In Europe

Author
Folgore74
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2018/03/01 13:38:26
  • Status: offline
  • Ribbons : 0
2020/10/23 11:55:10 (permalink)
Can i enter in this thread with an RMA problem? If yes, i have to ask why support service is so slow. In Europe i mean.
I started a ticket for my dead PSU in 10/8/2020 1:12:08 PM and they answered to me in 10/20/2020 1:44:50 AM with a something like this: ""...If you want to process RMA directly by EVGA We can certainly help you with warranty. Mean time please upload invoice of the product using following link...""
Upload whaaat? I already uploaded it when i registred my damned  psu! are you kiddin' me?? ..ok i upload it a second time so you don't have to search for it around your database.
And now? I'm waiting for an second answer because to start the RMA procedure i need some kind of "number" given from the service center itself, to start the RMA procedure.
So, do you think it can be done before the new year's day maybe?
After the RMA procedure opened, i need to ship the PSU to the address of EVGA technicians and after that i have to wait it coming back.
I'm really disappointed about this "policy" to weary people and, if possible, i would have gladly paid a technician on the field to repair it, also if my product is under a 10 YEARS WARRANTY but it's not possible, because of the proprietary components inside or any other "impossible" to find components.
So i'm stuck, with this paperweight because there's only the RMA system and i must wait for someone to wake up and hope they read my ticket.. read it again? i mean i already asked for a RMA so why don't you do it? Is there maybe too much destroyed psu or boards behind this? Is there maybe something not so good in EVGA products? DO you really need this to keep your money where they are?
I was so happy to see over the glass of my case the Supernova frieze.. but now i start to be happy to not to see it.
Do you think i'm angry? oh yes, i'm really angry
#1

16 Replies Related Threads

    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 24393
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 117
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/23 12:15:31 (permalink)
    I moved your post to your own thread ... adding to a thread from 2019 will not help you get faster reply
     
    New product launch 30 series has EVGA seeing much more contacts & the world wide Covid19 thing is not helping
     
     
    I have elevated your thread to EVGA
     
     

    RTX Project EVGA X99 FTWK-5930K@4.8GHz 2xEVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 Classified-5960X@4.5GHz 3-GPU Water Loop 1600P2 
    AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #2
    EVGATech_AdamB
    EVGA EU Tech Support
    • Total Posts : 1759
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: Brea, CA
    • Status: online
    • Ribbons : 4
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/23 16:35:38 (permalink)
    Hello Folgore74! I was able to find your ticket and responded back to it with instructions on how to submit your RMA. I apologize for any delay in being able to reply back to the ticket. Due to the 30-series launch we have been experiencing higher volume than normal.

    Like our service? Please provide feedback for us at the link HERE
    #3
    nicegab
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2019/02/28 13:14:56
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/24 00:32:34 (permalink)
    as far as I can see the rma evga is still as good as ever.....
     
    "Due to the 30-series launch we have been experiencing higher volume than normal"......it's reassuring that....
     
    for me it's over evga
     
    good luck friend
     
     
    #4
    paulkovnik
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2020/06/20 14:00:51
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/24 04:40:30 (permalink)
    Hi everyone. I have to support this problem, which needs to be solved. 
    Z390 Dark Story (Purchased from Amazon). The RMA procedure is very long.
    06/20/2020 applied to the general mail. Refunds are made through your personal account.
    06/21/2020 registered in the EVGA Rewards Program. Registered the product and asked to upload proof of purchase.
    06/24/2020 received an RMA ID Number. Transferred to the European office.
    06/29/2020 RMA request confirmed.
    07/04/2020 sent the parcel by Russian Post. For 1.9 kg of weight with a declared value, I paid ~ 2600 rubles.
    On 07/14/2020 a notification about the RMA order was received (response to the request from 06/20/2020), including a request for a photo of the CPU socket.
    08/07/2020 the parcel arrived in Germany. And everything got up. There was no movement and I began to ring the bells. According to gdeposylka, it was supposed to arrive at the German Post, there was no parcel for tracking.
    On the website gdeposylka found that the tracking number had changed and transferred to the DHL Express postal service. On our website I turned with the appeal “where is my parcel?”, They answered me, contact the local office.
    Since I don't know German, I turned to a friend who lives there. He said that he was hanging at customs. Lithium Battery Restrictions. I sent him a screenshot from the Shipping Rules. If the Russian Post accepted, there should be no restrictions.
    On September 8, 2020, a notification was received unexpectedly on September 7, 2020, to my replacement address via DHL.
    09/20/2020 received the parcel at the Russian Post office. I gave another 1,861.26 rubles as customs payment. The package was already in 2 kg 790 g.
    Everything took 78 days / 2 months and 16 days and 4400 rubles. But this is stage 1 of the epic.

    10/10/2020 I decided to start assembling the computer after purchasing all the components.
    I began the preparation by unpacking the motherboard. But at the first quick glance I saw the absence of factory films (the product is apparently after repair), as well as crookedly installed Wi-Fi connectors (at an angle!). And the left connector turns like a stripped-off screw!
    Photo & Video on Google Drive
    EVGA GmbH was unable to provide final quality control. On the same day I created a request to replace a faulty product.
    4 days have passed and on October 14th I duplicated an email request to EVGA support in the US and Europe.
    On October 17, colleagues from the United States reacted. I have already asked for a refund and refund. They cannot, because they did not buy from them. They suggest waiting for a response from the European office.
    I have been waiting for a response for 2 weeks, although the approval of the replacement is considered 1 day. Considering that 5 months have passed, the next replacement will take the same amount. Next year, something will be decided when a new generation comes out. The second after the Z490.
    Now I am in correspondence in support of the US office (I say hello to Anthony Stidham, Gabriel Talamantes, Manuel Dierl, Daniel McNamara).
    Soon I will know everyone and they will be my friends ...
    Stage 2 continues...

    P.S. Sorry, translation from Google






    #5
    paulkovnik
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2020/06/20 14:00:51
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/24 04:43:58 (permalink)
    Hi everyone. I have to support this problem, which needs to be solved. 
    Z390 Dark Story (Purchased from Amazon). The RMA procedure is very long.
    06/20/2020 applied to the general mail. Refunds are made through your personal account.
    06/21/2020 registered in the EVGA Rewards Program. Registered the product and asked to upload proof of purchase.
    06/24/2020 received an RMA ID Number. Transferred to the European office.
    06/29/2020 RMA request confirmed.
    07/04/2020 sent the parcel by Russian Post. For 1.9 kg of weight with a declared value, I paid ~ 2600 rubles.
    On 07/14/2020 a notification about the RMA order was received (response to the request from 06/20/2020), including a request for a photo of the CPU socket.
    08/07/2020 the parcel arrived in Germany. And everything got up. There was no movement and I began to ring the bells. According to gdeposylka, it was supposed to arrive at the German Post, there was no parcel for tracking.
    On the website gdeposylka found that the tracking number had changed and transferred to the DHL Express postal service. On our website I turned with the appeal “where is my parcel?”, They answered me, contact the local office.
    Since I don't know German, I turned to a friend who lives there. He said that he was hanging at customs. Lithium Battery Restrictions. I sent him a screenshot from the Shipping Rules. If the Russian Post accepted, there should be no restrictions.
    On September 8, 2020, a notification was received unexpectedly on September 7, 2020, to my replacement address via DHL.
    09/20/2020 received the parcel at the Russian Post office. I gave another 1,861.26 rubles as customs payment. The package was already in 2 kg 790 g.
    Everything took 78 days / 2 months and 16 days and 4400 rubles. But this is stage 1 of the epic.

    10/10/2020 I decided to start assembling the computer after purchasing all the components.
    I began the preparation by unpacking the motherboard. But at the first quick glance I saw the absence of factory films (the product is apparently after repair), as well as crookedly installed Wi-Fi connectors (at an angle!). And the left connector turns like a stripped-off screw!
    EVGA GmbH was unable to provide final quality control. On the same day I created a request to replace a faulty product.
    4 days have passed and on October 14th I duplicated an email request to EVGA support in the US and Europe.
    On October 17, colleagues from the United States reacted. I have already asked for a refund and refund. They cannot, because they did not buy from them. They suggest waiting for a response from the European office.
    I have been waiting for a response for 2 weeks, although the approval of the replacement is considered 1 day. Considering that 5 months have passed, the next replacement will take the same amount. Next year, something will be decided when a new generation comes out. The second after the Z490.
    Now I am in correspondence in support of the US office (I say hello to Anthony Stidham, Gabriel Talamantes, Manuel Dierl, Daniel McNamara).
    Soon I will know everyone and they will be my friends ...
    Stage 2 continues...

    P.S. Sorry, translation from Google
    #6
    rjohnson11
    EVGA Forum Moderator
    • Total Posts : 79457
    • Reward points : 0
    • Joined: 2004/10/05 12:44:35
    • Location: Europe
    • Status: online
    • Ribbons : 71
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/24 06:42:29 (permalink)
    the Russian Post accepted, there should be no restrictions.
    On September 8, 2020, a notification was received unexpectedly on September 7, 2020, to my replacement address via DHL.
    09/20/2020 received the parcel at the Russian Post office. I gave another 1,861.26 rubles as customs payment. The package was already in 2 kg 790 g.
    Everything took 78 days / 2 months and 16 days and 4400 rubles. But this is stage 1 of the epic.
    10/10/2020 I decided to start assembling the computer after purchasing all the components.
    I began the preparation by unpacking the motherboard. But at the first quick glance I saw the absence of factory films (the product is apparently after repair), as well as crookedly installed Wi-Fi connectors (at an angle!). And the left connector turns like a stripped-off screw!
    EVGA GmbH was unable to provide final quality control. On the same day I created a request to replace a faulty product.
    4 days have passed and on October 14th I duplicated an email request to EVGA support in the US and Europe.
    On October 17, colleagues from the United States reacted. I have already asked for a refund and refund. They cannot, because they did not buy from them. They suggest waiting for a response from the European office.
    I have been waiting for a response for 2 weeks, although the approval of the replacement is considered 1 day. Considering that 5 months have passed, the next replacement will take the same amount. Next year, something will be decided when a new generation comes out. The second after the Z490.
    Now I am in correspondence in support of the US office (I say hello to Anthony Stidham, Gabriel Talamantes, Manuel Dierl, Daniel McNamara).
    Soon I will know everyone and they will be my friends ...
    Stage 2 continues...
    P.S. Sorry, translation from Google
     
    Posted as normal text

    Specs: AMD Ryzen 9 3950X,  M.2 2TB, 128GB DDR4  Crosshair VIII Hero, EVGA RTX 3090 FTW3 Ultra,  Associate Code: H5U80QBH6BH0AXF

    #7
    Folgore74
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2018/03/01 13:38:26
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/24 12:03:17 (permalink)
    Glad to hear it, and thank you. I just don't understand if the service is the European or from the United States...
    #8
    paulkovnik
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2020/06/20 14:00:51
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/25 11:48:56 (permalink)
    Folgore74 Glad to hear it, and thank you. I just don't understand if the service is the European or from the United States...

    The first part of the post was cut off.
    I bought from Amazon (USA), so the first call was to general mail that the US support team receives. Then they were redirected to the European division of EVGA (Eu).
    To understand the timing, I attach the 1st part of the post.
    --------------------------------------------------------------------------------------------------------------------------------
    Hi everyone. I have to support this problem, which needs to be solved.
    Z390 Dark Story (Purchased from Amazon). The RMA procedure is very long.
    06/20/2020 applied to the general mail. Refunds are made through your personal account.
    06/21/2020 registered in the EVGA Rewards Program. Registered the product and asked to upload proof of purchase.
    06/24/2020 received an RMA ID Number. Transferred to the European office.
    06/29/2020 RMA request confirmed.
    07/04/2020 sent the parcel by Russian Post. For 1.9 kg of weight with a declared value, I paid ~ 2600 rubles.
    On 07/14/2020 a notification about the RMA order was received (response to the request from 06/20/2020), including a request for a photo of the CPU socket.
    08/07/2020 the parcel arrived in Germany. And everything got up. There was no movement and I began to ring the bells. According to «gdeposylka», it was supposed to arrive at the German Post, there was no parcel for tracking.
    On the website «gdeposylka» found that the tracking number had changed and transferred to the DHL Express postal service. On our website I turned with the appeal “where is my parcel?”, They answered me, contact the local office.
    Since I don't know German, I turned to a friend who lives there. He said that he was hanging at customs. Lithium Battery Restrictions. I sent him a screenshot from the Shipping Rules. If the Russian Post accepted, there should be no restrictions
    -------------------------------------------------------------------------------------------------------------------------------
    #9
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 24393
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 117
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/26 11:20:47 (permalink)
    Folgore74
    Glad to hear it, and thank you. I just don't understand if the service is the European or from the United States...




    You will work with the EVGA Customer Center assigned to the Region of the World - you live in

    RTX Project EVGA X99 FTWK-5930K@4.8GHz 2xEVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 Classified-5960X@4.5GHz 3-GPU Water Loop 1600P2 
    AIO Folding  X99 2x1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #10
    Folgore74
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2018/03/01 13:38:26
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/26 11:22:00 (permalink)
    Well guys, the rma has started, now i only have to print the pdf and ship the damaged psu, and the address is in Germany so i hope for a fast resolution
    #11
    paulkovnik
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2020/06/20 14:00:51
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/10/31 10:11:32 (permalink)
    3 weeks passed, the answer did not even come. I'm waiting for a week and will write directly to the head of the European office
    #12
    Folgore74
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2018/03/01 13:38:26
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/11/03 12:06:09 (permalink)
    the package has left...! 
    I wanted to upload some images but i don't find the "upload" link.. only url
    #13
    Helldog01
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2012/01/29 07:20:24
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/11/04 07:50:16 (permalink)
    EVGATech_AdamB
    Hello Folgore74! I was able to find your ticket and responded back to it with instructions on how to submit your RMA. I apologize for any delay in being able to reply back to the ticket. Due to the 30-series launch we have been experiencing higher volume than normal.





    Hi Adam,
     
    Would you be kind to find mine too, I cannot get an answere to my problem.
     
    Br.
     
    Kornel Toth
    #14
    Folgore74
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2018/03/01 13:38:26
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/11/09 11:23:49 (permalink)
    Ok, the new (refurbished) PSU has finally come in to my hands  and i'm very happy. I have to thank all the staff and Adam for the help given. I was initially angry by the missing answers on the site, but after i wrote my thread in here, in the forum, all has got the right move.
    Very thank you, i am happy to have chosen EVGA.
    I really hope we all get over this tragedy called Covid and i wish you a merry Christmas an also a happy new Year..! 
    #15
    EVGATech_MarkusK
    EVGA EU Tech Support
    • Total Posts : 234
    • Reward points : 0
    • Joined: 2013/05/28 08:56:25
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/11/13 01:04:51 (permalink)
    Hi Paulkovnik,
     
    we replied back to your email also - short, the package was received on 09/20/2020 and sent out at the same day - as we are shipping von EU / Germany it takes a while to your destination country, within the customs and due the current situation within Covid, so basically our turnaround time was just one day.
     
    Markus
     
     
    #16
    paulkovnik
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2020/06/20 14:00:51
    • Status: offline
    • Ribbons : 0
    Re: RMA issue - have to ask why support service is so slow In Europe 2020/11/13 02:07:22 (permalink)
    EVGATech_MarkusK Hi Paulkovnik, we replied back to your email also - short, the package was received on 09/20/2020 and sent out at the same day - as we are shipping von EU / Germany it takes a while to your destination country, within the customs and due the current situation within Covid, so basically our turnaround time was just one day. Markus 

     
    According to the tracking number CA047223371RU, the parcel was sent on 07/04/2020, then on 08/07/2020, the parcel processing began in Germany, traces are lost.
    According to the tracking number CY284999023DE, the replaced motherboard was sent on 09/08/2020 and I really received it on 09/20/2020.
    It is important that on October 10 I created an appeal in my personal account, since October 14 I have been in correspondence that the board came with a defective wi-fi module. The staff of the European office ignored the message, while the American office said to wait for an answer.
    Today I re-created an appeal to the "Supports ticket"
    I also work remotely. But it is unacceptable not to respond to an electronic appeal within 1 month.
     
    post edited by paulkovnik - 2020/11/13 02:09:25

    Attached Image(s)

    #17
    Jump to:
  • Back to Mobile