EVGA

Power on issue with TORQ X5

Author
spye435
New Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2016/08/19 05:33:48
  • Location: Preston UK
  • Status: offline
  • Ribbons : 0
2018/05/15 23:07:47 (permalink)
Hi all,
Every time i shut down my PC and power off at the wall AC outlet (such as overnight), when i come to start up my PC next my TORQ X5 is unresponsive and no mouse icon appears on screen. I have to physically unplug the USB from the MOBO and re insert, It then works as it should.
Its plugged into a USB 2.0 on my MOBO, I've tried it on USB 3.0 but its same. 

Is anybody else having this issue, or know if a solution?
 
Thanks in advance.

NZXT S340
I7 8086K @5.0 GHz
Kraken X62 AIO
16 Gb Corsair DDR4 3200 
256 Gb Samsung SM961 M.2 SSD, 512 Gb 850 Evo SSD WD Blue 2TB
Asus Maximus X Hero MOBO
EVGA Supernova P2 850W PSU
EVGA GTX 1080Ti FTW3
 
#1

5 Replies Related Threads

    MSim
    Omnipotent Enthusiast
    • Total Posts : 13891
    • Reward points : 0
    • Joined: 2005/05/22 23:13:30
    • Location: Earth
    • Status: offline
    • Ribbons : 33
    Re: Power on issue with TORQ X5 2018/05/16 17:27:00 (permalink)
    Any yellow flags in Device Manager?
    Do you have the problem with other mice?
    Test with the mouse software not installed.
     
     

    Affiliate Code: G8N4K5CUFY

    1.1.1.1
    #2
    spye435
    New Member
    • Total Posts : 21
    • Reward points : 0
    • Joined: 2016/08/19 05:33:48
    • Location: Preston UK
    • Status: offline
    • Ribbons : 0
    Re: Power on issue with TORQ X5 2018/05/16 23:21:08 (permalink)
    No issues in device manager. It doesnt show my X5 until i un plug and re plug.
    The issue doesnt occur with a basic mouse
    I uninstalled the EVGA software, but still the same. 
    It only occurs when the power to the system is completely removed. If i shut down the PC, but keep it switched on at the wall its ok. 

    NZXT S340
    I7 8086K @5.0 GHz
    Kraken X62 AIO
    16 Gb Corsair DDR4 3200 
    256 Gb Samsung SM961 M.2 SSD, 512 Gb 850 Evo SSD WD Blue 2TB
    Asus Maximus X Hero MOBO
    EVGA Supernova P2 850W PSU
    EVGA GTX 1080Ti FTW3
     
    #3
    MSim
    Omnipotent Enthusiast
    • Total Posts : 13891
    • Reward points : 0
    • Joined: 2005/05/22 23:13:30
    • Location: Earth
    • Status: offline
    • Ribbons : 33
    Re: Power on issue with TORQ X5 2018/05/17 10:30:42 (permalink)
    If it's still under warranty, request a RMA.

    Affiliate Code: G8N4K5CUFY

    1.1.1.1
    #4
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 10821
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Mid-Atlantic
    • Status: online
    • Ribbons : 84
    Re: Power on issue with TORQ X5 2018/05/17 11:06:35 (permalink)
    Mouse installed on the Rig in your signature ?
     
    OS ?

    Nibbler - EVGA X99 Classified, 5960X, 2-TitanX P & EVGA 1080FE, Custom loop, modded Phanteks Enthoo Primo, 32GB GSkill DR4, Intel NVMe PCIe 750 SSD, Win10 Pro, EVGA 1600 P2, Folding 3.5M PPD, 4K Acer XB280HK monitor
    Bling AIO Folding Rampage5e10, 5930K, EVGA CLC 240 2-EVGA 1080Ti FTW3 Hybrid, 32GB GSkill DDR4, Samsumg 850 Pro SSD, Win 7 Pro 64bit, EVGA 1200 P2 PSU, Folding 2M PPD, Thermaltake View 71 Affiliate code 05MLLDCG6B

    #5
    Sajin
    EVGA Forum Moderator
    • Total Posts : 30157
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 179
    Re: Power on issue with TORQ X5 2018/05/17 13:35:08 (permalink)
    spye435
    The issue doesnt occur with a basic mouse

    Time to rma.


    #6
    Jump to:
  • Back to Mobile