EVGA

Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago)

Author
gonzo5187
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2018/06/11 16:36:32
  • Status: offline
  • Ribbons : 0
2018/06/12 17:12:08 (permalink)
So I recently bought a 970 SC ACX 2.0 as a b-stock version to put in my girlfriends rig (running i7 3770k on an MSI board, 750w generic PSU - old prebuilt). One day she texted me saying the computer would turn on but nothing would display. I did some investigating and the card *appeared* to be dead. Nothing would display out of either port (hdmi and dvi) but when i plugged one into the onboard GPU it would display fine but the 970 was not detected. Before i RMA'ed it I decided to try 1) this card in my new build (8700k, asus z370e, corsair rm750) and 2) putting my gigabyte 970 in her rig to determine if her rig is bad. The gigabyte 970 works flawlessly in both rigs. The EVGA 970 at first didnt seem to work in my new build, but then I swapped the 6 pin connectors around, and it finally worked. I figured something with the power connector on the old rig just didnt work with the EVGA card (it runs 2x 6 pin whereas the gigabyte runs 6+8). Figured I had found a solution since they perform basically the same.
 
Next day after getting off work I boot up my pc (running the evga card) and once again... no display. Disconnected the card, swapped pins around. Didnt work. Did it one more time and it worked. It has no issues until you shut off the pc and let it sit for awhile (if i turn it off then immediately turn it back on it has no issues). Worked fine for a day, went to work, came home. same issue again. Was able to get it running again (currently using it to make this post) but it is becoming a real pain to open up my case, unscrew the bracket disconnect wires etc etc, to login and game each day.
 
Is this a known issue? is there a fix? It's only been 2 months since I bought this B-Stock card, knowing it has been used but I would still like to get a year or two at the minimum out of it before I upgrade. Would rather not go through the RMA process but if this continues without a fix I will have to.
#1

6 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 32108
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: offline
    • Ribbons : 185
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/06/12 17:18:53 (permalink)
    Time to rma.


    #2
    gonzo5187
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/06/11 16:36:32
    • Status: offline
    • Ribbons : 0
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/06/13 07:16:29 (permalink)
    Yep. Looks that way. Worked fine all last night (after i reconnected it all). Turned it on this morning before just to see, not working again. 
    #3
    gonzo5187
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/06/11 16:36:32
    • Status: offline
    • Ribbons : 0
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/06/13 09:18:55 (permalink)
    Anyone done an RMA on a bstock item? As of now it doesn't look like they have any 970s for sale... Will they wait till they have one in stock or will they replace it with a different model (980/1060/?)?
     
    EDIT* Found the answer to my question in the warranty/rma forums "EVGA's RMA Department does reserve stock of different models of our product lineups both old and new and we strive to replace your product with the same model you sent in for warranty.
     
    If we are running low on the model you sent in for warranty rather than having you wait, our policy is designed to offer you the next model that we do have available in stock based on equal or greater performance. EVGA will not downgrade your product's performance,"
    post edited by gonzo5187 - 2018/06/13 09:22:16
    #4
    gonzo5187
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/06/11 16:36:32
    • Status: offline
    • Ribbons : 0
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/06/15 10:09:26 (permalink)
    RMA was approved, shipping back tonight or tomorrow.
    #5
    gonzo5187
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2018/06/11 16:36:32
    • Status: offline
    • Ribbons : 0
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/07/02 14:12:15 (permalink)
    Update... received replacement card. Immediately broken. Blue lines/artifacting all over the place. Only one display would work. Crashes after 30 seconds, wont boot up unless i uninstall card and drivers. Reinstalled all drivers and card.. booted for 30 seconds, constantly cycles of crashing. This is getting ridiculous.
    #6
    EVGATech_AdamB
    Administrator
    • Total Posts : 349
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: EVGA
    • Status: offline
    • Ribbons : 2
    Re: Power issues/Card almost dead? 970 SC ACX 2.0 (Bought as B-Stock 2 months ago) 2018/07/02 14:17:42 (permalink)
    Hello gonzo5187! Sorry to hear about the issues you are having with your replacement. I will be sending you an e-mail to follow up with you directly. Please check your e-mail inbox shortly.

    Have a moment? Please rate our service 
    #7
    Jump to:
  • Back to Mobile