EVGA

PSU failing?

Author
Andrew71
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2019/11/07 03:27:32
  • Status: offline
  • Ribbons : 0
2019/11/08 16:49:56 (permalink)
Firstly, hello. So this last year I have been slowly upgrading my PC from an old i5 2500k........ A GPU Gigabyte 1070ti. Mobo Asus z270-a and cpu i7 6700k. 16g of HyperX ram. All a bit dated but they are what they are.
 
My old PSU had been getting louder/hotter as time went on so middle of June I bought a EVGA 850 GQ. Everything seemed fine.
 
Then at the end of July. I turn on my PC to find my Corsair H100i had died. So I got a replacement, H100i pro. From the word go I had what I thought was air in the system so I tolerated the noise, a buzzing in the pump. It did get quieter but continued and then I started to get the occasional knock/bang, not loud but it was doing my head in. A forum recommended that I try to mount it vertically in the front of my PC. The constant buzz faded for the most part but these annoying bangs continued. They would only happen under load but so random that I could never quite work out where they came from and had assumed it was the water cooler. I put up with this for three months, until recently when under load not only would I get the bangs but a much louder buzz with the AIO cooler.
 
I talked again to some people on a forum and they urged me to investigate the PSU. 
 
So I contacted EVGA support a few days ago, basically saying what Ive just said here. The reply was short, "Most likely the  Noise is coming from the pump of the Hybrid pump. Regards EVGA" 
 
I bought a new AIO water cooler. I decided on a Arctic Liquid Freezer II 240. Partly because of the good reviews so far, the price and that it is powered by the CPU_FAN header, not a SATA cable like the previous two Corsair AIO coolers were.
 
After it was installed today, I chilled and watched some videos and Twitch stuff for an hour. Then went on to play WoW to see how things went under load....... A short while later ........ the knocks were back. SIGH . I got my GF to sit right next to the computer and listen as I played for a little while longer. She knows even less about computers than I do but she clearly pointed out, with her ear right next to the PSU, that the knocks were from the PSU.
 
It isnt a coil whine, not at all. It's a metallic knock, a bit like if you knocked a side panel with your knuckle. Not a light tap, a knock.
 
Would this be an issue for you guys? I feel like it is and I certainly cant afford to buy all new components if the PSU blows up and takes everything with it.
 
I contacted EVGA a few hours ago. Hopefully I will get some sort of helpful reply.... Do I try to make a fuss if they arent overly helpful?
 






#1

10 Replies Related Threads

    EVGATech_DanielM
    EVGA Tech Support
    • Total Posts : 388
    • Reward points : 0
    • Joined: 2017/07/07 19:01:01
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 1
    Re: PSU failing? 2019/11/08 21:48:19 (permalink)
    If the PSU itself is making this noise and testing it outside of the case reveals the same noise, then yes, I would recommend to replace it. I will pop in to your ticket and take a look.

     
     
     
    -Daniel_EVGA
    #2
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5906
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: offline
    • Ribbons : 460
    Re: PSU failing? 2019/11/08 23:08:26 (permalink)
    Welcome to the forums, Andrew.
     
    As EVGATech_DanielM said, you can disconnect and take out the unit and turn it on for bench testing using the EVGA Detection Tool or the Paperclip Test..Just let it run for a while.
     
    You could also take the unit out so that it's farther away from the AIO cooler to better help isolate what's making the noise..Leave all the cables connected to your PC and boot into Windows (or whatever) normally.
     
    See: How do I test my power supply? in the EVGA FAQs.

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
     
    God created man... Samuel Colt made them equal.
     
     
     
    #3
    EVGATech_DanielM
    EVGA Tech Support
    • Total Posts : 388
    • Reward points : 0
    • Joined: 2017/07/07 19:01:01
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 1
    Re: PSU failing? 2019/11/08 23:25:06 (permalink)
    From what Andrew described in his ticket, it is hard to imagine it being another component. Recommended he replace it just to rule it out at this point. 

     
     
     
    -Daniel_EVGA
    #4
    bob16314
    CLASSIFIED ULTRA Member
    • Total Posts : 5906
    • Reward points : 0
    • Joined: 2008/11/07 22:33:22
    • Location: Transylvania
    • Status: offline
    • Ribbons : 460
    Re: PSU failing? 2019/11/09 00:10:43 (permalink)
    EVGATech_DanielM
    From what Andrew described in his ticket, it is hard to imagine it being another component. Recommended he replace it just to rule it out at this point. 



    My idea was to try to pinpoint the exact source of the noise rather than throwing darts and hanging parts.
     
    But yeah, it probably is the PSU.
     
    I have a case fan that's sometimes been knocking a little at low rpm for a while now..I need to get around to changing it... someday .

    * Corsair Obsidian 450D Mid-Tower - Airflow Edition * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K @ 5.2GHz * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
     
    God created man... Samuel Colt made them equal.
     
     
     
    #5
    Andrew71
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/11/07 03:27:32
    • Status: offline
    • Ribbons : 0
    Re: PSU failing? 2019/11/09 00:28:39 (permalink)
    Thanks EVGATech_DanielM .... I have just submitted an RMA with the ticket number provided. I hope I have done all of that correctly. Will now wait for instructions from the RMA people as to where the PSU should be sent etc.
     
    Fingers crossed this all works out soon.
     
    Thanks again.
     
    post edited by Andrew71 - 2019/11/09 00:54:45
    #6
    Andrew71
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/11/07 03:27:32
    • Status: offline
    • Ribbons : 0
    Re: PSU failing? 2019/11/09 00:37:44 (permalink)
    bob16314 , since this problem has developed I basically bought a new PC apart from the PSU. At this point I feel the only thing it could be is the PSU as it literally is the only part not replaced... not including the CPU but there is no way a CPU would do what I have described.
     
    Thanks for your reply.
     
    #7
    Hoggle
    EVGA Forum Moderator
    • Total Posts : 5046
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: offline
    • Ribbons : 3
    Re: PSU failing? 2019/11/09 02:46:43 (permalink)
    Hopefully the RMA takes care of the noise. It can be very annoying trouble shooting it as an issue and trying to pinpoint the source but since you replaced most everything else it makes sense it would be the PSU. Let us know how the RMA goes.
    post edited by Hoggle - 2019/11/09 02:49:18

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #8
    Andrew71
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/11/07 03:27:32
    • Status: offline
    • Ribbons : 0
    Re: PSU failing? 2019/11/09 05:12:34 (permalink)
    Hoggle, it's a bit like when you cant find your keys when your already late for an important appointment. That frustrating 5-10 mins until you find them. My dad would always swear and say, "Found the keys! They were in the last place I looked." Well ofc they were, always made me laugh when he said that.
     
    Yes it has been frustrating but it'll be fine though in the end.
     
    Thanks for your reply.
    #9
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 18113
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: online
    • Ribbons : 114
    Re: PSU failing? 2019/11/09 07:01:32 (permalink)
    a plastic or wood dowel [Only Use Dry Non-conductive material] is your friend when trying to pinpoint the source of noise in a PC.
     
    Touch the suspect part with one end & the dowel will conduct the sound to your ear
     
    Knocking sound ..... harmonics can sometimes shake the case in a way that one of the side panels amplifies the sound.
     
    If it happens again; touch the side panel on both sides of the case & see if it is reduced or stops
     
     
    Make sure you change the PSU cables if the RMA is a different model of PSU unit

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P
    Thank You for Your Support


    #10
    EVGATech_DanielM
    EVGA Tech Support
    • Total Posts : 388
    • Reward points : 0
    • Joined: 2017/07/07 19:01:01
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 1
    Re: PSU failing? 2019/11/10 22:16:04 (permalink)
    Andrew71
    Thanks EVGATech_DanielM .... I have just submitted an RMA with the ticket number provided. I hope I have done all of that correctly. Will now wait for instructions from the RMA people as to where the PSU should be sent etc.
     
    Fingers crossed this all works out soon.
     
    Thanks again.
     


    Not a problem my man. If you run in to any issues, feel free to shoot me a PM and I will look in to anything you need. Have a great week. 

     
     
     
    -Daniel_EVGA
    #11
    Jump to:
  • Back to Mobile