EVGA

Hot!Nu audio not working with amd x570 board

Page: 12 > Showing page 1 of 2
Author
viki80
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/07/18 00:28:48
  • Status: offline
  • Ribbons : 0
2019/07/18 01:03:06 (permalink)
Just upgrade to ryzen 5 3600x and gigabyte x570 board. Already using the latest bios and chipset driver. Nu audio doesnt work properly. With music, youtube, vlc, sound only work for few seconds and then no sound at all. What is the problem? I try the asus stx sound card and it work properly. The nu audio is working fine with my intel setup but not with amd setup. I am using win10 1903 version.
#1

40 Replies Related Threads

    LCaldas
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2004/01/13 16:43:44
    • Location: Rio de janeiro - Brasil
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/18 07:33:30 (permalink)
    Already switch the slot pci-e?
    Try another?
    post edited by LCaldas - 2019/07/18 11:20:36
    #2
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/18 11:16:31 (permalink)
    Also, what sample rate/bit-depth are you using?
    #3
    Zannnou
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/31 08:30:19
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/19 02:50:54 (permalink)
    I noticed the same issue as well when I changed CPU. Prior to the change, I had no issues.
    My previous CPU was Ryzen 7 1800x and I changed to Ryzen 9 3900x.
    MB is Asus Crosshair VII Hero (x470) with newest BIOS.
    OS is Windows 10 64-bit which is up to date.
     
    I've tried all the different PCI-E slots, reinstalling drivers and also tried all the possible sample rate/bit-depth options.
     
    Had no luck with any of those tb steps.
     
    All seem to point out that the sound card doesn't work at the moment with Ryzen 3rd gen CPU's for some reason.
    #4
    LCaldas
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2004/01/13 16:43:44
    • Location: Rio de janeiro - Brasil
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/19 03:55:18 (permalink)
    Zannnou
    (...)
     
    All seem to point out that the sound card doesn't work at the moment with Ryzen 3rd gen CPU's for some reason.


    This is very worrying.
    Because I plan to upgrade to Ryzen in the near future.
    #5
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/19 09:14:45 (permalink)
    Ok, I'll have this looked into.  Thanks to all of you for reporting these sorts of issues.
     
    Edit:  Any additional information you can provide will also help our team.
    post edited by EVGATech_LeeM - 2019/07/19 09:23:44
    #6
    Zannnou
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/31 08:30:19
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/19 12:27:26 (permalink)
    Thanks!
     
    I'm not an expert by any stretch of imagination, but I would start to look into the PCI-E config as 3rd gen Ryzen's brought the PCI-E 4.0 controller in. It highly likely processes the data a bit differently, even when it runs PCI-E 3.0 devices, so some small modifications for the drivers might be needed.
     
    If you need me to test something, just let me know 
    #7
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/21 17:16:51 (permalink)
    viki80
    Just upgrade to ryzen 5 3600x and gigabyte x570 board. Already using the latest bios and chipset driver. Nu audio doesnt work properly. With music, youtube, vlc, sound only work for few seconds and then no sound at all. What is the problem? I try the asus stx sound card and it work properly. The nu audio is working fine with my intel setup but not with amd setup. I am using win10 1903 version.

     
    Exactly the same thing happens to me. 
     
    In a Z390 motherboard (Asus ROG Maximus Hero XI) with an Intel 8700K has gone perfectly since I bought it, it has not given me any problem, but with a AMD Ryzen 7 3800X on a motherboard Asus ROG Crosshair VIII is impossible to use the EVGA Nu Audio sound card  because it always hangs the sound both in Spotify, YouTube, TeamSpeak, and so on.
     
    When will there be new drivers that make Nu Audio compatible with AMD X570 boards or AMD 3er. Gen processors?. 
    post edited by tomfuegue - 2019/07/21 17:20:54
    #8
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/23 09:59:35 (permalink)
    tomfuegue
    viki80
    Just upgrade to ryzen 5 3600x and gigabyte x570 board. Already using the latest bios and chipset driver. Nu audio doesnt work properly. With music, youtube, vlc, sound only work for few seconds and then no sound at all. What is the problem? I try the asus stx sound card and it work properly. The nu audio is working fine with my intel setup but not with amd setup. I am using win10 1903 version.

     
    Exactly the same thing happens to me. 
     
    In a Z390 motherboard (Asus ROG Maximus Hero XI) with an Intel 8700K has gone perfectly since I bought it, it has not given me any problem, but with a AMD Ryzen 7 3800X on a motherboard Asus ROG Crosshair VIII is impossible to use the EVGA Nu Audio sound card  because it always hangs the sound both in Spotify, YouTube, TeamSpeak, and so on.
     
    When will there be new drivers that make Nu Audio compatible with AMD X570 boards or AMD 3er. Gen processors?. 


    We're currently obtaining samples to do some testing for you guys.  It might surprise you, but we don't always have all the hardware on hand to do testing of this sort, especially if it's not a product we make.  That's why we always appreciate when you guys notify us of these issues.
    #9
    LCaldas
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2004/01/13 16:43:44
    • Location: Rio de janeiro - Brasil
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/23 10:02:02 (permalink)
    I hope is to find out if it's a Ryzen 3 CPU or motherboard problem. :)
    #10
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/23 10:09:51 (permalink)
    LCaldas
    I hope is to find out if it's a Ryzen 3 CPU or motherboard problem. :)


    Personally, I hope it's just a matter of a quick driver fix.
     
    For anyone that is having this issue, have you tried going into the motherboard BIOS and setting the NU Audio Card slot to a lower bandwidth PCIe version (Gen 2 or Gen 3)?
    #11
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 16345
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: online
    • Ribbons : 112
    Re: Nu audio not working with amd x570 board 2019/07/23 10:11:22 (permalink)
    Seeing any error in Device Manager ?
     
    Does your Rig have more than 1 sound driver installed ? (Nvidia's or your MB have its own Sound & Driver )
     
    Was Windows 10 Fast Startup OFF, when you upgraded drivers, firmware or hardware ?

         Windows Central - How to disable Windows 10 fast startup (and why you'd want to)

         How-to Geek The Pros and Cons of Windows 10’s “Fast Startup” Mode

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #12
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/23 13:00:31 (permalink)
    EVGATech_LeeM
    LCaldas
    I hope is to find out if it's a Ryzen 3 CPU or motherboard problem. :)


    Personally, I hope it's just a matter of a quick driver fix.
     
    For anyone that is having this issue, have you tried going into the motherboard BIOS and setting the NU Audio Card slot to a lower bandwidth PCIe version (Gen 2 or Gen 3)?


    I have precisely tested what you say and it still doesn't work. 
     
    Cool GTX
    Seeing any error in Device Manager ?
     

     
    There is no error in the device manager referring to the EVGA Nu Audio.
    #13
    bcavnaugh
    The Crunchinator
    • Total Posts : 37399
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 265
    Re: Nu audio not working with amd x570 board 2019/07/23 13:21:22 (permalink)
    Does the SATA Power Cable have 4 Wires or 5 Wires?
    It Requires a 5 Wire SATA Power Cable.
    Are you allowing your USB Ports to Turn Off or Sleep to save energy?

     
    post edited by bcavnaugh - 2019/07/23 13:27:50


    #14
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/23 14:26:54 (permalink)
    tomfuegue
    EVGATech_LeeM
    LCaldas
    I hope is to find out if it's a Ryzen 3 CPU or motherboard problem. :)


    Personally, I hope it's just a matter of a quick driver fix.
     
    For anyone that is having this issue, have you tried going into the motherboard BIOS and setting the NU Audio Card slot to a lower bandwidth PCIe version (Gen 2 or Gen 3)?


    I have precisely tested what you say and it still doesn't work. 
     
    Cool GTX
    Seeing any error in Device Manager ?
     

     
    There is no error in the device manager referring to the EVGA Nu Audio.


    Thanks for the update.  Can you try updating the ASMedia USB 3.0 eXtensible Host Controller driver in Windows Device Manager?  Just have it search automatically for the latest online.
    #15
    LCaldas
    New Member
    • Total Posts : 18
    • Reward points : 0
    • Joined: 2004/01/13 16:43:44
    • Location: Rio de janeiro - Brasil
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/23 14:57:46 (permalink)
    To me show diferente:

    #16
    bcavnaugh
    The Crunchinator
    • Total Posts : 37399
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 265
    Re: Nu audio not working with amd x570 board 2019/07/23 15:02:39 (permalink)
    LCaldas
    To me show diferente:



    Indeed, my point is about the Power Settings on the USB Hubs.
     
     I will make a Photo of mine and post back
     
    Does the SATA Power Cable have 4 Wires or 5 Wires?
    It Requires a 5 Wire SATA Power Cable.
     
    post edited by bcavnaugh - 2019/07/23 15:07:28

    Attached Image(s)



    #17
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/23 15:39:45 (permalink)
    LCaldas
    To me show diferente:



    Yes, update the ASMedia USB 3.0 eXtensible Host Controller - 1.0 (Microsoft).
    #18
    bcavnaugh
    The Crunchinator
    • Total Posts : 37399
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 265
    Re: Nu audio not working with amd x570 board 2019/07/23 16:13:15 (permalink)

    Attached Image(s)



    #19
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/24 05:08:10 (permalink)
    EVGATech_LeeM
     
    Thanks for the update.  Can you try updating the ASMedia USB 3.0 eXtensible Host Controller driver in Windows Device Manager?  Just have it search automatically for the latest online.


    I'll try tonight when I get home.
    #20
    Zannnou
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2019/03/31 08:30:19
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/24 06:53:40 (permalink)
    I just want to point out again that use X470 board, only change I did was to change the CPU from 1800X to 3900X and the problem started.

    When I put the 1800X back, the sound card started to work again as normal.
    #21
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/24 08:41:13 (permalink)
    Zannnou
    I just want to point out again that use X470 board, only change I did was to change the CPU from 1800X to 3900X and the problem started.

    When I put the 1800X back, the sound card started to work again as normal.


    This shows that it's a problem of the new AMD Gen. 3 processors, not of the X570 motherboards
    #22
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/24 10:26:48 (permalink)
    Zannnou
    I just want to point out again that use X470 board, only change I did was to change the CPU from 1800X to 3900X and the problem started.

    When I put the 1800X back, the sound card started to work again as normal.

    Yup.  This helps narrow down the testing.  We know that X470 works fine with previous gen Ryzen chips, but this helps to confirm that we might have a different issue here.
    #23
    kranrev
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2016/06/21 14:47:19
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/28 16:29:11 (permalink)
    Glad to see I am not the only person with this issue.
     
    Recently went from an Asus x99a/i7 6850k build to a Gigabyte x570 Aorus Master/ R9 3900X.  I had exactly the same issues as in this thread, unable to run the Nu without audio cutting out in any slot on the board.  Let me know if there is anything specific to this setup that you need to try...
     
    At least it turns out that the Aorus Master has great MB audio, wasn't planning on needing it!
    #24
    EVGATech_LeeM
    EVGA Forum Moderator
    • Total Posts : 1439
    • Reward points : 0
    • Joined: 2016/11/04 14:43:35
    • Location: Brea, CA
    • Status: offline
    • Ribbons : 14
    Re: Nu audio not working with amd x570 board 2019/07/29 18:38:08 (permalink)
    Did some testing and we were able to reproduce the issue.  It seems the latest Windows driver for ASMedia in 1903 doesn't want to play nice.  An older ASMedia driver version works fine.  We'll provide an ASMedia driver for anyone affected to install while we sort out this issue with ASMedia probably tomorrow.  I don't imagine it should make any difference in audio quality.
    #25
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/30 02:39:09 (permalink)
    And why does a USB controller affect the operation of the sound card if it is going on a PCIe port?.
    #26
    ty_ger07
    Insert Custom Title Here
    • Total Posts : 15248
    • Reward points : 0
    • Joined: 2008/04/10 23:48:15
    • Location: global traveler
    • Status: online
    • Ribbons : 146
    Re: Nu audio not working with amd x570 board 2019/07/30 05:41:55 (permalink)
    tomfuegue
    And why does a USB controller affect the operation of the sound card if it is going on a PCIe port?.

    Because the sound card microcontrollers are connected via USB controller to the PCI-E slot. Kind of odd, yes. Rather than designing PCI-E compatible signals, the audio card team decided to put an ASMedia USB controller in the middle and let it do the PCI-E communication stuff.

    ASRock Z77 • Intel Core i7 3770K • EVGA GTX 1080 • Samsung 850 Pro • Corsair AX1200
     
    Disclaimer: I own shares of AMD, Intel, and NVIDIA stock.
    #27
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/30 06:57:24 (permalink)
    ty_ger07
    tomfuegue
    And why does a USB controller affect the operation of the sound card if it is going on a PCIe port?.

    Because the sound card microcontrollers are connected via USB controller to the PCI-E slot. Kind of odd, yes. Rather than designing PCI-E compatible signals, the audio card team decided to put an ASMedia USB controller in the middle and let it do the PCI-E communication stuff.



    Ok, thank you very much for the explication.
    #28
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/30 07:10:42 (permalink)
    EVGATech_LeeM
    Did some testing and we were able to reproduce the issue.  It seems the latest Windows driver for ASMedia in 1903 doesn't want to play nice.  An older ASMedia driver version works fine.  We'll provide an ASMedia driver for anyone affected to install while we sort out this issue with ASMedia probably tomorrow.  I don't imagine it should make any difference in audio quality.
     



    SOLUTION!!!
     
    Driver v1.16.56.1 DON'T WORK and EVGA Nu Audio crash all sounds on computer: YouTube, Spotify, TeamSpeak, Discord...
     
    Driver v1.16.41.3 DON'T WORK and EVGA Nu Audio has an issue on Device Manager with this driver and EVGA software don't boot.
     
     
    If you install this driver version (1.16.29.1) the sound card works perfectly with AMD Gen 3 processor on X570 motherboard: dlcdnets.asus.com/pub/ASUS/nb/DriversForWin10/USB3/USB3_AsMedia_Win10_64_VER116291.zip
     

     
    I am checking it right now: 
     

     
     
    post edited by tomfuegue - 2019/07/30 08:51:10
    #29
    tomfuegue
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2008/11/01 10:09:24
    • Status: offline
    • Ribbons : 0
    Re: Nu audio not working with amd x570 board 2019/07/30 09:08:27 (permalink)
    Windows 10 is trying to update the ASMedia driver, I've blocked it using Windows Update Blocker.
     

    #30
    Page: 12 > Showing page 1 of 2
    Jump to:
  • Back to Mobile