EVGA

Hot!Nope. X15 still disconnects V1.0.16

Author
iDrizzt
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2021/05/11 08:23:01
  • Status: offline
  • Ribbons : 0
2022/05/19 13:12:25 (permalink)
The firmware update that I got notified about today says "fixes a common complaint", although it doesn't elaborate on what this complaint is, I was excited to see if it was the disconnecting issue. Much to my disappointed within 30 minutes of gaming after installing the update, it disconnected again. 
 
#1

6 Replies Related Threads

    Saberous
    Superclocked Member
    • Total Posts : 167
    • Reward points : 0
    • Joined: 2007/10/08 14:04:09
    • Status: offline
    • Ribbons : 0
    Re: Nope. X15 still disconnects V1.0.16 2022/05/24 14:48:08 (permalink)
    Same.
    Before the update, the mouse would dc and rc. Now the mouse just DC's and I have to unplug the mouse and plug it back in to get the mouse to rc again.

    PC Specs:
    ASUS Z390 Maximus XI Hero (Wi-Fi) MOBO
     i9 9900K @5GHZ
    Custom loop, Corsair pump and rads/ EKW Blocks
    32GB Corsair Vengeance RGB PRO DDR4 3600MHz
    ASUS RTX 2080 OC
    1 M.2 Samsung Evo 970 EVO 1T
    1 M.2 Sabrent Rocket Q 2TB
    1 Samsung Evo 860 2TB
    1 Samsung Evo 860 1TB
    1 Samsung Evo 850 1TB
    1 WD GOLD 4TB 5400RPM 256MB
    1 Seagate Barracuda 12TB 5400RPM 256MB
    ASUS THOR 1200
    Phanteks Enthoo 719
    1, 27" VG27AQL1A 170HZ 1440p.  1, 27" ROG PG278QR 165HZ 1440p. 2, 24” ASUS VH238H 60HZ 1080p
    Win 10 64 Pro
    Corsair K95 Keyboard
    EVGA X15 MMO Mouse
     
    #2
    cortina69
    New Member
    • Total Posts : 40
    • Reward points : 0
    • Joined: 2018/12/05 20:11:11
    • Status: offline
    • Ribbons : 0
    Re: Nope. X15 still disconnects V1.0.16 2022/05/25 14:10:33 (permalink)
    My near week old x17 disconnects and reconnects all the time. Tried every usb port, turning off the setting where pc can stop power to usb devices etc. Nothing has worked sadly. Gone back to my g502 although not comfortable to use like the x17 it doesn't disconnect on me. This is the first time I've ever had a mouse disconnect and reconnect while plugged in getting used. Get it together Evga fix your problematic hardware and peripherals
    #3
    EVGA_James
    EVGA Product Manager
    • Total Posts : 1001
    • Reward points : 0
    • Joined: 2012/12/14 14:54:29
    • Status: offline
    • Ribbons : 3
    Re: Nope. X15 still disconnects V1.0.16 2022/05/26 09:52:21 (permalink)
    We should be releasing an update sometime today 


    #4
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 28441
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 120
    Re: Nope. X15 still disconnects V1.0.16 2022/05/27 07:55:56 (permalink)

    Learn your way around the EVGA Forums, Rules & limits on new accounts Ultimate Self-Starter Thread For New MembersThank you for your support - I am a Volunteer Moderator not an EVGA employee RTX Project EVGA X99 FTWK 2xEVGA2080Ti EVGA1200P2  Nibbler EVGA X99 Classified EVGA 3080Ti FTW3 Ultra 1600P2
    #5
    Saberous
    Superclocked Member
    • Total Posts : 167
    • Reward points : 0
    • Joined: 2007/10/08 14:04:09
    • Status: offline
    • Ribbons : 0
    Re: Nope. X15 still disconnects V1.0.16 2022/06/07 20:22:43 (permalink)
    Knock on wood. I haven't had a DC in a while.

    PC Specs:
    ASUS Z390 Maximus XI Hero (Wi-Fi) MOBO
     i9 9900K @5GHZ
    Custom loop, Corsair pump and rads/ EKW Blocks
    32GB Corsair Vengeance RGB PRO DDR4 3600MHz
    ASUS RTX 2080 OC
    1 M.2 Samsung Evo 970 EVO 1T
    1 M.2 Sabrent Rocket Q 2TB
    1 Samsung Evo 860 2TB
    1 Samsung Evo 860 1TB
    1 Samsung Evo 850 1TB
    1 WD GOLD 4TB 5400RPM 256MB
    1 Seagate Barracuda 12TB 5400RPM 256MB
    ASUS THOR 1200
    Phanteks Enthoo 719
    1, 27" VG27AQL1A 170HZ 1440p.  1, 27" ROG PG278QR 165HZ 1440p. 2, 24” ASUS VH238H 60HZ 1080p
    Win 10 64 Pro
    Corsair K95 Keyboard
    EVGA X15 MMO Mouse
     
    #6
    Saberous
    Superclocked Member
    • Total Posts : 167
    • Reward points : 0
    • Joined: 2007/10/08 14:04:09
    • Status: offline
    • Ribbons : 0
    Re: Nope. X15 still disconnects V1.0.16 2022/06/14 15:14:53 (permalink)
    I guess it's time to start looking for a new mouse. It started DC'ing on me again today. :( . Now the debate, to buy another X15 or go with something else?

    PC Specs:
    ASUS Z390 Maximus XI Hero (Wi-Fi) MOBO
     i9 9900K @5GHZ
    Custom loop, Corsair pump and rads/ EKW Blocks
    32GB Corsair Vengeance RGB PRO DDR4 3600MHz
    ASUS RTX 2080 OC
    1 M.2 Samsung Evo 970 EVO 1T
    1 M.2 Sabrent Rocket Q 2TB
    1 Samsung Evo 860 2TB
    1 Samsung Evo 860 1TB
    1 Samsung Evo 850 1TB
    1 WD GOLD 4TB 5400RPM 256MB
    1 Seagate Barracuda 12TB 5400RPM 256MB
    ASUS THOR 1200
    Phanteks Enthoo 719
    1, 27" VG27AQL1A 170HZ 1440p.  1, 27" ROG PG278QR 165HZ 1440p. 2, 24” ASUS VH238H 60HZ 1080p
    Win 10 64 Pro
    Corsair K95 Keyboard
    EVGA X15 MMO Mouse
     
    #7
    Jump to:
  • Back to Mobile