EVGA

Missing Screws for EVGA Hybrid Cooler

Author
Xero717
New Member
  • Total Posts : 41
  • Reward points : 0
  • Joined: 2012/03/29 05:47:53
  • Status: offline
  • Ribbons : 0
2019/06/11 19:01:19 (permalink)
So i received my Hybrid Kit today for my 2080 Ti XC Ultra, and it was missing two of the required screws to complete the installation.  I'm thinking, oh yeah, I'll just call EVGA and they'll take care of this.  Instead, what i got was send us a bunch of pictures of proof because we think you're lying, even though we can see the kit you bought was delivered today, and that you recently purchased it. 
 
I can understand asking for a picture of the screw I was sent instead which isn't even supposed to come with the kit, but to be asked to take a picture of EVERYTHING, after I've already installed part of it on my card, the instructions (which you already have on your website), and the screw, I'm annoyed.  It's bad enough I'll have to wait at least a week to get the replacement screws to get the card up and running (unless I experiment with ones from the hardware store), but to be treated like I'm trying to screw you guys out of some screws?  Unreal.
#1

9 Replies Related Threads

    bcavnaugh
    The Crunchinator
    • Total Posts : 35918
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: online
    • Ribbons : 233
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/11 19:33:28 (permalink)
    Sometime users use the wrong screws and so on.
    You are NOT getting a Run-A-Round.
    If everyone called and said the same and EVGA just gives out screws they would run out in the end.
    Also lots of owners break the Screws.
     
    "it was missing two of the required screws to complete the installation" What Two Screws?
    post edited by bcavnaugh - 2019/06/11 19:36:33


    #2
    Xero717
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2012/03/29 05:47:53
    • Status: offline
    • Ribbons : 0
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/11 19:46:00 (permalink)
    bcavnaugh
    Sometime users use the wrong screws and so on.
    You are NOT getting a Run-A-Round.
    If everyone called and said the same and EVGA just gives out screws they would run out in the end.
    Also lots of owners break the Screws.
     
    "it was missing two of the required screws to complete the installation" What Two Screws?


    Exactly why I said I could understand if they wanted a picture of the screw that wasn't even supposed to come with the kit and was most likely put in place of the other screws.  I get needing to protect profits, but this is a bit much, sorry.
     
    The screws for the left VRM heatsink and to fasten the shroud to the insert (as the instructions call it).
    post edited by Xero717 - 2019/06/11 19:53:52
    #3
    bcavnaugh
    The Crunchinator
    • Total Posts : 35918
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: online
    • Ribbons : 233
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/11 20:07:40 (permalink)
    I can't see them miss, at least no one has ever posted missing screws.
    Did you empty the Box and the inside packing in the Box?
    Normally they are all in one bag and then each item in their own bag.
     


    #4
    Xero717
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2012/03/29 05:47:53
    • Status: offline
    • Ribbons : 0
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/11 20:22:32 (permalink)
    bcavnaugh
    I can't see them miss, at least no one has ever posted missing screws.
    Did you empty the Box and the inside packing in the Box?
    Normally they are all in one bag and then each item in their own bag.
     


    Of course I did, do you really think I want to wait for the screws?  I wanted to install the card tonight and get it running.  I double checked everything.  As I stated already, one of the bags contained a screw, that btw said qty 2 and only had one, that wasn't even on the parts list.  Stuff happens, I get it, but what about the customer in this case huh?  I didn't ask for them to be missing, and I'm not even asking to return the cooler, just for the two screws so I can actually use the card I've torn apart to install the kit.  They should of been there in the first place.
    #5
    Xero717
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2012/03/29 05:47:53
    • Status: offline
    • Ribbons : 0
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/11 20:35:16 (permalink)
    Oh, and you want another bad situation too?  My 2080ti XC Ultra also had an issue with one of the fan cords where it wasn't pulled snug enough so it was connecting with the one fan and making a clicking sound.  My options? Pay for return shipping and insurance and RMA the card for a documented problem with the coolers (which you can find evidence of on this forum), or figure out a sneaky way that wouldn't classify as a physical modification and possibly void my warranty to prevent the cable from coming in contact with the fan.
     
    I used some double sided tape which I can remove, but god knows if that'll be used as an excuse to void my warranty or not because the rep wouldn't give me a straight answer, just told me to remove it before I'd send it in.  Not only is this something i have to remember now, but if i want to sell the card in the future, it'd be an issue for the future owner.
     
    I'm really close to being done.  I know you love this company like it's your family, but crappy situations do happen to people, and it's not always their fault.
    #6
    bcavnaugh
    The Crunchinator
    • Total Posts : 35918
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: online
    • Ribbons : 233
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/12 08:43:23 (permalink)
    Xero717
    bcavnaugh
    I can't see them miss, at least no one has ever posted missing screws.
    Did you empty the Box and the inside packing in the Box?
    Normally they are all in one bag and then each item in their own bag.

    Of course I did, do you really think I want to wait for the screws?  I wanted to install the card tonight and get it running.  I double checked everything.  As I stated already, one of the bags contained a screw, that btw said qty 2 and only had one, that wasn't even on the parts list.  Stuff happens, I get it, but what about the customer in this case huh?  I didn't ask for them to be missing, and I'm not even asking to return the cooler, just for the two screws so I can actually use the card I've torn apart to install the kit.  They should of been there in the first place.

    At that time you should have taken a photo with unopened bags.
    Items not matching what is shown in the manual should have set a red flag for you.
    Because if this is the case then QA needs a re-look at the packing process of the Hybrid Kit.
    But then this is part of inventorying what is in the box before you start to take apart your card.
    Had you done this in the first place you would still be able to be using your card. Just a thought here.
     
    PS..
    Do not use any "double sided tape" as it can pull components of the PCB when you remove it.
    post edited by bcavnaugh - 2019/06/12 08:46:46


    #7
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 15336
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 110
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/12 08:56:31 (permalink)
     
    Sorry your having to deal with this issue - missing / wrong screws in your Hybrid kit
     
    I understand why you would be upset
     
    The pictures are most likely to help EVGA work with the Mfg to figure out what happened & help prevent this from happening to others. 

    EVGA & the Mfg need to figure out if this is just an odd mistake or did several kits happen to get packaged with wrong or missing screws
     
    https://www.evga.com/supp...les/400-HY-1384-B1.pdf
     
    as far as sourcing screws locally the Sizes are listed in the manual
     

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #8
    Xero717
    New Member
    • Total Posts : 41
    • Reward points : 0
    • Joined: 2012/03/29 05:47:53
    • Status: offline
    • Ribbons : 0
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/12 09:59:56 (permalink)
    bcavnaugh
    Xero717
    bcavnaugh
    I can't see them miss, at least no one has ever posted missing screws.
    Did you empty the Box and the inside packing in the Box?
    Normally they are all in one bag and then each item in their own bag.

    Of course I did, do you really think I want to wait for the screws?  I wanted to install the card tonight and get it running.  I double checked everything.  As I stated already, one of the bags contained a screw, that btw said qty 2 and only had one, that wasn't even on the parts list.  Stuff happens, I get it, but what about the customer in this case huh?  I didn't ask for them to be missing, and I'm not even asking to return the cooler, just for the two screws so I can actually use the card I've torn apart to install the kit.  They should of been there in the first place.

    At that time you should have taken a photo with unopened bags.
    Items not matching what is shown in the manual should have set a red flag for you.
    Because if this is the case then QA needs a re-look at the packing process of the Hybrid Kit.
    But then this is part of inventorying what is in the box before you start to take apart your card.
    Had you done this in the first place you would still be able to be using your card. Just a thought here.
     
    PS..
    Do not use any "double sided tape" as it can pull components of the PCB when you remove it.


    Except it's not on the PCB its on the heatsink beneath the shroud where the line runs....

    I'm sorry, I shouldnt have to inventory all my parts before I start putting this together. I didn't realize there was an errant part until I was looking for the correct screws. Regardless, that investigation can be done later by EVGA. I still haven't heard back from the support team since I sent the pictures in.

    Far as sourcing locally, I will as I'm not too hopeful this will be resolved, but sometimes the screws don't match right even given the exact measurements, as I've experienced in the past. If they weren't important ones I wouldn't of even bothered calling. I don't want the VRM heatsink falling when it's suspended upside down.
    #9
    bcavnaugh
    The Crunchinator
    • Total Posts : 35918
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: online
    • Ribbons : 233
    Re: Missing Screws for EVGA Hybrid Cooler 2019/06/12 10:08:22 (permalink)
    I am sure that EVGA will take care of you as you are still in good hands.
    Things Happen our world is not perfect.


    #10
    Jump to:
  • Back to Mobile