EVGA

K20 Linear Randomly Disconnecting

Author
Poofu1
Superclocked Member
  • Total Posts : 141
  • Reward points : 0
  • Joined: 2017/04/27 14:16:47
  • Status: offline
  • Ribbons : 0
2021/10/12 14:59:34 (permalink)
I love everything about this keyboard but I am getting an intermittent USB issue.
 
When doing any type of task that involves pressing a key down, the keyboard will sometimes freeze on the last key pressed spamming it repeatedly for a few seconds before all the LEDs go dark and the keyboard becomes unresponsive. It won't become responsive again until it is unplugged and plugged back in.
#1

4 Replies Related Threads

    tmaeller
    New Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2008/01/09 12:17:27
    • Status: offline
    • Ribbons : 2
    Re: K20 Linear Randomly Disconnecting 2021/10/12 16:21:37 (permalink)
    The Z20 pretty much requires a USB 3.0 port for the primary connection. If you've plugged it into a 2.0 port, this is likely why the issue is happening. The pass-through USB requires a USB 2.0.
     
    Note that plugging the board into a new USB port will deactivate any current programming you've done, such as custom color layers (the data is assigned to the USB port you had the keyboard plugged into at the time). There's a way to back up this info and apply it to a new config — let me know if you need that, and I'll post some quick instructions.
    #2
    Poofu1
    Superclocked Member
    • Total Posts : 141
    • Reward points : 0
    • Joined: 2017/04/27 14:16:47
    • Status: offline
    • Ribbons : 0
    Re: K20 Linear Randomly Disconnecting 2021/10/12 17:19:10 (permalink)
    I have the keyboard cable and the passthrough cable both plugged into USB 3.0 ports. I have also tried this with my work laptop and noticed the same issue. 
    #3
    tmaeller
    New Member
    • Total Posts : 50
    • Reward points : 0
    • Joined: 2008/01/09 12:17:27
    • Status: offline
    • Ribbons : 2
    Re: K20 Linear Randomly Disconnecting 2021/10/12 22:24:59 (permalink)
    Poofu1I have the keyboard cable and the passthrough cable both plugged into USB 3.0 ports. I have also tried this with my work laptop and noticed the same issue.

     
    Hmmm. Well if you try it on everything and it still fails, including other USB ports, then it may very well be a problem with the KB, or specifically the USB connector on the cable.
     
    FWIW, mine is very sensitive to the touch at the USB port. If I touch the connector right at the USB port, it briefly drops (Windows "unplugged" sound) and comes back up when I let it go. I'm not sure yet if it's the cable or the motherboard.
     
    #4
    EVGA_James
    EVGA Product Manager
    • Total Posts : 879
    • Reward points : 0
    • Joined: 2012/12/14 14:54:29
    • Status: offline
    • Ribbons : 3
    Re: K20 Linear Randomly Disconnecting 2021/10/13 14:19:44 (permalink)
    Poofu1
    I have the keyboard cable and the passthrough cable both plugged into USB 3.0 ports. I have also tried this with my work laptop and noticed the same issue. 




    If this is happening on 2 different system it would be best to contact our support team for a warranty replacement. 


    #5
    Jump to:
  • Back to Mobile