EVGA

Issue resolved, thanks for your help.

Author
masterkojiro
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2015/10/24 11:54:29
  • Status: offline
  • Ribbons : 0
2018/01/11 21:38:12 (permalink)
EDIT: My issues have been resolved and my card is on its way back to EVGA. Thanks to those who helped.
post edited by masterkojiro - 2018/01/23 22:16:52
#1

6 Replies Related Threads

    Sajin
    EVGA Forum Moderator
    • Total Posts : 29654
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 175
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/11 22:20:23 (permalink)
    Your thread has been reported to evga. 


    #2
    EVGATech_JoseC
    EVGA Tech Support
    • Total Posts : 164
    • Reward points : 0
    • Joined: 2017/06/05 00:00:00
    • Location: EVGA
    • Status: offline
    • Ribbons : 1
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/12 21:12:15 (permalink)
    Hello Masterkojiro and welcome to the forums

    I'm going to go ahead and send you an email to help get this matter resolved for you.
     
    -Jose C.
    #3
    masterkojiro
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2015/10/24 11:54:29
    • Status: offline
    • Ribbons : 0
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/22 23:09:10 (permalink)
    EDIT: Resolved.
    post edited by masterkojiro - 2018/01/23 22:15:47
    #4
    MSim
    Omnipotent Enthusiast
    • Total Posts : 13863
    • Reward points : 0
    • Joined: 2005/05/22 23:13:30
    • Location: Earth
    • Status: offline
    • Ribbons : 33
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/23 05:05:07 (permalink)
    Send an email to ChrisB, ask him to look into this for you.  ChrisB@evga.com 

    ٩(̾●̮̮̃̾•̃̾)۶Intel i7-7700k •̪̀●Corsair H100i V2 •̪̀●ASUS Z270 HERO •̪̀●G.SKILL DDR4 3200 2x16GB •̪̀●EVGA 750W P2 •̪̀●Windows10 Pro 64-bit •̪̀●EVGA GTX1060 •̪̀●Samsung 960 EVO m.2 1TB •̪̀●Corsair 450D •̪̀●ASUS 24" VE248H •̪̀●Corsair K70 Lux RGB •̪̀●Logitech G403 •̪̀●Sound BlasterX AE-5٩(̾●̮̮̃̾•̃̾)۶ Affiliate Code: G8N4K5CUFY

    1.1.1.1
    #5
    bcavnaugh
    The Crunchinator
    • Total Posts : 25386
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: Affiliate Code: E5L3CTGE12
    • Status: offline
    • Ribbons : 126
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/23 05:09:42 (permalink)
    masterkojiro
    Still haven't had any progress toward a resolution. My busted "replacement" card has just been sitting in the box for over a month now. While my trust GTX560ti has been at least getting me by for the past 2 months, I feel like this should've been taken care of by now.


    Are you not working with EVGATech_JoseC ?


    #6
    EVGATech_JeffP
    EVGA Tech Support
    • Total Posts : 283
    • Reward points : 0
    • Joined: 2017/02/20 09:03:47
    • Status: offline
    • Ribbons : 0
    Re: RMA Woes - Over 1 Month With No Working GPU and No Resolution in Sight. 2018/01/23 21:17:36 (permalink)
    Hello,
     
    I was informed by management today that this issue has been resolved. If you have further questions please do not hesitate to call 888.881.3842.
    #7
    Jump to:
  • Back to Mobile