EVGA

Helpful ReplyHot!GTX 570 plugged into motherboard, fan spinning, no connection

Page: 12 > Showing page 1 of 2
Author
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
2018/05/02 05:19:22 (permalink)
So a couple days ago I got my GTX 570 1280 MB DDR5 in the mail so I went to uninstall my old drivers and I plugged on my 570.... To my surprise it wouldn't show video for the mini hdmi port, and when I go install the drivers it says it can't find the 570 what do I do now?
#1
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 09:16:13 (permalink)
Try a different output, try a different mini hdmi cable, try the card in a different pci-e slot, & make sure your motherboard bios is completely up to date. If all that fails to correct the issue try the card in another system.


#2
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 10:05:18 (permalink)
I have tried a different HDMI cable should I try DVI-i? Also if I use the integrated graphics can the computer still read the graphics card when plugged in.
#3
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 10:09:31 (permalink)
DesirableUsername
I have tried a different HDMI cable should I try DVI-i? Also if I use the integrated graphics can the computer still read the graphics card when plugged in.

Yes.
 
&
 
Yes, but sometimes if the bios options aren't setup correctly it won't show up.


#4
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 10:18:14 (permalink)
Ok, do you know what options should be turned to what or should I take pictures?
#5
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 10:24:52 (permalink)
I'll lookup the settings. What motherboard do you have?


#6
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 11:17:13 (permalink)

Asus M4N68T-M V2
#7
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 11:32:14 (permalink)
Inside the bios navigate to...
 
Advanced, chipset, south bridge configuration primary, and make sure primary graphics adapter is set to pci-e -> pci -> igp.
 
Note: Make sure to unplug all display cables from the motherboard igp & only have display cables connected to the 570.
 
 


#8
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/02 11:37:13 (permalink)
Ok I'll keep in touch with you first I need to get my DVI-i to vga
#9
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/12 11:58:20 (permalink)
Hey, Just bringing back this thread back. I got my DVI-i adapter, and it still doesn't show any video, but I did get a two beep code 
#10
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/12 12:21:50 (permalink) ☄ Helpfulby DesirableUsername 2018/05/21 20:17:41
Sounds like the card may have a problem. I'd suggest testing it in another machine at this time.


#11
Much2Pink
New Member
  • Total Posts : 12
  • Reward points : 0
  • Joined: 2018/05/13 20:51:01
  • Location: Beverly Hills
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/16 03:02:48 (permalink)
I guess the age old question would be. 
Are you sure the 570 is getting enough power ?

I had this same problem with my old 580. long story short, I left the unit running over night and woke up the next day to find the window logon screen on. 
[ I blame the old gremlins in old tech  ]

When the Creator thought he had finished coloring the flowers, he heard one whisper "Forget me not!" There were no colors remaining except a very small amount of blue, and the forget-me-not was delighted to wear it.
#12
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/21 19:09:42 (permalink)
Well, is a 620W PSU good enough for the 570?
 
#13
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/21 19:13:59 (permalink)
I also forgot to mention I have a single PCI-e slot on my motherboard
#14
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 08:35:21 (permalink)
DesirableUsername
Well, is a 620W PSU good enough for the 570?

Yep.


#15
Much2Pink
New Member
  • Total Posts : 12
  • Reward points : 0
  • Joined: 2018/05/13 20:51:01
  • Location: Beverly Hills
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 11:01:55 (permalink) ☄ Helpfulby DesirableUsername 2018/05/23 07:01:49
Sajin
DesirableUsername
Well, is a 620W PSU good enough for the 570?

Yep.


I'm going to have to rebuttal your comment. 

Off the main EVGA website 
  • 550 or greater power supply
  • with a minimum of 38 Amp on the +12 volt rail.****PCI Express, PCI Express 2.0 or PCI Express 3.0
  • compliant motherboard with one graphics slot.
  • Two available 6-pin PCI-E power dongles

While you are right in that if you use base information a 620watt should cover this need. However, it's not taking into account everything else that needs power.

If you're using old core from the early 2000 before they started doing the power supply rating system ; you may have a lemon for a power supply. I'd use a thermaltake dr.power ii atx12v power supply tester to make sure. 


I'd start with this website and work your way though it. 
 coolermaster power-supply-calculator
 
I'm not saying throw money into the wind but, be sure with all angles not just one.
"hypothesis Vs theory"
 
post edited by Much2Pink - 2018/05/22 11:05:25

When the Creator thought he had finished coloring the flowers, he heard one whisper "Forget me not!" There were no colors remaining except a very small amount of blue, and the forget-me-not was delighted to wear it.
#16
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 19:14:07 (permalink)
If I recall, I have an AMD Athlon II X4 640 Processor clocked at 3.00
#17
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 19:15:08 (permalink)
3.00 GHz Sorry, was in a rush
 
 
#18
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 20:34:41 (permalink)
Update: I reslotted the graphics card for the millionth time, now I get a two short beep boot noise
#19
Much2Pink
New Member
  • Total Posts : 12
  • Reward points : 0
  • Joined: 2018/05/13 20:51:01
  • Location: Beverly Hills
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 21:01:54 (permalink)
I'm up for the task.
mainly cause i'm bored
 
 
List all the parts you have running in the system 
list the brand if you can 

CPU  : 
MEM :
MOTHERBOARD :
PS :
CASE : 
LED/LCD Strips : 
HDD : 
1394 : 
ETC.
I mean everything that draws power ~ even the optical drive

When the Creator thought he had finished coloring the flowers, he heard one whisper "Forget me not!" There were no colors remaining except a very small amount of blue, and the forget-me-not was delighted to wear it.
#20
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 21:03:42 (permalink)
So you can't test the card in another pc?


#21
Hoggle
EVGA Forum Moderator
  • Total Posts : 3045
  • Reward points : 0
  • Joined: 2003/10/13 22:10:45
  • Location: Eugene, OR
  • Status: offline
  • Ribbons : 2
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/22 23:54:31 (permalink)
What is the model of power supply since knowing the model could help though sometimes it can just be the random underperforming one that is the issue.
#22
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 05:03:48 (permalink)
It's the Antec Neo Eco 620C
#23
bob16314
CLASSIFIED ULTRA Member
  • Total Posts : 5119
  • Reward points : 0
  • Joined: 2008/11/07 22:33:22
  • Location: Transylvania
  • Status: offline
  • Ribbons : 366
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 06:15:35 (permalink)
You could try:
• Clearing CMOS as described in your Motherboard Manual
• With the GTX 570 removed, updating to the Latest BIOS if needed using EZ Flash (page 2-2 of mobo manual)

If no joy, try the card in another PC as suggested earlier or take it to a PC repair shop and have it tested.
 
Your PSU should be good enough.

* Cooler Master NV-334 * ASUS ROG Maximus X Hero (Wi-Fi AC) * Intel i7-8700K * 16GB G.SKILL Trident Z 4000MHz * Crucial MX500 M.2 1TB * WD Black 500GB (x2) * Seasonic M12 II 750W * Corsair H80i V2 * EVGA GTX 760 SC * Dual-Boot Win7 Home 64-bit/Win10 Home 64-bit *   
 
"If it ain't broke, fix it untill it is"


#24
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 07:00:23 (permalink)
The thing is that I don't have any other computers to try my graphics card in so I am thinking about going to Geek Squad to have them test it for me should I trust it although?
 
#25
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 08:12:25 (permalink)
They should be able to do the job, but they will most likely charge a high price. Take the card to a local computer repair shop instead of the geek squad.


#26
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 08:50:37 (permalink)
There's a Milwaukee PC by me I can go to
#27
Sajin
EVGA Forum Moderator
  • Total Posts : 31260
  • Reward points : 0
  • Joined: 2010/06/07 21:11:51
  • Location: Texas, USA.
  • Status: online
  • Ribbons : 181
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 10:11:38 (permalink)



#28
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/23 11:52:44 (permalink)
I'll get back to ya
#29
DesirableUsername
New Member
  • Total Posts : 19
  • Reward points : 0
  • Joined: 2018/05/02 05:13:31
  • Status: offline
  • Ribbons : 0
Re: GTX 570 plugged into motherboard, fan spinning, no connection 2018/05/24 13:56:09 (permalink)
Omg Omar gosh, I was reseating and resetting the CMOS Batterie and graphics card, and when I booted up it gave me a award Boot message, "1 long 2 short" video error no additional information
 
#30
Page: 12 > Showing page 1 of 2
Jump to:
  • Back to Mobile