EVGA

Hot!EVGA needs to stop pretending Precision X1 is fine

Page: < 12 Showing page 2 of 2
Author
yoadknux
New Member
  • Total Posts : 24
  • Reward points : 0
  • Joined: 2020/12/10 13:44:30
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/23 02:49:32 (permalink)
There is something that I want to emphasize, just because most of my issues relate to a previous gen card, it does not mean that they are not relevant to newer cards. Yes, the fans of the 30 series cards can be controlled with Afterburner, that's great, with 20 and 10 they cannot so you must use Precision. In the future there may be functions that will force 30 owners to also use Precision (for example Rebar support is more convenient there), and then what will you do. Also, the 2080Ti was a card that just last year was being sold for $1200. All you 3080 and 3090 owners that paid $1000-1500 I'm sure you don't want to be neglected when the 40 series comes out. 
#31
ClowReed
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2011/05/13 05:24:19
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/23 11:06:50 (permalink)
yoadknux
There is something that I want to emphasize, just because most of my issues relate to a previous gen card, it does not mean that they are not relevant to newer cards. Yes, the fans of the 30 series cards can be controlled with Afterburner, that's great, with 20 and 10 they cannot so you must use Precision. In the future there may be functions that will force 30 owners to also use Precision (for example Rebar support is more convenient there), and then what will you do. Also, the 2080Ti was a card that just last year was being sold for $1200. All you 3080 and 3090 owners that paid $1000-1500 I'm sure you don't want to be neglected when the 40 series comes out. 


Not at all. Afterburner can only control two fans. Most EVGA's 3080 and 3090 have 3 built-in fans plus one external header. It's very relevant for all of us. I would never touch Precision X1 again if I hadn't to. It's a complete mess.
#32
HeavyHemi
Omnipotent Enthusiast
  • Total Posts : 14956
  • Reward points : 0
  • Joined: 2008/11/28 20:31:42
  • Location: Western Washington
  • Status: offline
  • Ribbons : 114
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/23 13:44:36 (permalink)
The problem is... Unwinder coded many of the original and most efficient and stable API hooks years (almost decades now kids) back and has worked directly with both ATI, AMD and Nvidia developers. Much of this code is proprietary under copyright and cannot be reused. EVGA's earlier program was basically just a reskin of Afterburner with some feature locks by vendors.
So essentially EVGA had to reinvent their wheel with less efficient and stable code. And here they still are.

EVGA X99 FTWK / i7 6850K 4.5ghz / GTX1080 Ti FE Hybrid / 32GB Corsair LPX 3200mhz / Samsung 850Pro 256GB / Corsair AX1200 / Window 10 Pro
Fire Strike                        24,163
Fire  Strike Extreme        14,452 
Fire Strike Ultra                7,711 
Time Spy                        10,357

#33
will999999999
New Member
  • Total Posts : 72
  • Reward points : 0
  • Joined: 2016/07/25 18:08:02
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/23 15:56:58 (permalink)
I'm wondering how many support tickets and threads I've got to put myself through before EVGA at least acknowledges the resetting fan and RGB issues. I'm so done at this point.

Intel i7 10700K | Asus Z490-E | G.skill 4,000MHz CL16 2x16GB DDR4 | EVGA FTW3 ULTRA RTX 3090 | EVGA Supernova 1,000W G2 | 1TB Sabrent Rocket Q4 M.2, 4TB Samsung 870 EVO 2.5" SATA, 8TB Seagate IronWolf 8TB 7200RPM SATA HDD
#34
tbrown7552
Superclocked Member
  • Total Posts : 148
  • Reward points : 0
  • Joined: 2010/09/04 17:52:00
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/24 12:19:18 (permalink)
Precision X1 is awful. Its not uncommon for me to lose all ICX Sensor data except GPU Core temp within PX1 randomly and for no reason and it will come back when it wants. Reboots dont fix it either. I also intermittently loose all fan control or it will drop the fan header on the back of the card off and you loose control. It decides when it wants to come back as reboots wont fix that either.
 
The absolute worst experience is what really terrifies me with this software. It nearly bricked my 3090 KP. I updated PX1 and it went to flash a firmware update and failed. My card was stuck in firmware update mode and wouldnt come out. The GPU worked and showed video but the clocks were low like 200mhz core low all the time. I was barely able to get it to come out of after a weekend freaking out instead of having to RMA the card.

As it sits im on version 1.1.17 and im absolutely terrified to download any newer versions in fear of this atrocious software bricking my card. This is all my experience with just Ampere and PX1. One other factor of why i have to use PX1 over afterburner is that afterburner memory slider caps out at +1500 where PX1 doesnt.
#35
will999999999
New Member
  • Total Posts : 72
  • Reward points : 0
  • Joined: 2016/07/25 18:08:02
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/24 14:31:06 (permalink)
I have a rear exhaust and a bottom intake hooked up to my extension header. Thought it was the most clever thing. Only Precision can operate the 4th fan. But it keeps crashing randomly under load in games and whatnot and I basically lose my rear exhaust. At this point, I'm heavily considering hooking those fans up to the manual header on my case and just using Afterburner. It's been months. I'm so tired of this...

Intel i7 10700K | Asus Z490-E | G.skill 4,000MHz CL16 2x16GB DDR4 | EVGA FTW3 ULTRA RTX 3090 | EVGA Supernova 1,000W G2 | 1TB Sabrent Rocket Q4 M.2, 4TB Samsung 870 EVO 2.5" SATA, 8TB Seagate IronWolf 8TB 7200RPM SATA HDD
#36
will999999999
New Member
  • Total Posts : 72
  • Reward points : 0
  • Joined: 2016/07/25 18:08:02
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/26 18:58:42 (permalink)
Is there not ANY 3rd party software that can properly run all 4 fans headers on the FTW3 cards? I've already given up and turned all the RGB off and put the 2 fans I had on the extension header back onto a manual controller.

I'll even pay for the software at this point, I'm so tired of this. I just want my fan profiles to stick without crashing randomly during most games and basically taking out my rear exhaust.

Intel i7 10700K | Asus Z490-E | G.skill 4,000MHz CL16 2x16GB DDR4 | EVGA FTW3 ULTRA RTX 3090 | EVGA Supernova 1,000W G2 | 1TB Sabrent Rocket Q4 M.2, 4TB Samsung 870 EVO 2.5" SATA, 8TB Seagate IronWolf 8TB 7200RPM SATA HDD
#37
-jay-
New Member
  • Total Posts : 41
  • Reward points : 0
  • Joined: 2014/05/24 15:02:17
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/27 17:44:58 (permalink)
I used to have the ghost overclocking issue where when i reboot it shows no overclock, but its actually overclocked.  The recent update fixed that for me.
#38
kirbyrj
New Member
  • Total Posts : 16
  • Reward points : 0
  • Joined: 2007/08/09 20:23:09
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/04/28 07:50:30 (permalink)
I had some kind of error during the install of 1.1.9.0 and then immediately it wanted to flash the bios of my brand new 3090...30 seconds of anxiety.
#39
yoadknux
New Member
  • Total Posts : 24
  • Reward points : 0
  • Joined: 2020/12/10 13:44:30
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/05/03 09:50:11 (permalink)
No response, no fixes. Pretty good progress
#40
Madrok
New Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2020/09/08 13:30:55
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/05/03 20:19:26 (permalink)
yoadknux
Madrok
With the latest version, fan profile is starting up on bootup. Progress..

I thought so too, although today when I started my PC, fan2 was off (not detected by Precision) & fan 1+fan3 were on 40%. It was fixed when I rebooted the app. 

Yep, I found out that too when I just recently reinstalled windows. With the recent PX1 release, as usual, the fan profile is not starting up on reboot or when PX1 is closed and reopened. So damn frustrating!
post edited by Madrok - 2021/05/03 20:21:34
#41
ClowReed
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2011/05/13 05:24:19
  • Status: offline
  • Ribbons : 0
Re: EVGA needs to stop pretending Precision X1 is fine 2021/05/06 10:17:25 (permalink)
kirbyrj
I had some kind of error during the install of 1.1.9.0 and then immediately it wanted to flash the bios of my brand new 3090...30 seconds of anxiety.


If you have the time to learn (it's not that hard tbh), try to update your vbios via command prompt, waaaay safer and reliable. Too many bricked cards using PX1 to update (mine had several problems when I tried to... Done easily via command prompt and nvflash).
#42
Page: < 12 Showing page 2 of 2
Jump to:
  • Back to Mobile