EVGA

Helpful ReplyEVGA X99 Micro - Sound Card Problems

Page: 123 > Showing page 1 of 3
Author
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
2014/09/09 22:25:05 (permalink)
Hi, I just recently completed my i7 5820k + X99 mAtx build and have run into an issue that I can't replicate on my other systems (so I'm assuming it's limited to this board). I've installed an ASUS Xonar Essence STX card into the third PCIe slot and I get no audio from it whatsoever (I've used this card for the past 2.5 years without problem) if I try to "ping" the audio by clicking on the volume indicator it acts as if there is audio but simply freezes there (looks exactly like in the picture until the board shuts off). Was wondering if anyone had any tips or solutions to get this to work.
 
Thanks! (the attached images are all the same, had uploading problems.)
post edited by araris - 2014/09/09 22:27:06

Attached Image(s)


Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#1
EVGA_JacobF
EVGA Product Manager
  • Total Posts : 16910
  • Reward points : 0
  • Joined: 2006/01/17 12:10:20
  • Location: Brea, CA
  • Status: offline
  • Ribbons : 26
Re: EVGA X99 Micro - Sound Card Problems 2014/09/10 09:36:07 (permalink)
Known issue, try setting PCI-E slot to Gen2 in BIOS, this should fix it.


#2
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/09/10 20:40:57 (permalink)
It did not fix it. I've tried the other PCIe slot with no luck. I've got a fresh format of Windows 8.1 and the only thing I've changed in the BIOS is the CPU frequency (it's at 4.5Ghz) along with the Gen2 change in the PCIe configuration. The sound card works fine if I put it into my old system (i5 2500k).

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#3
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/09/11 22:07:19 (permalink)
I'd like to know if this is limited to the EVGA X99 mATX board so that if it is I can return it in time to purchase a board which works with it (or keep it if it's something EVGA's planning on fixing sooner rather than later). Thanks. (I tried it in my i5 750 system as well and it worked.)

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#4
Vanitas_59
Superclocked Member
  • Total Posts : 145
  • Reward points : 0
  • Joined: 2010/08/28 08:07:05
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/09/11 22:53:04 (permalink)
EVGA techs are already looking into it.  Its most likely related to a BIOS update.  The simple work around did not work for myself either.  It did work for someone else in a thread I created some few days back.  The tech is new and so is the BIOS.  This just happens to be one of the setbacks with adopting early.

EVGA Affiliate Code:  X26PBW0MJK
#5
MSim
Omnipotent Enthusiast
  • Total Posts : 14587
  • Reward points : 0
  • Joined: 2005/05/22 23:13:30
  • Location: Earth
  • Status: offline
  • Ribbons : 38
Re: EVGA X99 Micro - Sound Card Problems 2014/09/12 01:22:49 (permalink)
Looks like you have a choice to make. hold off and see if they can fix it or return the product for a refund.
 
 
 

Affiliate Code: G8N4K5CUFY

1.1.1.1
#6
kesnik
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2007/12/01 19:44:56
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/09/12 21:49:55 (permalink)
I just put together my new system today. I was having the same issue with my sound blaster Z.  I switched the PCI express slot from Auto to Gen 2 in the bios manually and it started working correctly.  I don't know what Generation the SoundBlaster Z is but, In the BIOS overview,  (TOP) the sound card shows up as Gen 1.
 
Just reporting my findings.
 
x99 FTW
 
-kesnik
post edited by kesnik - 2014/09/12 21:53:25

MOBO:   MSI x570 Unify
RAM:   3600 Mhz b-stock
PROCESSOR:   5800x
V-CARD:   EVGA GTX 1080 (waiting in queue for a 3080)
PSU:   EVGA 1300W Supernova
#7
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/09/22 18:29:22 (permalink)
Any updates on this? (PCIe Gen 2.0 does not work.)

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#8
KLEYBA
SSC Member
  • Total Posts : 932
  • Reward points : 0
  • Joined: 2005/01/30 15:53:56
  • Status: offline
  • Ribbons : 12
Re: EVGA X99 Micro - Sound Card Problems 2014/09/23 08:46:00 (permalink)
it's sad that you have to run Gen 2 on a Gen 3 board.  then why should we buy a Gen 3 board if we can't use it?!  come on EVGA, this is 3x in a row!  and now the evga cooler turns out to be design defect?  this explains why the temps on my old 770 were so high
 
http://www.guru3d.com/news-story/evga-geforce-gtx-970-acx-has-misaligned-gpu-vs-heatpipes.html
#9
Sethos88
New Member
  • Total Posts : 8
  • Reward points : 0
  • Joined: 2012/05/11 06:14:08
  • Status: offline
  • Ribbons : 1
Re: EVGA X99 Micro - Sound Card Problems 2014/09/24 03:08:34 (permalink) ☄ Helpfulby araris 2014/09/24 17:07:03
Hey there,
 
Asus X99 Deluxe user here with a Xonar Essence STX. Unfortunatly, Asus boards have the exact same problem, both the Deluxe and Rampage from what I've heard so far. Might be all the way down to a chipset and / or core issue with the X99 platform.
 
I found a temporary workaround; Put your PC into sleep / hibernation, then wake it up again. The Audio should be working fine. You will have to do this on every cold boot! 
 
May or may not work for you, however just wanted to drop in and say it's not an EVGA exclusive issue. 
#10
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/09/24 17:07:21 (permalink)
Sethos88
Hey there,
 
Asus X99 Deluxe user here with a Xonar Essence STX. Unfortunatly, Asus boards have the exact same problem, both the Deluxe and Rampage from what I've heard so far. Might be all the way down to a chipset and / or core issue with the X99 platform.
 
I found a temporary workaround; Put your PC into sleep / hibernation, then wake it up again. The Audio should be working fine. You will have to do this on every cold boot! 
 
May or may not work for you, however just wanted to drop in and say it's not an EVGA exclusive issue. 




Yeah that worked, thanks! Really hope this is addressed by ASUS in a driver update or if it's a chipset issue by a new chipset driver or BIOS update.

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#11
evfan
SSC Member
  • Total Posts : 562
  • Reward points : 0
  • Joined: 2006/05/20 19:12:10
  • Location: Los Angeles
  • Status: offline
  • Ribbons : 1
Re: EVGA X99 Micro - Sound Card Problems 2014/09/30 08:41:44 (permalink)
I'm having the same issue with my xonar essence stx and my rampage 5.. gen 2 setting did not work for me. sleep mode did though

ACER XB270HU IPS G-SYNC Monitor 
Fractal Design Define R5
Asus Z370
Intel Core i7 8700k @ 5.1ghz/Ek Predator 360
G Skill 16gb 3600 mhz 
Asus GTX 1080ti Strix
Samsung 840 EVO 1TB SSD 
EVGA 1200w Platinum   
Windows 10 Pro 64 Bit
Audio-gd NFB1 HP amp/ Schiit Modi Multibit DAC   
http://www.heatware.com/eval.php?id=67048
#12
superstringy
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2008/05/23 03:38:55
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/10/15 06:56:12 (permalink)
Same here - Asus Rampage V Extreme board and Asus Xonar D2X card.

Tried both non-beta BIOS updates, every combination of PCI-E slots and the aforementioned Gen 2 suggestion, nothing lets the card produce sound unless I knock the OS (Windows 7 Ultimate x64) into sleep mode and back again.
#13
UnsaidME
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2012/07/14 21:39:35
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/11/03 15:26:32 (permalink)
Switching the slot to Gen 2 worked for me! I tried the sleep mode thing in Gen 3, but didn't work.  I'm using 5820k. 
#14
evfan
SSC Member
  • Total Posts : 562
  • Reward points : 0
  • Joined: 2006/05/20 19:12:10
  • Location: Los Angeles
  • Status: offline
  • Ribbons : 1
Re: EVGA X99 Micro - Sound Card Problems 2014/11/03 21:15:51 (permalink)
superstringy
Same here - Asus Rampage V Extreme board and Asus Xonar D2X card.

Tried both non-beta BIOS updates, every combination of PCI-E slots and the aforementioned Gen 2 suggestion, nothing lets the card produce sound unless I knock the OS (Windows 7 Ultimate x64) into sleep mode and back again.


The issue was fixed with bios 0802 which is now on the asus website

ACER XB270HU IPS G-SYNC Monitor 
Fractal Design Define R5
Asus Z370
Intel Core i7 8700k @ 5.1ghz/Ek Predator 360
G Skill 16gb 3600 mhz 
Asus GTX 1080ti Strix
Samsung 840 EVO 1TB SSD 
EVGA 1200w Platinum   
Windows 10 Pro 64 Bit
Audio-gd NFB1 HP amp/ Schiit Modi Multibit DAC   
http://www.heatware.com/eval.php?id=67048
#15
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/11/08 08:46:14 (permalink)
And still no word from EVGA on why they haven't fixed it yet. I should have bought the ASUS, it's been 2 months now.

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#16
majinbuxl
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2014/11/18 19:58:47
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/11/18 20:05:34 (permalink)
Wish I had read up on this before buying. Just built my rig with the X99 FTW and have this problem also. Tried switching to Gen 2 but didn't work. Using latest bios version 1.11.
Come on EVGA give us a fix!
#17
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2014/11/23 10:06:45 (permalink)
majinbuxl
Wish I had read up on this before buying. Just built my rig with the X99 FTW and have this problem also. Tried switching to Gen 2 but didn't work. Using latest bios version 1.11.
Come on EVGA give us a fix!




Return the board for an ASUS motherboard before it's too late. EVGA's been completely silent on this issue so I really wouldn't put your faith in them to release a fix for this.

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#18
Vlada011
Omnipotent Enthusiast
  • Total Posts : 10257
  • Reward points : 0
  • Joined: 2012/03/25 00:14:05
  • Location: Belgrade-Serbia
  • Status: offline
  • Ribbons : 11
Re: EVGA X99 Micro - Sound Card Problems 2014/11/28 06:18:21 (permalink)
Immediately when I saw board I thought about possible problems with some sound card.
Because some of them as Sound Blaster Z series have problems with software and
Creative recommendation to use PCI-E x1 or PCI-E x4 slot.
In PCI-E x8 Slot people hear sound but than graphic card could work on x8 speed too and could cause software problem or not recognize after turn off and then you need to remove card, uninstall software, clean and install card and software again. 
That's worse scenario if we talk about motherboard without 3D Sound Chip or Supreme FX and some good sound card not work properly. Same would be if someone want SLI or X99 MIcro and Sound card in middle.
Best option for mATX board is two x16 PCI-E and one x4 or x1 in middle. 
Some manufacturer offer 3x little PCI-E more than really need only because such cards as Sound + PCI-E SSD or something else.
I think one is necessary.
 
On X99 FTW is one nice slot for Sound Card 

 
post edited by Vlada011 - 2014/11/28 06:27:07

i7-5820K 4.5GHz/RVE10-EK Monoblock/Dominator Platinum 2666/ASUS GTX1080Ti Poseidon/SBZxR /Samsung 970 EVO PLus 1TB/850 EVO 1TB /EVGA 1200P2/Lian Li PC-O11WXC/EK XRES D5 Revo 100 Glass/Coolstream PE360-Noctua NF-A12x25 PWM x3
http://www.evga.com
http://www.intel.com
http://www.nvidia.com
https://watercool.de
http://www.lian-li.com
https://www.youtube.com/watch?v=PHMun5xiRe0
 
https://xdevs.com/guide/2080ti_kpe/#intro
https://www.evga.com/articles/01386/evga-sr-3-dark/
 
 
 

 
 
#19
z3razerviper
New Member
  • Total Posts : 4
  • Reward points : 0
  • Joined: 2008/05/20 21:42:20
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2014/12/14 21:46:16 (permalink)
I have the same issue on an asus x99-e ws with a creative zxr and creative xf-i sound cards. I think its a chipset issue. Note the sleep hibernate trick does work  but is annoying as hell. 
 
Mainboard: Asus X99-E WS (Bios 0701)
CPU: Intel Core i7-5930K
Power Supply: Corsair AX1200i
Memory: Crucial 64GB(8x8GB) 2xCT4K8G4DFD8213 Kits
Video Card: EVGA GeForce GTX 980 Superclocked ACX 2.0 04G-P4-2983-KR
Drives: Micron 256GB SSD (MTFDDAK256MAM-1K1 (Boot), Samsung 830 (128GB) Used as a cache accelerator, 2xWD Blacks 1TB WD1001FALS (Accelerated Via Samsung 830) and 1xWB Black 2TB WD2001FASS
Sound Card: Creative Labs ZxR
#20
kyo1000
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2008/10/18 19:50:17
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2015/02/15 15:55:22 (permalink)
is any fix this problem ?
#21
bcavnaugh
The Crunchinator
  • Total Posts : 38268
  • Reward points : 0
  • Joined: 2012/09/18 17:31:18
  • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
  • Status: offline
  • Ribbons : 276
Re: EVGA X99 Micro - Sound Card Problems 2015/02/15 16:20:10 (permalink)
kyo1000
is any fix this problem ?

Is you card also the Xonar Essence STX?
For araris 
From Post: http://forums.evga.com/FindPost/2295833
 
Are you too also on Windows 8.1?
 
Have you given BIOS 1.14 a try?
Do you have the 4-Pin Molex Plugged in?
The Manual shows support for only Windows XP and Vista, what OS are you using?
 
System requirements • One PCI Express 1.0 (or higher) compatible slot for the audio card • Microsoft ® Windows® Vista (32/64bit) / XP (32/64bit) / MCE2005 • Intel ® Pentium® 4 1.4 GHz or AMD® Athlon 1400 CPU or faster CPU • 256 MB (or above) DRAM system memory • 60 MB available HDD space for driver installation package • CD-ROM drive (or DVD-ROM drive ) for software installation • High-quality headphones, powered analog speakers, or a Dolby Digital decoder, to enjoy the ultra-high fidelity sound of the card http://dlcdnet.asus.com/pub/ASUS/Audio_Card/Xonar_Essence_STX/E7806_Xonar_Essence_STX.pdf http://www.asus.com/us/Essence_HiFi_Audio/Xonar_Essence_STX/HelpDesk_Download/ As you are on Windows 8.1 all they have are BETA Drivers ATM 2014/01/06 Xonar Essence STX driver for Windows 8.1 32/64 bit Beta Version In over a Year Now ASUS Still Only Has A Beta Version of the Driver. (2014/01/06)
 
I would think that ASUS is a Fault Here Not EVGA.
 
post edited by bcavnaugh - 2015/02/15 16:25:04

Affiliate Code: E5L3CTGE12 & Associate Code: 9E88QK5L7811G3H


 
#22
oOEvil1Oo
New Member
  • Total Posts : 59
  • Reward points : 0
  • Joined: 2012/02/09 11:16:11
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2015/02/15 19:31:33 (permalink)
Make sure you have the 1.14 bios installed, that fixed a lot of problems I had.  I built system Friday evening, and the Motherboard was the only issue.  After flashing to the 1.14 bios that fixed a lot of issues.  Although for my Creative sound card I still had to manually set to gen 2.  Also I tried switching it to gen 1 and it worked like that as well.  Just something for you to try.

5820k 4.7Ghz, 16GB Crucial 2400Mhz, EVGA X99 FTW, EVGA 1300 G2 PSU, GTX 770 MSI Lightning (SLI), Corsair H110i GT, Phanteks Enthoo Pro case
#23
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2015/02/15 22:45:02 (permalink)
bcavnaugh
Are you too also on Windows 8.1?
Have you given BIOS 1.14 a try?
I would think that ASUS is a Fault Here Not EVGA.



http://forums.evga.com/FindPost/2296258
 
oOEvil1Oo
Make sure you have the 1.14 bios installed, that fixed a lot of problems I had.  I built system Friday evening, and the Motherboard was the only issue.  After flashing to the 1.14 bios that fixed a lot of issues.  Although for my Creative sound card I still had to manually set to gen 2.  Also I tried switching it to gen 1 and it worked like that as well.  Just something for you to try.




Thanks for trying to help but this has been suggested by Creative owners since back in September. It does not work for ASUS users.
post edited by araris - 2015/02/15 22:47:14

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#24
kyo1000
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2008/10/18 19:50:17
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 04:38:22 (permalink)
Yes Win 8.1 and Essences STX on X99 FTW

Gen1 or Gen2 not working , any good solution will be sell this sound card and buy creative or STX II
#25
oOEvil1Oo
New Member
  • Total Posts : 59
  • Reward points : 0
  • Joined: 2012/02/09 11:16:11
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 04:56:46 (permalink)
That sucks, it makes you wonder exactly what the issue is seeing as how its a ASUS seems to be the only ones not working.....  They are nice sound cards too.  Well if you do end up looking elsewhere I love my this: http://www.newegg.com/Product/Product.aspx?Item=N82E16829102040&cm_re=creative_fatality-_-29-102-040-_-Product  I have had it for a few years now, and the red LED are a nice touch.  Buddy of mine picked up a few of them refurb from micro center for like $20 a piece and they just didn't have the front panel adapter.  Good luck to you though which ever way you go.

5820k 4.7Ghz, 16GB Crucial 2400Mhz, EVGA X99 FTW, EVGA 1300 G2 PSU, GTX 770 MSI Lightning (SLI), Corsair H110i GT, Phanteks Enthoo Pro case
#26
GTXJackBauer
Omnipotent Enthusiast
  • Total Posts : 9598
  • Reward points : 0
  • Joined: 2010/04/19 22:23:25
  • Location: (EVGA Discount) Associate Code : LMD3DNZM9LGK8GJ
  • Status: online
  • Ribbons : 46
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 05:51:06 (permalink)
If it doesn't work with any of the manufacturer MBs than it could as well be the company driver itself.  You should be pursuing them, seriously.  I honestly never liked ASUS because of their CS but now I am starting to think because they cut their corners, everything else is going to poop.  I'll never buy ASUS ever again.  This is coming from a veteran standpoint in the PC world, not some youngster (no offense).
post edited by gtxjackbauer - 2015/02/16 05:53:40

 Use this Associate Code at your checkouts or follow these instructions for Up to 10% OFF on all your EVGA purchases:
LMD3DNZM9LGK8GJ
#27
kyo1000
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2008/10/18 19:50:17
  • Status: offline
  • Ribbons : 0
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 10:40:48 (permalink)
i will sell STX after this   i will buy Sound Blaster ZxR  the best option for now .
#28
bcavnaugh
The Crunchinator
  • Total Posts : 38268
  • Reward points : 0
  • Joined: 2012/09/18 17:31:18
  • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
  • Status: offline
  • Ribbons : 276
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 11:03:14 (permalink)
I have been looking for the Best Sound Card to use with the X99 Chipset and most seem to be having issues.
Even with the Build in Sound Card on the X99 Classified MB Sound is NOT smooth more garbled and distorted and delays when Windows 7 Boots Up.
I wished that EVGA had used the same card Realtek High Definition Audio that was used in the X79 Motherboards.
I Never had any Sound Delays or garbled and distorted sound like with Sound Blaster cards, the reason I stopped using Sound Blaster Products.

Affiliate Code: E5L3CTGE12 & Associate Code: 9E88QK5L7811G3H


 
#29
araris
SSC Member
  • Total Posts : 629
  • Reward points : 0
  • Joined: 2007/08/10 12:09:57
  • Status: offline
  • Ribbons : 2
Re: EVGA X99 Micro - Sound Card Problems 2015/02/16 19:39:21 (permalink)
gtxjackbauer
If it doesn't work with any of the manufacturer MBs than it could as well be the company driver itself.  You should be pursuing them, seriously.  I honestly never liked ASUS because of their CS but now I am starting to think because they cut their corners, everything else is going to poop.  I'll never buy ASUS ever again.  This is coming from a veteran standpoint in the PC world, not some youngster (no offense).




It works perfectly fine with ASUS motherboards. ASUS released a BIOS update for it months ago.

Intel Core i7-5820k @ 4.2Ghz (1.2v)
NVIDIA GTX Titan X (1202Mhz w/ACX)
Corsair 840 Evo SSDs (750GB)
Corsair 16GB DDR4 2666Mhz RAM
EVGA x99 Micro LGA2011-3
ASUS Xonar Essence STX Sound Card
Dell Ultrasharp 24" 1920x1200
Windows 8.1 Professional 64-bit
#30
Page: 123 > Showing page 1 of 3
Jump to:
  • Back to Mobile