EVGA

EVGA SC17 Not Turning on with Good AC Power Adapter

Author
skyted
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2018/06/28 15:21:23
  • Status: offline
  • Ribbons : 0
2021/01/18 20:08:57 (permalink)
AC power adapter tests good at 19V. Laptop will not run on AC adapter (with battery disconnected) and adapter will not charge the battery.  Opened case to test internal power connector. It has four black (-), four red (+) and one white wire. Connecting multimeter to each black and each red wire tests good at 19V. Connecting meter to red (or black) and single white wire shows no voltage--is this normal or is the internal power connector bad? (Photo of removed internal DC Jack/power connector attached. R,B, and W wires tested after connecting AC adapter to jack end).
 
Has anyone encountered this issue of laptop not working when connected to power and fixed it? Any suggestions on how to proceed?
 
Thanks for your help!
Ted
 
 
 
post edited by skyted - 2021/01/19 07:58:48

Attached Image(s)

#1

4 Replies Related Threads

    ty_ger07
    Insert Custom Title Here
    • Total Posts : 17645
    • Reward points : 0
    • Joined: 2008/04/10 23:48:15
    • Location: traveler
    • Status: offline
    • Ribbons : 183
    Re: EVGA SC17 Not Turning on with Good AC Power Adapter 2021/01/20 09:26:24 (permalink)
    Your measurements on red and black are correct.  EVGA's charger does not use a center "smart pin", therefore the white wire is not connected to anything to the charger.
     
    Measuring my SC 17, the center pin white wire is being back-fed about 3 volts from the laptop's internal charging circuitry.  But since the charger has no connection to that wire, it's inconsequential in my situation.  But if your laptop's charging circuitry isn't back-feeding any power-good signal (regardless of whether the charger uses the signal [it doesn't]), I think that indicates that your laptop's internal charging circuitry has a problem.
     
    To be clear, FROM your charger, the white wire will have 0 volts.  Like, if you disconnect the header from the motherboard and then measure the voltage on that wire from the charger, there should be no voltage on that pin.  That's normal.  There is no connection to the charger on that wire.  But from your laptop's motherboard, there SHOULD be voltage on the white wire.  Like, if you leave the header connected to the motherboard and plug in the charger, you should see voltage backfed to the white wire FROM the motherboard; indicating that the motherboard's charging circuitry is working properly.
     
    I can take pictures of my measurements and measurement methods, if you need something to compare with.
     
    Nothing looks or smells burnt?  I think the problem lies on your laptop's motherboard.
    post edited by ty_ger07 - 2021/01/20 10:40:24
    #2
    skyted
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/06/28 15:21:23
    • Status: offline
    • Ribbons : 0
    Re: EVGA SC17 Not Turning on with Good AC Power Adapter 2021/01/20 19:40:31 (permalink)
     ty_ger07, thank you very much for your reply. Your answer makes clear that the internal power connector is fine. Following your suggestion, I stuck a bent sewing pin into the white wire connection to the header, when plugged into the motherboard, to measure any voltage when meter connected to the black wire. I get 3.29 volts! So it seems that the motherboard's charging circuitry is working properly.
     
    What's really weird is that I found that the battery is able to be charged but only when the laptop is powered off and the AC adapter plugged in for many hours.  Electricity is not my strong suit, but it appears that the problem may be with the AC adapter. Although it reads a proper 19V, does it seem possible to you that it does not provide sufficient current to power the laptop (or charge the battery when the laptop is on)?
     
    Thanks again,
    Ted
    #3
    ty_ger07
    Insert Custom Title Here
    • Total Posts : 17645
    • Reward points : 0
    • Joined: 2008/04/10 23:48:15
    • Location: traveler
    • Status: offline
    • Ribbons : 183
    Re: EVGA SC17 Not Turning on with Good AC Power Adapter 2021/01/20 20:34:17 (permalink)
    Although it reads a proper 19V, does it seem possible to you that it does not provide sufficient current to power the laptop (or charge the battery when the laptop is on)?

    Yeah, maybe.  I don't know.
    I don't have a better suggestion.
    #4
    skyted
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/06/28 15:21:23
    • Status: offline
    • Ribbons : 0
    Re: EVGA SC17 Not Turning on with Good AC Power Adapter 2021/01/21 14:51:23 (permalink)
    Thanks again. I'll purchase another AC adapter and update this thread once I receive it.
    #5
    Jump to:
  • Back to Mobile