EVGA

Hot!EVGA Precision X1 - (OFFICIAL RELEASE - NON-BETA)

Page: 123 > Showing page 1 of 3
Author
GTXJackBauer
CLASSIFIED ULTRA Member
  • Total Posts : 5553
  • Reward points : 0
  • Joined: 2010/04/19 22:23:25
  • Location: U.S.A
  • Status: online
  • Ribbons : 27
2019/06/14 22:49:39 (permalink)
Everyone can check out the official Version of EVGA Precision X1 down below.
 
 
Version 0.3.19.0

Release: 6/14/2019

    Adds support for Frame Rate Limiter (Frame Rate Target)
    Various other fixes

 
Precision X1 Page
 
Download Standalone
 
Download Steam
post edited by GTXJackBauer - 2019/06/30 16:31:38

Use this Associate Code to get 5%-10% discounts on all your EVGA purchases:
LMD3DNZM9LGK8GJ
Use this Rewards Code below when registering your EVGA products. 
(Make sure to upload your invoice.)
#1

69 Replies Related Threads

    Hoggle
    EVGA Forum Moderator
    • Total Posts : 4489
    • Reward points : 0
    • Joined: 2003/10/13 22:10:45
    • Location: Eugene, OR
    • Status: offline
    • Ribbons : 3
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/14 23:15:15 (permalink)
    Thanks for the update 3.17 was pretty stable for me so hopefully 3.19 is even better.

    Use an Associates Code & SAVE 5% - 10% on your purchase. Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it. 
     
     
    #2
    d.burnette
    CLASSIFIED Member
    • Total Posts : 4847
    • Reward points : 0
    • Joined: 2007/03/08 13:19:32
    • Status: offline
    • Ribbons : 15
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 06:49:37 (permalink)
    I have reported this I know at least in the previous couple of versions of PX1.
    Under HWM tab, max temps are not being recorded properly.
    See image - this is after a gaming session.
    This used to work properly a few versions back. Would be nice if it did again.
    Other than this 0.3.19 working fine for me.
     
     


    Don 
     
     
    EVGA Z390 Dark MB | i9 9900k CPU @ 5.1 GHz | EVGA RTX 2080 Ti FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 DDR4 Ram | Corsair H150i Pro Cooler | EVGA T2 Titanium 1000w Power Supply | Samsung 970 Pro 1TB m.2 Nvme | Samsung 970 Evo 1TB m.2 Nvme | Samsung 860 Evo 1TB SATA SSD | EVGA DG 87 Case |
     
     
     
     
     
     
     
     
     
     
    #3
    akaash00
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2017/12/30 00:15:35
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 07:10:18 (permalink)
    Please fix HW montor starting at startup, Disabling it and saving does nothing. It's still active after restart. I hate disabling it manually everytime after reboot. I want to enable it on demand.
    #4
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 15590
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 111
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 07:40:22 (permalink)
    akaash00
    Please fix HW montor starting at startup, Disabling it and saving does nothing. It's still active after restart. I hate disabling it manually everytime after reboot. I want to enable it on demand.



    Did you Apply & then Save this change to a Profile Number ?

    Possible work around --> go through & Un-select the "X" in each HW section
     
     

     
     

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #5
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 15590
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 111
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 07:41:23 (permalink)
    GTXJackBauer
    Everyone can check out the official Version of EVGA Precision X1 - 0.3.19.0
     
    Version 0.3.19.0

    Release: 6/14/2019

       Adds support for Frame Rate Limiter (Frame Rate Target)
       Various other fixes

     
    Precision X1 Page
     
    Download Standalone
     
    Download Steam




     
    newer version

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #6
    Cool GTX
    EVGA Forum Moderator
    • Total Posts : 15590
    • Reward points : 0
    • Joined: 2010/12/12 14:22:25
    • Location: Folding for the Greater Good
    • Status: offline
    • Ribbons : 111
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 07:42:54 (permalink)
    d.burnette
    I have reported this I know at least in the previous couple of versions of PX1.
    Under HWM tab, max temps are not being recorded properly.
    See image - this is after a gaming session.
    This used to work properly a few versions back. Would be nice if it did again.
    Other than this 0.3.19 working fine for me.
     




     
    Did you try all the Steps in this link when changing Versions of X1 ?   How Do I Troubleshoot Precision X1 Issues?

    RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

    Thank You for Your Support






    #7
    akaash00
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2017/12/30 00:15:35
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 07:43:17 (permalink)
    Cool GTX
    akaash00
    Please fix HW montor starting at startup, Disabling it and saving does nothing. It's still active after restart. I hate disabling it manually everytime after reboot. I want to enable it on demand.



    Did you Apply & then Save this change to a Profile Number ?

    Possible work around --> go through & Un-select the "X" in each HW section
     
     

     
     


    I always do Apply then Save. This issue was also on the previous betas


    #8
    meta12
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2016/12/02 10:14:50
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 10:22:31 (permalink)
    I've been using Precision X1 for awhile now with no issues.
     
    Last night I turned off my PC, and this morning when I turned it on, Precision X1 would not start. I have it so it starts with Windows, but all that happens is the X1 logo appears on the screen and the program does not start.
     
    Same thing happens when opening it from the PX18.exe, the logo shows on screen and the program never starts. It shows up for a split second in task manager under processes and says 'suspended'.
     
    I've tried pretty much everything solution I could find searching around, but nothing helps.
     
    The same thing happens with any version I try. It's just so weird that it was working completely fine last night and now it won't even open.
     
    Any help would be greatly appreciated.
    #9
    GTXJackBauer
    CLASSIFIED ULTRA Member
    • Total Posts : 5553
    • Reward points : 0
    • Joined: 2010/04/19 22:23:25
    • Location: U.S.A
    • Status: online
    • Ribbons : 27
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 11:29:35 (permalink)
    meta12
    I've been using Precision X1 for awhile now with no issues.
     
    Last night I turned off my PC, and this morning when I turned it on, Precision X1 would not start. I have it so it starts with Windows, but all that happens is the X1 logo appears on the screen and the program does not start.
     
    Same thing happens when opening it from the PX18.exe, the logo shows on screen and the program never starts. It shows up for a split second in task manager under processes and says 'suspended'.
     
    I've tried pretty much everything solution I could find searching around, but nothing helps.
     
    The same thing happens with any version I try. It's just so weird that it was working completely fine last night and now it won't even open.
     
    Any help would be greatly appreciated.




    By any chance, are you using Aquasuite software?  I remember it conflicting with it once.
     
    Also check and make sure if there were any recent Window updates.

    Use this Associate Code to get 5%-10% discounts on all your EVGA purchases:
    LMD3DNZM9LGK8GJ
    Use this Rewards Code below when registering your EVGA products. 
    (Make sure to upload your invoice.)
    #10
    meta12
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2016/12/02 10:14:50
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 11:47:25 (permalink)
    GTXJackBauer
    meta12
    I've been using Precision X1 for awhile now with no issues.
     
    Last night I turned off my PC, and this morning when I turned it on, Precision X1 would not start. I have it so it starts with Windows, but all that happens is the X1 logo appears on the screen and the program does not start.
     
    Same thing happens when opening it from the PX18.exe, the logo shows on screen and the program never starts. It shows up for a split second in task manager under processes and says 'suspended'.
     
    I've tried pretty much everything solution I could find searching around, but nothing helps.
     
    The same thing happens with any version I try. It's just so weird that it was working completely fine last night and now it won't even open.
     
    Any help would be greatly appreciated.




    By any chance, are you using Aquasuite software?  I remember it conflicting with it once.
     
    Also check and make sure if there were any recent Window updates.


    I'm not using that software, and there was a Windows update this morning, however X1 was broken before the update came through as far as I can recall.
     
    I ended up doing a system restore to a few weeks back, and X1 is working again.
     
    However, everytime I open up the program, it now says "Requested value 'FTW3_ULTRA_HY' was not found." It then starts the program normally.
     
    What does this mean?
    #11
    meta12
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2016/12/02 10:14:50
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 12:42:12 (permalink)
    I think I've fixed it. 
     
    I did the system restore, uninstalled X1, deleted all the leftover files, then reinstalled the latest version. 
     
    Seems to work now. No clue what the issue was. 
    #12
    GTXJackBauer
    CLASSIFIED ULTRA Member
    • Total Posts : 5553
    • Reward points : 0
    • Joined: 2010/04/19 22:23:25
    • Location: U.S.A
    • Status: online
    • Ribbons : 27
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/15 20:26:08 (permalink)
    meta12
    I think I've fixed it. 
     
    I did the system restore, uninstalled X1, deleted all the leftover files, then reinstalled the latest version. 
     
    Seems to work now. No clue what the issue was. 






    Use this Associate Code to get 5%-10% discounts on all your EVGA purchases:
    LMD3DNZM9LGK8GJ
    Use this Rewards Code below when registering your EVGA products. 
    (Make sure to upload your invoice.)
    #13
    dc8flyer
    iCX Member
    • Total Posts : 269
    • Reward points : 0
    • Joined: 2016/02/23 00:10:47
    • Status: offline
    • Ribbons : 3
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 04:58:17 (permalink)
    PX1 3.19 has upped the CPU usage again to even higher percentages than I have seen before. PX1 3.17 cpu usage was less than one percent. PX1 3.19 cpu usage is up to 3.7 percent with computer at idle/no load.
     
    I'll go back to 3.17 and see what happens.
     
    Edit:
     
    My mistake. CPU usage still below one percent. I was looking at GPU usage that went as high as 3.7 percent. 
     
    PX1 3.19 looks good.
    post edited by dc8flyer - 2019/06/16 05:21:55
    #14
    dlbsyst
    iCX Member
    • Total Posts : 252
    • Reward points : 0
    • Joined: 2011/01/15 11:56:22
    • Status: offline
    • Ribbons : 1
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 05:35:07 (permalink)
    I think this new version should still be considered beta because I continue to have a problem with it. It sometimes only detects 2 of 3 fans on my RTX 2080 FTW3. I just don't understand why EVGA can't seem to fix this issue since the earlier version 0.3.12 worked correctly detecting my fans every time. Please fix this issue because I do not want to run an old version.:(
    post edited by dlbsyst - 2019/06/16 09:50:55
    #15
    FreedomParts
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2018/07/03 12:44:19
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 10:12:32 (permalink)
    This app does not work on my system. I uninstalled Precision XOC to try it out. First with beta v0.3.17, then with this official release. I tried installing with AV disabled, running as administrator..
     
    All that ever happens is I see a splash screen logo while it's loading, then nothing...
    Here's windows application logs, 2 error messages get created when I try to launch:
    -an application error entry:
    Faulting application name: PX18.exe, version: 0.3.19.0, time stamp: 0x5d031268
    Faulting module name: KERNELBASE.dll, version: 10.0.18362.145, time stamp: 0xef881ca4
    Exception code: 0xe0434352
    Fault offset: 0x000000000003a839
    Faulting process id: 0x17b0
    Faulting application start time: 0x01d5246591946232
    Faulting application path: C:\Program Files\EVGA\Precision X1\PX18.exe
    Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
    Report Id: 0104bb9a-da8c-46a4-9bdc-4153a594e739
    Faulting package full name:
    Faulting package-relative application ID:
     
    - a .NET runtime entry:
    Application: PX18.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.ArgumentOutOfRangeException
       at System.ThrowHelper.ThrowArgumentOutOfRangeException(System.ExceptionArgument, System.ExceptionResource)
       at PX18.ViewModel.HWMonitorVM.addMenus(System.Collections.Generic.List`1<PX18.Model.Monitor>)
       at PX18.View.HWMonitorUC.UserControl_Loaded(System.Object, System.Windows.RoutedEventArgs)
       at System.Windows.EventRoute.InvokeHandlersImpl(System.Object, System.Windows.RoutedEventArgs, Boolean)
       at System.Windows.UIElement.RaiseEventImpl(System.Windows.DependencyObject, System.Windows.RoutedEventArgs)
       at System.Windows.BroadcastEventHelper.BroadcastEvent(System.Windows.DependencyObject, System.Windows.RoutedEvent)
       at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(System.Object)
       at MS.Internal.LoadedOrUnloadedOperation.DoWork()
       at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
       at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
       at System.Windows.Media.MediaContext.RenderMessageHandlerCore(System.Object)
       at System.Windows.Media.MediaContext.RenderMessageHandler(System.Object)
       at System.Windows.Interop.HwndTarget.OnResize()
       at System.Windows.Interop.HwndTarget.HandleMessage(MS.Internal.Interop.WindowMessage, IntPtr, IntPtr)
       at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
       at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
       at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
       at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
       at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

    I'm running this on Windows 10 Pro v1903 build 18362.145, I have 2 1080ti FTW
    #16
    Vanitas_59
    Superclocked Member
    • Total Posts : 142
    • Reward points : 0
    • Joined: 2010/08/28 08:07:05
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 11:38:23 (permalink)
    This question may seem redundant if not stupid, but does EVGA Precision X1 support GTX 1080Ti FTW3?  I'm asking because the OSD on XOC 6.2.7 is wonky (seems to work whenever it feels like it), and on the main download page for X1 in the "Key Features" it lists: "Full support for GeForce RTX graphics cards (GTX support coming soon)".  However, in the System Requirements it lists Supports GeForce RTX, Geforce GTX 16 Series, and GeForce GTX 10 Series Graphics Cards.  I may be reading too much into this, but I'm confused.  I just want the OSD to function and the ability to control all 3 fans.  I tried older versions of XOC and I'm getting the same results: OSD is lolz.  Sometimes it functions, sometimes it don't.  Gonna try my luck with X1.  I'll report back in a bit.

    EVGA Affiliate Code:  X26PBW0MJK
    #17
    GTXJackBauer
    CLASSIFIED ULTRA Member
    • Total Posts : 5553
    • Reward points : 0
    • Joined: 2010/04/19 22:23:25
    • Location: U.S.A
    • Status: online
    • Ribbons : 27
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 11:57:22 (permalink)
    Vanitas_59
    This question may seem redundant if not stupid, but does EVGA Precision X1 support GTX 1080Ti FTW3?  I'm asking because the OSD on XOC 6.2.7 is wonky (seems to work whenever it feels like it), and on the main download page for X1 in the "Key Features" it lists: "Full support for GeForce RTX graphics cards (GTX support coming soon)".  However, in the System Requirements it lists Supports GeForce RTX, Geforce GTX 16 Series, and GeForce GTX 10 Series Graphics Cards.  I may be reading too much into this, but I'm confused.  I just want the OSD to function and the ability to control all 3 fans.  I tried older versions of XOC and I'm getting the same results: OSD is lolz.  Sometimes it functions, sometimes it don't.  Gonna try my luck with X1.  I'll report back in a bit.



    I think 10 series should work with PX1 now.  Won't hurt to try anyways.  If it does work, they should change that info on the page as it can be contradicting. 




    Use this Associate Code to get 5%-10% discounts on all your EVGA purchases:
    LMD3DNZM9LGK8GJ
    Use this Rewards Code below when registering your EVGA products. 
    (Make sure to upload your invoice.)
    #18
    Vanitas_59
    Superclocked Member
    • Total Posts : 142
    • Reward points : 0
    • Joined: 2010/08/28 08:07:05
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 12:10:39 (permalink)
    Update: It's very pretty.  I don't find it to be very user friendly, but it works.  All GPU fans spin, OSD functions as intended.  TLDR; Cumbersome to use, but it works, and if something works I can make do.

    EVGA Affiliate Code:  X26PBW0MJK
    #19
    Vanitas_59
    Superclocked Member
    • Total Posts : 142
    • Reward points : 0
    • Joined: 2010/08/28 08:07:05
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 12:18:38 (permalink)
    Update:  It's very pretty.  I don't find it to be very user friendly, but it works.  All GPU fans spin, OSD functions as intended.  As far I can tell, everything is good to go.  Well, except for the LED menu: Shows monstrous (in regards to the GPU cooler) GeForce RTX 20XX; I don't own one.  
     
    TLDR; Cumbersome to use, but it works, and if something works I can make do.
     
    Update #2:  I dun goofed in my reply.
     
    Update#3:  I'll shoot you some EVGA bux in the next few days GTXJackBauer.  I just finished building a X299 upgrade.  Using a 9920X.  I saw some post somewhere where you have a build extremely similar if not exactly to the one I just completed.  :)
     
    Update#4:  An update, for an update because. . .update?  Oh, please forgive the double post/reply.
     
    Update#5:  I'm just gonna stop editing my replies.  I'm borking everything in existence.

    EVGA Affiliate Code:  X26PBW0MJK
    #20
    raidflex
    Superclocked Member
    • Total Posts : 182
    • Reward points : 0
    • Joined: 2008/04/10 21:58:21
    • Location: USA
    • Status: offline
    • Ribbons : 2
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 18:38:04 (permalink)
    How do you resize the HWM window?

    Gigabyte X99M-Gaming 5
    i7 5820 (4.5GHz Vcore 1.27V)
    EVGA GTX 1080 FTW
    Samsung 850 Pro 120GB & 500 GB 
    Corsair AX1200
    Crucial Ballistix Sport 2400 4x4GB
    Caselabs Mercury S5 w/pedestal
    Windows 10 Pro x64
    EK Supremacy 
    Alphacool Nexxxos UT60 x2
    Monsoon Series Two Premium DDC Reservoir
    Bitspower Compression Fittings
    Swiftech Helix Fans
    LG 34UM95 Monitor
    #21
    GTXJackBauer
    CLASSIFIED ULTRA Member
    • Total Posts : 5553
    • Reward points : 0
    • Joined: 2010/04/19 22:23:25
    • Location: U.S.A
    • Status: online
    • Ribbons : 27
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 18:52:12 (permalink)
    Vanitas_59
    Update:  It's very pretty.  I don't find it to be very user friendly, but it works.  All GPU fans spin, OSD functions as intended.  As far I can tell, everything is good to go.  Well, except for the LED menu: Shows monstrous (in regards to the GPU cooler) GeForce RTX 20XX; I don't own one.  
     
    TLDR; Cumbersome to use, but it works, and if something works I can make do.
     
    Update #2:  I dun goofed in my reply.
     
    Update#3:  I'll shoot you some EVGA bux in the next few days GTXJackBauer.  I just finished building a X299 upgrade.  Using a 9920X.  I saw some post somewhere where you have a build extremely similar if not exactly to the one I just completed.  :)
     
    Update#4:  An update, for an update because. . .update?  Oh, please forgive the double post/reply.
     
    Update#5:  I'm just gonna stop editing my replies.  I'm borking everything in existence.


     
    Thanks m8. 

    raidflex
    How do you resize the HWM window?



    You can't unfortunately but hopefully we might be able to in the future.

    Use this Associate Code to get 5%-10% discounts on all your EVGA purchases:
    LMD3DNZM9LGK8GJ
    Use this Rewards Code below when registering your EVGA products. 
    (Make sure to upload your invoice.)
    #22
    raidflex
    Superclocked Member
    • Total Posts : 182
    • Reward points : 0
    • Joined: 2008/04/10 21:58:21
    • Location: USA
    • Status: offline
    • Ribbons : 2
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 19:36:26 (permalink)
     
    But this was possible in XOC, such a simple function I do not understand why this is not present in X1. Seems like X1 is form over function to me. 

    Gigabyte X99M-Gaming 5
    i7 5820 (4.5GHz Vcore 1.27V)
    EVGA GTX 1080 FTW
    Samsung 850 Pro 120GB & 500 GB 
    Corsair AX1200
    Crucial Ballistix Sport 2400 4x4GB
    Caselabs Mercury S5 w/pedestal
    Windows 10 Pro x64
    EK Supremacy 
    Alphacool Nexxxos UT60 x2
    Monsoon Series Two Premium DDC Reservoir
    Bitspower Compression Fittings
    Swiftech Helix Fans
    LG 34UM95 Monitor
    #23
    jedimstr
    New Member
    • Total Posts : 33
    • Reward points : 0
    • Joined: 2015/06/24 17:06:08
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 19:37:38 (permalink)
    So I must be blind because I can't find how to set the Frame Rate Limiter mentioned in the change notes.  Where is it set in the X1 ui?
    #24
    Wolfseven
    New Member
    • Total Posts : 52
    • Reward points : 0
    • Joined: 2010/03/08 21:41:28
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/16 20:46:58 (permalink)
    the in task icons for hardware display on task bar crashes after few minutes.

    AsusHW z370|i7x8700k|Cors WC100iv2|HyperX DDR4 Pc3200/32gb|EVGA/RTX-2080 8gb|ATX1200Csr|Turtle Beach Elite T.A.C Pro|Win10 64|Trackir Pro/ir|Gladiator Mki pro|MFG Crosswinds|X55 Throttle Control|Logitech G15|GEN/Mouse|32" Samsung crv gaming|
    2x7"Lilliputs;1x9"DblSght|
    #25
    dc8flyer
    iCX Member
    • Total Posts : 269
    • Reward points : 0
    • Joined: 2016/02/23 00:10:47
    • Status: offline
    • Ribbons : 3
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/17 03:58:47 (permalink)
    jedimstr
    So I must be blind because I can't find how to set the Frame Rate Limiter mentioned in the change notes.  Where is it set in the X1 ui?




    Look in lower panel where the ICX info is displayed. Click on the right arrow four times and to the right of the TEMP Color is the Framrate Target settings.
    #26
    murlo26
    New Member
    • Total Posts : 36
    • Reward points : 0
    • Joined: 2014/07/16 20:44:06
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/17 08:08:17 (permalink)
    So does the OSD work yet? I am still on 3.17 but the OSD hasn't been working in most games for me since like 10 versions ago. They said it was a bug that has been there since the beginning and said they wouldn't release it from BETA until they fixed it. So I assume it's fixed? Guess I will have to test later. 
    #27
    DarkAngel_ZERO
    Superclocked Member
    • Total Posts : 181
    • Reward points : 0
    • Joined: 2007/09/15 15:01:56
    • Status: offline
    • Ribbons : 2
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/17 08:13:09 (permalink)
    Dunno if it's the software or the GPU firmware, but my FTW3 Hybrid started hitting super high temps and throttling like mad during a Destiny 2 session. Checking Precision showed that the fan on the card was at 100%, but the fan on the radiator was only 34%. Core temp was pegged at 85C and mem temps were 83C. This doesn't happen all the time, just on occasion after the computer comes out of sleep, and generally restarting Precision seems to fix the issue.
     
    EDIT: So I did some testing. For whatever reason, the radiator fan would refuse to ramp up past 34%, even under manual control. To fix it, I set both fans as linked, cranked to 100%, and hit apply, then wound down to 0%, clicked auto, and hit apply. Suddenly the fan started responding normally and ramped up. Not gonna lie...this is a pretty serious issue if PX1 is causing the fans to malfunction on default settings...
    post edited by DarkAngel_ZERO - 2019/06/17 10:29:38
    #28
    bcavnaugh
    The Crunchinator
    • Total Posts : 36578
    • Reward points : 0
    • Joined: 2012/09/18 17:31:18
    • Location: USA Affiliate E5L3CTGE12 Associate 9E88QK5L7811G3H
    • Status: offline
    • Ribbons : 249
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/17 12:06:59 (permalink)
    I Dumped 0.3.17.0 and 0.3.19.0 on all three of my RTX Rigs due to Lock Ups using the Tool.
    I can make any changes in 0.3.16.0 and have No Lock Ups on any of my three RTX Rigs.
     
    Lock Ups = Having to Press the Reset Button
    Then it could also be caused by Driver 430.86
    post edited by bcavnaugh - 2019/06/17 13:54:52


    #29
    reinvented
    Superclocked Member
    • Total Posts : 141
    • Reward points : 0
    • Joined: 2006/05/22 13:18:49
    • Status: offline
    • Ribbons : 0
    Re: EVGA Precision X1 - Version 0.3.19.0 (OFFICIAL RELEASE - NON-BETA) 2019/06/17 17:07:00 (permalink)
    Still exhibiting the same problems of a fluctuating power target and temp slider.  I set mine to max for my card (114%, 88c), and upon reboot it'll be 113/88.  Still using 430.86, and did a clean install of PX1.  Hopefully you guys can figure this out!
    #30
    Page: 123 > Showing page 1 of 3
    Jump to:
  • Back to Mobile