EVGA

AnsweredHot!EVGA Nu Audio - Linux Drivers

Page: < 12 Showing page 2 of 2
Author
tigerdognew
New Member
  • Total Posts : 28
  • Reward points : 0
  • Joined: 2020/04/21 21:39:54
  • Location: Del Mar, California USA
  • Status: offline
  • Ribbons : 2
Re: EVGA Nu Audio - Linux Drivers 2021/05/03 07:15:10 (permalink)
ty_ger07
Line out has no volume control. That's why its called line out.

D'oh!  I assumed Teddy was talking about the headphone out.  Good catch, ty_ger07!  Anyway, if it helps, here is how I have the card configured using the EVGA control panel in Windows.  Switching to Linux, the card behaves as I expect.

Attached Image(s)

#31
Zerhot
New Member
  • Total Posts : 100
  • Reward points : 0
  • Joined: 2021/04/27 23:25:52
  • Status: offline
  • Ribbons : 0
Re: EVGA Nu Audio - Linux Drivers 2021/05/03 08:31:01 (permalink)
Omg thats why
#32
Teddy Rogers
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2019/08/23 05:58:27
  • Status: offline
  • Ribbons : 1
Re: EVGA Nu Audio - Linux Drivers 2021/05/04 01:01:03 (permalink)
tigerdognew
D'oh!  I assumed Teddy was talking about the headphone out.


I was talking about the headphone out! I'm just not using the headphone out now because of the reduced volume. Instead I have opted to connect a tube amp to the line out... 
 
Ted.
#33
thekraken8him
New Member
  • Total Posts : 9
  • Reward points : 0
  • Joined: 2017/07/25 01:01:57
  • Status: offline
  • Ribbons : 0
Re: EVGA Nu Audio - Linux Drivers 2021/05/10 16:58:56 (permalink)
tigerdognew
@Teddy Rogers and others:
I seem to have worked out the basics for functionality with a little help from EVGA and from the forum at Audiophilestyle.  Here's the gist:  the Linux kernel has supported USB 2.0 audio devices for years, and as of kernel 5.4, even has a special tweak so that the EVGA Nu can be recognized as capable of digital audio pass-through.  The hitch is, the EVGA Nu only works when loaded with the original firmware 0x027 from its initial release.  So to get it working in Linux, you must first put it in a Windows system, and load the EVGA driver version 0.1.1 or earlier (available on EVGA's web site.)  After that, Linux (at least Ubuntu 20.04) will recognize the card.  I tried three other firmwares (0x028, 0x02b, and 0x032.)  All of them cause the card to not function.
 
Once working, there seem to be a few quirks:
  • Initial volume level is low, and increasing the volume using the Pulseaudio volume control doesn't help.  You must use alsamixer from the CLI to set all levels at 100% (see attached screenshot)
  • When recording, all inputs seem to feed the "mic" circuitry (Cirrus Logic ADC), not the higher-quality ASMedia ADC.  This is sad, because the ASMedia ADC is an excellent piece of silicon.  Since this can be selected in the Windows driver, maybe we will find a way to tweak this in Linux.
  • When recording with Audacity under Ubuntu 20.04, the mic level in PulseAudio must be increased to 150%.
  • When recording, sample rate and type must be set in the /etc/pulse/daemon.conf file.  I've set mine like this:
    default-sample-format = s32le
    default-sample-rate = 384000
    alternate-sample-rate = 48000
I have tested my Nu, with 0x027 firmware, on two different Linux systems (different motherboards, different generation AMD CPUs) and it has worked in both cases.  I'd appreciate if someone else could see if the same steps work elsewhere.
 


This is awesome, I'd like to try it. Does rolling back to the older firmware cause any issues in Windows 10? I spend the majority of my time in Windows 10, but I also want my sound to work in Linux.
#34
Page: < 12 Showing page 2 of 2
Jump to:
  • Back to Mobile