EVGA

Helpful ReplyHot!EVGA EU Warranty support - PSU RMA - frustratingly slow service (4 weeks total)

Author
MartinUK
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2019/04/06 07:53:25
  • Status: offline
  • Ribbons : 0
2021/01/23 06:07:24 (permalink)
I own an EVGA 750 G3 (220-G3-0750-X3), it worked absolutely fine, 100% reliable with my old EVGA 1080Ti SC Black (11G-P4-6393-KR).
 
I managed to grab a 3080 FE at the end of last year, swapped the cards, made no other changes, and since then I've had the problem where OCP trips on the PSU randomly (its fine in any stress test, but randomly powers off, usually when going from a menu/loading screen to rendering the game).
 
Fair enough, some PSU's (notably the EVGA GA series) have problems coping with 3080's. Its rare the G3 is effected by this, so I reckon mine must have a fault, but that's ok, I have a 10 year EVGA warranty, and their customer service is often touted as the best, so I'll be fine right?...wrong!
 
29-Dec - Create support ticket
    <9 days pass with no response at all, but its the holiday season, maybe not so bad>
7-Jan - Eventually get bored waiting on a reply, phone up EVGA EU, get to talk to someone pretty quickly, they accept the issue and I get ticket number to create Advanced RMA
8-Jan - Advanced RMA gets approved...maybe things are not so bad...
    <7 days pass with no contact from EVGA, but they take the Advanced RMA collateral payment>
15-Jan - Notice 'Part Number Out' on RMA page shows as an EVGA 850 G5 (220-G5-0850-X3) - Reply on ticket asking if I could have a G3 instead, but that I would accept a G5
    <4 days pass with no reply from EVGA, no PSU shipped, nothing>
19-Jan - Get bored waiting for reply to ticket, send email to EVGA customer support directly asking what is happening - Get told that the replacement they were going to send me was faulty and I have to wait longer
    <4 days pass with, PSU still faulty, replacement still not shipped, EVGA still have my money>
23-Jan - Check on the RMA page, notice 'Part Number Out' has now changed to an EVGA 750 GA (220-GA-0750-X2), which is not only a cheaper PSU than the faulty one ($129.99 for the GA vs $149.99 for the G3 on EVGAs own site) but is also well known to have even more problems running a 3080 than the G3 ever does:
https://forums.evga.com/S...80-FTW-U-m3117599.aspx
https://forums.evga.com/E...s-Please-m3128600.aspx
https://forums.evga.com/E...y-recall-m3152699.aspx
   <2 pass since I created this forum thread, and emailed support, two replies here from moderators/staff saying it would be forwarded to EVGA EU>
25-Jan - (Update) - Received reply from email to EVGA support - 'Part Number Out' corrected from the 750 GA model to a 750 T2 (just luck as it seems they did not have any G3 available at this time) - Advanced RMA status changed to shipped, no ETA but no complaints at that.
   <5 days pass waiting on the delivery>
30-Jan - (Update) - Replacement PSU arrived, brand new sealed in box, swapped it with the faulty one, and after two days of testing I'm confident PC is back to being 100% stable, now I just need to work out how to return the old one.
 
So 3.5 weeks after reporting a fault with a critical component with a 10 year warranty, with a company supposedly famed for their support, and I was left still sitting with a faulty PSU, feeling habitually ignored by support, requiring circumventing the ticket system with phonecalls and emails, and being presented with the prospect of (eventually) being sent a downgraded PSU that will almost certainly not work.
 
(Update) It worked out in the end, as after 4 weeks from initial ticket I have my replacement PSU, which works flawlessly. I do appreciate this all happened at a bad time (Christmas, COVID and Brexit all at once), but I do still feel 4 weeks was too much. Hopefully this is an isolated incident, but more hopefully I never need to RMA anything again to find out. Thanks to those at EVGA who replied here and tried to get things moving. 
 
Honestly, I've had better, faster, and more efficient support from sellers on Ali Express than I'm getting from EVGA.
 
The only saving grace is that I can at least still use my PC for work, as it doesn't power off unless I'm actually using my 3080. If it had been completely dead, I'd not even have been able to power my PC for almost a month.
 
I expect nobody who reads this will care, but at least now I have it written down for when I attempt to find someone in EVGA to escalate this to.
 
For anyone who finds this in the future, unless you like in NA, ignore everything you have been told about EVGAs good support, they are worlds apart.
 
Cheers
 
Martin
post edited by MartinUK - 2021/02/01 05:38:11
#1
rjohnson11
EVGA Forum Moderator
  • Total Posts : 81448
  • Reward points : 0
  • Joined: 2004/10/05 12:44:35
  • Location: Scotland, UK
  • Status: online
  • Ribbons : 72
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/01/23 06:39:38 (permalink)
forwarding this to EVGA

AMD Ryzen 9 5950X,  Corsair Mp600 Pro M.2 2TB, 128GB DDR4  Crosshair VIII Hero, RTX 3080 XC3,  Associate Code: H5U80QBH6BH0AXF

#2
EVGATech_JustinT
Superclocked Member
  • Total Posts : 117
  • Reward points : 0
  • Joined: 2019/11/01 14:01:33
  • Status: offline
  • Ribbons : 0
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/01/23 20:28:05 (permalink)
Hello MartinUK, Thank you for reaching out to us and bringing this to our attention. I have reached out to our EU team on this for further clarification and to assist you in getting this resolved as soon as possible.

Like our service? Please provide feedback for us at the link HERE
#3
MartinUK
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2019/04/06 07:53:25
  • Status: offline
  • Ribbons : 0
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/01/25 03:05:56 (permalink)
EVGATech_JustinT
Hello MartinUK, Thank you for reaching out to us and bringing this to our attention. I have reached out to our EU team on this for further clarification and to assist you in getting this resolved as soon as possible.




Thanks, I appreciate you trying at least. If only NA support handled things worldwide I wouldn't be in this situation.
 
I sure hope the EU RMA team decide to take a look at this before the warehouse team decide to dispatch the downgrade GA unit. With EVGA NA apparently accepting the GA series doesn't work well with a 3080 I'm not even going to waste more my time installing it to confirm, so all they would be doing is wasting the companies money.
 
I'll certainly keep this thread (and the various other places I've mentioned it online) updates with the progress, of lack of.
EDIT: Updated original thread with current progress
post edited by MartinUK - 2021/01/25 06:13:31
#4
EVGATech_MarkusK
EVGA EU Tech Support
  • Total Posts : 265
  • Reward points : 0
  • Joined: 2013/05/28 08:56:25
  • Status: offline
  • Ribbons : 0
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/01/25 06:11:08 (permalink) ☄ Helpfulby MartinUK 2021/01/25 06:14:59
Hi MartinUK,
 
we offered hopefully now and finally the right replacement model - if you have any additional questions, please let us know through supporteu@evga.com
 
Markus
#5
Inst1nct
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2017/06/19 03:52:12
  • Status: offline
  • Ribbons : 0
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/01/28 06:15:32 (permalink)
EVGATech_MarkusK
Hi MartinUK,
 
we offered hopefully now and finally the right replacement model - if you have any additional questions, please let us know through
 
Markus


 
Maybe you could take a look at my thread too? It's been one month since my initial contact to EVGA support and over 2 Weeks since my RMA was approved and collateral paid.
#6
MartinUK
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2019/04/06 07:53:25
  • Status: offline
  • Ribbons : 0
Re: EVGA EU Warranty support - PSU RMA - astonishingly bad service (3.5 weeks and counting 2021/02/01 05:39:39 (permalink)
So, it seems it all worked out in the end, as after 4 weeks from initial ticket I have my replacement PSU, which works flawlessly. I do appreciate this all happened at a bad time (Christmas, COVID and Brexit all at once), but I do still feel 4 weeks was too much. Hopefully this is an isolated incident, but more hopefully I never need to RMA anything again to find out. Thanks to those at EVGA who replied here and tried to get things moving.
 
(Updated my original post and edited thread title to give the full story)
#7
Jump to:
  • Back to Mobile