EVGA

EVGA 2070 XC Ultra No boost clocks

Author
Ducrider
iCX Member
  • Total Posts : 357
  • Reward points : 0
  • Joined: 2010/06/01 18:38:12
  • Location: Guyton GA
  • Status: offline
  • Ribbons : 0
2021/10/03 17:38:37 (permalink)
Posted originally in the folding section but after much testing. The issue belongs in here. This card was running fine made good ppd rgb worked and was running at boost clocks when folding.  Temps when folding were in the low to mid 60's. Good temps for folding on air. Picked up a New EVGA Hydro Copper water block. Yes correct block for the card. Temps were down as expected. RGB now inop. Main thing is the core clock is stuck at 1410. Will not run at boost clocks. 
 
Things tried. Swapped to different mobo on the bench. Changed from Win 10 to Win 7. tried 6 different drivers. All using DDU between installs. Loaded a fresh copy on Win 10. Nothing on it but Precision. Flashed to a different Vbios from techpowerup. Vbios was a updated version for the card. Unplugged the RGB/fan connector from the waterblock.
 
Highlights of things I have run across. Precision will not work. Loads to splash screen and stops. Afterburner works but can not adjust any settings other than fan speed(no fans but still). When adjusting any setting Nvidia drivers will crash. All this in Win 7. In Win 10 Precision will start up and run. Still no boost clocks. Still no setting adjustments without a drivers crash.  I did the vbios update because I figured it was a vbios issue.
 
After a lot of research only thing I have run across was some issues with Gigabyte cards being stuck on base clocks. Nothing about EVGA 2070's having that issue. At this point I am thinking about putting the air cooler back on and seeing if goes back to normal.
 
Original install after water block is the specs in my sig.
 
Bench combo is I3-4160 
Asus B85m-e/csm
4 gigs of ram unknown speed DDR3
EVGA 850w psu
Custom WC loop.
Win 7 and Win 10
 
Link to vbios used for the updated vbios.
https://www.techpowerup.com/vgabios/204724/evga-rtx2070-8192-180919
 
I hope one of you guys/gals or a EVGA Tech can give me some insight on what is going on with this.

I9 10850K
MSI MPG Z490 Gaming Edge
Gigabyte 1080ti Aorus
Corsair HX1050
Cougar Dark Blade
Win10 64 bit
 Elite ID https://www.evga.com/memb...id=92AD5FMPFQC6Y9R5XNU
950 at 4.427  http://valid.canardpc.com/show_oc.php?id=1471094
Heatware=http://www.heatware.com/eval.php?id=72404
Hwbot:http://www.hwbot.org/user/ducrider/

#1

5 Replies Related Threads

    TjFNQ
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2019/10/26 00:18:04
    • Status: offline
    • Ribbons : 0
    Re: EVGA 2070 XC Ultra No boost clocks 2021/10/09 16:50:53 (permalink)
    Fire up GPUZ---- and look specifically at the Sub vendor, Bios Version, Bus width, Bandwidth etc. and make sure there are no "unknown" labels in those boxes. Also make sure the device id's and bios version match the card. You mentioned folding? I thought that was only for ATI cards not Nvidia, don't quote me on that. Also how have you connected the 6 and 8 pin pwr connectors? Hopefully not daisy chaining the one cable out of PSU.
     
    Lets us know
    post edited by TjFNQ - 2021/10/09 16:53:57

    Asus Maximus XII Apex
    16GB DDR4 ADATA D50 @3600
    EVGA 2070s XC ULTRA on Water @2190MHZ
    x3 M.2 nVme, x4 SSD
    Corsair Rmi 850w
    AOC 32" @144hz 2560x1440
     
    HWBOT : 
    #2
    Ducrider
    iCX Member
    • Total Posts : 357
    • Reward points : 0
    • Joined: 2010/06/01 18:38:12
    • Location: Guyton GA
    • Status: offline
    • Ribbons : 0
    Re: EVGA 2070 XC Ultra No boost clocks 2021/10/10 16:28:42 (permalink)
    TjFNQ
    Fire up GPUZ---- and look specifically at the Sub vendor, Bios Version, Bus width, Bandwidth etc. and make sure there are no "unknown" labels in those boxes. Also make sure the device id's and bios version match the card. You mentioned folding? I thought that was only for ATI cards not Nvidia, don't quote me on that. Also how have you connected the 6 and 8 pin pwr connectors? Hopefully not daisy chaining the one cable out of PSU.
     
    Lets us know




    All those boxes have the correct info on device id sub vender bios. bus width is 256 bit bandwidth is 448 gigs. Bios was updated to the latest on Techpowerup
    Nvidia has been the leader over ATI/AMD in folding since the beginning. AMD has now started making cards that can keep up with Nvidia cards.
    Yes 6 pin and 8 pin hooked up and dedicated lines from the EVGA 850w psu.

    I9 10850K
    MSI MPG Z490 Gaming Edge
    Gigabyte 1080ti Aorus
    Corsair HX1050
    Cougar Dark Blade
    Win10 64 bit
     Elite ID https://www.evga.com/memb...id=92AD5FMPFQC6Y9R5XNU
    950 at 4.427  http://valid.canardpc.com/show_oc.php?id=1471094
    Heatware=http://www.heatware.com/eval.php?id=72404
    Hwbot:http://www.hwbot.org/user/ducrider/

    #3
    Sajin
    EVGA Forum Moderator
    • Total Posts : 45827
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 198
    Re: EVGA 2070 XC Ultra No boost clocks 2021/10/11 02:27:52 (permalink)
    Let us know how putting the stock cooler back on goes.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #4
    Ducrider
    iCX Member
    • Total Posts : 357
    • Reward points : 0
    • Joined: 2010/06/01 18:38:12
    • Location: Guyton GA
    • Status: offline
    • Ribbons : 0
    Re: EVGA 2070 XC Ultra No boost clocks 2021/10/17 16:06:14 (permalink)
    Sajin
    Let us know how putting the stock cooler back on goes.



    OK just put stock cooler back on. Had to wait on a some thermal pads. Card has the side led flashing red from the get go on power up. Fans spin up during windows load. Once in Windows the fans shut off. Then fans ramp up when Precision starts then shut back down once the drivers crash. Using Win 10 I can not get any over clock as before. In Win 7 which is my folding Windows. It keeps crashing display drivers. So with the stock cooler back on it's even worse than before. I could at least fold on it with the Hydro Copper block installed.
    post edited by Ducrider - 2021/10/17 16:09:13

    I9 10850K
    MSI MPG Z490 Gaming Edge
    Gigabyte 1080ti Aorus
    Corsair HX1050
    Cougar Dark Blade
    Win10 64 bit
     Elite ID https://www.evga.com/memb...id=92AD5FMPFQC6Y9R5XNU
    950 at 4.427  http://valid.canardpc.com/show_oc.php?id=1471094
    Heatware=http://www.heatware.com/eval.php?id=72404
    Hwbot:http://www.hwbot.org/user/ducrider/

    #5
    Sajin
    EVGA Forum Moderator
    • Total Posts : 45827
    • Reward points : 0
    • Joined: 2010/06/07 21:11:51
    • Location: Texas, USA.
    • Status: online
    • Ribbons : 198
    Re: EVGA 2070 XC Ultra No boost clocks 2021/10/17 19:47:56 (permalink)
    Sounds like you’ll need to rma.

    Want to save 5 to 10% on your next EVGA purchase? Just click on the associates banner to save, or enter the associates code at checkout on your next purchase. If you choose to use my code I want to personally say "Thank You" for using it.
     

     
    #6
    Jump to:
  • Back to Mobile