EVGA

Helpful ReplyHot!Display corruption when monitor resumes from sleep

Author
francisw19
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2008/05/03 15:29:50
  • Status: offline
  • Ribbons : 0
2016/02/28 18:06:23 (permalink)
Hello all, I've got a reference EVGA GTX980Ti connected to my LG 24GM77 display using a Display Port connection.  In Windows, I have the monitor set to sleep after 10 minutes and power to the PC is always on (sleep time set to Never).  Sometimes, when I come back to my PC and wake the monitor, I will get a corrupted display that looks like the pictures attached.
 
It doesn't happen every time I wake the monitor, but often enough to start bugging me (I'd say 1 out of 10 times).  A simple restart and everything is back to normal so I don't think it's a hardware problem.  Plus, I've never had this happen with normal use - only sometimes when the monitor goes to sleep mode.
 
I've got the latest 361.91 NV drivers installed (but this has persisted over several of the previous releases as well).  I run Afterburner 4.2.0 with a moderate overclock (+100 core/+200 memory) and the card has been very stable with benchmarks and hours of gaming.  I've tried a few different display port cables (one Startech and two Mono Price) but the issue still persists.  I've also tried switching to other display ports as well and that hasn't helped.
 
Anyone else experience this as well?  Any thoughts or suggestions?
 
Thanks in advance. :)
post edited by francisw19 - 2016/02/28 18:34:09

Attached Image(s)


Intel 4790K | Gigabyte Z97X Gaming 7 | 2x 8GB G.Skill TridentX DDR3-2400 | EVGA GTX 980Ti | Creative Sound Blaster ZxR | SanDisk Extreme Pro 480GB | 2x WD Black 2TB | LG 16x BD-RW QL (BDXL) | EVGA SuperNOVA 850 G2 | Corsair 750D
#1
AndrewA
EVGA Alumni
  • Total Posts : 543
  • Reward points : 0
  • Joined: 2016/01/28 13:54:38
  • Location: Land of Opportunity
  • Status: offline
  • Ribbons : 1
Re: Display corruption when monitor resumes from sleep 2016/02/29 06:17:37 (permalink)
Hello,
 
You may want to try to run Display Driver Uninstaller and then reinstall the latest drivers. You can get the program here http://www.wagnardmobile.com/forums/viewtopic.php?f=5&t=183
#2
NO_sauce
iCX Member
  • Total Posts : 270
  • Reward points : 0
  • Joined: 2016/01/25 13:37:44
  • Status: offline
  • Ribbons : 3
Re: Display corruption when monitor resumes from sleep 2016/02/29 08:08:38 (permalink)
Is it a certified cable? Sometimes changing settings on the monitor helps with DP issues.
 
http://www.evga.com/support/faq/afmmain.aspx?faqid=59615
 

If you have a moment, please rate my service  Agent: Joseph L
#3
EVGATech_JoseR
EVGA Tech Support
  • Total Posts : 763
  • Reward points : 0
  • Joined: 2014/04/11 09:39:05
  • Status: offline
  • Ribbons : 1
Re: Display corruption when monitor resumes from sleep 2016/02/29 08:39:04 (permalink)
You may want to also test with a different refresh rate and resolution combo. Have you tested the graphics card with stock settings?
#4
bsmegreg
FTW Member
  • Total Posts : 1610
  • Reward points : 0
  • Joined: 2014/07/19 19:18:29
  • Status: offline
  • Ribbons : 6
Re: Display corruption when monitor resumes from sleep 2016/02/29 09:11:01 (permalink)
It sounds like it could be one of three things.
1) The driver version you're using is not compatible with your system. For one reason or another not all NVIDIA drivers work for everyone. You said it's continued for several generations of drivers, so maybe try taking it old school and go back to awhile. Also you should use DDU. Detailed instructions are here: http://forums.evga.com/Ba...mode-etc-m2451023.aspx

2) It could also be some strange DP cable problem. You could opt to buy another one as there not going away anytime soon so you could buy one now and even if it doesn't fix the issue then at least you have a spare cable laying around.

3) Lastly, it could somehow be the GPU clock. I have my doubts with this, but you never know. On the link above there is instructions on how to enable debug mode. As seen in the link above this should be used in a last case scenario.

If none of these fix the issue, then I'm not sure.

#5
francisw19
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2008/05/03 15:29:50
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/02/29 09:31:55 (permalink)
Thanks for the replies! :)
 
OK, I'm going to give DDU a go and reinstall drivers as you guys suggested.
 
@NO_sauce, @bsmegreg interesting you guys mention the DP cable.  I've been googling like crazy over this and I've come across some discussions about the quality of display port cables.  I've ordered one that's properly certified by displayport.org this time so I'll see if that helps.  It should be here later this week.
 
Thanks again for the help.  I'll start with the reinstall and new cable and see how it goes.  This is somewhat of an intermittent issue so it's going to be some time before I can say for sure if it's fixed so apologies in advanced for delayed replies.

Intel 4790K | Gigabyte Z97X Gaming 7 | 2x 8GB G.Skill TridentX DDR3-2400 | EVGA GTX 980Ti | Creative Sound Blaster ZxR | SanDisk Extreme Pro 480GB | 2x WD Black 2TB | LG 16x BD-RW QL (BDXL) | EVGA SuperNOVA 850 G2 | Corsair 750D
#6
bsmegreg
FTW Member
  • Total Posts : 1610
  • Reward points : 0
  • Joined: 2014/07/19 19:18:29
  • Status: offline
  • Ribbons : 6
Re: Display corruption when monitor resumes from sleep 2016/02/29 10:46:38 (permalink)
I have this Cat5e cable that I use between my router and my wall and I just got internet that's faster than 100Mb/s. I thought I could get my Cat5e to go gigabit, so I tried. But, it simply wouldn't go. So I troubleshooted the issue up to the point of trying another shorter cable and concluded two things. 1) My secondary router which is kind of more a switch is not Gigabit capable, despite being labeled 300Mb/s and 2) My beloved 50' Cat5e cable is bad. Maybe it's always been bad or maybe I damaged it somehow, but somethings wrong with it. So I bought a 35' Cat6 cable, and hopefully I get the speed I deserve!

But the DP cable reminded me of that and it just shows that not every cable works as expected, even if it's certified.

#7
francisw19
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2008/05/03 15:29:50
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/03/15 08:41:56 (permalink)
Hello all, sorry to dig up an old post, but I wanted to follow up on this issue in case there was any one else out there having the same trouble.
I have been using the Acell display port cable (linked above) that's certified by displayport.org and haven't experienced this issue since.  It's been easily long enough that it would have recurred by now, so I'm going to say this issue is resolved. :)

Intel 4790K | Gigabyte Z97X Gaming 7 | 2x 8GB G.Skill TridentX DDR3-2400 | EVGA GTX 980Ti | Creative Sound Blaster ZxR | SanDisk Extreme Pro 480GB | 2x WD Black 2TB | LG 16x BD-RW QL (BDXL) | EVGA SuperNOVA 850 G2 | Corsair 750D
#8
Xfools
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2007/08/08 16:44:42
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/08/15 19:35:23 (permalink)
Hey there... I have EXACTLY same issue...Just like on your screen shots! Tried 2 different cards at this point GTX1060, and now on  GTX1070, so its not a GPU for sure.
What we do have in common - is the SAME monitor - LG 24GM77. I never had this issue happen with my old R9 280X, and the same config... even used same DP cable.. go figure.
 
Could it be MSI Afterburner?
 
Even tried clean  windows re-install.... Please let me know if you are still clear of issues!?
 
 
#9
francisw19
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2008/05/03 15:29:50
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/08/15 20:00:47 (permalink)
Xfools
Hey there... I have EXACTLY same issue...Just like on your screen shots! Tried 2 different cards at this point GTX1060, and now on  GTX1070, so its not a GPU for sure.
What we do have in common - is the SAME monitor - LG 24GM77. I never had this issue happen with my old R9 280X, and the same config... even used same DP cable.. go figure.
 
Could it be MSI Afterburner?
 
Even tried clean  windows re-install.... Please let me know if you are still clear of issues!?




Sorry to hear that. 
Since my last post, things have been going well for the most part.  However, around early June it did it again.  I will say, the new Accell cable made a big improvement on my end since I went several months without a problem (otherwise was like a weekly occurance previously).  No problems otherwise though.
 
Also, I don't have my LG display anymore.  About a month ago, I picked up a Dell U2515H which has only DP and HDMI inputs.  I've been using display port on the Dell with the same Accell cable and have had zero troubles with it thus far.
 
I'm not sure what to suggest though...I never really pinned down the exact cause.  The cable certainly did help big time, but wasn't perfect.  Maybe a combination of things (say monitor, cable, GPU drivers combination?)

Intel 4790K | Gigabyte Z97X Gaming 7 | 2x 8GB G.Skill TridentX DDR3-2400 | EVGA GTX 980Ti | Creative Sound Blaster ZxR | SanDisk Extreme Pro 480GB | 2x WD Black 2TB | LG 16x BD-RW QL (BDXL) | EVGA SuperNOVA 850 G2 | Corsair 750D
#10
Xfools
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2007/08/08 16:44:42
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/08/15 20:47:18 (permalink)
francisw19
Xfools
Hey there... I have EXACTLY same issue...Just like on your screen shots! Tried 2 different cards at this point GTX1060, and now on  GTX1070, so its not a GPU for sure.
What we do have in common - is the SAME monitor - LG 24GM77. I never had this issue happen with my old R9 280X, and the same config... even used same DP cable.. go figure.
 
Could it be MSI Afterburner?
 
Even tried clean  windows re-install.... Please let me know if you are still clear of issues!?




Sorry to hear that. 
Since my last post, things have been going well for the most part.  However, around early June it did it again.  I will say, the new Accell cable made a big improvement on my end since I went several months without a problem (otherwise was like a weekly occurance previously).  No problems otherwise though.
 
Also, I don't have my LG display anymore.  About a month ago, I picked up a Dell U2515H which has only DP and HDMI inputs.  I've been using display port on the Dell with the same Accell cable and have had zero troubles with it thus far.
 
I'm not sure what to suggest though...I never really pinned down the exact cause.  The cable certainly did help big time, but wasn't perfect.  Maybe a combination of things (say monitor, cable, GPU drivers combination?)




Your new monitor, I am guessing it doesnt support 120 / 144hz... maybe that is the issue.
You are literally, the only person, i had found with the same issue... I will be trying to turn MSI Afterburner off, if that is not the case, switch to DVI cable, and if that doesnt work switch to 120Hz... Then its monitor I guess.
#11
francisw19
New Member
  • Total Posts : 11
  • Reward points : 0
  • Joined: 2008/05/03 15:29:50
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2016/08/16 14:13:04 (permalink)
Xfools
francisw19
Xfools
Hey there... I have EXACTLY same issue...Just like on your screen shots! Tried 2 different cards at this point GTX1060, and now on  GTX1070, so its not a GPU for sure.
What we do have in common - is the SAME monitor - LG 24GM77. I never had this issue happen with my old R9 280X, and the same config... even used same DP cable.. go figure.
 
Could it be MSI Afterburner?
 
Even tried clean  windows re-install.... Please let me know if you are still clear of issues!?




Sorry to hear that. 
Since my last post, things have been going well for the most part.  However, around early June it did it again.  I will say, the new Accell cable made a big improvement on my end since I went several months without a problem (otherwise was like a weekly occurance previously).  No problems otherwise though.
 
Also, I don't have my LG display anymore.  About a month ago, I picked up a Dell U2515H which has only DP and HDMI inputs.  I've been using display port on the Dell with the same Accell cable and have had zero troubles with it thus far.
 
I'm not sure what to suggest though...I never really pinned down the exact cause.  The cable certainly did help big time, but wasn't perfect.  Maybe a combination of things (say monitor, cable, GPU drivers combination?)




Your new monitor, I am guessing it doesnt support 120 / 144hz... maybe that is the issue.
You are literally, the only person, i had found with the same issue... I will be trying to turn MSI Afterburner off, if that is not the case, switch to DVI cable, and if that doesnt work switch to 120Hz... Then its monitor I guess.




Yep, my Dell doesn't support 144 Hz (just a standard IPS 60Hz 1440p display...change in priorities is all).  Might be worth running 60Hz for some time if you suspect that's the culprit.  Could be an issue with Afterburner too, but it's doubtful IMO.  It's such a popular program I think we'd hear more about it if there was an inherent problem.

Intel 4790K | Gigabyte Z97X Gaming 7 | 2x 8GB G.Skill TridentX DDR3-2400 | EVGA GTX 980Ti | Creative Sound Blaster ZxR | SanDisk Extreme Pro 480GB | 2x WD Black 2TB | LG 16x BD-RW QL (BDXL) | EVGA SuperNOVA 850 G2 | Corsair 750D
#12
SCoffey
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2004/08/18 15:28:41
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2018/11/20 10:24:08 (permalink)
I know this is an old thread, but I found it while searching for the exact same problem with my monitor, an Asus PG279Q.  I'm pretty sure it's caused by a loose power connector.  The end that plugs into the monitor wasn't seated all the way, and after fixing that it hasn't happened since.  Hope it helps someone. :)
 
#13
squall-leonhart
CLASSIFIED Member
  • Total Posts : 2869
  • Reward points : 0
  • Joined: 2009/07/27 19:57:03
  • Location: Australia
  • Status: offline
  • Ribbons : 21
Re: Display corruption when monitor resumes from sleep 2018/11/21 05:24:35 (permalink) ☄ Helpfulby Cool GTX 2018/12/13 08:56:52
its caused by the 416 drivers.

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme
#14
demon09
FTW Member
  • Total Posts : 1010
  • Reward points : 0
  • Joined: 2016/09/16 21:18:42
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2018/11/24 06:53:06 (permalink)
this seemed to be what caused it for me also I am rolled back to 411.70 atm as 416 drivers will randomly give me display corruption even if I have sleep and hibernation truned off and just have it set to have the screen turn off after X amount of time randomly it will come back corrupted and all pixelated .
#15
magamiako
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2007/08/10 17:15:51
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2018/12/13 08:32:50 (permalink)
The 417 drivers do the same thing. I'm having the exact same problem:
 
EVGA 980Ti, Asus PG27AQ, Display Port connection.
#16
squall-leonhart
CLASSIFIED Member
  • Total Posts : 2869
  • Reward points : 0
  • Joined: 2009/07/27 19:57:03
  • Location: Australia
  • Status: offline
  • Ribbons : 21
Re: Display corruption when monitor resumes from sleep 2018/12/13 12:50:13 (permalink)
the 417 drivers are 416 drivers.

CPU:Intel Xeon x5690 @ 4.2Ghz, Mainboard:Asus Rampage III Extreme, Memory:48GB Corsair Vengeance LP 1600
Video:EVGA Geforce GTX 1080 Founders Edition, NVidia Geforce GTX 1060 Founders Edition
Monitor:BenQ G2400WD, BenQ BL2211, Sound:Creative XFI Titanium Fatal1ty Pro
SDD:Crucial MX300 275, Crucial MX300 525, Crucial MX300 1000
HDD:500GB Spinpoint F3, 1TB WD Black, 2TB WD Red, 1TB WD Black
Case:NZXT Phantom 820, PSU:Seasonic X-850, OS:Windows 7 SP1
Cooler: ThermalRight Silver Arrow IB-E Extreme
#17
tacklemcclean
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2019/05/24 08:58:38
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2019/05/24 09:01:25 (permalink)
Hey there, I have the same issue with:
GPU: Asus GTX 1070 Strix
Monitor: Acer 27" Predator XB271HU G-Sync
 
I believe the DP cable came with the monitor.
Anyways, I've had this problem for many years. No idea if it's fixable or what's causing it. I too use MSI Afterburner, not sure that's a common denominator but I do use it.
 
It happens rarely, but it happens. Only on waking the screen after it's been put to sleep (NOT hibernation in Windows).
 
When it happens, if I unplug the DP cable from the GPU, the system hangs completely.
#18
Cool GTX
EVGA Forum Moderator
  • Total Posts : 16475
  • Reward points : 0
  • Joined: 2010/12/12 14:22:25
  • Location: Folding for the Greater Good
  • Status: offline
  • Ribbons : 112
Re: Display corruption when monitor resumes from sleep 2019/05/24 09:21:25 (permalink)
tacklemcclean
Hey there, I have the same issue with:
GPU: Asus GTX 1070 Strix
Monitor: Acer 27" Predator XB271HU G-Sync
 
I believe the DP cable came with the monitor.
Anyways, I've had this problem for many years. No idea if it's fixable or what's causing it. I too use MSI Afterburner, not sure that's a common denominator but I do use it.
 
It happens rarely, but it happens. Only on waking the screen after it's been put to sleep (NOT hibernation in Windows).
 
When it happens, if I unplug the DP cable from the GPU, the system hangs completely.




 
Have you tried this tool ?
 
DP 1.3 / 1.4 monitor could blank screens on boot until the OS loads or Hang on Boot

RTX Project EVGA X99 FTWK-5930K,EVGA2080Ti EVGA-1200P2  Nibbler EVGA X99 3-GPU Water Loop 1600P2  AIO Folding  1080Ti FTW3 Hybrid, 1200P

Thank You for Your Support






#19
tacklemcclean
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2019/05/24 08:58:38
  • Status: offline
  • Ribbons : 0
Re: Display corruption when monitor resumes from sleep 2019/05/25 08:03:00 (permalink)
Cool GTX
 
Have you tried this tool ?
 




I have not, at first glance it seems to only regard booting.
However, I downloaded it and it wanted me to do a firmware update, so I did. Time will tell me if it fixed the problem! Regardless of description, it doesn't seem far fetched that it could work.
#20
Jump to:
  • Back to Mobile